Jump to content
Scan_Speedy

Transedit, neues Ton Format bitte einbauen

Recommended Posts

Scan_Speedy    0
Scan_Speedy

Hi @Griga

 

Ich hab gestern die Info bekommen, das der SES Astra Sender mit AC-4 Audio sendet.

Also hab ich Transedit angeworfen, aber der Pid wird nur als Private PES erkannte.


Es geht um " SES UHD Demo" auf 10995 auf Astra 19.2

AC-4 Audio ist wohl ganz neu, und muss sicher nur in die Erkennung eingebaut werden ;)

Es geht um den Audio Stream auf PID 513.

 

 

PS: ich verwende Transedit 4.0.8.0

Edited by Scan_Speedy

Share this post


Link to post
Derrick    62
Derrick

Aha, für AC-3 sind die Lizenzen abgelaufen aber Dolby will weiter kassieren. Wundert mich, dass die Provider das unterstützen. Oder ist der Sender von Dolby? Kann leider nicht selbst checken.

Share this post


Link to post
Scan_Speedy    0
Scan_Speedy

So ich noch mal :)

 

Die Info war im übrigen von der Firma Dolby selbst, hab gerade noch mal etwas per Mail nachgefragt.

Was mich weiterhin etwas stutzig macht ist der AC3 Eintrag in der CSV Datei.

 

Dort steht eine 33 drin, wandle ich die nach HEX um ergibt das eine 21.

 

2 = HEVC , das passt

1 = AC3, das passt nicht

müsste es nicht 5 für EAC3 sein ?

Wenn ich das richtig kapiert hab ;)

 

Oder hab ich gerade einen Denkfehler ?

 

Edit, ich wusste doch, das hab ich schon mal gefragt :D

Zitat

AC3 und E-AC3 wird im DVBViewer erst bei der Wiedergabe (Erkennung durch DVBViewer Filter und/oder Audio-Decoder) unterschieden. "AC3" ist im Scanner-Kontext als Kategorie zu verstehen, die alle AC3-Arten zusammenfasst, ebenso wie "AAC" verschiedene Arten AAC (da gibt es auch solche und solche) oder "MPEG Audio" MP2 und MP3.

 

Das war damals die Antwort von Griga, das Thema EAC3 hat sich somit erledigt ;)

 

Edited by Scan_Speedy
Tippfehler

Share this post


Link to post
Griga    359
Griga

Zwischenablage01.png

Share this post


Link to post
Derrick    62
Derrick

Du kannst ja mal im Source Fiter nachschauen.Ganz genau geht es in Transedits analyzer. Rechts klick auf Audio-pid -> Header Analysis

Share this post


Link to post
Derrick    62
Derrick

Im Zweifelsfall immer die Neuste ;)

Share this post


Link to post
Griga    359
Griga

Gerade erst entstanden. Nachdem ich deinen Post gelesen hatte.

Share this post


Link to post
Scan_Speedy    0
Scan_Speedy

cool :)

 

Das ging ja fix, super Arbeit :D

Share this post


Link to post
Griga    359
Griga

Ich lasse das noch etwas liegen (mit etwas Abstand sieht man manchmal noch Bugs), danach kannst du das eventuell testen. Ich melde mich dann per PM.

Share this post


Link to post
Scan_Speedy    0
Scan_Speedy

Darf ich dich noch auf einen Bug in der Software hinweisen ?

Der mir seinerzeit aufgefallen ist.

Möglich das du ihn bereits kennst.

 

Folgender Sachverhalt.

16E Frequenz 11131

Scanner ließt folgendes mit Version 4.0.8.0 ein

 

image.png.add2cf08a10a8eab74c33a716da62242.png

 

Scanne ich den selben TP mit 3.8.3.0 erhalten ich die Richtigen Namen

 

image.png.cd75003db3c8c0ce2c7c47b118f3a42f.png

 

Oben sind 15 Einträge  vorhanden, unten nur 10.

Irgendwas scheint mit der Erkennung da nicht zu stimmen.

Ist kein gewaltiges Problem, wollte es nur mal anmerken.

Falls du die XML Daten des TP brauchst, kann ich sie anhängen.

 

Edited by Scan_Speedy

Share this post


Link to post
Derrick    62
Derrick

Ich kann nix checken und @Griga kann die nicht empfangen. Ich denke mal, da sind unterschiedliche Haken gesetzt wie zB Anzeige von Datendiensten.

 

Share this post


Link to post
Scan_Speedy    0
Scan_Speedy

Es ging nicht um die Datendienste ;)

 

Sondern warum Mpeg2 hinten am Sendernamen steht.

Und wieso der Scanner Sender findet, die dort nicht existieren.

Also einen Sender "Antenna 3 HD" gibt es nicht.

Der Scanner findet dort 5 HD Sender, aber tatsächlich existiert nur einer.

 

4sactuw2.jpg

 

Nachtrag die Häkchen unten bei Filter 1 + 3 sind identisch.

Edited by Scan_Speedy

Share this post


Link to post
Derrick    62
Derrick

Um den korrekten Namen zu erfahren, musst du SDT oder PMT aufklappen. Im Scanner kannst den Namen editieren wie du lustig bist. Keine Ahnung, warum da mpeg2 steht.

Share this post


Link to post
Scan_Speedy    0
Scan_Speedy

So, hab vermutlich den Fehler gefunden, der TP hat mehrere SDT Daten.

Sowas hatte ich noch nie, seht selbst.

 

jkulvbq2.jpg

 

Da sieht man die komischen Kennungen, ist also kein Bug von Transedit, sondern von dem TP Betreiber ;)

Nur komisch das es beide Versionen unterschiedlich behandeln.

Share this post


Link to post
Derrick    62
Derrick

Ja sowas kommt vor. Allerdings kann man auf deinem Bild nicht sehen, was richtig ist.  Zunächst die SDT für das aktuelle Netzwerk und dann muss die Transponder ID mit der PAT übereinstimmen. Man muss allerdings dabei bemerken, dass bei manchen Providern Fehler drin sind.  das macht sich zB im fehlendem EPG bemerkbar.

Share this post


Link to post
Scan_Speedy    0
Scan_Speedy

So da bin ich wieder :)

 

Erstmal danke an @Griga für die neuste Test Version.

Beim 19.2 Scan ist mir erstmal nix negatives aufgefallen.

Es fehlt keine Sender oder irgendwelche Senderdaten.

 

Nun zum Audio Problem.

Hab nun die Audiodaten ausgelesen und bei mir eingebaut.


Zu sehen hier

http://www.satindex.de/channel/8729/

 

Folgendes fehlt aktuell noch, kein Plan ob das überhaupt so Übertragen wird.

Aber bevor ich bei Dolby deswegen nachfrage, erstmal hier ;)

 

1. der Channelmode (Mono, Stereo und Sourround) in dem fall die Angabe 2/0 oder 3/2

2. die Audio Bitrate

3. die Audi Sample Rate

4. die ISO 639 Language Angabe (wie beim EAC3)

 

Dann noch eine Allgemeine Frage bezüglich dem Export der Audio Daten.

Mein Script liest die Exportierten Dateien alle ein.

Es sucht nach XML Dateien die *Audio.XML heißen

Das klappt zu 99% auch.

 

Nur nicht bei EAC3, denn da heißt die Datei, XXX EAC3.XML

Da fehlt das Audio, ich editiere das dann gehts auch.

Nur ums zu verstehen, warum haben alle anderen das Wort Audio enthalten, nur EAC3 nicht ?

 

So das wärs fürs erste.

Morgen ist wieder 16E mit dem komischen Transponder dran, mal sehen was dann passiert :D

Edited by Scan_Speedy

Share this post


Link to post
Griga    359
Griga
2 hours ago, Scan_Speedy said:

1. der Channelmode (Mono, Stereo und Sourround) in dem fall die Angabe 2/0 oder 3/2

2. die Audio Bitrate

3. die Audi Sample Rate

4. die ISO 639 Language Angabe (wie beim EAC3)

  1.  Steht optional im AC-4 Descriptor, aber wollte SES wohl nicht verraten. Kann man wahrscheinlich auch aus den AC-4 Headern lesen, aber dazu muss man den Stream höchstpersönlich analysieren.
  2. Erfordert das Lesen der AC-4 Header.
  3. Erfordert das Lesen der AC-4 Header.
  4. Da fehlt einfach ein klassischer ISO Language Descriptor in der PMT. Es gibt dort jedoch einen unbekannten Descriptor (Extended Descriptor mit Descriptor Tag Extension 0x19), der u.a. die Buchstaben "eng" enthält. Die Bedeutung ist unbekannt. In den mir vorliegenden Spezifikationen ETSI EN 300 468  V1.15.1 ist er (noch) nicht beschrieben. Eine neuere Version der Spezifikationen habe ich nicht gefunden.

Damit TransEdit die AC-4 Header lesen kann, müsste ich erst mal ETSI TS 103 190 studieren (ebenfalls im Web auffindbar). Ob und wann ich dazu komme, weiß ich nicht. Es hat nur geringe Priorität, solange das Audioformat im DVB-Bereich keine größere Bedeutung erlangt.

 

3 hours ago, Scan_Speedy said:

Nur nicht bei EAC3, denn da heißt die Datei, XXX EAC3.XML

Da fehlt das Audio

 

Korrigiere ich bei Gelegenheit.

Share this post


Link to post
Scan_Speedy    0
Scan_Speedy

Hi, klingt logisch, wegen einem Sender musst du jetzt nicht die Unterlagen zu AC4 studieren ;)

Mal sehen vielleicht gibts ja irgendwann einen 2. der zumindest den Language Teil angibt.

Share this post


Link to post
Scan_Speedy    0
Scan_Speedy

So wie angekündigt hier das Ergebnis vom 16E Scan.


Das Problem mit diesen komischen TP 11131 V besteht weiterhin.

Hab das Problem mal genauer untersucht.

Wenn ich z.B. 10x in folge den TP scanne, bekomme ich  bis zu 4 verschiedene Ergebnisse.

Einmal die vom von dem SDT Eintrag, dann von dem usw.


Das Problem ist, siehe Screenshot von oben, das im SI Tree 7x die SDT vorhanden ist.

7x mit Unterschiedlichen Sendernamen.

 

Es gibt einen Haupt eintrag

 

SDT PID = 17 - Actual TS  (das ist vermutlich der richtige)

 

und dann gibt es noch

 

SDT PID = 17 - Other TS (hier sind die ganzen Falschen Kennungen drin)

dieser ist dann noch unterteilt in Stream

2

3

50

usw.

 

Nun zu meiner Idee @Griga könnte man es nicht so machen, das Transedit nicht per Zufall eine der SDT Daten ausließt, sondern nur die 1., welche den Zusatz Actual hat ?

Alle anderen sind ja quasi "Fake Daten" ;)

 

Wie gesagt das Problem betrifft eigentlich so wie ich das sehe nur 16E.

Auf anderen Satelliten ist es mir bisher nicht aufgefallen.

Ist also kein großes Problem.

Edited by Scan_Speedy

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×