Jump to content

Search the Community

Showing results for tags 'rot'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Deutsch
    • Ankündigungen & Neuigkeiten
    • Einsteigerfragen DVBViewer Pro/GE
    • Allgemeines DVBViewer Pro/GE
    • Vorschläge & Ideen
    • Fehlermeldungen DVBViewer Pro/GE
    • Plugins und AddOns
    • DVB Hardware (Digital TV Karten)
    • DVBViewer Recording Service 1.x
    • DVBViewer Media Server
    • Sat>IP Viewer & Co (Android,iOS,Mac)
    • Verschiedenes
    • DVBViewer Video Editor
  • English
    • News & Announcements
    • Newbies DVBViewer Pro/GE
    • General DVBViewer Pro/GE
    • Suggestions & Ideas
    • Bug Reports DVBViewer Pro/GE
    • Plugins and AddOns
    • DVB Hardware (Digital TV cards)
    • DVBViewer Recording Service 1.x
    • DVBViewer Media Server
    • Sat>IP Viewer & Co (Android,iOS,Mac)
    • Off-Topic
    • DVBViewer Video Editor
  • Miscellaneous
    • Scripting Lounge / API (de/en)
    • Area HTPC
    • HDTV / UHDTV (de/en)
    • DVB - The technique behind
    • Conversion & Encoding
    • OEM Edition - User Helping Users (de/en)
    • Forum / Wiki / Website (de/en)
  • Survey ● Umfragen
    • DVBViewer Pro Cleanup (en/de)

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. Hello everybody, First of all, many thanks to the DVBViewer Pro team for your wonderful software. I have a problem and will try to explain it. I’m using scripts to communicate with DVBViewer Pro via the COM interface. For that I use AutoIt and the DVBViewer.au3 UDF that works fine. What is important is that I have two instances of DVBViewer Pro installed as I sometime run the two instances at the same time (I use one for live TV and the other one for recordings, pausing and switching between the two instances as wished). Note that I followed the recommendations stated on this page in order to install two instances of DVBViewer Pro: http://en.DVBViewer.tv/wiki/Multiuser_mode And that’s were there is a problem: only the COM server of the DVBViewer Pro instance started first is accessible/working. If I switch to the second instance (giving it focus) and try to communicate with it, it is the first instance that reacts. If I close the first instance, then I get a COM error if I try to communicate with the second instance as it seems it has not been registered. I did some tests using a modified version of the DVBViewer.au3 in order to indicate the “instance” of the COM server I want to communicate with ( https://www.autoitscript.com/autoit3/docs/functions/ObjGet.htm ) but it didn’t help. Parameter “0” or “1” only allows communicating with the first instance of DVBViewer Pro, parameter “2” returns an error. I saw in AutoIt forum that some people were able to communicate via COM with several instances of the same program (e.g. Excel sheets) and that some other had problems with specific programs (https://www.autoitscript.com/forum/topic/182524-objget-same-classname/?_fromLogin=1#replyForm ). Note that I also did a few tests with a VBS script (I didn’t find any “instance” parameter in the command) and the problem is the same, only the first started instance of DVBViewer Pro is accessible. That’s why I think the problem is on DVBViewer COM interface or its COM server registration (ROT table) itself. What do you think? Can you reproduce this problem? Is it a bug on DVBViewer Pro side or something else? Any idea to workaround the problem in order to be able to communicate with two different instances of DVBViewer Pro depending on which has focus? Note: I know that using two instances of DVBViewer Pro at the same time is not a usual use case and rather something rare, but I would appreciate any response or comment about my problem. Best Regards, Stéphane P.S.: I attached a support.zip file as requested but I’m not sure that it will be of some help in my case ;-) support.zip
×