Jump to content
Sign in to follow this  
Holger

Async Audio Video

Recommended Posts

Holger

Hallo Leute,

 

mit welchen Tool kann ich Audio und Video Files zu mpg-Files zusammenbringen und dabe die Async. zu beheben.

 

Danke

 

Holger

Share this post


Link to post
Guest Oliver

Am einfachsten mit dem Xmuxer von Moonlight.

 

Besser wäre es natürlich, gleich im gemuxten PVA-Format aufzuzeichnen und dann mit PVAStrumento nach MPG2-PS zu konvertieren.

 

Bis dann, Oliver

Share this post


Link to post
Holger

Ich kann beim Xmuxer nicgts finden um die Audio und Video syncron zu bekommen?!

Share this post


Link to post
Guest Oliver

Das sollte eigentlich automatisch beim Multiplexen geschehen. :rolleyes:

 

Bis dann, Oliver

Share this post


Link to post
Holger

Habe es gerade noch einmal probiert. Funktioniert nicht! Habe bei Option den Haken bei Check Sync Points gesetzt.

Der Ton kommt immer noch zu spät.

Share this post


Link to post
Guest Oliver

Hm, das ist schlecht. Könnte es vielleicht an etwas anderem liegen? Möglich wäre, dass du für die Wiedergabe der Dateien nicht den Overlay-Modus deines Players verwendest; wenn dann die Systemlast zu hoch ist, kommt es auch zu asynchroner Wiedergabe.

 

Ansonsten versuche doch, die vom XMuxer zusammengefügte Datei mit PVAStrumento noch mal zu remuxen. Ist so natürlich recht aufwändig, aber wenn man gesplittet aufnimmt, wüsste ich jetzt keinen anderen Weg mehr.

 

Wenn du mindestens die Version 1.91 vom DVBViewer hast, kannst du ja auch direkt als gemuxter MPG2-PS oder (in der Vollversion) im PVA-Format aufnehmen. Letzteres mache ich und konvertiere dann mit PVAStrumento nach MPG2-PS. Dabei wird der Anfangsversatz komplett korrigiert.

 

Bis dann, Oliver

Share this post


Link to post
Holger

Also ich habe mit pvaStrumento, aus dem mit Xmuxer gemuxten File, ein mpg-File erstellt, aber ohne Erfolg. Es ist schon komisch, dass vom Programm angezeigt wird, dass Audio und Video syncron sind obwohl der Ton schätzungsweise mindestens eine halbe Sekunde zu spät kommt. Kennt niemand eine Software um das zu beheben ?! Ich glaube ich habe so etwas schon gesehen, dass man die Delay-Time eingeben kann um Audio und Video synchron zu bekommen.

Share this post


Link to post
Guest Oliver

Also, wenn PVAStrumento anzeigt, dass es synchron ist, dann ist es synchron. Jetzt kann es nur noch an der anderen Sache mit der Systemlast liegen. Starte doch während des Abspielens mal den Taskmanager und schaue nach, wie hoch die CPU-Last ist. Das mit der Delay-Time kannst du bei VirtualDub eingeben, aber das Programm dient nur der Konvertierung nach AVI.

 

Bis dann, Oliver

Share this post


Link to post
Klausing
obwohl der Ton schätzungsweise mindestens eine halbe Sekunde zu spät
Ich hatte dieses Phänomen auch schon einmal. Niemand bekam zuerst mit, dass der Ton über gut eine halbe Stunde des Filmes eine halbe Sekunde hinterher hing. man merkte dies auch nur wenn man den Leuten direkt auf die Lippen schaute. Angezeigt wurde bei mir auch, dass alles synchron sei.

Ich habe dann den Film in der Wiederholung noch einmal aufgenommen und saß dabei an einer der betreffenden Stellen direkt vor der Glotze und siehe da, die Anzeige, dass der Film synchron sei war richtig.

Der Film insgesamt war einfach schlecht synchronisiert worden und dieser Fehler war schon im Original enthalten. (und das bei einem Kassenschlager aus Hollywood "Hals über Kopf") Ich habe das ganze dann mit Adobe Premiere behoben, da kann man den Ton beliebig hin und herschieben bis es passt. Allerdings wünschte ich mir für den privaten Gebrauch auch ein Tool was weniger kostet und einfacher ist. So etwas wie demuxen, den Audiostream an den betreffenden Stellen markieren und verschieben können und dann wieder zusammen muxen. Das ganze dürfte dann eigentlich auch nicht all zu lange dauern, weil ja nichts umgerechnet werden muss.

Vielleicht kennt ja jemand ein Tool das dies kann.

Gruß

Steffen

Share this post


Link to post
troidl

Hallo Holger,

 

hatte exakt das gleiche Problem wie Du.

 

Ich habe zum synchronisieren das Media Studio Pro 6.5 von Ulead benutzt. Du hast dort mehrere separate Spuren für Audio und Video (ist ja auch ein Videoschnittprogramm) und kannst dann der Tonspur eine andere Geschwindigeit geben.

 

Musst halt ein bisschen experimentieren - ich habe bisher noch jedes Video synchron bekommen.

 

Du kannst bei Ulead auch eine auf 30 Tage beschränkte Demoversion der neuen Version 7 herunterladen. Damit funktioniert es ebenso.

 

Wenn Du (zukünftig?) im DVBViewer in MPEG aufzeichnest kannst im Media Studio Pro 7 die Dateien auch direkt per "Drag and drop" verarbeiten und direkt eine DVD o.ä. erstellen.

 

Falls Du weitere Hilfe benötigst kannst Du Dich gerne melden. Oder Du suchst im Netz, gibt bestimmt jede Menge Anleitungen...

 

Schöne Grüße,

Thomas

Share this post


Link to post
Holger

Dank Euch allen!

 

Na dann werde ich mich mal ranstürzen.

An der Systemlast liegt es nicht! Da ist alles im grünen Bereich und ich hatte von dem Film auch ein Stück gesehen und da ist mir nichts aufgefallen, dass mit der Syncronisation was nicht stimmt. Das hätte ich sicher auch gemerkt. Wie ich jetzt festgestellt habe sind es fast 1 Sekunde die der Ton dem Film nachhängt. Habe das Problem auch mal versucht mit ifoedit (Authoring) wegzubekommen, doch leider kann man da keine so große negative Delay eingeben, da stürzt da Programm ab.

 

Holger

Share this post


Link to post
dankescheen

Bei der Konversion mit TMPGEnc gibt's auch die Möglichkeit der Korrektur im SourceRange Menü.

( Audio Gap Correct in ms )

Works perfect !

Share this post


Link to post
Holger

Hi,

 

also ich habe jetzt mal einen Film als mpg-File aufgenommen. Läuft wunderbar syncron. Sobald ich diesen mit Xmuxer bearbeiter geht die Syncronität verloren. Das gleiche passiert mit pvastrumento. Es erkennt 935 ms Delay (obwohl, wenn ich den Film abspiele alles syncron ist). Wenn ich danach "make ps" ausführe, ist der Film dann nicht mehr syncron.

 

Dann habe ich mal versucht mit dem Tool MPEG2Cut diesen zu schneiden. Da kann ich nur immer vom Filmanfang bis zu einer Position schneiden (geschnittenes ist dann aber syncron), dazwischen was herausschneiden geht es nicht. Datei wird mit 0 kb gespeichert. Das gleiche passiert mit Vidomi.

 

Könnt Ihr mir helfen ??

 

Danke

Share this post


Link to post
Guest Oliver

Hallo!

 

Also, das mit PVAStrumento kann ich nicht mehr nach vollziehen. Hast du mal versucht, im PVA-Format aufzuzeichnen, bzw. welche Version des DVBViewer benutzt du eigentlich? Alternativ könntest du sonst noch mal DS-Jar ausprobieren, irgendwo hier im Forum ist ein Link dazu.

 

Sonst benutzte mal Graphedit - "render media file" um die aktiven Filter darzustellen, vielleicht kannst du einen Screenshot davon mal posten.

 

Bis dann, Oliver

Share this post


Link to post
Holger

DVBViewer habe ich Version 1.99

Du mußt mir nur mal schnell helfen, wie ich hier im Forum ein Screenshot posten soll ?

 

Ich mach es mal so:

 

mpg-File -> Elecard MEG2 Demulti. --->(Audio 0) Xform In- MGEG Audio Decoder -Xform Out -> Audio Input pin (rendered) - Defaulft DirectSound...

|

-->(Video 0 0xE0) MPEG Input - DVD Express Video Decoder - Video Output -->VMR Input0 - Video Renderer

 

DS-Jar habe ich im Internet nicht mehr gefunden !! Ich hatte ein Posting gesehen, dass der Eigentümer es nicht mehr verbreiten möchte !

Share this post


Link to post
Klausing
Du mußt mir nur mal schnell helfen, wie ich hier im Forum ein Screenshot posten soll
klick einfach beim posten auf den IMG-Button und gib die Adresse des Bildes ein. (denk aber bitte daran es klein zu halten)

Einen funktionierenden Link zu ds-jar findest Du in diesem thread.

Gruß

Steffen

Share this post


Link to post
Holger

Bekomme immer die Meldung:

 

Sorry, dynamic pages in the tags are not allowed

 

Was mach ich falsch ?!

Share this post


Link to post
Klausing

Deine Adresse muss ungefähr so aussehen: http://www.derserver.de/verzeichnis/bild.jpg Du musst also den direkten Pfad zu dem Bild angeben.

Dann funktioniert es auch.

Gruß

Steffen

Share this post


Link to post
Guest Oliver

Und was mache ich, wenn ich das Bild nur auf Platte habe? :rolleyes: Einfach den Pfad angeben hat bei mir nicht funktioniert.

 

Bis dann, Oliver

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...