Jump to content

Recordingservice Beta


Lars_MQ

Recommended Posts

Big thanks for implementing the "search selective day(s)" option. This is working really well for me.

 

I haven't tried it yet, but the "after-recording process task" you've since added should allow me to call BBC HD Fix to patch files after recording ;)

 

One thing I noticed (still running 1.4.7.95 ) is the check/tick boxes on the timers web page say "delete recording" when you hover over them instead of "delete timer".

 

Any chance of a right click option on the tray icon to "inhibit standby/hibernate/shutdown"? Maybe change the icon (picture/colour) slightly to indicate that this option is active. I prefer to have the default option to standby after recording, but this has caught me out on a couple of occasions and the PC has gone to standby when I'm doing something else on it >_<

Link to post
  • Replies 602
  • Created
  • Last Reply

Top Posters In This Topic

  • Lars_MQ

    155

  • janip

    42

  • uglyned

    35

  • smallant

    22

Top Posters In This Topic

Popular Posts

Thanks, timerwindow work now. Maybe is good if webinterface "show timerwindow" setting is only for normal web use? Not for mobile.

Pleas post your support.zip   @all Please do not start new topics in this topic.   We have now a section for the Recording Service and it is hard to find informations in such a big mix topic. ht

Posted Images

Mobile use:

 

1. "/mobil/timer_add.html was not found on this server", if i select "do not use timer window" (one button record)

 

2. Timer active should be "yes", when start timer window.

 

3. Look "after recording" drop down. Why my recording folder is there? User error again? ;)

 

I use s60 and opera mini.

post-53217-1239878258_thumb.jpg

Link to post
Try the attached file (extract into svcweb\mobil\), you need to stop/start the service to get the new file.

 

Thanks, timerwindow work now.

Maybe is good if webinterface "show timerwindow" setting is only for normal web use? Not for mobile.

  • Like 1
Link to post

Lars, thanks for updating the Command Line tool dvbv_tvg.exe, however I can't see it in the Members Area - I can see that the TvGenial + CMDline was last updated yesterday, but the download still brings down the old version, 1.1. Or am I looking in the wrong place for it?

Link to post

Idea.

 

I use rainlendar calender and there is nice TV addon.

There i can see actual programs.

 

That rainlendar is nice, but maybe vista gadgets is more common.

 

So, how about if i can start one button record from vista gadget?

Link to post
Barleyman

I found an issue with the service - It seems like if there's DVB subtitle included in the stream the recording and/or streaming to dvb client will fail almost immediately. I had 1h recording scheduled and ended up with a whole mess of <1MB files, probably due to the "if no data for 60 seconds restart" -option.

 

I need to test that more but since the same problem occurs with live streaming and recordings it shouldn't be codec-oriented. Also recordings/live tv works quite OK on channels without DVB subtitles.

Link to post
Barleyman

That is, problem happens using 1.4.7.96 service. I'll check .105 but at least changelog does not suggest anything like this being changed.

 

2x TT C-1501 cards in XP SP3, no CI in use.

Edited by Barleyman
Link to post
Barleyman

Yup, it's borked with .105 also.

 

Like so:

dvb.jpg

 

Logfile reads like so:

Yle TV1 21.4.2009

 

D:\DVB-Record4-21_21-29-53_Yle TV1_Generation Kill (K15).ts

 

Device: TechnoTrend BDA/DVB-C Tuner (1)

 

21:29:53 / 0:00:00 (~ 0,0 MB) Start

21:29:54 / 0:00:01 (~ 0,4 MB) Errors: 806

21:29:54 / 0:00:01 (~ 0,4 MB) PID 512: MPEG2 Video, 16:9, 720x576, 25 fps

21:29:54 / 0:00:01 (~ 0,4 MB) PID 650: MPEG Audio Stereo, 48 khz, 224 kbps

21:29:54 / 0:00:01 (~ 0,4 MB) PID 651: MPEG Audio Stereo, 48 khz, 224 kbps

21:29:55 / 0:00:02 (~ 0,8 MB) Errors: 841

21:29:56 / 0:00:03 (~ 0,8 MB) Errors: 60

21:30:57 / 0:01:03 (~ 0,8 MB) Stop

 

Average Data Rate: 0,013 MB/s

Total Size: 0,8 MB (845624 Bytes)

Link to post
Barleyman

Not a bad idea. But the _other_ cable muxes (who do not use DVB subs) work just fine. Here's one I made earlier today:

Nelonen HD 21.4.2009

 

D:\DVB-Record\Officer Gentleman4-21_16-40-00_Nelonen HD_Unelmien poikamies.ts

 

Device: TechnoTrend BDA/DVB-C Tuner (1)

 

16:40:00 / 0:00:00 (~ 0,0 MB) Start

16:40:01 / 0:00:00 (~ 1,8 MB) PID 401: H.264 Video, 16:9, 1920x1088, 25 fps

16:40:01 / 0:00:00 (~ 1,8 MB) PID 402: MPEG Audio Stereo, 48 khz, 256 kbps

17:03:51 / 0:23:50 (~ 2697,1 MB) Errors: 7

17:04:35 / 0:24:34 (~ 2780,0 MB) Errors: 2

17:05:30 / 0:25:29 (~ 2883,7 MB) Errors: 1

17:06:07 / 0:26:06 (~ 2953,5 MB) Errors: 1

17:07:12 / 0:27:11 (~ 3076,1 MB) Errors: 1

17:12:49 / 0:32:48 (~ 3711,5 MB) Errors: 1

17:45:41 / 1:05:40 (~ 7430,8 MB) Errors: 2

17:55:00 / 1:14:59 (~ 8484,8 MB) Stop

 

Average Data Rate: 1,886 MB/s

Total Size: 8484,8 MB (8896963136 Bytes)

Edited by Barleyman
Link to post

You call that working??? this is how a recording hast to look like:

\\POWERPC\Public\Recorded TV4-07_03-35-03_kabel eins_Babylon 5 - Spacecenter Babylon 5.ts

 

Device: 713x BDA DVBS Tuner (3)

 

03:35:03 / 00:00:00 (~ 0,0 MB) Start

05:15:00 / 01:39:57 (~ 3058,0 MB) Stop

 

Average Data Rate: 0,510 MB/s

Total Size: 3058,0 MB (3206552064 Bytes)

see the difference? None, nada, Null, zipp errors. ;)

 

So I think you should:

1. check which channels are really heavy affected (frequency) is there a pattern? (forget the subtitles as an indicator. It must be something else)

2. check your cables

3. check your connections

4. check your cable outlet.

 

We're under quite heavy surveillance (maybe wrong wording but don't find a fitting translation just now ;):D) by our finnish friends and users, so if this problems would be software based, we would have for sure a lot more reports of it.

Link to post
Barleyman

OK, you're right.

 

I spend many hours doing exactly that, up to and including wiping out entire DVBViewer setup and starting over, just in case. It seems the problem is indeed SNR issue. It's interesting it suddenly developed with no changes whatsoever to the actual cabling setup here.

 

Now that you mention it, there ARE guys tearing up the road next block so it's quite possible there's connection between that and sudden drop in signal quality as the problem appeared last week with zero problems before for a year. :D

 

In any case, I tested a few alternatives on the cabling side and it seems to be very sensitive now to signal level - If I have one decent cable splitter between wall and DVB tuner card I start losing signal quality / cable muxes. I usually have two in series with no issues.. Straight cable is OK but not practical.

 

Sorry to waste your time, but there have been so many problems with the dvb subs and having that one particular mux collapse seemed a bit too much of a coincidence.. For the record there doesn't really seem to be a pattern to which muxes drop. I suppose they would have had lower signal quality to start with.

 

Is there any way to display the SnR btw? Would be helpful WRT complaining to the cable operator?

 

One feature request:

It'd be nice if in the epg search page when you enter a new name to the search preset box and save, it would create a new preset with that name, not overwrite whatever was the previous preset you made!

 

This can easily happen when making more than 1 search at a time..

Edited by Barleyman
Link to post
Idea.

 

I use rainlendar calender and there is nice TV addon.

There i can see actual programs.

 

That rainlendar is nice, but maybe vista gadgets is more common.

 

So, how about if i can start one button record from vista gadget?

 

My friend do that.

Don't know if there is any DVBViewer gadget, but this one use RSS feed. Maybe only finland now.

 

Only first beta, still ugly, but it work. Just press rec button and service start record.

That is all what i need.

 

For Recservice use, edit gadget.js file and add this text to end.

 

wshShell.Run("dvbv_tvg.exe -d " + title + " -c " + channelID + "|" + channelName + " -e " + recordDate + " -s " + recordTimeBegin + " -p " + recordTimeEnd + " -a 0 -xf 2 -xu -xsvc ,,User:password@82.123.14.11:8080");

 

http://japesone.kapsi.fi/gallery/Images/ka..._kuvat/mRSS.jpg

http://japesone.kapsi.fi/files/mRss.Gadget.7z

 

Oh, and help.txt is only for finnish. :D

Edited by janip
Link to post
Springveldt

I've noticed a couple of issues with the recordingservice on a couple of occasions now. My setup is I have 2 Skystar2 pci cards.

If I have a DVBViewer client open watching a channel and the recordingservice starts a recording it changes the channel automatically, which I understand. The problem is that I then can't change the channel, it is stuck on the recording channel. Every other channel just displays a black screen, even issuing Rebuild Graphs commands do nothing. If I close DVBViewer and restart all is fine, I can change channel without problems.

Both cards are using channel group A and I don't have a problem using both tuners, the issue only arises if I have DVBViewer open when a recording starts. That is with DVBViewer beta 50 and recordingservice beta 1.4.7.96.

 

2nd issue is that some of my Search Presets just disappeared. I set up my presets a few weeks ago and all of them have no time range but for some reason 2 of them just disappeared. No idea why, I've since re-added them and they are still there now. Sorry I can't give exact details as how to replicate as I don't know how to myself. :(

Link to post

Please try the current Beta Versions (1.4.7.105 4.0.1.55) and if there is still a problem attach a support.zip otherwise your report will change nothing.

Link to post
SakuraNekoCS

hi everyone

i am a user in hongkong (and thus my ways of expression aint good- -" sorry)

my version of dvbviewpro and rec.svr is 4.0.0.0 and 1.4.7.110 resp.

my problem is, when i called the configure window of the DVBViewer Service and tried to change the settings, eg save format, dont write log file etc,

and after pressing OK, when i opened the configure once again, it would not change a bit at all

that is, whatever changes i made in the rec.svr (not the dvbviewerpro settings!), it wouldn't change even if i had saved it.

 

i am not sure that whether or not anyone had asked this silly question already, nor my poor english can be read by anyone- -"

but it is affecting me at the time of speaking, especially i cannot use ts to save the file nor save the subtitle,

so when i watch jimmy's cooking lessons or person break, i cannot exactly know the ingredient of the dishes or the plans of prison breaking

 

in addition my win is windows 6.0 service pack1 and i hasn't reinstalled the DVBViewer and rec.svr yet

being sorry again for asking such nonsense question

Link to post

your running most likely it in the wrong usermode or there are access rights issues with the userdata folder...

Link to post

I've just updated from 1.4.7.95 to 1.4.7.110 as I wanted to take advantage of the after recording process task introduced in 1.4.7.96 to patch my BBC HD recordings.

 

I've created a batch file as:

 

@echo off

echo Start: %date% %time% > %1.fix.txt

echo File : %1 >> %1.fix.txt

START /WAIT c:\DVTools\BBC_HD_Fixer.exe -c %1

echo End : %date% %time% >> %1.fix.txt

 

and a task as:

 

<task name="Fix BBC HD" tasktype="1">

<Description>Patch BBC HD recordings</Description>

<Properties>

<Filename>C:\DVTools\BBC_HD_Fixer.bat</Filename>

<Parameters>"{SOURCE_FILE}"</Parameters>

<WorkDir/>

</Properties>

</task>

 

This is being executed when recordings are finished (I can see this from the .fix.txt file I create and can also see BBC_HD_Fixer.exe in the task manager), but the shutdown action of the recording timer (I'm using standby) is NOT handed down and doesn't get executed after the process task timer ended, it just finishes the process task and does nothing.

 

Any idea what could be wrong?

Link to post
Confirmed, there is a problem, I take care of it.

 

Great, look forward to the update.

 

Sorry I have sent you the PS3 UPnP logs I promised. Will try and sort this over the coming weekend.

 

Rob.

Link to post
SakuraNekoCS

i wonder where exactly the userdata folder (or the ini files) is,

i've checked up :\ProgramData\CMUV, :\Program Files\DVBViewer and i couldn't find the settings of rec.svr

 

do :\ProgramData\CMUV\DVBViewer\config store every setting of the DVBViewer Recording Service?

 

i belongs to the administrator usergroup

Link to post
Lars_MQ

Open the Recording Service Options (right click on the systemtray icon and select "Configure". In the following window click on the link "Show Configuration folder". This opens an explorer window.

Link to post
SakuraNekoCS

yes i can open it, but i still couldn't find the setting file in which the "software setting" eg saving format was stored

i see searches.xml, 128b; svchardware.xml, 934b; svcuserdata.xml, 274b; tasks.xml, 125b; svbtimers.xml, 58b; epg.dat, 140kb; webstreaming.ini, 258b and finally the service.xml which occupied 2.16kb (i didn't show the .bak files)

is it the real setting file of the rec.svr? but inside all i could see is lots of blanks, that is the file doesn't contain a readable data(opened by notepad, cant be opened by eg word07 or ie8), i don't know if it's related to my notepad encoding(since my win is in chinese)

 

shall i upload the file?

Link to post
Lars_MQ

Well it seems the file service.xml is somehow corrupted. just stop the recording service, remove all files from the config folder and start the service options program to set up everything from a fresh start.

Link to post

Good evening,

first of all thank you for your great efforts and the interesting discussion. Useing the web frontend, i can start DVBViewer, time recordings and can stream video over internet using wmv and adjustable transcoding.

I would appreciate using DVBViewer recording service, but i can only anctivate direct playback via vlc (vlc 0.8.6i+activex plugin installed) ... playpack in browser is not possible, eihter with vlc or wmp. Is there a possibility to use DVBViewer recording service for internet video streaming? (direct playback doesn't fit to internet connection speed)

Thanx in advance, line

Link to post
Lars_MQ

It does work without problems here. You have to a. install the fitting plugin for your webbrowser on the client PC and you need vlc 0.8.6i on the pc which runs the DVBViewer recording service...

Link to post
It does work without problems here. You have to a. install the fitting plugin for your webbrowser on the client PC and you need vlc 0.8.6i on the pc which runs the DVBViewer recording service...

 

 

thank you for your quick reply,

i did everything you mentioned above ... anyway with http web server everythin is fine ... via WMP bowser plugin. Using DVBRecording service i can use direct connection but not in browser streaming with scaling features. VLC 0.8.6i on server VLC 0.8.6i with IE activeX plugin (installed via usual installation routine). I've actually no idea what to do. Again HTTP frontend works with no probs ... but i LIKE to use recording service.

Thanx and greets from aachen line

Link to post
Lars_MQ

aachen? well you could use the german part of the beta forum, this could make the dialog a little bit easier for both of us. :biggrin:

Link to post

I change windows 7 to my other computer and now i can't use unicast device.

Everything look good, when i go to unicast network device settings, i can see server.

But i get "no hardware available" error, when i start DVBViewer.

What could be wrong?

Link to post
Springveldt

I'm sure someone else had this problem before but I can't remember how it got fixed. Basically my autosearch timer is adding a duplicate for a specific search each time the autotimer is run. Now the weird part is I've actually removed the offending timer but the autosearch still keeps adding it!

Example of my timers page...

TimerDupes.jpg

 

Here is my xml file

Timers.jpg

 

There is no timer there for Teletubbies but the autotimer keeps adding it, even when it already exists. Does the RecordingService look at other places for the searches.xml file?

 

And yes most of that crap is for the wife and daughter. :bye:

Link to post

Am I going crazy or have the check boxes to delete (multiple) recordings been removed in 1.5 RC? I'm sure this feature was there in earlier versions.

Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...