Jump to content

Recordingservice Beta


Lars_MQ

Recommended Posts

what kind of entry? a error? or just a warning or information. please check if there are any plugins involved.

 

I'm using a fresh 4.0 install without any other plugins. And it's a warning in event-viewer. But it's a problem because the service is hanging in the 'stopping' state and so will not restart unless i kill any dvbv related proces.

 

Eppo

Link to post
  • Replies 602
  • Created
  • Last Reply

Top Posters In This Topic

  • Lars_MQ

    155

  • janip

    42

  • uglyned

    35

  • smallant

    22

Top Posters In This Topic

Popular Posts

Thanks, timerwindow work now. Maybe is good if webinterface "show timerwindow" setting is only for normal web use? Not for mobile.

Pleas post your support.zip   @all Please do not start new topics in this topic.   We have now a section for the Recording Service and it is hard to find informations in such a big mix topic. ht

Posted Images

Whenever i trie a radio station via upnp i have PH hanging in 'buffering'.

I cant see if this is a NMT - or a recordingservice problem.

 

Anyone with the same problem?

Link to post

Hi Lars,

 

I've been playing with the new service for a few weeks now and have a suggestion i hope you want to discuss:

 

Consider splitting the service into seperate services (applications) the recording service and the media extender streaming services.

Why?

The services have little in common. Also, it would probably open the possibility to use the streaming services also pointing to DVBViewer clients using unicast devices where you would probably keep the recording services bound to physical devices only.

 

This would imply also a split into the webpages for these different products, but they could be 'crosslinked': In a client setup i can point to the central recording services page.

 

Eppo

Edited by pastimer
Link to post

Hi Lars

 

Would it be possible to make the UPnP AV server work with a Linksys/KiSS DP600? With the DP600 I can see the server, but it does not list any content when I select it. The DP600 works fine with TVersity and Nero Home as UPnP servers, and your UPnP server of course works perfect with my Poppy. This is what my svcdebug log says:

 

09.01.2009 16:34:01 Start App		-----------------------------------
09.01.2009 16:34:01 thread		   service started
09.01.2009 16:34:01 StartService	 start timer
09.01.2009 16:34:01 StartService	 create plugin list
09.01.2009 16:34:01 StartService	 loadchannellist
09.01.2009 16:34:01 TDVBDevice.InitDevice 713x BDA DVBT Tuner
09.01.2009 16:34:01 TDVBDevice.InitDevice IPTV Network Device
09.01.2009 16:34:01 Device		   @device:pnp:\\?\pci#ven_1131&dev_7133&subsys_33064e42&rev_d1#4&bc67b8d&0&00f0#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{3ff44ee5-8547-402a-94f3-d447f4d7c400}
09.01.2009 16:34:01 loadsetup		load vcr
09.01.2009 16:34:01 StartService	 load setup
09.01.2009 16:34:01 Recorderservice  Enabled
09.01.2009 16:35:20 MAC			  found
09.01.2009 16:35:20 Client:		  DLNA-CP/1.0 KiSS_UPnP_STACK/1.0 UPnP/1.1 DLNADOC/1.00 INTEL_NMPR/2.0  
09.01.2009 16:35:20 MAC			  found
09.01.2009 16:35:20 MAC			  found
09.01.2009 16:35:20 MAC			  found
09.01.2009 16:35:20 MAC			  found

 

I guess this could be useful for owners of other KiSS players. Thanks a lot for your work with the recording service, even if you are not interested in this particular aspect.

Link to post
have you tried the hack with the alternative response (the one for the buffalo link theatre)?

 

Yes, I tried that too with the same negative result. I have also tried an old XBOX with XBMC in the same network socket as the DP600 and it works beautifully, so it's a KiSS specific problem. Anyway, it's not a critical functionality for me so if there are no more users of KiSS players around...Thanks anyway for your time.

Link to post

Hi Lars,

 

I don't know why you are ignoring my posts. If you have a problem with me, please tell me and maybe we can sort it out.

 

Anyway. I observed that when i'm streaming to PH on device X, device Y,Z are not available on dvbserver.

 

As soon as i stop the recordingservice, all devices are available.

 

So it seems that the recording service claims all devices although it is using only one.

 

Regards, Eppo

Link to post

Please check the status page in the webinterface, there you can see, which devices are currently in use. in use are devices which show the receptionvalue percentage.

The service only blocks the devices it does currently use (like all other DVBViewer related programs).

 

And no I'm not intentional ignoring you. ;)

Link to post
Doesn't it show anything at all, if you choose the entry, or does it show empty folders?

 

A blank screen, no folders at all. The only possibility is going back to the previous page (the UPnP server list).

Link to post

Hi Lars,

 

I'm not able to play any radio from popcornhour. TV is working great.

This could also be a ph problem.

 

Logging:

 

11.01.2009 00:14:55 tStreamClient Allocate TechnoTrend BDA/DVB-S Tuner (2)

11.01.2009 00:14:56 TVLCStreamer Allocate TechnoTrend BDA/DVB-S Tuner (2)

11.01.2009 00:14:58 Release TechnoTrend BDA/DVB-S Tuner (2)

11.01.2009 00:15:12 tStreamClient Release TechnoTrend BDA/DVB-S Tuner (2)

11.01.2009 00:15:12 tStreamClient Allocate TechnoTrend BDA/DVB-S Tuner (2)

11.01.2009 00:15:12 TVLCStreamer Allocate TechnoTrend BDA/DVB-S Tuner (2)

11.01.2009 00:15:14 Release TechnoTrend BDA/DVB-S Tuner (2)

 

So, two seconds after selection the device is released. But on ph it still says 'buffering' and after a few minutes returns to the menu.

 

Can you help me to find out what is happening?

Link to post

I can confirm that my poppy does not stream radio from the UPnP server. However, radio works with Nero Showtime as UPnP client. It can take up to 50 seconds to start streaming, though.

Link to post

Hi,

 

Observed: When dvbserver is started after recording service (the most common situation of course) no devices are available to dvbserver, even when EPG is not using the selected device. If then the recording service is stopped, anything will play again from dvbserver.

If thereafter the recording service is restarted, devices remain available to dvbserver.

 

Regards, Eppo

Link to post

Have you checked the status as I told you? My guess the epg update does block the device. I've been using service and server all the time and have no problems at all (3 dvb-s device here).

Link to post

Hi, sometimes I have to restart the recording service to get it work with PCH. Don't know exactly when, but I can select a channel and PCH starts buffering but no picture or audio. If I then restart recording service (without doing anything on PCH) the picture and sound is back.

 

Maybe problem with my setup but it would be nice if you could restart the recording service from the GUI thats is shown on PCH.

 

Regards

Stefan

Link to post

Hi Lars,

 

I have set up de recordingservice to record to a mapped network drive. Since I have Gigabit LAN in the whole house, I don't think this is a problem. However, there is another problem: De service does not want to start recording because it 'thinks' that the drive is full. (The recordingsystem seems unable to get the real free hard disk space from the network map... it shows "0,00 KB.")

 

This is the log of the service:

 

16.01.2009 21:21:40 R:1-16_21-21-40_ ..... n.mpg Disk full!

16.01.2009 21:21:40 R:1-16_21-21-40_ ..... n.mpg Discontinuities: 0 - Total size: 0,00 KB - Device:TechnoTrend BDA/DVB-S Tuner

 

This is what I propose: Can you add an extra checkbox in the configuration where we can choose to ignore the disk full-check? (I assume the recording service checks the free disk space, a value it probably gets from a call to a win API method, which results incorrectly to 0 for a mapped network drive.)

Link to post

Yes that's normal. The service runs in a service (user) account, managed by windows). This account has NO access to network or even knowledge of mappings (they are user dependend and your "normal" user account has nothing to do with the service user account). There is no easy solution for this. It is a build in windows "feature". :bye:

 

Oh I can implement your wish but it would do nothing. Disc full simply means, the service can not write the data... So disabling this would mean keep on writing no data :(

Link to post
Yes that's normal. The service runs in a service (user) account, managed by windows). This account has NO access to network or even knowledge of mappings (they are user dependend and your "normal" user account has nothing to do with the service user account). There is no easy solution for this. It is a build in windows "feature". :bye:

 

Oh I can implement your wish but it would do nothing. Disc full simply means, the service can not write the data... So disabling this would mean keep on writing no data :(

Ok, then what if I change the user that runs the service in the service list? And not using the mapped drive but the unc-path? Ex.: \\server\share\.

Would that make the above scenario work?

 

What you say is correct: the service user does not have the mapped drive (which is indeed the fact with windows and services) but shouldn't the log be showing another error like 'Map not found', 'Unable to write to folder', ... ?

Link to post

I'm having some problems getting my Popcorn Hour working with the Recording Service, and I think I may have also found a bug.

 

My host PC is running Vista, but has two network interfaces - 192.168.1.201 and 10.0.0.79. The Poppy connects on 192.168.1.201 and so in the recording service I have the config set so it listens on that interface:

 

rec-config.jpg

 

However, I also have Netlimiter installed which shows which ports each process is using. This shows the Recording Service is listening on the wrong interface on port 1900:

 

netlim.jpg

 

However, even if I disable the 10.0.0.79 interface, so the service then listens on the correct interface, I still cannot get it to work - on the Poppy the DVBViewer service never appears in the list of sources. I have tried this on my XP Laptop and it all works fine - the service appears on the Poppy and I can change channels, watch etc. So there is something strange about how it is running on my Vista machine. The odd thing is, in Netlimiter I can see the Poppy connect and establish a connection to the service.

 

Any help would be gratefully received.

Link to post

could it be a firewall issue? the netlimiter seems to have it's own.

 

for a fast check of the opened ports/adresses you should try sysinternals process explorer. it does at least show the listenning adress/Port combination correctly (and doesn't need installation :biggrin: ).

Link to post

I'm having some success with the Recording Service, so I thought I would share a few little problems I've had to see if there's any solution.

 

I have Dual Pinnacle Stargate DVB-S Tuners in Vista. I have recordings being scheduled from Digiguide, through dvbv_tvg.exe and into the recording service without ever having to run the DVBViewer app. I've also been able to stream channels to VideoLAN locally. I'm using VideoLAN or Zoom Player to watch my recordings. I've disabled the Recording Service plugin from DVBViewer because I don't want it to ever to any recording of its own or stop the service. I would only ever to use it to watch live TV although at the moment I can't do that because if the recording service is already recording something it will try and record it too, locking up both tuners with the same thing. Removing the plugin has solved one problem and created another. It would be great if there was a way to stop DVBViewer looking at the timers at all.

 

Problem number two is that sometimes when I go to the web interface only a small subset of my channels are visible in the TV guide. At first I thought it might be hiding services on transponders which weren't available due to hardware availability, but sometimes it happens when both tuners are idle and other times (like right now) both tuners are busy but all the channels are visible.

 

Problem three probably stems from the same issue as problem one. Sometimes VideoLAN can't connect to particular channels even though hardware is available. Restarting the service seems to do the trick, but not ideal if it's busy recording.

Link to post

Oops, forgot problem four. The timebuffer beginning and timebuffer end settings don't appear to work as I would expect (e.g. in DVBViewer). They don't have any effect on recordings scheduled by dvbv_tvg.exe or manually through the web interface. I guess they are only programmed to affect recordings from the web-interface's EPG.

Link to post

1. this is by design. It will change with the next versions.

 

2. Enable in the configurationspage of the webservice "show channels without EPG"

 

3. have a look into the statuspage of the webinterface, if there really is a free device.

 

4. Completly normal and works the same as in the DVBViewer. Neither external nor manual generated timers are affected by the timerbuffer settings.

Link to post

Problem 1:

If you don't want to have DVBViewer recording, you can install a second instance of DVBViewer (be sure to change the path in usermode.ini). So the second instance of DVBViewer knows nothing about the recordings that are scheduled for the first instance (and that the recording service will handle).

Issues:

1. Not possible to program timers via the second DVBViewer

2. The second DVBViewer is able to block dvb hardware with watching tv, so that recordings can be blocked (a possible solution could be to configure the second DVBViewer as unicast client for the recording service, maybe that will resolve issue one someday, too :)).

Link to post
could it be a firewall issue? the netlimiter seems to have it's own.

 

for a fast check of the opened ports/adresses you should try sysinternals process explorer. it does at least show the listenning adress/Port combination correctly (and doesn't need installation :) ).

 

Thanks Lars. I don't have the firewall part of Netlimiter enabled, and Process Explorer doesn't really show any more other than what I have already seen.

 

However, this is now really starting to drive me nuts. I have a second Vista machine (single NIC) so installed DVBViewer and the Recording service on there. With POPI and UPNP enabled it immediately appeared in the list of sources on the Popi, and worked fine.

 

Back on the PC where I want to get it going, I tried:

 

Disabling the second NIC

Disabling Windows Firewall

Disabling the SSDP discovery service (so only the recording service was listening on UDP 1900)

 

and it still wouldn't appear on the Popi.

 

I then ran Wireshark on both PCs, and the dialogue on both with the Popi was identical. I could see the Popi do it's SSDP broadcast, the recording service answered, they send each other their URLs - but still nothing. It looked the same on the one that does work, so I have no idea why it doesn't work on my main PC.

 

I have found a sort of a workaround. In Wireshark I can see the recording service advertising it's URL, so on the Popi I set up a Web Source for the following:

 

http://username:password@192.168.1.201/popi

 

(username and password are what you have configured in the recording service)

 

and it works.

 

So not the end of the world, but I don't know what else to try to get it working properly. If anyone else has had this problem and fixed it, please let me know!

Link to post
If anyone else has had this problem and fixed it, please let me know!

I would also be interessted in a solution or a hint where the problem could be. I'm a little clueless myself what goes wrong there. :)

Link to post
  • 2 weeks later...

Discontinuities: 9793 - Total size: 1,24 GB - Device:TechnoTrend BDA/DVB-C Tuner (2)

I get two bad recordings. How i can try to find reason for that?

 

I Think that vista or i do something stupid in sametime, when service is recording.

Is there any log in vista, where i can compare "Discontinuities" time? And how i can see exact times for Discontinuities in services log?

 

My configuration:

 

Redordingservice- TechnoTrend BDA/DVB-C Tuner (2) and Cinergy HTC USB XS Digital Tuner (3)

DVBViewer- TechnoTrend BDA/DVB-C Tuner (2)

Link to post

open the configuration app (right click on the tray icon and select options). Go to recordings -> check write log.

 

But this amount of disconties is a sure indicator that something is very wrong with your reception or that you run the system at 150% cpu usage all the time :)

Link to post

Lars, a question about the new version 1.4.7.40 before I install it. Will the command line tool dvbv_tvg.exe still be able to place timers into the Recording Service? The release notes say that the service now has it's own timers xml, so I was wondering if dvbv_tvg.exe will still put timers into DVBViewer and not the service?

 

Thanks.

Link to post

Yes, it will work. The timers will have only the defaultsettings in the additional properties, but this should pose no problem, because it was this way before. :)

Link to post

The UPnP server isn't working with XBMC (tried Windows and Xbox versions) I reverted back to the previous version and is working again. Could you check it?

 

Thanks in advance.

Link to post
McenterFreak2

I haven't installed the new version, and i would like to know if the problem with disabling of scheduled recordings are solved. eg. if i schedule a recording to be done every day at 17:30 it works, but if i start DVBViewer when the rcording goes on, i am asked something like this "A recording is going on, do you want to stop it?". When answering No, the recording continues. BUT now the scheduled recordings ar now marked as disabled, and no more future recording is done. Very anoying!

Link to post
open the configuration app (right click on the tray icon and select options). Go to recordings -> check write log.

 

But this amount of disconties is a sure indicator that something is very wrong with your reception or that you run the system at 150% cpu usage all the time :)

 

I think i watch hdtv with ati dxva sametime, but i am not sure.

What if problem is only poor signal and there is nothing wrong on my htpc? Can i see that service log?

Link to post
I haven't installed the new version, and i would like to know if the problem with disabling of scheduled recordings are solved. eg. if i schedule a recording to be done every day at 17:30 it works, but if i start DVBViewer when the rcording goes on, i am asked something like this "A recording is going on, do you want to stop it?".

which part of

The Timers.xml of the DVBViewer is not used any more

(source changelog) do you not understand?

 

 

 

The UPnP server isn't working with XBMC

Works without problems. please check your settings.

Link to post
Works without problems. please check your settings.

 

I found the problem: if the UPnP AV server is enabled, the service ends (see the attached log) so neither the Webserver nor the UPnP server is running :)

 

Any info you need to fix this?

svcdebug.log

Link to post
please check your settings.

 

I'm using exactly the same settings with versions 1.4.7.10 and 1.4.7.40 (upnp server at 192.168.0.3, port 8889) and as I wrote before, with 1.4.7.40 if the upnp server is enabled, the service ends.

Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...