Jump to content

Premiere HD/ Discovery HD gleichmäßiges ruckeln nach wenigen Sekunden


searge

Recommended Posts

Hallo zusammen.

 

Vor einem Monat noch hatte ich bei der HD-Wiedergabe mit DVBViewer 3.6.1.20 kein Problem.

Nun aber hat sich folgendes "Phänomen" eingestellt:

Premiere HD und Discovery HD laufen die ersten Sekunden nach dem Programmwechsel

noch flüssig (Änderungen bei den Audio/Video-Filtern haben den selben Effekt) und dann

"hakelt" die Wiedergabe gleichmäßig. Auch die Wiedergabe der FTA HD Kanäle (H.264) ist nicht

ganz sauber.

Die CPU-Last beider Kerne kratzt kaum die 50%-Marke.

Mein System (Vista Ultimate 32bit) ist auch ausreichend dimensioniert (Core 2 Duo E6600@3000MHz, 2GB RAM, GF 7600 GT PCI-E).

Als TV-Karte setze ich die TT 3200 (BDA-Treiber 4.4.10.18) von Technotrend ein.

Darüber hinaus nutze ich den Nvidia-Treiber 158.42 und für den Sound den 1.69 für Realtek HD.

Des Weiteren verwende ich PowerDVD Ultra 7.2 und daraus den entsprechenden H.264-Codec.

Das seltsame ist, dass ich bis vor einem Monat keinerlei Probleme hatte.

Deshalb habe ich Treiber und Codecs im Verdacht, da ich diese nach Möglichkeit immer auf den aktuellen Stand

halten möchte. Nun habe ich schon diverse Treiber-Install- und Konstellationen ausprobiert und habe auch sämtliche Foren durchforstet, aber eine Lösung konnte ich bislang nicht finden.

Meine einzigen Erkenntnisse bislang: Ein Nutzer mit dem gleichen Problem (Future777), der den Audio AC3 von Cyberlink auf

AC3-Filter umgestellt hat und damit glücklich wurde (hat bei mir nicht geholfen). Und ein Nutzer, der die Werte in der DVBSource geändert hat (Latency: 1000 Max Qued Audio (ms): TV Radio: 1500 File: 0). Letzteres bringt bei mir auch eine deutliche Besserung bei Premiere HD, aber andere Sender bekommen dann neue Schwierigkeiten (Ruckeln oder das Bild bleibt schwarz). Beide Nutzer haben den Sound(-Treiber) im Verdacht...

 

Mich ärgert vor allem, dass bis vor kurzem noch alles rund lief und ich nun diesen Zustand nicht mehr rekonstruieren kann.

 

Hat jemand bereits ähnliche Probleme beobachtet und vielleicht eine Lösung gefunden?

 

Für Tipps und Lösungsvorschläge wäre ich dankbar. Ich kann auch gerne später noch einen Support.zip anfügen, wenn es hilftreich ist.

 

Danke vorab,

Searge

Link to comment
  • Replies 311
  • Created
  • Last Reply

Top Posters In This Topic

  • Moses

    30

  • uglyrooster

    29

  • CiNcH

    32

  • darky

    21

Top Posters In This Topic

Posted Images

Bei mir ist das Problem auch wieder da. Der AC3Filter war ein Sackgassen-Tipp, denn nach ein paar Neustarts des DVBViewer war das PRoblem wieder da. Die Programme laufen für ein paar Sekunden ruckelfrei, und dann stottert das Bild gleichmässig vor sich hin.

 

Ich verwende den DVBViewer aber ohnehin nur noch zum Aufnehmen. Und das funkioniert sehr gut. Schaut man sich die Filme halt später an...aber seltsam ist es schon.

 

viele Grüße

Future

Link to comment

Also ich hab auch so ein Problem, wie von searge beschrieben. Aber das Ruckeln äußert sich so, dass es anfangs die ersten 10-20 sec. problemlos funktioniert (nichts ruckelt), dann aber anfängt zu ruckeln. Wobei man dabei sagen muss, dass dieses Ruckeln bei schnellen Bewegungen und Kamerafahrten zu sehen ist. Bewegt sich die Kamera oder die Personen ganz langsam, ist es nicht so deutlich zu sehen.

 

Nun habe ich schon diverse Treiber-Install- und Konstellationen ausprobiert und habe auch sämtliche Foren durchforstet, aber eine Lösung konnte ich bislang nicht finden.

 

Welche DVBViewer Version hast du installiert? Ich habe die aktuelle beta 3.6.3 im Einsatz und im Verdacht.

Edited by darky
Link to comment

Die Erhöhung der Latency im Filter scheint etwas zu bringen, selbst wenn die Buffers unverändert bleiben. Umgekehrt bleibt das Problem.

 

Eine Erhöhung der Prozesspriorität auf Realtime bringt auch eine massive Verbesserung, selbst wenn scheinbar keine anderen Prozesse den DVBViewer behindern.

Link to comment

Ja, das mit der Prozesspriorität ist mir auch schon aufgefallen. Manchmal scheint es mir auch so, als ob der DVBViewer nicht alle Ressourcen nutzen würde (bei HDTV ja eher nötig), da die Prozessorlast teilweise auch "nur" 40-60% beträgt.

 

mein sys:

 

- OS: Vista 64bit

- MB: K9A Platinum, Rev. 1.0

- RAM 4 GB RAM DDR2-800 Corsair XMS

- GraKa: ATI x1900xtx

- CPU: AMD x2 3800+ @2,6 GHz

- Soundkarte: X-Fi Platinum

- TV: TT3200, Treiber 5.0.0.2 (beta)

+ PowerDVD Ultra 7.3 (ohne Patch 2911)

+ DVBViewer 3.6.3 (beta)

Edited by darky
Link to comment

@Darky

 

Ergänzend hier mein System samt Treiberversionen:

 

Vista 32bit

CPU: Core 2 Duo 6600

MB: GA-965P-DS3 (rev. 1.0)

RAM: 2GB DDR2-667 (2x1GB)

GraKa: GF 7600 GT (154.24)

Sound: Realtek HD (1.69)

TV: TT-3200 (4.4.10.18)

+ PowerDVD Ultra 7.2

+ Vista Codec Pack

+ DVBViewer 3.6.1.20

Link to comment

@darky

Die 3.6.3 (beta) hatte ich auch bereitsgetestet und auch der Beta-Treiber von TT war zwischenzeitlich installiert.

Den PowerDVD 7.3 Ultra hatte ich auch versucht (der soll allerdings Grütze sein).

Es waren keine positiven Änderungen feststellbar.

Was mich insboesondere stutzig macht, ist der Tatbestand, dass die ersten Sekunden immer flüssig sind

und erst dann die Probleme auftreten.

Was verändert sich denn dann noch?

Liegt es am Puffer, der dann komplett ausgelastet ist?

Kennt sich jemand mit den Einstellungen unter DVBSource aus?

Was bewirken die eigentlich?

Link to comment

Was habt Ihr denn für ein CAM? Vermutlich kein Alphacrypt-Light.

 

Alle anderen (Hardware-)Lösungen sind kritisch, auch wenn teilweise behauptet wird, dass den Stream das nicht interessiert (was leider nicht so ist).

Link to comment

Nehmt mal was auf, oder nutzt Timeshift, läuft dann die Wiedergabe flüssig?

Falls ja, dann liegt es wahrscheinlich irgendwie an der Soundkarte. Griga hatte das mal in einem Thread erklärt. Die Soundkarte ist quasi die Uhr nach der die Wiedergabe funktioniert. Wenn die Uhr jetzt nicht synchron mit der "Uhr" vom Lifestream läuft, dann kommt es zu so Problemen, entweder ist sie zu schnell -> es stockt, weil auf neues Material gewartet werden muss, oder sie ist zu langsam, dann laufen irgendwan die Puffer über und Bilder gehen verloren -> sieht aus wie ruckeln!

In beiden Fällen sollte das raufsetzen der Latency das ganze ein wenig kompensieren... bei 4 Sekunden (man muss dann auch immer 4 Sekunden warten, bis Bild da ist, zusätzlich zur Zeit, die für das Umschalten sowieso gebraucht wird! Zappen ist da nicht mehr :bye:) wird das ganze schon mehrere Stunden gut gehen können... :bounce:

 

Man könnte mal Reclock versuchen, das ersetzt die Uhr der Soundkarte und soll angeblich hoch genau sein und daher ein super flüssiges Bild geben... es kann aber natürlich zu genau den gleichen Problemen führen!

 

Zum CAM: dem CAM sollte das Format ob MPEG2 oder MPEG4 (H.264) vollkommen egal sein, aber das CAM kann durchaus mit der hohen Bitrate in Schwierigkeiten kommen! Das Alphacrypt kann das auch erst seit der 3.11 / 1.11 Firmware. Wenn es aber am CAM liegt, dann sind die Fehler auch in der Aufnahme, und auch auf anderen PCs bei der Wiedergabe zu sehen.

Edited by Moses
Link to comment
Eine Erhöhung der Prozesspriorität auf Realtime bringt auch eine massive Verbesserung

Vorsicht damit!!! Das kann üble Folgen für Aufnahmen haben, weil Windows eventuell nicht mehr dazu kommt, seinen Disk-Cache rechtzeitig wegzuschreiben, und das bedeutet Datenverlust (nicht nur theoretisch, schon passiert). Aus der Win32 Developers Reference:

 

REALTIME_PRIORITY_CLASS: Specify this class for a process that has the highest possible priority. The threads of the process preempt the threads of all other processes, including operating system processes performing important tasks. For example, a real-time process that executes for more than a very brief interval can cause disk caches not to flush or cause the mouse to be unresponsive.

Deshalb wird das im DVBViewer nicht als Priorität-Einstellung angeboten.

Link to comment

Stimmt und lässt sich auch nicht mit allen Programmen machen.

 

Mit DVBViewer seit Monaten (inkl. excessiven Tests) kein Problem, aber natürlich muß jeder selbst wissen, was er da macht.

 

Ein kleines Programm (Process-Tamer) kann die von Griga genannten negativen Effekte etwas einschränken.

 

Vielleicht kann Griga in einer kommenden Filterversion die Latency für MPEG2 und H264 getrennt behandeln. In der Tat wird mit hohen Latency-Einstellungen das Rucklen behoben, das ist aber nur notwendig bei H264. Bei MPEG2 hat man so den Nachteil der längeren Umschaltzeiten.

Link to comment

@uglyrooster

Ich kann bestätigen, dass die Latency-Einstellungen eine Besserung bewirken,

aber was ich nicht verstehe ist, dass es vor einigen Wochen ohne Modifikationen problemlos lief.

Ein Problem der Hardwarezusammenstellung kann es somit eigentlich nicht sein.

Deshalb beschränkt sich meine Fehlersuche nun auf Treiber, DVBViewer-Versionen und Codecs.

 

Zum Testen habe ich meinen Realtek Sound-Onboard-Controller deaktiviert und deinstalliert.

Anschließend habe ich denn eine SB Audigy samt aktuellem Vista-Treiber installiert.

Das Problem blieb bestehen.

 

Mag sein, dass der Sound das Problem verursacht, aber die eigentliche Problemquelle ist es nicht.

 

Es bleiben noch viele Rätsel offen.

 

Nebenbei noch eine andere Frage, auch wenn sie hier im Thread nicht ganz richtig platziert ist.

Ich habe gesehen, dass Purevideo HD die PCI-E-Karten der Nvidia 7er und 8er-Reihe unterstützt.

Purevideo HD ist ja nun in den aktuellen Nvidia-Treibern berücksichtigt.

Weiss nun jemand, ob eine zukünftige DVBViewer-Version Purevideo HD auch standardmäßig unterstützen wird?

In einem anderen Thread habe ich schon gelesen, dass mit DVBViewer GE und etwas Trixerei schon Teilerfolge erzielt wurden.

Link to comment

Purevideo HD wird unter XP bereits mit dem 165.01 NVidia-Beta-Treiber unterstützt und läuft prima. Der Treiber ist aber noch etwas buggy (paßt also zum Cyberlink :bounce: ).

 

Neuere Treiber sind mir bisher nicht bekannt, unter Vista läuft das so (noch?) nicht.

Link to comment
Es bleiben noch viele Rätsel offen.

..so ist das. Auch die frage nach den CAMs bleibt bisher offen. Wenn dann noch die GE in diesem topic ins spiel gebracht wird, wird hier vielleicht am falschen ende gesucht :bounce:

Link to comment
Vielleicht kann Griga in einer kommenden Filterversion die Latency für MPEG2 und H264 getrennt behandeln. In der Tat wird mit hohen Latency-Einstellungen das Rucklen behoben, das ist aber nur notwendig bei H264. Bei MPEG2 hat man so den Nachteil der längeren Umschaltzeiten.

 

Das (Heraufsetzen der Latenz) hat bei mir auch das Problem beseitigt. Den Vorschlag würde ich unterstützen.

Edited by darky
Link to comment

Ok, eine "Quick & Dirty"-Lösung: Im Mitgliederbereich, Beta-Sektion, gibt es eine Testversion 2.8.5.2 des DVBViewer Filters. Durch manuelles Ergänzen eines Eintrags in der DVBSource.ini lässt sich eine separate Latency in Millisekunden für H.264 festlegen:

 

[Params]

udH264Latency=4000

 

Wenn der Eintrag fehlt oder der Wert negativ ist, geht alles wie gewohnt. Die relevante DVBSource.ini befindet sich im Konfigurationsordner - ihr wisst ja hoffentlich, wie ihr den findet, und dass der DVBViewer bei der Manipulation nicht laufen darf.

Link to comment

Erst einmal vielen Dank Griga für die schnelle Lösung! Schade, dass sich niemand sonst bisher geäussert hat.

 

Also: Funktioniert prima. Die Buffers müssen mindestens zwei Drittel des Latencywertes betragen (ungefähr bei diesen hohen Werten), sonst kommt kein Bild.

 

Erste Tests einwandfrei, hatte heute nur keine Zeit.

 

Ich denke nur, wenn man so schnell reagiert hat man auch ein Feedback verdient! :bye:

Edited by uglyrooster
Link to comment
Ok, eine "Quick & Dirty"-Lösung: Im Mitgliederbereich, Beta-Sektion, gibt es eine Testversion 2.8.5.2 des DVBViewer Filters. Durch manuelles Ergänzen eines Eintrags in der DVBSource.ini lässt sich eine separate Latency in Millisekunden für H.264 festlegen:

 

[Params]

udH264Latency=4000

 

Wenn der Eintrag fehlt oder der Wert negativ ist, geht alles wie gewohnt. Die relevante DVBSource.ini befindet sich im Konfigurationsordner - ihr wisst ja hoffentlich, wie ihr den findet, und dass der DVBViewer bei der Manipulation nicht laufen darf.

 

Jetzt fehlt nur noch, dass man die Latency auch bequem über das GUI einstelln kann im Filter...

Link to comment

immer mit der Ruhe, das ist ein "Quick-Fix", der extra für euch paar, die das Problem haben, eingebaut worden ist... ausserdem ist es nichtmal ein echter Fix, sondern eher ein work arround... sei froh, dass es jetzt überhaupt halbwegs komfortabel nutzbar ist :bye:

Link to comment

Von meiner Seite auch erstmal Danke für den Q&D-Ansatz.

Eine Besserung, speziell bei Premiere HD ist erkennbar.

Obwohl nun die FTA HD-Kanäle nicht mehr ganz sauber sind.

Aber vielleicht bin ich nun auch Paranoid und sehe Bildverzögerungen, wo keine sind.

Wenn man die ganze Zeit mit den Feineinstellungen spielt, dann verliert man vielleicht etwas die Übersicht.

 

Ich teste zzt. auch ältere vistafähige DVBViewer-Versionen, die ich einfach mal parallel installiert habe.

Ich glaube, vor der Integration des DVBsource Filters (ich glaube also vor der Version 3.6) kann ich das Problem

nicht erkennen und insbesondere die FTA HD Sender erscheinen mir besser. Ich muss das ganze aber noch eindringlicher untersuchen.

Link to comment

Juhuuuuuuuuuu, und ich dachte schon mein CPU ist langsamer geworden !Früher konnte ich HD ohne erkennbaren ruckler anschauen und jetzt nach ca 3 Monaten kann ich das endlich fortsetzen.

 

So macht HD schauen wieder Spaß !!!

 

Am besten funktionierts bei mir so:

 

[Params]

udH264Latency=950

 

Dann ist der Cyberlink H264 Codec doch nicht schuld und auch der TT-budget / Nova BETA Version 5.0.0.2 (15.05.07) Windows XP and Vista 32bit and 64bit Treiber ist nicht schuld und Vista 64Bit ist auch nicht schuld !!!!!!!!!!!!!!!!!!!!!!

 

Ich freu mich schon auf die sauber lösung in der DVBSource

 

 

Wieder ein Problem das der vergangenheit angehört

 

MfG Nameless

Link to comment

Die Erhöhung der Latency ist sicherlich die richtige Spur, aber 100% behoben ist das Problem damit nicht.

 

Während früher die Ruckler permanent blieben (nach ca. 10 Sekunden) wird das durch die Erhöhung der Latency behoben. Bei horizontalen Schwenks (also offenbar hoher Bitrate) tritt das Problem immer noch auf, egal was in der Buffers oder der Latency angegeben wird.

 

Der grösste Vorteil so ist aber, dass es nach wenigen Sekunden wieder behoben ist und nicht bleibt, was vorher nicht war.

Link to comment
Die Erhöhung der Latency ist sicherlich die richtige Spur, aber 100% behoben ist das Problem damit nicht.

 

Während früher die Ruckler permanent blieben (nach ca. 10 Sekunden) wird das durch die Erhöhung der Latency behoben. Bei horizontalen Schwenks (also offenbar hoher Bitrate) tritt das Problem immer noch auf, egal was in der Buffers oder der Latency angegeben wird.

 

Der grösste Vorteil so ist aber, dass es nach wenigen Sekunden wieder behoben ist und nicht bleibt, was vorher nicht war.

 

> in einem anderen Thread hat jemand den Puffer (für Bild) auf 4000ms gesetzt und war danach wohl glücklich..

 

Tja, bei mehr als 1200 auf meiner Kiste kommt bei HD mal gar kein Bild mehr...

 

Irgendwie ist das alles seit Monaten Murx :P

 

Da wirft man hunderte von Euro für die miserablen Nvidia und Ati Grakas zum Fenster raus (siehe den Link zu TomsHardware vonwegen HD Bild mit den TestDVD´s...), wird von EVR 2911 Patches, wo hinterher die Hälfte nicht mehr geht, genervt und letztlich wird man dann zu WinVista genötigt, wobei man ein System erhält, was einfach nur noch quälend lahm ist und unfassbar nervig ist.

 

In Summe hab ich jetzt noch einen WinVista stehen mit dem man mit dem "Casimir666" Mediaplayer Classic-MOD wunderbar bei 6% CPU-Load auf einem Celeron 3 GHz H264 TS anschaun kann...

 

Von einem "normalen" Lifebetrieb als stabilen "TV-Tuner" für SD und HD sind wir mit dem DVBV leider noch weit entfernt.

 

Entweder nervt der MPEG2 Codec mit Interlaceartefakten rum, oder der HD Codec wackelt sich zu tode, und wenn das Bild mal passt

kackt irgendwas beim Audio wieder ab, weil irgend ein Anbieter meint er muesse mp2 mit 96 kbit senden und das der Codec

das wieder nicht mag ;)

 

Toll das die GE Version unter WinXP EVR/H264 Hardware "irgendwie" macht, nur als CI-User mit Premiere HD Abo bekommt man auch

hier wieder die Rote Karte.

 

Im Grunde drehen wir uns bei den laufenden Sachen im Kreis seit Monaten...Nvidia hat dies nicht, Ati kommt erst, wieder neue Karten,

die haben aber keine Treiber, sollen kommen, sind aber nicht da, wenn da - dann nur Vista... SO GEHTS EINFACH NICHT!

 

Ich denke ich spreche für viele geplagte Nutzer hier, wenn bei zukünftigen Beta-Versionen die Prioritäten etwas auf die eigentlichen

Probleme verlagert werden. An OSD-Fixes kam jetzt wirklich reichlich - nur wollen viele keine OSD-Tunings haben sondern endlich

ohne rumgepatche und gefummel mal die Fernbedienung in die Hand nehmen und einfach nur Life gucken & zappen ?!

 

Was sich die Meisten wohl Wünschen wäre dieses:

 

- WinXP mit einer ATI X19xx+ oder Nvidia 85/86xx GT(s) bei funktionierenemdem H.264 in Hardware!

- MPEG2 Video & Audio in SD ohne absemmeln beim zappen. Und keine Schutzverletzungen mehr beim umschalten von SD auf HD

 

Niemand will hier wirklich freiwillig dieses lame Windows Vista haben, wenn er zuvor ein 5 mal schnelleres XP hat, wo alle "bekannten"

Programme "einfach" nur seit Jahren laufen.

 

Der Kauf oder Nutzung eines DualCore nur um "etwas" H264 zu interpolieren, was eigentlich die sündhaft Teure Graka hätte

schon lange tun sollen ist absolut unzweckmässig. (und eine Frechheit...)

 

Es tut nun wirklich nicht not; a.) Einen Flughafen (wegen der zig Lüfter...) neben dem Beamer stehen zu haben beim Film schaun, b.) minimum 340 Watt Strom zu verheizen für ein halbwegs ruckelfreies Bild.

 

Lieber Entwickler: Macht doch mal bitte eine OSD-Tuning Pause und löst unser grösstes Problem: Nutzt doch bitte die

in den Treibern derzeitigen propitären Lösungen (meintwegen auch über EVR) um dem DVBV -endlich- H264 Hardwarewiedergabe

beizubringen - OHNE VISTA-Zwang. Ohne Blue-Screen-Nvidia-Beta-Treiber...

 

Das Latency/Fummeln/H264 Ruckeln sollte auch dringend gelöst werden. Sonst stehen wir nächstes Jahr noch da mit einer

reinen Off-line-Recording Lösung wo man brav das Video abschaltet, den Stream aufnimmt, dann die TS via Netzwerk zu einer "Vista-Glotzen-Only" Kiste schiebt und dann manuelles Timeshifting praktiziert.

 

Für jemand wie mich, der zig Codecs nutzt, Programme wie GordianKnot mit allen seinen zig Tools zum encoden im Einsatz hat um TS-HD Formate weiterzuverarbeiten ist Vista als "Hauptsystem" einfach keine Lösung. Statt 7 Stunden encoden auf einmal 17 Stunden nur weil

Vista pennt ???? - Nein danke...

 

Aber ansonsten: DVBV ist die beste Offline-HD-TS Recordinglösung die es gibt ;-)

 

Ach ja: Am CI-Support gibts nach wie vor das Problem mit einem Alphacrypt, das auf einem einem 1801-Nagra-Chan auf dem die PID´s 1702/1762 NICHT gesendet werden keine EMMs empfangen werden!

 

Was bei nem reinen HD Abo dazu führt, das man zwangsweise alle paar Wochen zum TIER-Update auf einen SD-Kanal gehen muss,

das es wieder "hell" wird. Bug im AlphaCrypt Classic oder im CI-Support des DVBV ?

Link to comment

OSD Tuning ist für TV gucken und zappen deutlich besser....

 

Deine Probleme mit den Nvidia / ATI Grafikkarten haben hier eigentlich nichts verloren, die solltest du an Nvidia / ATI richten. Wenn der Treiber nicht funktioniert, dann kann der DVBViewer daran auch nicht viel ändern, ausser vielleicht ein paar dreckige Work-Arrounds zu lassen, die aber nie eine optimale Lösung bieten werden.

 

Mich wundert ausserdem, warum du zu Vista "gezwungen" wurdest... da warst du wahrscheinlich zu voreilig? Mitlerweile gibt es hier im Forum ein paar Leute, die mit der Nvidia 8500/8600 unter Windows XP mit dem VRM9 Renderer im DVBViewer Pro wohl gute Ergebnisse erzielen.

 

Du kannst auch nicht sagen, dass es eine "Frechheit" wäre für H.264 Decodierung (nix Interpolation!) eine Dual Core CPU als mindest Vorraussetzung anzusetzen.... das steht so schon seit Monaten überall dabei! Da hättest du lieber bei der Grafikkarte sparen sollen und keinen Celeron geholt. :P

Eine Dual Core CPU kann man ganz Problemlos leise betreiben, wahrscheinlich noch besser als deinen Celeron. :)

 

Wenn du einer der ersten sein willst, die H.264 unbedingt mit der Grafikkarte decodieren müssen, dann musst du dich halt auf Beta Treiber und viel fummeln einstellen. So einfach ist das. Der Workarround mit der Latency ist hier als freundliches Entgegenkommen der DVBViewer Crew zu sehen und sollte auf keinen Fall so ein Post nach sich ziehen! Im übrigen verwundert es, dass bei dir gar kein Bild kommt... wahrscheinlich warst du zu ungeduldig. 4000ms Latency -> Bild kommt erst nach 4 Sekunden + die Zeit für Umschalten und CI initalisierung usw. Bei einer TT S2 3200 kommt man da schon über 10 Sekunden! Ausserdem müssen natürlich die Buffer groß genug sein um auch die 4 Sekunden Material auf zu nehmen, also stell nochmal nach. :o

 

Bei mir funktioniert HD im übrigen immer noch absolut prima auf der CPU (ja, Dual Core... eine Mobile CPU, daher stromsparender als dein Celeron und auch leiser gekühlt ;)) und in Windows XP und auch Premiere HD.

Link to comment

Also ich muss sagen das es bei mir auch nicht möglich ist eine udH264Latency von 4000 einzustellen, auch bei längeren warenten kommt kein bild, nur die meldung Graph Too Late (14),bei mir funktioniert es höchstens bis 1010.

 

Meine Hardware:

 

CPU AMD X2 4800

Mainboard A8N32-SLI Deluxe

2GB RAM

 

TT3200-DVB-S2 Satkarte

 

OS: Vista 64Bit

DVB-S2 Treiber:TT-budget / Nova BETA Version 5.0.0.2 (15.05.07) Windows XP and Vista 32bit and 64bit Treiber

Grafikkarte: Geforce 7800GTX / Aktueller Treiber

 

Ich finde DVBViewer ist zur zeit das Beste Programm in sachen DVB-S2 und bin sicher das die Programmiere auch wieder eine Saubere Lösung finden !

Währe zwar schön wenn der Bug schon bald gefixt würde , aber ich kann warten !!!

 

Hab vor 2 Tagen mal WatchTVPro ausprobiert und bei dem Ruckelt ein H264 Stream noch viel mehr.

Doch eins verstehe ich immer noch nicht bis ca 28.05 2007 lief DVBViewer mit DVB-S2 sender super flüssig und dann kam plötzlich das ruuckeln aus heitern himmel was wurde da verändert!

Link to comment
Premiere hat auf variable Bitrate umgestellt?

 

Zumindest haben sie die Bitrate vor ein paar Wochen etwas verändert (gesenkt). Zuerst damit auch die Bidlquali, aber mittlerweile ist diese wieder "fast" so gut wie vor der Änderung.

 

Ich kann nur immer wieder betonen, das die ATI1950Pro die Erleutung bei mir war in Sachen Bildqualität und Problemlosigkeit.

Perfektes MPEG2 in 50Hz und mein auf 2400MHz beschleunigter X2 3800+ reicht zusammen mit der wenigen "Beschleunigung" der 1950Pro aus, um HDTV perfekt genießen zu konnen. Pro7HD bei ca. 35-45% und PremHD bei max 80-85%.

Codec. Cyberlinks PowerDVD7.

Was will ich mehr?

Bin gespannt, was für Probleme User von Mengen mit der neuen HD2400/2600 bekommt. Auch hier wird es möglciherweise einige Treibergenerationen und PowerDVD-Updates beötigen bis die Sache "rund" läuft. Ich drücke mal die Daumen.

 

Nochmal: Wer schon eine Dual-Core CPU hat und JETZT problemfreies Fernsehen will: ATI 19xx-Serie kaufen !

 

Ach ja: Diese Tearing-Effekte bei dunklen Bildinhalten kommen von der automatischen Rauschunterdrückung der ATI-Karten. Diese lässt sich aber in der Registry abschalten und nach einem Reboot passt dann alles. Im AVS-Forum ist beschrieben wie es geht.

Link to comment

Also ich kann mich mit der GeForce 8600 nicht wirklich beklagen. Die Bildqualität bei MPEG-2 ist perfekt, dank perfektem Deinterlacing und Schärfe-Filter. Auch Bloomberg TV Germany zeigt eine perfekt "deinterlacte" Laufschrift.

 

H.264 funktioniert bei mir ebenfalls super. Kann bei mir die Instabilitäten mit dem 165.01 Treiber nicht bestätigen.

 

2 Kleinigkeiten würde ich mir seitens nVIDIA aber noch wünschen. Zum einen ist das der VMR-Bug (welcher ja für GF8-Treiber noch besteht) (der VMR-Fix im DVBViewer verursacht bei mir ein gestauchtes Bild bei SD Anamorph Sendungen), zum anderen die Zuschaltung der GPU-PostProcessoren bei HD-Material. Stört mich im Moment allerdings weniger, da ich auf den HD-Kanälen eh nur Spielfilme schaue, welche progressiven Ursprungs sind.

Edited by CiNcH
Link to comment

Eventuell hat sich auch die Art geändert, wie Video und Audio gemuxt werden. Dass der Wiedergabezeitpunkt bis zu 4 s in die Zukunft verschoben werden muss, damit es läuft, ist schon drastisch :P

 

Im Prinzip läuft es bei DirectShow so ab, dass der Videorenderer die decodierten Frames mit einem Zeitstempel speichert (Scheduling) und dann auf ein Zeitsignal des Audiorenderers hin das richtige Frame zum richtigen Zeitpunkt an die Graka ausgibt - so wird der Kram synchron. Dies ist schon allein deshalb notwendig, weil die Video-Frames nicht unbedingt in der Wiedergabe-Reihenfolge gesendet werden. Durch eine Vertauschung lässt sich oft die Kompression verbessern, zumindest bei MPEG2, und ich vermute, bei H.264 ist es ähnlich.

 

Deshalb wird Video fast immer mit einem Zeitvorsprung gesendet, d.h. die gesendeten Zeitstempel der Videodaten (PTS, Presentation Time Stamps) liegen weiter in der Zukunft als die der gleichzeitig eintreffenden Audiodaten. Damit wird der Tatsache Rechnung getragen, dass das Verarbeiten und Sortieren der Video-Frames länger dauert. Bei einem aktuellen Premiere HD-Sample betrug die Differenz 0.8 s, also relativ viel.

 

Was nun genau zu welchen Problemen in dem Decoder-Renderer-Graka-Komplex führt, kann ich schlecht beurteilen. Der DVBViewer ist schließlich nur das Frontend, und die verwendeten Komponenten sind nicht Open Source. Niemand (außer dem Hersteller) weiß wirklich, was darin vorgeht.

Link to comment

Also ich habe leider genau die gleichen Probleme wie oben beschrieben und bekomme sie leider auch durch den Workaround nicht gelöst.

 

Meine HW-Config:

CPU: Core2Duo E6600 (2x2,4Ghz)

RAM: 2x512MB DDR400 oder 2x1GB DDR2-800 (Kombimainboard, beides getestet, keinerlei Unterschied feststellbar)

GraKa: nVidia MX440

MainBoard: Asrock 775 Dual-VSTA

Codec: h.264 von PowerDVD 7.2

 

Ich habe ebenfalls mit den Latenzen herumgespielt und zwar eine Besserung erzielt, aber leider trotzdem noch kein perfektes Bild. Das Phänomen ist das gleiche wie schon oben beschrieben. Wie es jedoch vor ein paar Wochen war kann ich leider nicht sagen da ich da noch kein PremiereHD-Abo hatte.

Ebenfalls eine gewaltige Besserung brachte der Einbau einer nVidia 6600GT (AGP) mit entsprechendem Treiber. Die CPU-Auslastung hat sich mehr als halbiert, aber dennoch habe ich kein perfektes Bild.

Auch wenn man in den erweiterten Filtereinstellungen des Cyberlink ein wenig rumspielt kann man noch einiges verbessern, aber es ruckelt trotzdem sporadisch. Für die die es noch nicht wissen: Die erweiterten Einstellungen erreicht man durch Drücken der STRG-Taste beim klicken auf den Filter (im Menü Ansicht/Filter war´s glaube ich, sitze gerade auf der Arbeit).

Zu guter Letzt habe ich auch noch mit den PCI-Latencies rumexperimentiert und auch damit leider keine Besserung erzielt.

 

Zu 75% denke ich nicht das der DVBV das Problem ist. Wie Moses auch schon geschrieben hat können die DVBV-Jungs (und Mädels?) nur Workarounds liefern bzw. improvisieren, aber generelle Fehler im Codec natürlich nicht beseitigen. Allerdinx in den restlichen 25% spricht gegen den DVBV das verschiedene Codecs ähnliche Probleme haben.

 

Wenn man einigen Posts glauben schenken kann, dann ist derzeit die 8600GTS von nVidia die einzig gescheite Lösung. Dennoch schrecke ich vor einem Kauf zurück, da ich Angst habe mich damit auch nur im Kreis zu drehen...

 

Normale h264-Videos laufen auf dem PC im PowerDVD 1a, alles was vom DVBV kommt jedoch nicht. Im MPEG2-Bereich gibt es ja das Problem das sich viele Sender nicht an MPEG-Standards halten und einen nicht Konformen Stream senden der z.B. in dem ein oder anderen Player Probleme machen kann. Erst Programme wie z.B. ProjectX bereinigen die Streams dann. Ich würde mal darauf Tippen das das bei h264 ein ähnliches Problem ist. Die Frage ist nur was bei welchem Sender falsch läuft und ob man es in Echtzeit ggf. fixen kann. Mulitplexing anders?

 

In meinen Augen bleibt vermutlich erstmal nur abzuwarten welche Tricks den DVBV-Jungs noch einfallen bzw. wie Updates seitens PowerDVD oder anderen Codecs aussehen.

 

Grüße,

DarkSoul

 

P.S.: Hat eigentlich schonmal jemand die mitgelieferte Software der Kartenhersteller diesbezüglich mit dem DVBV verglichen?

Link to comment
Also ich muss sagen das es bei mir auch nicht möglich ist eine udH264Latency von 4000 einzustellen, auch bei längeren warenten kommt kein bild, nur die meldung Graph Too Late (14),bei mir funktioniert es höchstens bis 1010.

 

Versuch mal gleichzeitig den Puffer zu erhöhen, etwa 2/3 der eingestellen Latency (hier im Bsp. etwa 2700 ms), damit hat es bei mir funktioniert. Bei mir funktioniert es aber nun auch mit einer Latency von 950 ms.

Edited by darky
Link to comment

Habe auch das Problem das Pre...HD beim DVBViewer nach 5-10s anfängt stark zu ruckeln und teilweise ganz einfriert. Hatte früher schon mal Pre...HD absolut stabiel mit dem DVBViewer zum laufen gebracht. Aber gut da hatten die glaube auch noch keine variable Bitrate. Pro7HD usw. laufen übrigens auch absolut stabiel.

 

Bei mir bewirkt das erhöhen der Latens nur das aus dem Rückeln nun ein in größeren Abständen resultierendes Aussetzen von Bild und Ton über mehre Sekunden wird.

 

Habe auch folgende andere Tips probiert:

 

Timeshift -> das Ruckeln bleibt auch bei der Timeshiftwiedergabe

Aufnahme und abspielen mit PowerDVD und VLC -> das Ruckeln bleibt auch bei der Wiedergabe

alte Cyberlink Version installiert -> keine Änderung

CoreAVC Version 1.2 und 1.3 -> läuft mit keinem HD-Sender richtig

andere AC3-Dekoder ->keine Änderung

andere DVBViewer Versionen -> keine Änderung

andere Videorenderer -> keine Änderung

 

aber alles ohne Erfolg, hat noch jemand hier eine Idee woran das liegen könnte?

Link to comment
Aufnahme und abspielen mit PowerDVD und VLC -> das Ruckeln bleibt auch bei der Wiedergabe

 

Das ist ein gutes Zeichen dafür, dass dein System entweder einfach zu langsam ist (also die Hardware) oder irgendwo anders etwas Hakt, ausserhalb des DVBViewers und der Live Wiedergabe... da wird dir die Latenz auch nicht helfen. Die hilft nur genau dann, wenn es nur bei Live-TV ruckelt und Aufnahmen ruckelfrei wiedergegeben werden können.

Link to comment

Also bei mir tritt das Phänomen auch auf Astra HD, ProSieben HD und Sat.1 HD auf (verwenden über Astra alle denselben H.264 Enkoder?).

 

Mit eingeschaltetem PureVideo HD 2 der GeForce 8600 bleibt alles wunderbar flüssig.

 

Bei der Wiedergabe von Aufnahmen (Wiedergabe durch DVBViewer und DVBSource) bin ich noch etwas unschlüssig. Da scheint sich die Wiedergabe zwischendurch wieder etwas zu erholen und nur phasenweise zu ruckeln (jedenfalls scheint es deutlich besser zu funktionieren als die Live-Wiedergabe).

 

TT-Media Center ist auch davon betroffen.

 

 

Ich werde mir heute noch den 'InterVideo Video Decoder' mit DVBViewer GE zu Gemüte führen...

 

 

Achja, falls jetzt jemand mein System anzweifeln will... Ist ein Core 2 Duo @ 2.67GHz und eigentlich ziemlich frisch und gut konfiguriert. CPU-Last beträgt bei abgeschaltetem PureVideo HD 2 maximal 40% bei den hohen Bitrate von Astra HD (bei durch SpeedStep heruntergetakteten 2GHz).

Edited by CiNcH
Link to comment

Ok, InterVideo versagt komplett. Hat schon mal jemand einen anderen Dekoder probiert? Meine MainConcept-Demo ist glaub auch abgelaufen. Jedenfalls kommt keine Verbindung mehr zustande und es wird stattdessen der H.264 Dekoder mit höchstem Merit verwendet.

Edited by CiNcH
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...