Jump to content

Premiere HD/ Discovery HD gleichmäßiges ruckeln nach wenigen Sekunden


searge

Recommended Posts

das selbe problem hab ich auch... ka worans liegt kenn mich mit diesen ganzen sachen nicht so wirklich gut aus.. ich weiß nur das es bei mir anfangs alles super gefunzt hat und jetzt nicht mehr...

Link to comment
  • Replies 311
  • Created
  • Last Reply

Top Posters In This Topic

  • CiNcH

    32

  • Moses

    30

  • uglyrooster

    29

  • darky

    21

Top Posters In This Topic

Posted Images

musst Du wohl noch länger drauf warten. Hilfe gibt es hier leider nicht dazu. :-(

...für die 15 Euro hätte man auch einen schönen Kasten Bier kaufen können...

 

 

aber Du kannst ja gerne mal genau Dein Problem beschreiben, damit Dir jemand helfen kann usw. blablabla - und nützt auch nichts.

Edited by pappnase_01
Link to comment
...für die 15 Euro hätte man auch einen schönen Kasten Bier kaufen können...

 

Also ich weiß nicht, aber mich hat niemand gezwungen die Software zu kaufen. Ich habe kein Problem damit wenn etwas nicht 100pro funktioniert, ich aber genau weiß das sich die Entwickler Gedanken darüber machen und versuchen die Probs in den Griff zu bekommen. Du solltest lieber froh sein das Du für 15€ überhaupt so eine gute Software bekommst und nicht ständig versuchen hier negative Stimmung zu machen.

Link to comment

Ausserdem hast du doch schon eine funktionierende Lösung gehabt... oder nicht? Bzw. jetzt sogar zwei:

XP + Cyberlink Decoder von PowerDVD 7.2

Vista + Mainconcept Decoder

Was willst du mehr?

 

Wenn du unbedingt dein System durch Vista ersetzen willst, musst du halt damit leben auf Kinderkrankheiten des Systems zu stoßen. Dafür kann der Viewer ja immer noch nix.

Du kannst nicht behaupten, dass dir hier nicht geholfen wurde. Wenn es mit einem anderen Decoder Problemlos funktioniert, ist es eigentlich auch sehr merkwürdig anzunehmen, dass das Problem im DVBViewer liegt... da wird wahrscheinlicher ein Problem mit dem Decoder sein. Unter Umständen auch ein Problem in der Kommunikation zwischen Decoder und DVBViewer. Diese ist aber eigentlich standarisiert und da der DVBViewer eigentlich mit den meisten Decodern zusammen läuft, könnte man annehmen, dass er sich recht gut an den Standard hält, was einen dann wieder zu dem Decoder als Problemverursachter führt.

 

Du benimmst dich hier wie im Mittelalter... Töte den Boten bei schlechten Nachrichten ;)

Link to comment

1. der MainConcept-Decoder ruckelt zwar nicht unter Vista, jedoch ist auch hier das Bild irgendwie nicht fließend.

2. der MainConcept-Decoder kostet wiederrum Geld, das ich aber nicht mehr bereit bin auszugeben.

3. Cyberlink sind auch keine Blödmänner; wenn die einen Fehler im Filter hätten, würden die ein Update herausbringen

4. Cyberlink läuft ja wie beschrieben ca. 30 Sekunden sauber unter Vista und erst dann fängt das Ruckeln an; sehr merkwürdig; aber ich kann den Fehler nicht beheben, da ich 1: kein Programmierer bin und 2:den Source-Code nicht habe

5. Man sollte den Kunden schon darauf hinweisen, dass es mit HD (eventuell) Probleme gibt; sonst sieht das doch sehr nach Abzocke aus; wenn man das Teil als EierledengeWollMilchSau verkauft; Irreführende Werbung!!!

6. Vista hat bessere Hybernate Funktionen

7. Ich bin kein Beta-Tester und möchte auch nicht noch 6 Monate warten bis es vielleicht funktioniert; dafür bezahlte ich doch keine 15 Euro

8. ja, ich weiss, sonst funktioniert die Software ja; aber dafür habe ich sie nicht erworben; ich will damit HD sehen

 

9. So, wo bekomme ich jetzt mein Geld zurück? Dann werde ich sofort jede Version der Software von meinem Rechner entfernen und garantiere auch dafür, dass dies wirklich so ist. Anschließend gehe ich ins Geschäft und kaufe mir den Humax (oder so). Der kann HD und auch ohne das Ruckeln.

 

10. Ich weiss, ihr könnt auch nicht dafür; aber ich erst recht nicht.

 

11. nein, Moses, ich finde deinen Eisatz gut, und ich bin nicht sauer auf Du. Du kannst ja nicht dafür. Ich will nur eine Lösung, die auch richtig funktioniert, ohne wenn und aber und getestet habe ich jetzt lange genug. Für mich ist das Ding mit DVBViewer und HD jetzt (bei dem Entwicklungsstand der Software, sei es DVBViewer oder Vyberlink oder MS oder weiss Goitt wer) zu Ende. Keine Lust mehr; immer nur Testen und keine sinnvollen Ergebnisse. 8 mal Windows installieren und div. Treiber etc. testen sollte genügen. Vielleicht sollten sich die Entwickler vom DVBViewer mal langsam die Mühe machen, hier entsprechend zu testen. Sehe hier nämlich aus dieser Richtung gar nicht kommen.

Edited by pappnase_01
Link to comment

Naja, wenn man keine Lust auf Basteleien hat, da sollte man in den nächsten 10 Jahren noch die Finger von HTPCs lassen, egal was die können sollen. Da wird man mit einer Set Top Box immer besser bedient sein. :)

Link to comment

Wenn man mit DVBViewer Probleme hat, muss man in der Tat generell die Finger von HTPC's lassen.

 

Das Ruckelproblem ist definitiv auf CyberLink zurückzuführen, zweifelst du das immer noch an? Dass da umgehend Fixes kommen ist ziemlich realitätsfremd, da lebst du wohl etwas in einer Traumwelt oder hast mit IT überhaupt keine Erfahrung. CyberLink weiß wahrscheinlich noch nicht einmal von diesem Problem. Betroffen sind im Moment nur H.264 Kanäle auf Astra, seitdem da wohl Änderungen am Enkoder vorgenommen wurden. Bis vor einem Monat lief es noch problemlos. Leider ist es momentan noch relativ schlecht um H.264 Dekoder Alternativen bestellt.

 

Bitte kläre das mit dem Refund auf dem dafür vorgesehenen Weg. Ich persönlich hätte dafür kein Verständnis, müssen aber die DVBViewer-Verantwortlichen entscheiden. Hauptsache ich muss mir hier den Schwachsinn nicht mehr anhören und wir können wieder konstruktiv über kurz- oder langfristige Lösungen diskutieren.

Man hat dir hier lange versucht sachlich zu helfen obwohl du immer wieder provoziert hast. Aber irgendwann ist auch fertig...

Edited by CiNcH
Link to comment
So, wo bekomme ich jetzt mein Geld zurück? Dann werde ich sofort jede Version der Software von meinem Rechner entfernen und garantiere auch dafür, dass dies wirklich so ist. Anschließend gehe ich ins Geschäft und kaufe mir den Humax (oder so).

 

Wo bekommt man eigentlich diesen Humax für 15 Euro? :)

Edited by uglyrooster
Link to comment

übrigens: ich habe einfach mal die Grafikkarte ausgetauscht im Windows Xp. Treiber sind ja die gleichen. Sonst habe ich auch nichts geändert. Also 6600 gegen 8600. und schon ruckelt es wieder. das soll jetzt am cyberlink filter liegen? glaub ich nicht. dann doch wohl eher am grafikkartentreiber. aber wie auch immer - es funktioniert nicht - also für mich unbrauchbar. ich weiss, da gibt es tausend zufriedene kunden; die machen aber kein HD. dann is ja auch alles gut.

 

und gegen das testen habe ich ja nicht auszusetzen. wenn der weg dann mal zu einem ziel führen würde. endet aber immer wieder in einer sackgasse. zumal das einmal geht, dann wieder nicht, dann wieder usw. und kaum glaub ich, dass wenigstens im ansatz etwas geht und dann war es das auch dirket wieder. ruckeln. ruckeln. ruckeln.

 

ich würde echt mal konstruktiv wie vorgeschlagen eine negativ liste aufstellen. wenn es dann wirklich nicht am DVBViewer liegt, dann wir sich das problem schon finden lassen. aber immer wieder nur einen kleinen teil davon zu betrachten (ein user hier ein anderer da), wird zu keiner lösung führen.

 

dann gebt mir doch mal einen richtig guten tipp:

also konfiguration ist windows vista 32 + nvidia 8600 + technotrend 3200 + cyberlink. und wie jetzt? ruckelt - und nun?

das kann der entwickler ja gerne selber testen - und diese hard/sofware ist ja nun wirklich nicht ungewöhnlich, oder?

wenn ich jetzt irgende eine karte aus der mongulei hätte oder so, aber so...

 

 

@urlyrooster:

130 Euro Technotrend + 15 Euro DVBViewer + 30 Euro Elecard (falls der dann sauber läuft), adaptersteckt dvi->hdmi 20 Euro = 195 Euro

Humax: 225 Euro - der geht. ohne die ganze ärgerei bis jetzt.

hat dann auch weniger funktionen - is klar - kann z.b. nicht übers netz streamen - ach ja - geht auch auch mit HD nicht im DVBViewer

wie gesagt, ist eine gute software, nur für mich nicht, weil ich die für HD erworben habe, und da geht es halt nicht :-(

Edited by pappnase_01
Link to comment

Nun, die 15 Euro sind dann der bisher geringste Anteil. Es klingt nur so, als ob Du auf eine Rückzahlung der 15 Euro warten musst, bevor Du Dir den Humax leistest.

 

Wir haben alle ein ähnliches Problem und mir wäre auch eine Aussicht auf Besserung lieber. So lange basteln wir halt am Symptom herum und müssen es als teures und zeitintensives Hobby betrachten.

 

Die Kommunikation könnte allerdings von allen Seiten etwas verbindlicher sein, Du musst ja nicht gleich so herumpoltern wie manche genervten Programmierer...

Edited by uglyrooster
Link to comment
Du musst ja nicht gleich so herumpoltern wie manche genervten Programmierer...

Ooch die verzogenes Gör aus dem Kindergarten nummer gibt er schon ganz gut. jetzt noch n bisserl auf den boden schmeissen und mit den füssen strampeln, dann wirkt das total glaubhaft. :):blush:

Link to comment
Auf Basis der Softwareentschlüsselung werden wir hier wohl nicht weiter diskutieren, denn da haben wir eine weitere nicht unerhebliche Fehlerquelle, die nicht supported wird da illegal...

 

So, hab nun das Problem mit MainConcept gelöst. Der Installer bzw. Uninstaller versemmelt die Registration/Unregistration der Filter ein bisschen. Mit MainConcept habe ich besagtes Problem nicht mehr.

Wer's probieren will...

 

http://www.elecard.com/ftp/pub/AVC/EAVCStr...gPlugIn_WMP.zip

 

Achtung! Der Filter muss händisch registriert werden nach der Installation unter C:\Programme\Gemeinsame Dateien\Elecard (regsvr32 mcavcvd.ax)

 

Ist dieser Mainconcept kostenlos? Gibt es dafür keinen funktionierenden Installer?

 

was wäre hier die richtige demoversion?

Edited by darky
Link to comment

Den MainConcept-Dekoder gibt es im Moment nur bei Elecard. Einfach den Link klicken und der Download startet. Der Installer-Fehler ist ja halb so schlimm, einfach manuall über Kommandozeile den Filter registrieren (regsvr32 mcavcvd.ax).

 

Der Installer enthält lediglich eine 21-Tage Demo. Was nach diesen 21 Tagen passiert, weiß ich nicht.

Link to comment

Ja, die Namen der Elecard DirectShow-Produkte sind etwas dämlich gewählt, aber der Link führt definitiv zum richtigen Paket.

Link to comment
Leider ist es momentan noch relativ schlecht um H.264 Dekoder Alternativen bestellt.

 

Hat WinDVD nicht auch einen Dekoder? Wie funktioniert der?

Link to comment

Ja, allerdings erkennt der DVBViewer Pro diesen nicht als H.264 Filter an. Aber man bekommt das trotzdem ans Laufen, indem man den H.264 Dekoder im DVBViewer auf 'System Default' einstellt. Danach muss man sicherstellen, dass der 'InterVideo Video Dekoder' den höchsten Merit unter allen im System registrierten H.264 Dekoder Filtern hat (Merits kann man mit dem Radlight Filter Manager editieren, siehe Download-Sektion). Der Default-Graph, der aufgebaut wird, sollte nun den 'InterVideo Video Dekoder' als H.264 Dekoder beinhalten.

 

 

(soweit ich mich erinnere, hatte ich bei InterVideo Probleme mit Overlay, kann also nicht schaden, in diesem Zusammenhang dann auch mal VMR zu probieren, oder umgekehrt?...)

Edited by CiNcH
Link to comment
und wie läuft er im Zshg. mit HDTV?

Der MainConcept? Einfach im DVBViewer den MainConcept Dekoder in der H.264 Dekoder Selektion wählen (Optionen -> DirectX).

Link to comment

Ich habe nicht wirklich lange damit getestet. Über Stabilität kann ich also gar nichts sagen. Die Performance war relativ gut und das Ruckelproblem hatte ich damit auch nicht.

Edited by CiNcH
Link to comment

Also ich hab ja gestern länger getestet mit HD (Premiere HD; CL 7.3; Latency: 950 ms; Puffer: 500 ms). Und was mir aufgefallen ist, dass es im Großen und Ganzen ruckelfrei funktionierte, allerdings hat es immer mal sporadisch für 5-10 Sek. kurz geruckelt und lief dann wieder ruckelfrei weiter...

 

Keine Ahnung warum...

Edited by darky
Link to comment

Hast Du mal darauf geachtet ob Du da evtl. Discontinuities hattest? Wenn ja, dann ist das der gleiche Effekt wie bei mir.

Probiere dann doch mal die GE oder analysiere mit Transedit den Transponder - da habe ich komischerweise keine Probleme mit dem Empfang.

Link to comment

Ich hatte hier auch eine Zeitlang das Problem, dass es mit meiner FireDTV-S und dem DVBViewer GE gelegentlich zu Diskontinuitäten kam, aber nie im TransEdit-Analyzer. Nach vielen Versuchen stellte sich heraus, dass es nur passierte, wenn ein Videodecoder lief, der DXVA nutzte. Irgendwie kamen sich Graka- und FireDTV-Treiber in die Quere, oder auch die FireWire-PCI-Karte... letztere habe ich dann irgendwann entnervt ausgebaut (und vorher den FireWire-Treiber deinstalliert, den XP selbst mitbringt), um eine neu gekaufte zu probieren.

 

Ging aber nicht, weil die nicht in den PCI-Slot passte, man hatte mir irrtümlich irgendein Spezialmodell verkauft, das nur mit einem bestimmten Mainboard verwendbar war. Also die alte PCI-Karte wieder rein, PC gestartet. Der FireWire-Treiber wurde automatisch neu installiert, aber plötzlich behauptete Windows, mit dem Treiber für die FireDTV wäre etwas falsch. Musste ich neu installieren. Seitdem ist das Problem weg. Irgendwie hat der Vorgang die ungesunde Wechselwirkung mit der Graka entflochten. Aber frage mich bitte keiner, auf welche Weise...

Link to comment
Aber frage mich bitte keiner, auf welche Weise...

 

Ok, dann frage ich anders: WIESO??? :)

 

Das ist aber schonmal ein Anhaltspunkt den ich heute Abend mal versuchen werde nachzuvollziehen. Vielleicht habe ich ja das gleiche bzw. ein ähnliches Problem. Vielleicht liegts auch an der uralten Yamaha-Soundkarte. Die hatte ich schon häufiger mal "im Auge"....

Link to comment

Den cyberlink kann man echt vergessen seit Premiere auf variable Bitrate umgestellt hat. Der elecard läuft ziemlich gut, braucht leider aber deutlich mehr Rechenleistung.

System:

c2d 1,86@2,33

2gb ram

x300 128mb

Link to comment

Hi naggn,

 

also erstmal hat Premiere die HD Kanäle nicht auf variable Bitrate umgestellt, die war schon früher variabel. Die Änderung besteht vielmehr darin, daß früher sehr viele P-Slices und sehr wenige B-Slices verwendet wurden und jetzt ist es umgekehrt. Und dies führt ( unter anderem ) dazu, daß die Bitrate jetzt merklich stärker schwankt als früher.

 

Was die hier beschriebenen Ruckelprobleme betrifft, kann ich das mit meiner Konfig nicht nachvollziehen:

 

A64 X2 3800+

1GByte RAM

Windows XP Pro SP2

Asus 8500GT

NVIDIA Forceware 165.01 ( beta )

neuster cyberlink h.264 codec

DVBViewerPro 3.6.1.2

overlay renderer

 

und als DVB-Karte eine Cablestar2 und / oder eine Twinhan CabCI

 

Da ruckelt nix, und wie ich inzwischen feststellen konnte, macht die Cablestar2 nahezu nie Diskontinuitäten, während mit der Twinhan regelmäßig welche auftreten.

 

Wie an anderer Stelle schon gesagt wurde ist der Treiber für die 8500GT aber wirklich noch beta, da friert der Rechner schon mal beim schließen des DVBViewers ein oder sowas in der Art *g*

 

C.U. NanoBot

Link to comment
Was die hier beschriebenen Ruckelprobleme betrifft, kann ich das mit meiner Konfig nicht nachvollziehen

Das Problem kannst du nur nachvollziehen, wenn du die Hardware Beschleunigung abschaltest. Im Prinzip verwendest du im Falle einer 8500 dann einen komplett anderen Dekoder, dann nämlich die Software-Algorithmen des CyberLink-Dekoders, welche IMHO das Problem verursachen.

Link to comment
Den MainConcept-Dekoder gibt es im Moment nur bei Elecard. Einfach den Link klicken und der Download startet. Der Installer-Fehler ist ja halb so schlimm, einfach manuall über Kommandozeile den Filter registrieren (regsvr32 mcavcvd.ax).

 

Der Installer enthält lediglich eine 21-Tage Demo. Was nach diesen 21 Tagen passiert, weiß ich nicht.

 

Da (wenn ich den Befehl in die Kommandozeile eingebe und ausführe) kommt bei mir immer "Das Modul konnte nicht gefunden werden...". Was mach ich falsch?

 

//edit: hab's hinbekommen.

 

//edit2: mit dem mainconcept codec (TESTVERSION): jetzt wird halt bei(m) hd-abspielen/hd-sendern oben rechts das logo von mainconcept/elecard angezeigt.

Edited by darky
Link to comment
Neuer CyberLink-Patch: http://www.cyberlink.com/multi/download/patches_112_ENU.html

 

Mal schauen, ob dieser die ganzen aktuellen Probleme mit CyberLink fixt...

 

Hat jemand den Patch schon getestet? Löst er das Problem?

 

Ich habe das auch bei allen HD Sendern. Komischerweise läuft es flüssig, erst wenn ich das OSD aufmache fängt nach ein paar Sekunden dieses Ministottern an. Hatte das Problem früher auch nicht, könnte als wirklich am 2911er PDVD update gelegen haben.

 

Fahre übrigens unter XP.

Link to comment
Hat jemand den Patch schon getestet? Löst er das Problem?

 

Ich habe das auch bei allen HD Sendern. Komischerweise läuft es flüssig, erst wenn ich das OSD aufmache fängt nach ein paar Sekunden dieses Ministottern an. Hatte das Problem früher auch nicht, könnte als wirklich am 2911er PDVD update gelegen haben.

 

Fahre übrigens unter XP.

Der patch löst das Problem auch nicht !

Link to comment

QUARK:

 

traurig aber wahr: es geht nur mit dem elecard h.264 decoder ruckelfrei.

und auch nur dann, wenn:

a. die cpu richtig wums hat und

b. die grafikkarte richtig wums hat und

c. im elecard filter "double rate" aktiviert ist und

d. das ganze über overlay läuft (auf jeden nicht vmr7 oder vmr9); DVBViewer kann ja (leider) kein vista evr

e. vista sollte durchgepatched werden; (ms fix im bereich videoausgabe)

 

sonst kommt es immer wieder zu (mini)rucklern.

Edited by pappnase_01
Link to comment

Bei mir läuft der cyberlink mit nvidia gut. Kann nicht klagen.. ..auch dxva funktioniert mit ausnahmen. Bei deiner auflisting der voraussetzungen für den elecard ist wums bei der gk imho unwichtig, da ohne dxva. Nach dem motto: ohne dxva sind alle GKs grau :bye:

Link to comment

frag mich nicht wieso, aber: wums muss die gk haben, weil sonst klappt dat nich mit der double rate. (auf jeden bei nvidia)

 

hd ruckelfrei und flüssig bei deiner konf.? mit DVBViewer? nicht die griga edt.! glaubt ich ned - oder glück gehabt.

und schon gar nicht im vollbild bei 1920*1080i dauerhaft - nie im leben - aber die ansprüche sind ja unterschiedlich

Edited by pappnase_01
Link to comment

Die MainConcept-Homepage ist schon seit Monaten auf diesem Stand:

http://www.mainconcept.com/site/developer-...sion-17754.html

obwohl man den Decoder bei Elecard längst runter laden kann.

 

Ansonsten: Ich schaue nur die freien HD Sender und bin vom Ruckelproblem bislang verschont geblieben. Vielleicht haben manche Sender ja wirklich an der Komprimierung gedreht, um Bandbreite zu sparen. Lt. c't gibt es z.B. bei der H.264 Entropie-Codierung die Verfahren "CAVLC" (Context Adaptive Variable Length Coding) und "CABAC" (Context Adaptive Binary Arithmetic Coding). Da letzteres Verfahren für den Encoder wesentlich aufwendiger ist (jedoch bis zu 15% Reduktion der Datenrate bringen kann), wurde es anfangs noch nicht so oft eingesetzt. Vielleicht haben ja die ersten Versionen der H.264 Decoder hiermit ein Problem. Ich will damit nur sagen, die Anzahl der Stellen, an denen Probleme auftreten können, sind nicht so leicht eingrenzbar.

Edited by SnoopyDog
Link to comment

Hi !

 

Ich bin hier auf diesem Thread gestossen und muss mein Problem auch mal schildern.

 

Es betrifft wie erwartet den Cyberlink 7.3 Ultra Decoder , jedoch weniger stört mich das Ruckeln, sondern ganz einfach das super schlechte Bild.

 

Es sieht bei diesem Codec immer so aus als wäre da heftiges Banding im Bild , Ich hab viel rumgetestet und herrausbekommen das bei diesem decoder

 

irgendwie immer der overlay2 mode benutzt wird , welches mein Bild dann total verschandelt. Leider krieg ich das beim DVBV nicht abgeschaltet , egal ob ich

 

den normalen Overlay nehme oder auf unchanged gehe. Das Problem bleibt weiterhin bestehn.

 

Diese ganzen Probleme treten bei dem mainconcept Decoder nicht auf , bedauerlicherweise braucht der zuviel CPUPower weshalb er immer so im 80% berreich rumiirt und da durch auch gelegentlich rumruckelt.

 

Mein System:

 

AMD Opteron 170@2x 2,6ghz

Nvidia Geforce 7900GT

2 GB RAM

1TB Raid

 

Wie nur bekomme ich das mit dem Overlay gelöst ;) Wenn ich auf VMR7 oder VMR9 schalte , ists ja auch weg , jedoch ist das Bild dann nur noch am Ruckeln und spinnen.

 

Weiss da einer Rat?

Link to comment

Ich hab übrigens festegestellt, dass Pro7HD/Sat1HD in letzter Zeit viel mehr Probleme macht als Premiere/Discovery HD. Es braucht bei mir deutlich länger um ein Bild zu erzeugen nach dem ersten tunen und auch bei Aufnahmen, wenn ich im Stream sprinnge... könnte aber an meiner alten Decoder Version liegen.

 

@unreality: Wie siehst aus, wenn du VRM9 nimmst und den Nvidia Fix aktivierst? (Hat auch Nachteile, ich weiß, aber mal zum testen)

Link to comment

Der Cyberlink Dekoder hat noch spezielle Optionen, die normal nicht sichtbar sind: im DVBViewer unter Ansicht/Filter den Cyberlink Video Dekocer wählen und dabei Strg drücken (einfach mehrmals probieren). Wenn es klappt sieht noch zwei Spalten mit Qualitätsoptionen sichbar. Die Einstellungen wirken sich wirklich auf die Bildqualität aus!

Edited by is-is
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...