Jump to content
Sign in to follow this  
Alessandro

stream to videolan vlc

Recommended Posts

Alessandro

I am using dvbserver to stream to one or two client equipped with DVBViewer on a wifi lan; everything works fine

 

I'd like too to capture the stream with vlc on the server and restream it on a different port with lower dimension and bandwidth for seeing on a pocketPC or via internet connection.

 

Is it possible to capture the stream of dvbserver with vlc ? What is the format used in unicast streaming ?

 

Thanks in advance ;)

Share this post


Link to post
Derrick
Is it possible to capture the stream of dvbserver with vlc ? What is the format used in unicast streaming ?

No, alas not possible.. ..it's tcp/ip and it should work with http:// in vlc but it doesn't. It seems to be a proprietary protocol. If you use the netstreaming plugin you can stream to the vlc either unicast (http) or multicast (udp). Multicast is not recommendable in a small network.

Share this post


Link to post
Alessandro
No, alas not possible.. ..it's tcp/ip and it should work with http:// in vlc but it doesn't. It seems to be a proprietary protocol. If you use the netstreaming plugin you can stream to the vlc either unicast (http) or multicast (udp). Multicast is not recommendable in a small network.

 

Thank you for the quick answer. I'll try with the plugin in unicast, in fact multicast doesn't work in my lan because of the wi-fi router

Share this post


Link to post
Lars_MQ

It can not work, cause the client has to set the apropriate tuning parameters (and PIDs to be delivered). How would you do that with vlc?

Share this post


Link to post
Derrick

..but why can't the dvbserver stream to a passive, secondary vlc client when an active primary DVBViewer client is present?

Share this post


Link to post
Alessandro
..but why can't the dvbserver stream to a passive, secondary vlc client when an active primary DVBViewer client is present?

 

that is exaclty what I want to do, but I've just tried and it doesn't work

the streamer plugin recognise 1 client connected, but no video and audio in VLC

pheraps even the plugin uses a proprietary encoding for unicast....

Share this post


Link to post
Derrick

no, with the plugin it works ok. Must be your settings..

Share this post


Link to post
NanoBot

Hi,

 

I can confirm that streaming

 

DVBViewer netstream plugin ( unicast ) -> VLC on first PC -> VLC on second PC

 

works fine. When I am choosing a low bitrate and a smaller size of the videoframe, e.g. 352 * 288, h.264 256kBit/s and m4a ( = AAC ) 32kBit/s it is even possible to receive the stream via the internet. Of course the outgoing streaming port of the vlc server has to be forwarded correctly.

 

The limitation is the following: Whenever you change the channel on the DVBViewer, you will have to stop both the vlc server and the client, change the channel and then restart them. Otherwise the vlc server will be confused on the change of the video- and audiopids in the stream delivered from the netstream plugin. Changing the audio channel, e.g. from german to english has to be dealt with in the same manner.

 

Of course it would be possible to program a special client software for the client pc ( in the internet ), which handles anything correctly by using the HTTP interfaces of both the DVBViewer and the VLC server. When using the DBox2 as signal source, the programm "dboxTV" exactly does this:

 

First it gets the channel list and the EPG from the DBox2 via HTTP. Second it tunes the DBox2 to the desired channel. Third it sends an MRL: to the HTTP interface of the vlc server, which indicates source IP, port and streaming protocoll, desired reencoding and resizing parameters and desired port and protocoll for the outgoing stream. Then it starts both the vlc server on the remote PC and it's ( build in ) vlc streaming client. Whenever you switch to another channel, both vlcs are stopped and everything starts from the beginning.

 

C.U. NanoBot

Edited by NanoBot

Share this post


Link to post
Alessandro
no, with the plugin it works ok. Must be your settings..

Working fine, many thanks

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...