Jump to content
Sign in to follow this  
hercum

Mediaguard 3 problem TV Vlaanderen

Recommended Posts

hercum

TV Vlaanderen changed to Mediaguard 3 encryption and now I can't watch Eén and Canvas anymore.

The strange thing is that everything works in Technisat TV Center (I have a skystar HD).

But that software is terrible to use, DVBViewer is the best ;)

So I'm thinking it's a software problem, can anyone help me out or do I have to wait until a software update?

Sure would be nice if the developer(s) let me know something. :biggrin:

support.zip

Share this post


Link to post
CiNcH
So I'm thinking it's a software problem, can anyone help me out or do I have to wait until a software update?

Also TechniSat TV Center (or TechnoTrend-Media Center) >= v1.0.7.8 is affected. The MediaGuard CAM does not like the CA_PMT which is being sent by the application. I am afraid that this is not likely to be fixed without the appropriate hardware (MediaGuard CAM + TV Vlaanderen/Canal Digitaal SmartCard).

 

TechnoTrend knows about the problem and how to fix it but you won't get any information there. Seems this place is in bad shape...

Edited by CiNcH

Share this post


Link to post
Lars_MQ

For technotrend cards only the SID is send. So it is a driver problem.

Share this post


Link to post
CiNcH
For technotrend cards only the SID is send.

How about trying to send the CA_PMT? In case of TT-Media Center it is driver independent, so it most likely sends a CA_PMT.

Share this post


Link to post
hercum

I have Technisat TV Center v1.0.7.6 and it works in there so it must be software related right?

Btw I'm on vista x64 so I use technotrend drivers for my card.

CiNcH I have no idea how I can send the CA_PMT.

I do have quite some experience with satellite hardware/software so could you explain how to do this?

And F.Y.I. I do have an official TV Vlaanderen smartcard and CAM.

The whole idea of switching to mediaguard 3 is for those how like to hack TV ;) (that's what TVV told me).

Edited by hercum

Share this post


Link to post
Derrick

..you can't send a CA_PMT. This has to be implemented in the DVBViewer.

Share this post


Link to post
Benarty

I only had to re-activate the smartcard and the original TV Vlaandren cam was capable to show the channels after the mediaguard 3 update.

So go to the TV Vlaanderen website and re-activate the smartcard.

 

 

ps. I use Digital Everywhere DVB-S and S2

Edited by Benarty

Share this post


Link to post
Derrick

The firedtv_CI gets the full CA_PMT. In contrast to e.g. nagra, mediaguard uses only a single ca_id (0x0100) for all different ca_systems. Selection is done by a provider_id. With the new seca3 (it's in fact nagra3) the same id (0x006a and 0x006c for canal digtitaal) is used twice. Once for old cards and once for the new cards but with different ecm_pids. If the application or the driver or the ci_module filters the ca_pmt and takes only the first it finds in the pmt, it could be the wrong one B)

Share this post


Link to post
hercum

Well I reactivating my smartcard and it didn't help, I guess I'll have to wait for a new version of DVBViewer to get it working again.

I'll try the beta version later on and post the results.

Thanks for the support so far, I hope it gets fixed soon.

Share this post


Link to post
Benarty

3.9.4 can work with TV Vlaanderen.

 

Windows XP pro downtweaked

Power DVD 8 Ultra

DVBViewer 3.9.4

 

Oh and:: under mediaguard2: the TV vlaanderen cam did block HD content.

After the move to mediaguard3: the cam does not block HD content anymore

 

There is a small problem tho. Sometimes, if the computer starts up, then DVBViewer does not show any scrambled TV vlaanderen channels.

I need to close down DVBViewer and restart it again to fix this problem.

 

I did not install the floppyDTV software, just the drivers.

 

 

Re-activation: After the activation, swiitch to a TV vlaanderen channel and let it on that channel , if You want to view something choose BVN.

Do not change to another channel and stay on that channel for at least one hour.

Then you should be able to view all other channels.

Edited by Benarty

Share this post


Link to post
hercum

Benarty I did re-activate they way you said, maybe it wasn't an hour but it normally doesn't take that long.

The only "problem" I have/had with hd channels from TVV: when watching non hd channel and switch to hd, I have to restart DVBViewer or rebuild graph.

Don't know what floppyDTV is maybe from the technotrend card?

Anyway I just have the technotrend driver because there is no vista x64 driver from technisat.

I'm still using DVBViewer 3.9.4 I tried to watch motors tv today and I can add it to the list (één and canvas) of nogo.

The strange thing of this all is that I had no problems before reinstalling my windows.

Coincidence (the change to mediaguard 3 just happend then) or did something go wrong?

It's getting a bit annoying, I'll play around with some settings and perhaps some drivers and hope for the best.

Share this post


Link to post
Benarty

Which windows version, if XP, then you have to install:

 

SP2 Hotfix for DVB: KB896626

 

SP3 contains the hotfix.

 

 

After XP install, install mainboard chipset drivers,, audio drivers, video drivers.

Visit windowsupdate tiil it's uptodate, avoid SP3 in the first place, try sp2 with the hotfix, it should work.

 

Use BDA drivers under DVBViewer.

 

FloppyDTV is from Digital everywhere, a rather expensive but excellent firewire DVB device.

 

Problem are usual related to drivers, less with DVBViewer.

 

In case of problems, do test Free to air (FTA) channels first.

Your HTPC system should be able to tune on all FTA channels without any problem.

Except the HD demo channels perhaps.

 

When tuning onto a TV Vlaanderen channel and it doesn't work, it's most of the time CAM related.

You can check this within DVBViewer, HTPC modus en Infos.

Look at the bitrate, if You see lousy low bitrates under 1mbps so usual 0,1 to 0,2mpbs then the cam is blocking

traffic. Unfortunatly, DVBViewer gives no warning message if this happens.

 

If this happens, end DVBViewer and restart DVBViewer and you should see the channels now.

You may expect such error then frequentle, usual after a few hours.

 

If you get good results with the tehnotrend software, then DVBViewer should have no problem neither.

Share this post


Link to post
hercum

Maybe someone can post there channel list so I can see if that works or not.

How can I see the bitrate?

I can see all channel encrypted or not, hd or not just those few tv vlaanderen channels.

As far as I can see I have the same settings in DVBViewer as in technisat tv center.

Share this post


Link to post
Benarty

How can I see the bitrate?

 

in DVBViewer, tune on the channel, then select the menu, htpcmodus, Infos

 

Just scan channels, the TV Vlaanderen channels are located at the end of the entire list.

 

 

First try a FTA channel

 

 

Just don't forget that your problem can be related to the technisat card.

I use floppy DTV and have no problems at all with mediaguard3 and original TV Vlaanderen CAM.

 

Satcodx info about TV Vlaanderen is wrong.

Edited by Benarty

Share this post


Link to post
hercum

Problem sort of solved, I bought a FireDTV S2 everything works on it.

Still have no clue what the problem is, if it works in technisat tv center it should work in DVBViewer.

Again, all channels work fine just a couple of TV Vlaanderen channels are not working.

Anyway I don't have to fix the problem anymore, maybe if I have some spare time I'll check on it again.

Thanks for everyone's help on this strange problem.

Share this post


Link to post
hercum

Just want to add that TV Vlaanderen is having problems switching to mediaguard 3, this is why I for example had my problems.

I also spotted some other people who had similar problems to mine.

TV Vlaanderen will now replace all smartcards with new ones, this should solve the problems they're having.

Canaal Digitaal will probably follow TV Vlaanderen in this, mostly because of the shared channels.

Share this post


Link to post
Derrick

..apparently there's still a bug. Canal Digitaal has sent me a new mediaguard/nagra3-card. To make up for the inconvenience the entire package on 19/23,5E is open for 3 weeks. The SD channels on 23,5E are ok but the HD channels are not! :)

 

2 of the hd channels on 11856V have at least audio. The others are black and mute. The descrambled audio streams are normal layer2 audio while the others are ac3 but with the same ca_descriptor structure.

 

The PMTs are quite complex with 2 global cryptoworks ca_descriptors and 4 seca descriptors per elementary stream: prov. 6A, 6C, 6A, 6C (6A is for the netherlands and 6C for belgium, the last 2 are mediaguard 3). I can't tell what is wrong but imho the ca_pmt is probably the culprit.

 

Who can decode these channels??

 

Hardware: FireDTV-S2, 2 different CI-modules (matrix, aston)

and latest DVBViewer beta

Share this post


Link to post
Lars_MQ

what about the SD channel PMTs are they equally complex?

Share this post


Link to post
Derrick

..no, a little less complex. There are only mediaguard_CA_descriptors on ES_level. But imho the important difference are the stream types. The canal digitaal SD_channels on 23,5E and 19E carry only mpeg2 video and mpeg audio. 2 of the HD_channels have mpeg audio as well and these audio tracks are correctly descrambled. ES with 0x1b (h.264) and 0x06 (ac3) don't work.

 

It would be helpful to log the ca_pmt or at least what is sent by the dvbv to the ca_appl. Then I could compare the log with the PMTs.

Share this post


Link to post
Lars_MQ

I noticed just now: The FireDTV Devices get the complete PMT, directly like it is received.

 

I'll provide you with a special debug version but I doubt it will help you. :)

Share this post


Link to post
hercum

Derrick I think I know what you mean, I can't decode these channels from the first time either. (only on astra 23.5, the new channel mtvn hd on 19.2 works fine)

I usually tune in to bbc hd, then anixe hd and then the hd channel I want (Een hd or so).

After I did this I can tune in to all hd channels without a problem, weird he?

For some reason this does the trick every time.

 

I also have FireDTV-S2, hd decoder core avc, works in DVBViewer 4 and latest beta.

 

PS: I am using latest beta driver and firmware (recent updated, fixed a lot of bsod's for me) for FireDTV-S2, since I use vista 64

Share this post


Link to post
boulder2
Derrick I think I know what you mean, I can't decode these channels from the first time either. (only on astra 23.5, the new channel mtvn hd on 19.2 works fine)

I usually tune in to bbc hd, then anixe hd and then the hd channel I want (Een hd or so).

After I did this I can tune in to all hd channels without a problem, weird he?

For some reason this does the trick every time.

 

I also have FireDTV-S2, hd decoder core avc, works in DVBViewer 4 and latest beta.

 

PS: I am using latest beta driver and firmware (recent updated, fixed a lot of bsod's for me) for FireDTV-S2, since I use vista 64

Strange, I have a Technotrend S2-3200 and when I received the SECA3 TV Vlaanderen card I got no issues.

The issues I had in the past were :

 

* not able to decode any channels, turned out I needed the latest version of the Technotrend DLL's in one of the DVBViewer folders

* problems with H264 codecs. Then I did get a similar problem to yours.

Had to swich several Times to different HD channels before it worked.

Only way to solve this was by using Overlay instead of VMR7/9.

* currently having a problem with green spots in many programs.

Just discovered it is a video RAM problem :bounce:

Share this post


Link to post
Derrick
Strange, I have a Technotrend S2-3200 and when I received the SECA3 TV Vlaanderen card I got no issues.

 

..are you talking about the dvb-s2 transponder 11856V on Astra 1D/3A at 23.5°E ??

Share this post


Link to post
hercum

Derrick I was talking about the dvb-s2 transponder 11856V on Astra 1D/3A at 23.5°E, I only have problems there.

Have you tried what I said? It's strange but it works.

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...