Jump to content

DVBViewer 4.0 eure Meinung !?


M@rio

Recommended Posts

Mir ist grad beim Aufnehmen was aufgefallen:

Ich habe es so eigestellt, dass beim Aufnahmen unter anderem die Sendung im Dateinamen steht, also %event.

Da man mit dem aufnehmen ja immer etwas vor der eigentlichen Sendung beginnt, werden bis zu 5 min. vor der Aufnahme der Titel der nächsten Sendung genommen. Das stimmt soweit auch bei den EPG-Infos die in der Datei-Infos bzw. der extra Textdatei stehen, allerdings im Dateinamen %event steht hier die alte Sendung (die gerade läuft, nicht die in den nächsten 5 Minuten). Vorher hat das richtig geklappt...

Link to post
  • Replies 118
  • Created
  • Last Reply

Top Posters In This Topic

  • Martin K

    20

  • Lars_MQ

    15

  • Griga

    10

  • dgdg

    8

Top Posters In This Topic

Posted Images

@dgdg

Das klingt ganz eindeutig nach völlig falscher benutzer einweisung.

 

Was macht ein sat receiver? ch+ und ch-. Du willst mir doch nicht erzählen, das schwiegermuttern die bedienung von x verschiedenen satreceivern mit menü führung im kopf hat. Wenn sie vom älteren kaliber ist, braucht sie ne fernbedienung mit 5 (!!!) knöpfen. Kanal+, Kanal-, Laut, Noch lauter und aus. mehr nicht. Ich sehe das selbst bei meinen eltern, mehr braucht man nicht.

 

Wenn Du allerdings versucht einem "gelegenheits" seher die gesamte (schon komplexere) bedienung des Viewers nahe zu bringen, dann läuft was falsch. Zeige Ihnen: so schaltest Du um, so machst Du lauter/leiser, mehr wollen die doch gar nicht. Was interessiert es die stundenlang im EPG zu blättern, wenn sie mal kurz aufs baby aufpassen sollen?

 

Immer, wenn der WAF ins spiel geworfen wird, stelle ich mir insgeheim die frage: Begreift die gute Frau wirklich die paar funktionen fürs fernsehen nicht, oder ist eher der Mann zu dämlich seine Erläuterungen sauber zu struktieren (sprich auf die (hoffentlich bekannten) gewohnheiten der angetrauten genau einzugehen)?

Ich meine, wenn frau interesse an mehr hat bei der Bedienung, dann wird sie mit sicherheit selber auf entdeckungsreise gehen und wenn sie probleme oder ideen hat, kannst Du ihr gerne zeigen, wie man hier im forum postet... ;):D

Link to post

Also bei mir läuft die Version 4.0 genau so flüssig wie die vorherige. All die Probleme die ich mit dem DVBViewer hatte, waren meine Schuld. Für die moderaten 15 Euro, die dieses Programm kostet, kann es enorm viel und ich bin davon überzeugt, dass es das beste in seiner Klasse ist. Ich hatte vorher Tests mit dem Windows Media Center (was ja ab Vista HP dabei ist) gemacht, doch da fingen die Probleme schon mit dem Treiber an, da das Windows Media Center den original Pinnacle Treiber nicht erkannte. Nachdem ich dann den Universal Treiber (UDR) installiert hatte, fand er einmal mehr einmal wenig Sender und einmal gingen sie, dann wieder nicht. Ich habe alles mögliche versucht, um es doch noch wieder zum laufen zu bringen, leider ohne Erfolg. Durch meinem Cousin habe ich dann vom DVBViewer gehört und habe ihn mir gleich bestellt, denn für 15 Euro kann man gar ja nichts falsch machen. Als ich das Programm installiert hatte, ging es noch nicht, da der noch installierte UDR gestört hatte (aber das war ja, wie oben schon geschrieben, meine Schuld :D) Ich habe den Treiber deinstalliert und es funktioniert bis heute tadellos. Ich danke den Programmierern für dieses super Programm.

 

Ich wünsche allen eine frohe und besinnliche Weihnachtszeit und ein gesundes neues Jahr.

 

Viele Grüße

 

FighterX

Edited by FighterX
Link to post
Da man mit dem aufnehmen ja immer etwas vor der eigentlichen Sendung beginnt, werden bis zu 5 min. vor der Aufnahme der Titel der nächsten Sendung genommen. Das stimmt soweit auch bei den EPG-Infos die in der Datei-Infos bzw. der extra Textdatei stehen, allerdings im Dateinamen %event steht hier die alte Sendung (die gerade läuft, nicht die in den nächsten 5 Minuten). Vorher hat das richtig geklappt...

 

Das Problem kann ich nicht nachvollziehen. Ich benutze den Default-Namen "%date_%time_%station_%event" und 10 Minuten Vorlauf bei der Aufnahme (weil einige Privatsender den Beginn eines Films nachts einfach mal vorverlegen).

 

Hier werden alle Sendung nach wie vor mit dem richtigen Namen aufgenommen. Ich gehe davon aus, dass der Name der Sendung aus der Timerliste und nicht aus dem EPG-Daten entnommen wird.

Edited by dgdg
Link to post

..den DVBViewer bediene ich nicht mit einer FB, aber alle meine vorhandenen FBs (viel zu viele) fangen bei programmwahl mit der 1 an. Wie war das noch mit dem(n) geisterfahrer(n) ? :D

Link to post

Also ich nehme nicht mit Timer, sondern manuell auf. Und hier war es auch immer so, das bis zu 5 Min. vorher der Aufnahme als %event der Name der nächsten Sendung genommen wird. Also bei mir wird nix aus der Timerliste genommen, sondern nur aus dem EPG und das hat vorher immer so geklappt wie ich wollte...

Link to post

@Martin K

Griga und ich müssen erstmal rücksprache halten, woran das liegen könnte, zumal das scheinbar ja nur bei sehr wenigen nutzern auftritt. Da spielt noch irgendwas mit rein, nur was ist die frage...

Link to post
Also ich nehme nicht mit Timer, sondern manuell auf.

Was hast Du denn als instant epg buffer eingetragen? das ist die zeit, die vorausgeschaut wird für die epg sachen, wenn man eine manuelle aufnahme macht.

Link to post
@Martin K

Griga und ich müssen erstmal rücksprache halten, woran das liegen könnte, zumal das scheinbar ja nur bei sehr wenigen nutzern auftritt. Da spielt noch irgendwas mit rein, nur was ist die frage...

 

Kann ich euch mit einer Aufnahme dienen, dass ihr den AC3-Stream genauer analysieren könnt, falls ihr kein Zugang zu RTL über Unitymedia habt?

Link to post
Also ich nehme nicht mit Timer, sondern manuell auf.

Was hast Du denn als instant epg buffer eingetragen? das ist die zeit, die vorausgeschaut wird für die epg sachen, wenn man eine manuelle aufnahme macht.

 

Jo, gerade nachgeschaut, hier stehen 5 Min. Wie gesagt bei den EPG-Daten als Datei-Info und in der extra Textdatei stimmts ja auch, nur eben nicht beim %event im Dateinamen.

Link to post

Was die "Geisterfahrer"-Sache angeht, so bitte ich solche "lustigen" Vergleiche nicht mehr zu bringen. Letzte Woche war ich hautnah mit so einem geisteskranken Arschloch auf Tuchfühlung. Mehr als Wegfangen und Einsperren nebst Führerscheinentzug, fällt mir da nicht ein.

Link to post
Alleine die Tatsache, dass ich meine Bluerays und HDDVD's direkt angucken kann ist schon ne 4.0 Wert.

Helft mir mal auf die Sprünge! Wie mache ich das denn? Das geht ohne z.B. Power DVD, Codec et cetera zu installieren?

 

Danke und Gruß, silentrix

Link to post

@Derrick

Du kennst doch sicher den Witz:

 

Meldung im Radio: "Vorsicht! Auf der Autobahn kommt Ihnen ein Geisterfahrer entgegen!"

Autofahrer : "Wieso einer? Hunderte!!!". :D

Edited by dgdg
Link to post

Hallo beisammen,

 

die aktuelle Version ist nach einigen tollen (und weniger tollen) betas ein weiterer Meilenstein der HTPC/DVB-Software. Allein das feature zum (automatischen) Umschalten der Audio-Renderer ist genial!

 

@Entwickler: Scheinbar überträgt die COM nicht mehr so wie bei Version 3.9.4...markymarks VFD/LCD-plugin kann einige Infos nicht mehr auslesen und die displays entsprechend bestimmte Symbole nicht mehr anzeigen...bug/feature?!...

 

Zum Thema Bedienbarkeit des DVBV...keines meiner Familienmitglieder hat Dank eines genialen Programms/Konzepts (Danke Entwickler!), einer guten Konfiguration und eines eines tollen OSD (Danke MarkusK!!!) Probleme bei der Bedienung unseres HTPC auf WinXP/DVBV-Basis. Selbst mein kürzlich verstorbener Opa (91) konnte hier ohne Hilfe DVDs/TV sehen oder mit der Restfamilie "sceneit" spielen/steuern...die Bedienung ist intuitiv und das nicht nur für technisch/taktisch versierte Ostfront-Veteranen...

 

Zu viele stellen sich leider etwas dämlich an, sobald ein Gerät mit Elektrizität funktioniert...ich "liebe" Klebstoff-/Tippex-Reste beim Kopieren/Scannen...soviel am Rande.

 

Schöne Feiertage!!!

 

MogRuith

Edited by MogRuith
Link to post
die displays entsprechend bestimmte Symbole nicht mehr anzeigen...bug/feature?!...

Markymark hat das schon angesprochen. Hat sich leider ein bug bei der audioformat ausgabe über COM eingeschlichen :D

Link to post

Hallo!

 

Ich bin lange nicht mehr hier gewesen und habe gestern zufällig mal geschaut ob es eine neue Version gibt B)

Bisher konnte ich ihn noch nicht sehr lange testen, aber die wichtigste Neuerung ist, dass ich nun auch auf dem Zweitmonitor (Lenovo L220 mit 1920x1200) in Fullscreen schauen kann :D

Da wurde er bisher immer schwarz (alternativ auch wenn ich den Viewer so lange vergrößert habe bis dessen Ränder fast den ganzen Bildschirm ausgefüllt hatten).

Beim Hauptmonitor (1600x1200) hat das anstandslos geklappt bisher.

Sollte eigentlich vorher auch geklappt haben, aber hats aus irgend nem Grund nicht ;))

 

Die restlichen Änderungen betreffen mich eher peripher, aber das macht mich schon sehr glücklich.

Ist eine tolle Investition gewesen..

Weiter so!

 

Thalon

Link to post

Bearbeiten ging nicht mehr, also hier noch eine kleine Anmerkung im nachhinein:

Bei MKV scheint das Anzeigen von Untertiteln nicht zu funktionieren, mehrere Ton-/Sprachspuren laufen einwandfrei.

Die Untertitel stehen zwar korrekt zur Auswahl, aber sie werden mir nicht angezeigt, beim VLC-Player z.b. schon.

 

Und es wäre praktisch, wenn man eine OSD-Taste für "eine Ebene höher" definieren könnte (Datei-Navigation).

Würde es sich nach der Auswahl eines Videos auch noch automatisch schließen wäre das auch toll *g*

 

Mit diesen 3 Verbesserungen würde ich den Player vermutlich für alle Videos als Standardplayer verwenden :D

 

Thalon

Edited by Thalon
Link to post
Bei MKV scheint das Anzeigen von Untertiteln nicht zu funktionieren,

Funktioniert hier einwandfrei. Wirf mal einen Blick auf die Konfigurationshinweise, die ich anlässlich eines DVBViewer GE Releases gegeben habe:

 

http://www.DVBViewer.info/forum/index.php?...st&p=210694

im Abschnitt mit der entsprechenden Überschrift.

 

beim VLC-Player z.b. schon.

VLC ist schlecht zum Vergleich geeignet, da er nicht auf DirectShow aufsetzt, sondern eine eigene Wiedergabe-Engine hat.

Link to post

@Griga

Danke für die prompte Antwort, funktioniert nun wunderbärig :-)

 

Ich habe nun auch die "eine Ebene höher" Taste belegt (gelbe OSD).

 

Jetzt muss ich nur noch schauen ob ich herausfinde wieso vorhin eine Videoaufnahme heftigst geruckelt hat. Eventuell tritt das Problem nach dem Wechsel des Decoders auch nicht mehr auf.

 

Der Support hier ist aber immer vorbildlich!

 

Herzlichsten Dank, ich mag den DVBViewer täglich mehr :D

 

Thalon

Link to post

Hallo,

 

Und es wäre praktisch, wenn man eine OSD-Taste für "eine Ebene höher" definieren könnte (Datei-Navigation).
darum kann man das ja auch per OSD-Gelb erledigen, egal ob in MyVideos oder MyComputer.

 

Würde es sich nach der Auswahl eines Videos auch noch automatisch schließen wäre das auch toll *g*
Optionen -> OSD-Details -> Schließe das OSD bei Video Wiedergabe.

 

:D

Link to post

So.. einstellungstechnisch ist nun alles optimal :D

Jetzt nur noch schauen ob das Ruckler-Problem noch einmal auftritt, die letzte halbe Stunde wars jedenfalls weg...

 

Thx,

Thalon

Link to post
Zu viele stellen sich leider etwas dämlich an, sobald ein Gerät mit Elektrizität funktioniert...ich "liebe" Klebstoff-/Tippex-Reste beim Kopieren/Scannen...soviel am Rande.

 

Ich werde das mal so an meine Schwiegermutter (65) und an unseren Babysitter (19) weiterleiten. :D

 

Und was mich betrifft: Logisch - erst einen HTPC aufsetzen und dann zu doof, das Ding zu bedienen. Ich werde mir demnächst einen zusammen kleben. ;)

Edited by dgdg
Link to post
Zu viele stellen sich leider etwas dämlich an, sobald ein Gerät mit Elektrizität funktioniert...ich "liebe" Klebstoff-/Tippex-Reste beim Kopieren/Scannen...soviel am Rande.

 

Ich werde das mal so an meine Schwiegermutter (65) und an unseren Babysitter (19) weiterleiten. :D

 

Und was mich betrifft: Logisch - erst einen HTPC aufsetzen und dann zu doof, das Ding zu bedienen. Ich werde mir demnächst einen zusammen kleben. ;)

 

Ich kann Dir hier bei Deinen Post´s nur zustimmen. B)

 

Habe auch einen neuen HTPC (funktioniert alles einwandfrei), nur die Bedienung des DVBViewer schreckt meine Frauen noch sehr ab (mich teilweise auch).

Sie wollen lieber "noch" mit der Dreambox schauen.

 

Frohe Weihnachten

Thomas

Link to post

Gibts neue Erkenntnisse bezüglich des Graph-Neustarts bei RTL mit der AC3-Tonspur?

 

Übrigens hatte ich eben wieder den folgenden Fehler, den hatte ich schon bei der alten DVBViewer Version ab und zu, tritt nach dem Sender umschalten auf, vom neu umgeschalteten Sender ist dann für wenige Sekunden der Ton zu hören, das Bild bleibt aber schwarz, dann stürzt der DVBViewer ab mit folgendem Fehler (Windows Ereignisanzeige):

Ereignistyp:	Fehler
Ereignisquelle:	Application Hang
Ereigniskategorie:	(101)
Ereigniskennung:	1002
Datum:		26.12.2008
Zeit:		21:51:58
Benutzer:		Nicht zutreffend
Computer:	MARTIN
Beschreibung:
Stillstehende Anwendung DVBViewer.exe, Version 4.0.0.0, Stillstandmodul hungapp, Version 0.0.0.0, Stillstandadresse 0x00000000.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 48 61 6e 67   ion Hang
0010: 20 20 64 76 62 76 69 65	 dvbvie
0018: 77 65 72 2e 65 78 65 20   wer.exe 
0020: 34 2e 30 2e 30 2e 30 20   4.0.0.0 
0028: 69 6e 20 68 75 6e 67 61   in hunga
0030: 70 70 20 30 2e 30 2e 30   pp 0.0.0
0038: 2e 30 20 61 74 20 6f 66   .0 at of
0040: 66 73 65 74 20 30 30 30   fset 000
0048: 30 30 30 30 30			00000

Link to post
Gibts neue Erkenntnisse bezüglich des Graph-Neustarts bei RTL mit der AC3-Tonspur?

Nö. Kann hier nicht reproduziert werden. Auch wenn ich längere Zeit RTL mit AC3 (via Satellit) laufen lasse, tut sich nichts. Da bleibt nur Herumprobieren. Ist bei dir Sender -> Sender Auto-Update aktiviert? Falls ja, schalte das mal ab. Die Funktion könnte auch einen Stop auslösen.

 

dann stürzt der DVBViewer ab

Da würde ich auf einen Decoder tippen. Wenn er im DVBViewer-Kontext läuft, rechnet Windows den Absturz dem DVBViewer zu.

Link to post
Nö. Kann hier nicht reproduziert werden. Auch wenn ich längere Zeit RTL mit AC3 (via Satellit) laufen lasse, tut sich nichts. Da bleibt nur Herumprobieren.

Ja ist klar, ich habe hier RTL über Unitymedia (Kabelanbieter in Hessen) und die codieren den Stream neu.

 

Ist bei dir Sender -> Sender Auto-Update aktiviert? Falls ja, schalte das mal ab. Die Funktion könnte auch einen Stop auslösen.

Auch ohne diese Einstellung tritt dieses Phänomen weiterhin auf.

 

Komischerweise: Wenn ich RTL über TransEdit -> Preview schaue, gibt es hier keine Graph-Neustarts. Aber da wird auch "DVB Source 3.3.1.0" verwendet (Rechtsklick auf das Videofenster). Was ist dann hier anders in der Wiedergabekette? Auch wenn ich eine entsprechende Aufnahme wieder über den DVBViewer anschaue (und auch hier ist wieder DVB Source 3.3.1.0), erhalte ich diesen Fehler mit den Graph-Neustarts nicht...

 

 

dann stürzt der DVBViewer ab

Da würde ich auf einen Decoder tippen. Wenn er im DVBViewer-Kontext läuft, rechnet Windows den Absturz dem DVBViewer zu.

Ja, nehme ich auch an. Sehr wahrscheinlich der VideoDecoder, da der Ton nach dem Umschalten ja kommt, aber das Bild schwarz bleibt, bis der DVBViewer nach ca. 5 Sekunden abstürzt (wahrscheinlich bis der Puffer voll ist). Aber das Ganze kommt nur sehr selten vor, der andere Fehler dagegen ca. alle 2 Minuten bei RTL, das nervt schon....

Link to post
Wenn ich RTL über TransEdit -> Preview schaue, gibt es hier keine Graph-Neustarts. Was ist dann hier anders in der Wiedergabekette?

Hast du die gleichen Decoder eingestellt? Als Videorenderer verwendet TransEdit grundsätzlich den VMR 7 in einem Modus, der der Einstellung "System Default Renderer" im DVBViewer Pro entspricht. Vielleicht probierst du das mal...

Link to post
Wenn ich RTL über TransEdit -> Preview schaue, gibt es hier keine Graph-Neustarts. Was ist dann hier anders in der Wiedergabekette?

Hast du die gleichen Decoder eingestellt? Als Videorenderer verwendet TransEdit grundsätzlich den VMR 7 in einem Modus, der der Einstellung "System Default Renderer" im DVBViewer Pro entspricht. Vielleicht probierst du das mal...

Bringt leider auch keine Verbesserung. Bei <System Default> werden die gleichen Decoder verwendet wie sonst auch. Und wenn ich statt Overlay Mixer einen anderen verwende, also "VMR 7 Video Mixing Renderer" oder "System Default Renderer" ändert das wie gesagt nix.

 

Aber sehr eigenartig, irgendwie war das vorher mal so, dass unter VMR 7 das OSD halbtransparent war (oder wars VMR9?). Jedenfalls hab ich immer Overlay Mixer eingestellt und da war das OSD nie transparent. Aber irgendwie ist es jetzt unter gar keiner Einstellung transparent, weder VMR7 noch VMR9?!?

 

Ich übrigens auch festgestellt, dass manchmal nach einem Graph-Neustart im DVB Source in der ersten Zeile oben kurz steht: "Video ??? 3,3 MBit/s", während die Audio-Anzeige normal ist. Komisch, ich dachte eigentlich das liegt am Audio, also am AC3-Stream. Also zumindest steht auch bei "Audio State" weiterhin "Enabled / Reconnected" während bei "Video State" "Enabled / Connected" steht.

Link to post

Juhu, ich hab's hingekriegt :biggrin:

 

Keinen Graph-Neustart seit über 20 Minuten!!!

Da mich das ganze mit dem VMR7/9 keine Transparenz sehr gewundert hab, habe ich mal geschaut was es auf der DirectX-Seite noch so für Einstellungen gibt:

Hier habe ich die Einstellung "TV/Radio Vorab-Formaterkennung" gefunden und habe einfach mal bei beiden ein Häkchen gesetzt.

Das mit der Transparenz hat sich zwar nicht geändert (diese Einstellungen haben ja auch offensichtlich nichts mit dem Video Renderer zu tun, aber diese Graph Neustarts sind jetzt weg!!!

Link to post

Kleiner Nachtrag (eigentlich wollte ich den letzten Beitrag editieren, aber irgendwie geht das nicht mehr?!?):

Es genügt bereits, wenn bei Audioformat das Häkchen gesetzt ist!

Link to post
Ich übrigens auch festgestellt, dass manchmal nach einem Graph-Neustart im DVB Source in der ersten Zeile oben kurz steht: "Video ??? 3,3 MBit/s",

Das ist normal. Die Fragezeichen erscheinen, solange der DVB Source das Videoformat noch nicht erkannt hat. Dauert manchmal ein bisschen, da erst ein Sequence Header im Stream auftauchen muss, was eine halbe Sekunde dauern kann.

 

Es genügt bereits, wenn bei Audioformat das Häkchen gesetzt ist!

Schön eingekreist! Das Häkchen sorgt dafür, dass der DVB Source bereits vor dem Wiedergabestart den Stream analysiert (was die Senderumschaltung deshalb leicht verzögert) und so dem Audiodecoder beim Verbinden die richtigen Audioparameter melden kann. Ansonsten verbindet er sich mit Defaultwerten - bei AC3 wäre das z.B. 5.1, 48 khz Samplerate - und es obliegt dem Decoder, das Format selbst zu erkennen. TransEdit lässt den DVB Source immer eine Video- und Audioformat-Erkennung durchführen, was deine Ergebnisse bestätigt.

 

Anzunehmen ist, dass etwas auf einen (vermeintlichen) Formatwechsel reagiert und es für notwendig erachtet, Filter neu zu verbinden, was einen kurzzeitigen Stop des Graphen erfordert. Trotzdem fragt sich, warum es sich bei dir öfters wiederholt. So oft wechselt RTL ja nicht zwischen AC3 2.0 und 5.1.

 

Auch ein Wechsel der Samplerate könnte einen Stop auszulösen, und in dem Fall würde der DVBViewer es sogar selbst durchführen, wenn ihm der DVBSource eine entsprechende Änderung meldet, außer wenn die Audioformaterkennung eingeschaltet ist. Der DVBSource nimmt beim Verbinden defaultmäßig 48 KHz an, aber wenn es dann tatsächlich 32 oder 44,1 KHz sind (selten im DVB-Bereich), erhält der DVBViewer eine entsprechende Meldung und reagiert mit Stop -> Audiofilter neu verbinden -> Run. Das Verbinden mit der richtigen Samplerate wird in dem Fall praktisch zwangsweise nachgeholt, da Audiowiedergabe mit falscher Samplerate sich i.a. katastrophal anhört :biggrin: Wenn jedoch die Audioformat-Erkennung eingeschaltet ist, unterlässt der DVBViewer diese Aktion, weil er davon ausgeht, dass es bereits geregelt ist - Änderungen der Samplerate im laufenden Betrieb kommen praktisch nicht vor.

 

Bei Dateiwiedergabe kann so etwas nicht passieren, da in diesem Fall das Audioformat auf jeden Fall vor dem Wiedergabestart ermittelt wird.

 

Alles deutet also darauf hin, dass dies der Auslöser ist, und damit gibt es zwei mögliche Ursachen: Der AC3-Stream ist fehlerhaft kodiert, so dass der DVBSource darin gelegentlich eine falsche Samplerate liest, oder die AC3-Formaterkennung im DVBSource enthält noch einen Fehler, der unter bestimmten Bedingungen zuschlägt. Das bleibt jetzt zu untersuchen... hilfreich wäre eine Aufnahme einer solchen Stelle, wobei Audio bzw. eine AC3-Datei reicht (Optionen -> Aufnahme-Optionen -> Aufnahmeformat Audio einstellen, und nicht vergessen, das nach der Aufnahme wieder auf MPG oder TS zurückzustellen, sonst enthalten auch weitere Aufnahmen nur Audio). Kannst du eine solche AC3-Datei erzeugen und irgendwo hochladen?

Link to post
So oft wechselt RTL ja nicht zwischen AC3 2.0 und 5.1.

 

Auch ein Wechsel der Samplerate könnte einen Stop auszulösen, und in dem Fall würde der DVBViewer es sogar selbst durchführen, wenn ihm der DVBSource eine entsprechende Änderung meldet, außer wenn die Audioformaterkennung eingeschaltet ist. Der DVBSource nimmt beim Verbinden defaultmäßig 48 KHz an, aber wenn es dann tatsächlich 32 oder 44,1 KHz sind (selten im DVB-Bereich),.....

Also es gab keine Wechsel zwischen 2.0 und 5.1 und die Samplerate liegt auch konstant bei 48 kHz.

Keine Ahnung was diesen Stop auslöst...

 

Hab einfach mal ein bisschen von RTL aufgenommen, hier die Datei:

http://www.file-upload.net/download-134285...-28-23.ac3.html

 

Diese Graph-Stops bzw. Neustarts traten (ohne das Häkchen bei Audioformat) bei dieser Aufnahme an den Stellen bei 1:05 und 1:15 auf (Angaben in min:sek).

Hoffe ihr könnt damit was anfangen ...

Link to post

Ich habe gerade noch etwas anderes festgestellt:

Beim Demultiplexen einer ts-Aufnahme von RTL mit ProjectX erhalte ich beim Auswerten des Teletext folgende Fehlermeldungen:

!> letzter Video PTS endet vor dem Start PTS aus diesem Strom! Synchronisierung unmöglich

!> Video & Teletext PTS stimmen zu keiner Zeit überein!

 

Also irgendwie scheint hier einiges nicht zu stimmen ...

Link to post
Der ac3-schnipsel wird bei mir ohne irgendwelche probleme durchgehend abgespielt. Egal ob mit vlc oder dvbv :biggrin:

Ja, bei mir auch. Die Aufnahmen werden problemlos abgespielt...

 

Wohlgemerkt handelt es sich bei der Meldung von ProjectX um die Synchronität von Video und Teletext, Video und Audio dagegen sind in Ordnung von vollkommen synchron :)

Edited by Martin K
Link to post
hier als zip:

Ok, das hat's gebracht :biggrin: Wie der Debugger zeigt, gibt es tatsächlich einen Fehler in der AC3-Streamerkennung des DVB Source, der bei den Änderungen für Enhanced AC3 reingerutscht ist, in bestimmten Fällen zu einer falschen Erkennung führt und als Folge ein Stop/Run auslöst. Ich nehme jedenfalls an, dass es das ist.

 

@Martin K: Kannst du bitte mit ausgeschalteter Audio-Formaterkennung die Testversion 3.3.1.1 des DVB Source probieren, die ich in den Mitgliederbereich -> Beta Section hochgeladen habe? Einfach die Datei PushSource.ax in DVBViewer\Filters austauschen.

 

P.S. Nicht von Derrick irritieren lassen. Der blickt nicht durch...

Edited by Griga
Link to post
@Martin K: Kannst du bitte mit ausgeschalteter Audio-Formaterkennung die Testversion 3.3.1.1 des DVB Source probieren, die ich in den Mitgliederbereich -> Beta Section hochgeladen habe? Einfach die Datei PushSource.ax in DVBViewer\Filters austauschen.

Jo, sieht gut aus!

Seit 10 Minuten kein Graph-Neustart!

 

Würde mich mal interessieren, was im AC3-Stream das ausgelöst hat, es müssen dann doch schon irgendwelche Fehler oder Formatänderungen in dem Stream sein, da es ja nur hier bei RTL auftrat?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...