Jump to content
rmor

Cannot render Mediafile/Output pin, error 0x80004002 No such interface

Recommended Posts

rmor

When I try to receiver the new Danish mpeg4 channels, I get this error message: "Cannot render Mediafile/Output pin, error 0x80004002 No such interface supported ?"

 

I'm using "Elecard AVC Video Decoder" as codec. With this one I get actual video once I press enter to the error message (although it's not stable and I don't get audio). Anyway, one step at a time here, anyone knows what this error means?

 

The MPEG2 channels are fine.

 

Using XP, DVBViewer pro 4.2.1.0, DVT-T USB tuner from WE Tech

Share this post


Link to post
Devastation
Cannot render Mediafile/Output pin, error 0x80004002 No such interface supported

Normally I would say this will be a decoder problem. Maybe Elecard can't handle the

new Danish mpeg4 channels

 

Have you other codecs installed that you can try?

 

I don't get audio

Maybe it helps to use 32bit AC3Filter as audiocodec.

Share this post


Link to post
rmor

Tried the AC3Filter - no change, i.e. no audio other than when I switch to the mpeg2 channels. I do still get the error message whenever I try to change the audio codecs for MP2 and AC3 audio. The channel info states that it is an h264 video stream and AAC audio stream. In DVBViewer I cannot change the AAC Audio Decoder, it stays at >System Default>. Does that sound right?

 

I have no other video decoder installed, got one you can recommend to try out?

Share this post


Link to post
Devastation

Maybe not to recommend but its good for a try cause its free. Test one of the latest ffdShow (x86) http://www.xvidvideo.ru/

 

And for AAC maybe system default is none? Post a support.zip please.

Share this post


Link to post
rmor

Tryed the ffdShow - and I get the exact same error message when chaning to an mpeg4 channel.

 

On audio: Not sure what the default is in my system (I don't know how to check that). It just say system default, and I can not change it.

 

support.zip attached.

support.zip

Share this post


Link to post
Gioxy

Your PC lacks a AAC filter/decoder/splitter...

Install Haali Media Splitter, it most probably solve your problem...

 

:biggrin:

Share this post


Link to post
thl

I have a similar problem.

 

I can see a MPEG-4 canal but the picture have errors. When I change the DirectX settings (H.264) I get this error "Cannot render Mediafile/Output pin, error 0x80004002 No such interface supported ". I have tried to use the ffdshow Video Deconder, the CyberLink Video/SP Decideren (PDVD9) and have installed the - Haali Media Splitter.

 

I send a support.zip and hope you can help me !

support.zip

Share this post


Link to post
thl

I found a solution.

 

Regards

Thomas

Share this post


Link to post
Radioman

I'm having a similar problem. I receive the MPEG4 DVB-T transmission OK, but no audio in DVBViewer. If I however use Transedit, both audio and video are OK.

A check with Graphedit, shows that there is no connection 'between two filters'?

The stream is MPEG4 Audio ISO/IEC 14496-3. Any hints?

Share this post


Link to post
capellec
When I try to receiver the new Danish mpeg4 channels, I get this error message: "Cannot render Mediafile/Output pin, error 0x80004002 No such interface supported ?"

 

I'm using "Elecard AVC Video Decoder" as codec. With this one I get actual video once I press enter to the error message (although it's not stable and I don't get audio). Anyway, one step at a time here, anyone knows what this error means?

 

The MPEG2 channels are fine.

 

Hello rmor.

I have the same error when trying to receive Danish terrestrial mpeg 4 channels. When I'm using Windows Media Center (version 6.1.7600) I receive the mpeg4 channels perfectly fine. So it seems not to be a question of not having intstalled the right codec as some people here suggest. Tried to repeat the test with 2 different tuners (Happauge SMS 1000 and EyeTV Hybrid DVB-T Tuner) with the same results: WMC works, DVBViewer doesnt. While both Scandinavia & UK are in a transition to the newer mpeg4 standard, Germany holds on to mpeg2. Perhaps this explains why DBViewer does'nt (yet) support the newer mpeg4-standard for terrestrial TV.

Christoph, Copenhagen

Share this post


Link to post
Griga
When I'm using Windows Media Center (version 6.1.7600) I receive the mpeg4 channels perfectly fine.

Windows 7, isn't it? You need DVBViewer Filter 3.5 (see members area). Previous versions are not able to connect to the Microsoft AAC decoder (provided since Windows 7), due to new AAC media subtypes defined by Microsoft. And maybe additionally DVBViewer Pro 4.3.1.60 Beta, that allows to select the MS AAC decoder in the options (I'm not sure whether this is necessary or not).

 

Or use the libfaad2 wrapper, as Tjod suggested. It is taylored for DVBViewer.

 

While both Scandinavia & UK are in a transition to the newer mpeg4 standard, Germany holds on to mpeg2. Perhaps this explains why DBViewer does'nt (yet) support the newer mpeg4-standard for terrestrial TV.

We are supporting it since terrestrial MPEG4 transmissions in Norway started in 2007 B) People from Norway are already aquainted with it and know what to do and what is required. Seems Danish people still have to learn a bit...

Share this post


Link to post
Anders Heerfordt

I have a similar problem. I am located in Copenhagen and receive DVB-T using a Hauppauge card. DVBViewer shows the MPEG2 channels OK, but it does not show MPEG4 (H.264) channels OK.

After installing the Elecard codec, the video part is shown, but not without some problems. I have not been able to get the audio working from the MPEG4 channels.

 

It seems to be a general DVBViewer problem in Denmark, as it has been discussed in the http://www.recorders.dk/ forum, where many members are using DVBViewer, and where the members generally are very technically skilled. None seem to have found a solution.

 

I think the broadcasting company (Danmarks Radio) has a history of implementing new features in a slightly different way from how it is done in neigboring countries. I suspect this could be a new example...

 

 

Regards,

Anders

support.zip

Share this post


Link to post
Griga
I have not been able to get the audio working from the MPEG4 channels.

 

According to your support.zip the libfaad2 Wrapper V1.2.1.0 is installed. Usually it decodes AAC in terrestrial transmissions without problems. Are you sure that you have carefully followed the instructions in the ReadMe?

 

Please provide a sample TS recording containing that type of audio, so I can check it. The debugger will tell me what's going on...

Share this post


Link to post
Anders Heerfordt

I was missing the libfaad2.dll file in the DVBViewer\Filters folder. After adding the libfaad2.dll to the folder, the audio problem is solved.

 

However the video still has a number of problems. It seems somewhat random whether the video fills out the DVBViewer window or appears as a small rectangle in the left upper part of the otherwise black window. When the video appears as a small rectangle in a large black window, it can help to select previous channel and then select next channel from the menus.

I sometimes get an error window with the title "Anwendungsfehler", and the text "Exception EInvalidPointer in Modul PushSource.ax bei 000029B8. After this error, DVBViewer becomes not responding, and it has to be killed.

 

The maximum upload size is 248K. I have been unable to make a TS recording that small, How do I do that?

 

Regards,

Anders

Share this post


Link to post
Anders Heerfordt

More on the video problems with the Danish H.264 channels

 

The videopart of the signal is frequently garbled. Either completely garbled, as if it were encrypted, or the video is split into 2-3 parts which are offset horizontally relative to each other, and then merged together. When a speaker should appear on the screen, instead 3 copies of the speaker appear on the screen. As if the picture was interlaced, and the interlacing not working correctly.

 

But when the transmission is recorded, and then replayed from the harddisk instead of live from the air, then the video part is OK.

 

When the video is garbled a "Previous channel" + "Next channel" will often remove the garbling, and the video is shown OK.

 

Regards,

Anders

Share this post


Link to post
Anders Heerfordt

I have uploaded 30 seconds of TS recording of a Danish H.264 new channel.

 

URL:

http://rapidshare.com/files/360141535/03-0...og_vejr.ts.html

MD5: E2BFDD7B7830D6D607E036E246FA86CE

 

Additional information:

• exact TV-card modell and used driver version : Hauppauge WinTV 88X (WinTV-HVR 1300)

• type and chipset of the mainboard: Mainboard Gigabyte GA-M57 SLI-S4, AMD Athlon™ 64X2 Dual Core Processor 3800+

• graphics card and used driver version: NVIDIA GeForce 7300 GT. Driver NVIDIA version 6.14.10.9371

 

Regards,

Anders

Share this post


Link to post
Griga
After installing the Elecard codec, the video part is shown, but not without some problems.

Maybe the decoder can't handle that type of H.264 properly.

 

I've tried to play your file with several H.264 decoders. Cyberlink (PowerDVD) fails badly. But the following do their job well: ffdshow, DivX H.264 decoder, MainConcept, CoreAVC 2.0, ArcSoft (all without DXVA = hardware accelerated decoding, because my graphics card doesn't support it for H.264).

 

Some links:

 

http://ffdshow-tryout.sourceforge.net/

 

http://www.free-codecs.com/download/DivX_H264_decoder.htm

 

http://corecodec.com/products/coreavc

Share this post


Link to post
OEL

Hi everybody...

 

I use TotalMedia software to watch DigitalTV h.264/ACC terrestrial signal, over a HP Compaq Laptop with over Windows XP SP3, 2 Gb RAM, Intel Core 2 Duo T5270 1.40 Ghz CPU x 2, SoundMAX Integrated Digital HD Audio, Mobile Intel 965 Express, MyGica S870 dongle and everything works rigth, video and audio, but this application is to much heavy and use many CPU.

Then I ordered and installed DVBViewer 4.2.1.0 with CyberLink 8 codecs and I can not to hear audio watching DigitalTV channels.

Starting DVBViewer I receive the error message: "Cannot render Mediafile/Output Pin, error: 0x80004002 No such interface supported."

 

I can watch and hear all formats, but watching DigitalTV channels... I can not hear audio.

I was trying with several CODECS and configurations.

I´m attaching support file.

 

I installed several codecs: CCCP, CiberLink, XP Code Pack, Fantasy, K/Lite... etc

 

Please I will apreciate some help for this issue.

Thanks in advance

OEL

Share this post


Link to post
Davor

Is installation of these encoders required, or is simply putting them somewhere in a folder enough (and letting DVBViewer use the DLLs)?

 

I prefer the second approach because I don't like installing many codecs (for obvious reasons).

Edited by Davor

Share this post


Link to post
Tjod

You know that this topic is 7 years old and that is such time frame lots of things charge in PC software.
10 years ago no iPhon or Android Smartphon existed. So it is a better idea to start a new topic the append a question to a old topic which mostly contains outdated informations.

 

Don't install Code Packs, which collect codecs from different places. Thy can mess up you system an often contain outdated versions.

Codecs must be registered in the system and should be unregistered before removing the files.

 

Installing LAV Filters vis setup is the best solution an should cover nearly everything you need codec wise (don't unselect the 32 Bit version in the setup).

https://github.com/Nevcairiel/LAVFilters/releases

Share this post


Link to post
Davor

I was lead to this thread because I have the same error message as the thread title. Apparently DVBViewer's usage of DirectShow is still unchanged. So I am sure it will help people in the future. Anyway, I am not into bashing or being smart. I am just looking for a way to make DVBViewer work without installing any codecs, not even LAV filters. I see there is a zip file that I can download. Can I make DVBViewer somehow load the required DDLs without installing LAV filters? Putting them in the Filters directory in DVBViewer root doesn't work - as someone suggested.

 

An other thing. I bought this software 8 years ago and my member credentials still work. But I was lead to this URL https://www.DVBViewer.tv/members/keynochange.php.to request a key change. I am still waiting for a mail. Could you look into this, or am I to request assistance elsewhere? Thanks.

 

PS The email I received the registration 8 years ago is still working.

 

Edited by Davor

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×