Jump to content
CiNcH

X10 Empfänger bzw. USB-Root-Hub weckt ständig PC aus S3

Recommended Posts

CiNcH

Ich habe hier die X10 Fernbedienung von Pollin und bin nach wie vor begeistert von der Lösung über Funk. Auch kann ich mit der Power-Taste den PC aus dem S3 aufwecken. 'powercfg -lastwake' liefert dann folgendes:

Aktivierungsverlaufsanzahl - 1
Aktivierungsverlauf [0]
 Aktivierungsquellenanzahl  - 1
 Aktivierungsquelle [0]
   Typ: Gerõt
   Instanzpfad: USB\VID_0BC7&PID_0006\5&1e3b7be0&0&2
   Anzeigename:
   Beschreibung: X10 USB Wireless Transceiver (ACPI-compliant)
   Hersteller: X10 Wireless Technology, Inc.

 

Macht Sinn...

 

Seither passiert es allerdings auch häufig, dass der PC plötzlich "von selber" aufwacht. In diesem Fall liefert 'powercfg -lastwake':

Aktivierungsverlaufsanzahl - 1
Aktivierungsverlauf [0]
 Aktivierungsquellenanzahl  - 1
 Aktivierungsquelle [0]
   Typ: Gerõt
   Instanzpfad: USB\ROOT_HUB\4&10b2c51b&0
   Anzeigename:
   Beschreibung: USB-Root-Hub
   Hersteller: (Standard-USB-Hostcontroller)

 

Über den Geräte-Manager habe ich dann herausgefunden, dass am USB-Root-Hub mit dieser Geräteinstanz ('USB\ROOT_HUB\4&10b2c51b&0') der 'X10 USB Wireless Transceiver (ACPI-compliant)' angeschlossen ist. Sonst hängt kein USB-Gerät an diesem Root-Hub.

 

Treiber vom X10 Empfänger ist der aus der Windows Online Treiber Datenbank:

Treiberanbieter:   X10 Wireless Technology, Inc.

Treiberdatum:      30.11.2006

Treiberversion:    6.0.0.210

Signaturgeber:     Microsoft Windows Hardware Compatibility

 

Ich habe schon den Funkkanal von 1 auf 13 geändert, für den Fall dass evtl. etwas reinfunkt. Wenn das der Fall wäre, wäre aber IMHO der 'powercfg -lastwake' Output ein anderer und würde wie im ersten Fall auf den X10 Empfänger hinweisen.

 

Hat jemand eine Idee, was den Root-Hub da veranlasst, den PC aus dem S3 zu holen und wie man das unterbinden kann? Oder evtl. wie ich das Problem genauer einkreisen könnte?

Share this post


Link to post
Tüftler

Ich kann dir zwar nicht direkt helfen aber bei mir war ein Defekt der FritzBox 7270 an den LAN-Ports dafür verantwortlich das der HTPC immer mal wieder aus dem Standby geweckt wurde.

Den eigentlichen Verursacher habe ich aber nicht für den Übeltäter gehalten sondern einen Defekt am Board vermutet, da ständig die Verbindung zum Net aufgebaut wurde und wieder zusammenbrach. Bei einem Test des Lappis ging dieser dagegen über LAN an der Box ohne Fehler.

Also USB-LAN Hub gekauft und die Verbindung ging wieder, nur leider ging mit dem Ding kein S3. Nach 4 Monaten war dann wieder die Verbindung zum Net weg :unsure:

Glücklicherweise habe ich zu Weihnachten in der Bucht ne zweite FritzBox geschossen (als DECT Erweiterung), also beide untereinander ausgetauscht und jetzt geht wieder alles ohne sonderbares Aufwecken. B)

Share this post


Link to post
CiNcH

Ich komm da nicht hinter. Ich denke, das ist ein HW-Problem. BIOS vom Mainboard ist auf Stand.

 

Was ich die Nacht probiert habe:

- Legacy USB Support im BIOS deaktiviert

- WOL abgeschaltet, obwohl der Wakeup-Event natürlich auf ein USB-Problem schließen lässt

- X10 Treiber aktualisiert (von hier)

- intel inf Treiber aktualisiert

 

Wobei ich nicht glaube, dass da software- bzw. treibermäßig was reinspielt. Das Aufwachen passiert ja irgendwo auf Hardware-Ebene, wo noch kein Treiber läuft. Der Treiber könnte aber evtl. ein Register falsch konfigurieren oder dergleichen.

 

In der Nacht ist mir der Rechner jedenfalls wieder aufgewacht, ziemlich genau um Mitternacht. Hab erst gedacht, Windows Update könnte sowas geplant machen. Laut 'powercfg -lastwake' und Windows Event Viewer war die Ursache aber wieder der USB-Root-Hub. Gestern ist der Rechner um 11 Uhr vormittags aufgewacht.

 

Momentan probiere ich den S4/Suspend-to-Disk. Der lässt sich evtl. von diversen Events nicht beeindrucken.

Share this post


Link to post
erwin

Hast du dieses Verhalten auch an anderen USB-Root-Hubs?

 

 

erwin

Share this post


Link to post
CiNcH
Hast du dieses Verhalten auch an anderen USB-Root-Hubs?

Mit der Power-Taste den PC aufwecken funktioniert IMHO nur am ersten USB-Root-Hub. An anderen Root-Hubs dürfte Ruhe sein, dafür aber wie gesagt auch kein manuelles Aufwecken per FB.

Share this post


Link to post
erwin

Ich weiss jetzt nicht obs hilft.

 

Ich hatte auch mal unerklärliche wake-ups. Des Rätsels Lösung war die doch sehr durch Zufall entdeckte Koinzidenz eines leise wahrnehmbaren Anruftones von einem Mieter eine Etage über mir. Wohl ein Dect-Telefon. Obs über meine Funktastatur oder meine X10-Remote reingekommen ist kann ich jetzt nicht mehr sagen.

 

erwin

Share this post


Link to post
CiNcH

Eine eventuelle Störquelle hatte ich auch schon in Vermutung, weshalb ich testweise den Funkkanal vom X10 gewechselt habe, was aber nichts gebracht hat. Auch komisch ist, dass nicht der X10 Empfänger als Aufwachquelle ausgemacht wird (wie wenn die Power-Taste gedrückt wird), sondern der USB-Root-Hub, an dem der X10 hängt.

Share this post


Link to post
erwin

Was passiert denn wenn du im S3 den X10-Receiver einstöpselst? Wake-Up? Und wenn ja, wer wird als Auslöser gemeldet? Er sendet dann normalerweise ein DeviceInit-Event. Evt. ein "USB-Wackelkontakt" der dann erratisches DeviceInit bewirkt.

 

erwin

Share this post


Link to post
CiNcH

Werde ich am Abend mal ausprobieren.

 

Meine Agenda:

 

- X10 Empfänger während S3 anschließen

- PC ohne X10 im S3 lassen und schauen, ob der PC immer noch vom USB-Root-Hub aufgeweckt wird (evtl. Tastatur an diesen Root-Hub anschließen)

- S4 probieren (ob PC mittels Power-Taste aus diesem State geweckt werden kann, ob PC durch USB-Root-Hub geweckt wird)

- anderer USB-Root-Hub (ob PC mittels Power-Taste geweckt werden kann, ob PC durch USB-Root-Hub geweckt wird)

Share this post


Link to post
CiNcH

Kenn ich schon. Da ist die Maus die Ursache für den Wakeup am USB-Root-Hub, bzw. 'Unknown' als Quelle durch WOL hervorgerufen. Hab mich gestern auch schon quer durchs Internet gekämpft.

Share this post


Link to post
erwin

Evt. ein "USB-Wackelkontakt" der dann erratisches DeviceInit bewirkt.

 

Übrigens meine ich das nicht nur mechanisch. Auch eine instabile S3-Stromversorgung könnte dies bewirken.

 

Tu auch mal die X10-Events mitloggen (Eventghost oder mein X10-Plugin)

 

erwin

Share this post


Link to post
CiNcH
Übrigens meine ich das nicht nur mechanisch. Auch eine instabile S3-Stromversorgung könnte dies bewirken.

Guter Ansatz. Dem werde ich nachgehen.

 

Tu auch mal die X10-Events mitloggen (Eventghost oder mein X10-Plugin)

Wann? Ein Event im S3 bekommt dein Plugin nachträglich mit?

Share this post


Link to post
erwin

Gute Frage. Müsste ich mal ausprobieren. Wäre dann aber vom konkreten Plugin unabhängig ob solche Events DeviceInit/PowerOn durchgereicht werden.

 

erwin

Share this post


Link to post
CiNcH
Gute Frage. Müsste ich mal ausprobieren. Wäre dann aber vom konkreten Plugin unabhängig ob solche Events DeviceInit/PowerOn durchgereicht werden.

Ha! Jetzt wo ich drüber nachdenke... Das Plugin bekommt zumindest den Event vom Power-Button mit, womit der PC aus dem S3 geholt wurde. Deshalb habe ich das Extended-Exit Menü dazumal auf "Power-Botton Hold" gelegt. Weil wenn man das Extended-Exit Menü normal auf den Power-Button legt (sprich ohne Hold), kommt das Menü auch wenn man den PC per Power-Button aus dem S3 holt.

 

USB-Events glaube ich mal nicht, dass du damit mitbekommst. Mal schauen, was in den entsprechenden Fällen im Log landet...

Share this post


Link to post
erwin

Mit der Power-Taste den PC aufwecken funktioniert IMHO nur am ersten USB-Root-Hub.

 

OK, was dazu gelernt. Was muss ich denn sonst noch einstellen damit der Powerkey den PC hochjagt? BIOS - welche wake-on?

 

erwin

Share this post


Link to post
CiNcH
OK, was dazu gelernt. Was muss ich denn sonst noch einstellen damit der Powerkey den PC hochjagt? BIOS - welche wake-on?

Es gibt Guidelines, die ich aber nur zum Teil befolgt habe bzw. befolgen konnte (Kommentare folgen nach dem Zitat):

Wie kann ich meinen Computer mit der Fernbedienung aufwecken?

 

Ob das Aufwecken funktioniert, ist mehr oder weniger Zufall. Folgende Maßnahmen erhöhen aber die Wahrscheinlichkeit, dass es funktioniert:

 

  • Stecken Sie den Empfänger in den USB-Port, der sich hinten am Computer oben links/rechts befindet (am weitesten entfernt von den PCI-Karten). An einem Hub funktioniert das Aufwecken in der Regel nicht.
     
  • Verwenden Sie zum Aufwecken die Power-Taste auf Ihrer Fernbedienung. Andere Tasten funktionieren in der Regel nicht.
     
  • Installieren Sie den Treiber von unserer Seite (Download hier auf der rechten Seite).
     
  • Aktivieren Sie "WakeOnUSB" im BIOS.
     
  • Stellen Sie sicher, dass Windows für den Energiesparmodus S3 und nicht S4 verwendet. Auch dies lässt sich unter Umständen im BIOS konfigurieren.
     
  • Aktivieren Sie im Gerätemanager von Windows den Haken "Gerät kann den Computer aufwecken" im Reiter "Energieverwaltung" in den Eigenschaften aller X10-Geräte (diese befinden sich bei den USB-Geräten und bei den Eingabegeräten.

 

Wenn ich das richtig in Erinnerung habe, hat der Treiber von X10Receiver.net wie oben vorgeschlagen bei mir bezüglich Wakeup unter Windows 7 nicht funktioniert. Ich verwende deshalb den Treiber von der Online Windows Treiber Datenbank. Der Eintrag im Geräte-Manager lautet dann 'X10 USB Wireless Transceiver (ACPI-compliant)'. Man kann auch diesen Treiber nehmen. Das ist der Versionierung nach zu urteilen derselbe wie aus der Windows-Datenbank, aber aktueller. Den habe ich momentan in Verwendung. Man muss bei diesem aber im Geräte-Manager die ganzen X10 HID-Geräte deaktivieren. Die funken sonst rein.

 

"Gerät kann den Computer aufwecken" ist bei mir ausgegraut, funktioniert aber trotzdem.

 

Auch "WakeOnUSB" gibt es in meinem BIOS nicht, funktioniert aber trotzdem ;) .

 

S4 wird nicht empfohlen. Muss ich heute noch schauen, ob das funktioniert.

 

Ich habe vor einiger Zeit mal diverse USB-Root-Hubs an meinem Mainboard (ASUS P5B-E Plus mit Intel P965/ICH8 Chipsatz) durchprobiert, weil ich es erst auch nicht zum Laufen gebracht habe. Wenn ich mich recht entsinne, hat das bei meinem Mainboard nur auf dem ersten (dem mit der niedrigsten Adresse, der wie oben beschrieben situiert ist, wo sonst üblicherweise Maus und Tastatur dran hängen) funktioniert. Ist sicher abhängig von der Verdrahtung auf dem Mainboard.

 

 

Ansonsten kann man gemäß dem Zitat...

 

Ob das Aufwecken funktioniert, ist mehr oder weniger Zufall.

... nur noch viel Glück wünschen ;) .

Share this post


Link to post
CiNcH

Hier mal ein Zwischenfazit...

 

-> Rechner per Power-Taste der X10 Fernbedienung aufzuwecken funktioniert sowohl aus S3 als auch S4 (mein Rechner braucht im S3 3.2W und im S4 2.2W).

 

-> Log-Eintrag nach dem Aufwecken per Power-Taste aus S4:

13 17:56:08.45 DN Power        >                                 >
13 17:56.08.57 UP Power        > Power                           > LiveTV::Power

 

-> Bereits das Ausstecken des X10 Emfängers während S3/S4 bewirkt in der Tat ein Einschalten des Rechners. Quelle ist natürlich der USB-Root-Hub. erwin scheint also in der Tat richtig zu liegen. Im Exten.log ist in diesem Fall nichts gelandet.

 

Jetzt ist nur noch die große Frage, wie man diesen "Disconnect/Reconnect" unterbinden kann oder dem System sagen kann, dass es nicht darauf reagieren soll.

 

Ich hatte noch eine 10cm USB-Verlängerung zwischen PC und X10 Empfänger. Die habe ich nun einmal rausgenommen. Jetzt heißt es erstmal wieder abwarten.

 

Vielen Dank erwin für den Denkanstoß!

Share this post


Link to post
erwin

-> Rechner per Power-Taste der X10 Fernbedienung aufzuwecken funktioniert sowohl aus S3 als auch S4 (mein Rechner braucht im S3 3.2W und im S4 2.2W).

 

Auch S4 - gute Nachricht.

 

Bereits das Ausstecken des X10 Emfängers während S3/S4 bewirkt in der Tat ein Einschalten des Rechners. Quelle ist natürlich der USB-Root-Hub.

 

Wäre dann das DeviceStop-Event (beim Einstecken dann DeviceStart - nicht wie ich oben sagte DeviceInit)

 

Im Exten.log ist in diesem Fall nichts gelandet.

 

Ich habs gestern im lfd. Betrieb (nicht S3/S4) getestet und bekomme die Sequenz

 

DeviceStop

DeviceStart

 

geloggt. Möglicherweise habe ich eine neuere ExTen-Version (falls so, bekommmst du die per PM).

 

Den Test im S3 hole ich heute abend nach.

 

 

Jetzt ist nur noch die große Frage, wie man diesen "Disconnect/Reconnect" unterbinden kann oder dem System sagen kann, dass es nicht darauf reagieren soll.

 

Als Workaround, damit der PC nicht die ganze Nacht läuft, könnte man per Eventghost auf DeviceStart/DeviceStop mit erneutem S3/S4 reagieren (natürlich entsprechend konfiguriert - sonst geht der PC beim Receibver-Einstecken immer in dee Schlaf

 

erwin

Edited by erwin

Share this post


Link to post
CiNcH
Als Workaround, damit der PC nicht die ganze Nacht läuft, könnte man per Eventghost auf DeviceStart/DeviceStop mit erneutem S3/S4 reagieren

Ich hoffe das Problem nun durch das Entfernen der 10cm USB-Verlängerung im Griff zu haben. Mittlerweile schläft der Rechner schon 18 Stunden. In dieser Zeit wacht er sonst in der Regel mindestens einmal auf.

 

Können EventGhost und ExTen-Plugin parallel auf dem X10 Empfänger horchen?

 

natürlich entsprechend konfiguriert - sonst geht der PC beim Receibver-Einstecken immer in dee Schlaf

Die Frage ist, ob dieser Reconnect auch während des Betriebs passiert. Dann wäre ein Auslösen des S3/S4 vlt. nicht so optimal ;) . Wie mächtig EventGhost ist, weiß ich nicht. Ich habe in der Vergangenheit nur mal kurz damit herumgespielt.

 

Wenn es ein Versorgungsproblem im S3/S4 ist, passiert der Reconnect im Betreib nicht. Wenn die USB-Verlängerung schuld ist evtl. schon. Die typischen Windows-Töne, wenn ein USB-Gerät an- bzw. abgesteckt wird, sind mir bis jetzt noch nicht bewusst aufgefallen. Kann aber auch sein, dass ich mir nur nichts dabei gedacht habe..

Share this post


Link to post
erwin

Ich hoffe das Problem nun durch das Entfernen der 10cm USB-Verlängerung im Griff zu haben.

10cm Verlängerung? Wo gibts denn sowas? Selbst gelötet? :whistle:

 

Können EventGhost und ExTen-Plugin parallel auf dem X10 Empfänger horchen?

Theoretisch schon. Der X10-COM-Server sollte alle registrierten Eventhandler bedienen.

 

Die Frage ist, ob dieser Reconnect auch während des Betriebs passiert. Dann wäre ein Auslösen des S3/S4 vlt. nicht so optimal ;)

:oops:

 

erwin

Share this post


Link to post
CiNcH
10cm Verlängerung? Wo gibts denn sowas? Selbst gelötet?

Ne, ausnahmsweise mal nicht :bounce: . Das USB-Kabel für die interne Anysee habe ich selbst gelötet. Die hängt aber an einem anderen Root-Hub :whistle: .

 

Die Verlängerung war bei einem DVB-T Stick mit bei (siehe hier), um selbigen hinter dem Notebook vorzuholen. Für sowas sind diese kurzen Kabel bei TerraTec recht üblich, wohl wegen dem IR-Auge. (sieht dann aber doch mehr nach 20cm aus ;) )

 

Wusste ich gar nicht, dass das Teil am X10 dran war. Ist mir erst aufgefallen, als ich den Abstecktest durchgeführt habe ;) .

Share this post


Link to post
CiNcH

Verdammt! Wieder aufgewacht.

Share this post


Link to post
Ivi

Hoi,

 

hoert sich zwar bloed an aber ..

bei mir weckt die X10 den Rechner immer mindestens 1x in 24h wenn die Akkus! in der Fernbedienung fast leer sind.

Geht dann ueber Tage so (Fernbums funktioniert normal ausser dass es dieses Aufwecken gibt)..

Akkus laden und schon hab ich wieder Ruhe fuer 2-3 Monate..

 

Bis denne..

Share this post


Link to post
CiNcH
bei mir weckt die X10 den Rechner immer mindestens 1x in 24h wenn die Akkus! in der Fernbedienung fast leer sind.

Geht dann ueber Tage so (Fernbums funktioniert normal ausser dass es dieses Aufwecken gibt)..

Akkus laden und schon hab ich wieder Ruhe fuer 2-3 Monate..

Es gibt in der Tat verschiedene Quellen, die den PC aufwecken können. Das ist eine davon. Dann liefert 'powercfg -lastwake' jedoch IMHO 'X10 USB Wireless Transceiver (ACPI-compliant)' als Quelle.

 

Auch Windows Update hat mir den PC schon aufgeweckt.

 

USB-Root-Hub als Quelle hat meiner Meinung nach eine andere Ursache, evtl. wirklich ein Spannungsproblem im S3/S4.

Share this post


Link to post
erwin

Für sowas sind diese kurzen Kabel bei TerraTec recht üblich, wohl wegen dem IR-Auge.

Und ich dachte schon die DVB-T Anbieter haben endlich mitbekommen, dass DVB-T-Stick + MCX/Coax-Adapter + Antenne einen viel zu langen Hebel ergeben der wirklich jede USB-Buchse ruiniert. Ich betreibe meine DVB-T auch nur noch mit Verlängerungskabel (1m).

 

Verdammt! Wieder aufgewacht.

Da ich auf die Schnelle nicht weiss ob die downloadbare ExTen 1.3.2 auch die DeviceStop/DeviceStart-Events loggt hier meine aktuelle Arbeitsversion 1.4.1

 

ExTen.zip

 

Achtung (auch für andere Downloader): Dies ist kein offizielles Update (da noch nicht fertig). Also kein Changelog und Bugs-inklusive. Die X10-Interop ist (dank late-Binding) nicht mehr notwendig. ExTen.exe ist ein Trayutil falls man ExTen ohne DVBViewer nutzen will, etwa zur PowerDVD-Steuerung. ExTenConfig.exe ist der Konfigurationsdialog als Standalone.

 

wenn die Akkus! in der Fernbedienung fast leer sind.

Diese wake-ups durch Batterie-Low-Events habe ich an meiner Funktastatur auch schon gehabt

 

 

erwin

Share this post


Link to post
CiNcH
Da ich auf die Schnelle nicht weiss ob die downloadbare ExTen 1.3.2 auch die DeviceStop/DeviceStart-Events loggt hier meine aktuelle Arbeitsversion 1.4.1

Ach verdammt. Jetzt landen DeviceStart/DeviceStop im Log, auch mit 1.3.2, sowohl im Betrieb als auch S3. Wieso das beim ersten Mal nicht der Fall war, weiß ich nicht :blink: .

 

Diese wake-ups durch Batterie-Low-Events habe ich an meiner Funktastatur auch schon gehabt

Ich komm da nicht wirklich hinter. Ich denke, mein Mainboard bzw. das BIOS setzt ACPI nicht optimal um. Hier mal ein bisschen Output von powercfg:

C:\Users\Daniel Bechter>powercfg -devicequery wake_armed
Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
HID-konforme Maus
HID-Tastatur (002)


C:\Users\Daniel Bechter>powercfg -devicequery wake_programmable
HID-konformes Benutzersteuergerõt
Cinergy DT USB XS Diversity (MKII) Capture
Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
HID-konforme Maus
HID-konformes Benutzersteuergerõt (001)
HID-konformes Gerõt (001)
HID-konformes Gerõt (003)
HID-Tastatur (002)
HID-konformes Gerõt (006)

 

Der X10 Empfänger scheint da gar nicht erst auf, wie auch die USB-Root-Hubs. Trotzdem können beide den PC aufwecken. Zudem kann ich für beide die Option "Gerät kann den Computer aus dem Ruhezustand aktivieren" im Geräte-Manager nicht editieren. Beim X10 Empfänger gibt es die Registerkarte "Energieverwaltung" erst gar nicht, beim USB-Root-Hub ist die Option ausgegraut.

 

 

Ich habe jetzt mal sämtliche Kabel vom Netzteil am Mainboard festgedrückt, den Netzstecker auf eine andere Steckdose gelegt und den X10 Empfänger an den USB2 vom ersten USB-Root-Hub verlegt.

Share this post


Link to post
dbraner

wo hast Du das denn her?

 

Wie kann ich meinen Computer mit der Fernbedienung aufwecken?

 

Ob das Aufwecken funktioniert, ist mehr oder weniger Zufall. Folgende Maßnahmen erhöhen aber die Wahrscheinlichkeit, dass es funktioniert:

 

Stecken Sie den Empfänger in den USB-Port, der sich hinten am Computer oben links/rechts befindet (am weitesten entfernt von den PCI-Karten). An einem Hub funktioniert das Aufwecken in der Regel nicht.

 

Verwenden Sie zum Aufwecken die Power-Taste auf Ihrer Fernbedienung. Andere Tasten funktionieren in der Regel nicht.

 

Installieren Sie den Treiber von unserer Seite (Download hier auf der rechten Seite).

 

Aktivieren Sie "WakeOnUSB" im BIOS.

 

Stellen Sie sicher, dass Windows für den Energiesparmodus S3 und nicht S4 verwendet. Auch dies lässt sich unter Umständen im BIOS konfigurieren.

 

Aktivieren Sie im Gerätemanager von Windows den Haken "Gerät kann den Computer aufwecken" im Reiter "Energieverwaltung" in den Eigenschaften aller X10-Geräte (diese befinden sich bei den USB-Geräten und bei den Eingabegeräten.

 

die einzigen Aussagen, die hier stimmen sind die BiOS Einstellung und der Haken im Gerätemanager bei "Gerät kann ... Aufwecken". Ich würde mich bei der Suche nach der Ursache auch nicht auf die Ausgabe des powercfg Befehls verlassen, sondern mal grundsätzlich im Gerätemanager prüfen, dass nirgendwo die o.g. Option gesetzt ist. Auch wichtig: in den Netzwerkkarten Einstellungen kann man ein Aufwachen bei Empfang von Netzwerkpaketen aktivieren. Das muss auf jeden Fall deaktiviert sein. Dabei muss man auch bedenken, dass andere Geräte wie TV-Karten oder bluetooth adapter oder Firewire-Anschlüsse als Netzwerkkarten erkannt werden können (parallel zu ihrer normalen Funktion). Diese Geräte sollten am besten ganz deaktiviert werden.

Share this post


Link to post
CiNcH
wo hast Du das denn her?

Hier

Share this post


Link to post
dbraner

Ich meine nur:

 

Ob das Aufwecken funktioniert, ist mehr oder weniger Zufall. Folgende Maßnahmen erhöhen aber die Wahrscheinlichkeit, dass es funktioniert:

 

Stecken Sie den Empfänger in den USB-Port, der sich hinten am Computer oben links/rechts befindet (am weitesten entfernt von den PCI-Karten). An einem Hub funktioniert das Aufwecken in der Regel nicht.

 

Klingt für mich nach Voodoo mit Huhn opfern und so ;-)

 

Mit Aufwachen beim Empfang von Netzwerkpaketen meine ich NICHT wake on lan. Manche Netzwerkkarten wecken den PC beim Empfang beliebiger Pakete. Man sollte zwar meinen, dass der PC dann öfters aufwachen müsste, da im Netzwerk immer etwas Traffic ist. Die Karten reagieren aber nur auf Ethernet-Pakete, die im Header die MAC des Adapters enthalten.

Share this post


Link to post
erwin

Ach verdammt. Jetzt landen DeviceStart/DeviceStop im Log, auch mit 1.3.2, sowohl im Betrieb als auch S3. Wieso das beim ersten Mal nicht der Fall war, weiß ich nicht :blink: .

Du meinst jetzt die von dir provozierten DeviceStart/DeviceStop im S3? Oder hast du Einträge von deinen mystischen Fällen und somit das Problem eingegrenzt? Und wake-up ohne Log-Eintrag was könnte man daraus schließen?

 

erwin

Share this post


Link to post
CiNcH
Du meinst jetzt die von dir provozierten DeviceStart/DeviceStop im S3?

Ich meine vom provizierten, ja. Ich lass das Logging jetzt aktiv und berichte gegebenenfalls.

 

Und wake-up ohne Log-Eintrag was könnte man daraus schließen?

Vielleicht hab ich es ja irgendwie verbockt ;) .

Share this post


Link to post
erwin

Vielleicht hab ich es ja irgendwie verbockt ;) .

Ne dass hab ich jetzt nicht gemeint. Was wäre wenn der PC wieder hochspringt und kein Log? Vielleicht falsche Spur oder so.

 

Noch ein par Beobachtungen bezüglich der Events:

 

Gehe in den Standby. Sehe noch kurz im ExTen-Monitorfenster DeviceStop. Die Devices werden ja vom System kurz noch vorher informiert. Im S3 ziehe ich den Stecker und stecke ihn woanders wieder ein.

 

Dieses raus/rein bewirkt bei mir kein wake-up.

 

Die LED ist im S3 AUS. Bei dir auch?

 

Jeweils beim rausziehen/einstecken kurzes Aufblinken. Wieder im Betriebsmodus im Log

 

> DeviceStop <- noch im Monitorsichtbar

> DeviceStop <- offenbar im S3 und vom System gecached

> DeviceStart <- S3 ?? Oder nach dem Wiederanlauf

 

 

erwin

Share this post


Link to post
CiNcH
Die LED ist im S3 AUS. Bei dir auch?

Ja, LED ist aus.

Share this post


Link to post
CiNcH

Heutiger Wakeup-Event...

 

 

Hier wurde der PC schlafen geschickt:

01 11:20:47.69 DN Power        >                                > 
01 11:20:48.30 RT Power        > Power Hold                     > LiveTV::Power Hold
01 11:20:48.37 UP DeviceStop   >                                > 

 

Das Aufwachen:

01 16:25:31.42 DN DeviceStart  >                                > 
01 16:25:32.03 DN Power        >                                > 
01 16:25:32.13 UP Power        > Power                          > LiveTV::Power

 

Da wurde um 16:25 scheinbar selbstständig der Power-Event ausgelöst, als ich beim Training war. Das ist der Fall, den Ivi beschrieben hat.

 

Obwohl offensichtlich der Power-Event ausgelöst wurde und die Quelle demnach der X10 Empfänger sein sollte, liefert der Windows Event Viewer den USB-Root-Hub als Quelle um 16:25. Wenn ich es manuell mache, also tatsächlich über die physikalische Power-Taste, scheint der X10 Empfänger als Quelle auf. Sehr merkwürdig :blink: .

 

Ich wechsel die Batterien jetzt erstmal nicht, sondern mach sie raus und schau, ob es immer noch passiert. Aber ich denke schon, weil wenn es wirklich durch die FB ausgelöst wird, scheint wie gesagt der X10 Empfänger als Quelle auf.

 

Im ExTen-Log steht ob manuell oder automatisch ausgelöst dasselbe drin (siehe Code-Block oben).

 

Zieht man den X10 Empfänger während dem S3 kurz, sieht das Log etwas anders aus:

 

01 18:29:35.39 DN DeviceStart  >                                > 
01 18:29:45.52 UP DeviceStop   >                                > 
01 18:29:46.63 DN DeviceStart  >                     

 

Scheint also doch nicht der "Reconnect" das Problem zu sein.

 

 

Die neue Frage ist also, wieso kommt da sporadisch der Power-Event an und wieso ist die Aufwachquelle der USB-Root-Hub und nicht der X10 Empfänger? Evtl. sollte ich den PC nicht über die Power-Taste schlafen schicken. Evtl. wird der Event irgendwo gecached :blink: .

 

 

Test 1: Batterien der X10 FB immer entfernen, wenn der PC schläft.

Test 2: PC nicht über die Power-Taste schlafen schicken, sondern über das Extended-Exit Menü.

Share this post


Link to post
erwin

Interessante Ergebnisse!

 

Erstmal schön dass das Logging Ergebnisse zeitigt.

 

 

Das Aufwachen:

01 16:25:31.42 DN DeviceStart  >                                > 
01 16:25:32.03 DN Power        >                                > 
01 16:25:32.13 UP Power        > Power                          > LiveTV::Power

Das merkwürdige hier ist, dass es völlig normal aussieht. DOWN gefolgt von UP. "Batterie LOW° soll so vernünftig reagieren? Und das mit POWER-Key? Sag mal hast du ein Haustier :bounce:

 

 

erwin

Share this post


Link to post
CiNcH

Kann ich mir auch nicht erklären. Ich kann jedenfalls ausschließen, dass jemand die Taste drückt. Und wenn das der Fall wäre, würde mir der Windows Event Viewer sowieso den X10 Empfänger als Quelle melden und nicht den USB-Root-Hub. Evtl. sind wir nach den nächsten beiden Tests schlauer...

Share this post


Link to post
erwin

Nochmal nachgedacht. Wenn POWER die einzige VORGESEHENE Taste für den WAKE-UP ist, dann kann es sein dass es auch so protokolliert wird weil der Treiber es so liefert, egal was da wirklich passiert ist (Denkfehler beim Treiberentwickler).

 

erwin

Share this post


Link to post
erwin

Das merkwürdige hier ist, dass es völlig normal aussieht. DOWN gefolgt von UP.

Ich korrigier mich jetzt mal selber. So normal siehts doch nicht aus. Zwischen DOWN und UP liegt nur eine Zentelsekunde (0,1 s). Das beste Ergebnis welches ich manuell bei Tstendrücken erreiche ist ca 2,7 Zehntel.

Über die minimale Zeitauflösung die die Treiber kiefern kann ich nichts sagen.

 

Vielleicht doch Fremdwirkung (DECT)?

 

PS. Du solltest doch deinen exotischen Kanal 13 nutzen. Nur für den Fall das doch der Nachbar! 16 Uhr ist eine gute Zeit den TV einzuschalten, wie auch mitten in der Nacht zum Ausschalten einlädt. Der _falsche_ Empfangskanal fällt dann im Log besser auf.

 

Ich habe schon den Funkkanal von 1 auf 13 geändert, für den Fall dass evtl. etwas reinfunkt.

 

Wo? Auf der FB. Im ExTen-Config die Checkbox?

 

Meines Wissens bewirkt die Kanalumstellprozedur nur eine Änderung des Sendekanals. Der Empfänger lauscht trotzdem auf allen Kanälen. Also selbst wenn du auf 13 bist, kann dein Nachbar auf 1 reinfunken. ExTen filtert dann zwar raus aber der wake-up wäre schon gelaufen.

 

erwin

Share this post


Link to post
CiNcH
Test 1: Batterien der X10 FB immer entfernen, wenn der PC schläft.

Test 2: PC nicht über die Power-Taste schlafen schicken, sondern über das Extended-Exit Menü.

Beides Fehlanzeige.

 

Vielleicht doch Fremdwirkung (DECT)?

Glaub ich auch nicht dran. Mich macht wie gesagt stutzig, dass die Quelle der USB-Root-Hub und nicht der X10 Empfänger ist.

 

Dennoch habe ich auch in der Fritz!Box überprüft, ob zu den Uhrzeiten des Aufwachens ein eingehender oder ausgehender Anruf war (DECT). Auch nichts. Ich wohne hier in ländlicher Gegend in einem Haus, wo ich jedes einzelne Gerät kontrolliere ;) . Sehr oft wacht der PC in der Nacht auf...

 

PS. Du solltest doch deinen exotischen Kanal 13 nutzen

Ich werde nochmal einen anderen probieren.

 

Wo? Auf der FB. Im ExTen-Config die Checkbox?

Beides ja. Inkl. in der ini die "Key ID's" angepasst, damit das dann auch funktioniert ;) . Ich habe es nur irgendwann wieder auf den 1. Kanal zurückgestellt.

 

 

 

Langsam bin ich mit den Ideen jedenfalls am Ende...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...