Jump to content

Erster Eindruck HbbTV-Engine DVBViewer 5.2


Cool_Spot

Recommended Posts

  • Replies 180
  • Created
  • Last Reply

Top Posters In This Topic

  • hackbart

    28

  • BALOU

    17

  • nordstern70

    14

  • GBWebmaster

    11

Top Posters In This Topic

Popular Posts

Einfach mal Notepad öffnen, folgenden Code eingeben: Dim DVBViewer Set DVBViewer = GetObject(, "DVBViewerServer.DVBViewer") DVBViewer.HbbTV.LoadInBrowser "http://www.spiegel.de", 0 DVBViewer.H

Hi, habe mir jetzt auch das HBB-TV Plugin gekauft. Gibt es denn irgendwo ne richtige Anleitung dafür?   1. Habe nach einigem Suchen gefunden dass man die Channel+- Tasten brauch, um nach links und

Habt ihr das MP4Stream Preset aktiviert und den LAV-Filter installiert? http://de.DVBViewer.tv/wiki/GraphPresets

Posted Images

Nein es reicht wenn es aktiviert ist. Startet man den DVBViewer mit dem Parameter -debug wird übrigens angezeigt was genau geladen wird. Da steht dann übrigens auch der Videolink. Den kann man auch via Open URL öffnen, so spart man ggf. beim Testen der Einstellungen Zeit.

Link to post

Ich weiß ja nicht, ob sie's schon wußten, aber der neueste Media Player Classic HC nutzt jetzt auch nur noch LAV und wenn ich mit dem so eine rauskopierte URL öffne, habe ich all das, was ich mir beim DVBViewer auch wünsche: Er spielt alles ruckelfrei ab, ich kann hin- und herspulen oder springen wie ich will ohne einen einzigen Aussetzer, alles synchron - was will man mehr?

 

Könnte diese Erkenntnis einer Fehleranalyse dienlich sein?

Link to post

Nun wenn man in deine Log guckt sieht man das du keinen MP4 Splitter hast. Es wird der vom LAV durch das Preset verlangt, der fehlt. Deswegen gibt es auch Probleme. Der VOD Filter kümmert sich um das lesen und Puffern der Streams, braucht aber einen Splitter der die Audio und Videodaten aus dem Stream liest und dem Video und Audiodekoder zur Verfügung stellt.

Link to post
  • 4 months later...

Hallo,

 

DasThema ist zwar älter aber egal, gebe nun auch mal meinen Senf dazu:

 

HbbTV ist schonmal gut, es gibt jedoch ein/mehrere Problem(e):

Wenn die HbbTV App hängt, dann reißt es den ganzen DVBViewer mit. Es müsste eine Möglichkeit geben die App über eine Fernbedienungsaktion zu beenden und in die normale OSD-Bedienung zurück zu kommen.
Auch das Puffern von Live-Streams dauert mit 45s teilweise echt viel zu lange!

Während dieser Zeit kann der DVBViewer nicht bedient werden, da hilft nur abschießen und neustarten:
Screen20140219-111042.jpg

 

(was auf einem HTPC mit nur einfacher fernbedienung auch sehr lange dauert aber schneller geht)...

Link to post

Naja der puffert nur so viel an Daten wie der Dekoder unbedingt braucht. Das ganze ist wie eine Badewanne wo du gleichzeitig Wasser einfüllst und raus lässt. Ist der Abfluss größer als der Zufluss kannst du so lange Wasser einfüllen und die Wanne bleibt dennoch nur ein bisschen feucht. Insbesondere in Abendstunden wirds bei einigen Diensten und Mediatheken eng.

Abstürzen tut der DVBViewer nicht, aber da der Browser und der Javascriptparser im gleichen Thread laufen frisst sich bei problemen mit Java gerne das Chromium-Embedded fest. Einige Dienste musste ich mit javascript injections notdürftig "patchen" damit das nicht passiert.

Link to post
  • 2 weeks later...

Hallo,

 

ich hatte folgendes Problem. Beim Drücken von F5 hat sich nichts getan. Erneutes installieren des Plugins brachte aber dann Abhilfe. Jemand eine Idee woran das gelegen haben könnte?

 

Das zweite ist das HBB von "Das Erste". Da wird zwar nun wieder ein Menu eingeblendet, aber sonst funktioniert "nix". Also wenn ich dann z.B. Videotext auswähle blinkt es einmal und ich sehe weiter das "Olympia-Layout". Ist das bei noch jemanden so oder ist das z.Z. generell beim Ersten so?

Link to post
  • 3 weeks later...
nordstern70

Mir ist heute aufgefallen, das ich im DVBViewer unter "Hilfe", "Info" in der Taskleiste für HBBTV/MHEG5 die Version 1.0.0.11 angezeigt bekomme.

Im Membersbereich ist jedoch die Version 2.0.0.1 angegeben, welche ich auch installiert habe.

Warum wird da nicht die aktuelle Version angezeigt?

Hab ich beim installieren was falsch gemacht?

support.zip

Link to post
  • 4 weeks later...

Hallo zusammen.

 

Also, ich nutze auch das Plugin, habe aber so einige Probleme mit diesem Teil.

 

Hab mir diesen Thread jetzt mal durchgelesen, aber nicht so richtig durchgeblickt.

 

Wenn ich HbbTV mit der roten Taste aufrufe, funnktioniert es soweit auch.

Habe aber dann das Problem, das alles nur in 4:3 dargestellt wird, habe das zwar in dem Thread gelesen, aber nicht so wirklich verstanden wie man das abstellen kann.

 

Meinn größeres Problem aber ist, dass bei mir alles stumm bleibt. Ich habe bei keinem Sender einen Ton.

Ich habe das Ganze mit dem LAV Filter und auch mit AC3 probiert - aber nichts - es bleibt stumm.

Auch die Filter von Microsoft geben keinen Laut von sich.

 

Irgendwie verstehe ich das Ganze jetzt nicht mehr.

 

Ach ja ich habe auch die 2.0.0.1 installiert und in der Hilfe wird mir auch die Version 1.0.0.11 angezeigt.

 

Vielen Dank schon mal für eure Unterstützung.

 

Gruß

Artus

Link to post
  • 2 weeks later...

hallo zusammen... hab da mal ne ganz doofe laienfrage... WIE öffne ich das plugin? hab es mir heute mal gekauft. bei den sendern wie zb rtl wird auch das vorhandensein von hbbtv angezeigt, aber wie starte ich es? den ominösen red button gibts ja auf ner laptop tastatur nicht so wie bei ner fernbedienung. und da ich DVBViewer nur am laptop nutze brauch ich ja auch keine remote. also wie komme ich zu hbbtv bei den einzeknen sendern??

Link to post
  • 1 month later...

Nun wenn man in deine Log guckt sieht man das du keinen MP4 Splitter hast. Es wird der vom LAV durch das Preset verlangt, der fehlt. Deswegen gibt es auch Probleme. Der VOD Filter kümmert sich um das lesen und Puffern der Streams, braucht aber einen Splitter der die Audio und Videodaten aus dem Stream liest und dem Video und Audiodekoder zur Verfügung stellt.

 

So, neuer PC, alles sauber installiert samt LAV natürlich aber trotzdem,

 

DIE ZDF MEDIATHEK MACHT MICH SCHWACH!

 

Manchmal funktionierts einwandfrei, aber leider nicht verläßlich. Immer wieder laden Videos nicht und der DVBViewer hängt sich auf...wenn's doch wenigstens jetzt zur WM alles klappen würde!

 

Ich verstehe nicht, warum bei mir ab und zu kein Splitter gefunden wird - es sind alles MP4's und mal laufen sie und mal nicht. Ist das Murphy oder was habe ich hier übersehen?

 

Der LAV-Splitter ist bis auf .asf und .wtv für alle Dateitypen registriert - bin echt für jede Hilfe dankbar,

 

mfg

 

Hier die support.zip: support.zip

Edited by C.O.D.
Link to post
hackbart

Hmm, stimmt da hast du Recht, laut deiner Log will er zum Beispiel bei http://www.metafilegenerator.de/ondemand/zdf/hbbtv/de/zdf/14/06/140618_bramex_kompakt_2_wm_spo_2328k_p35v11.mp4 den LAV Splitter nicht nutzen und lässt Directshow entscheiden. Hier gehts allerdings ohne Probleme. Ich wollte für die nächste Version vom DVBViewer die Streamingklasse eh komplett neu gestalten und hoffe mal das sowas dann bei den meisten Streams nicht mehr passiert.

In der Zwischenzeit kann man aber den VODSource mit regsvr32 deregistrieren. In dem Fall wird immer (außer bei WMV) der LAV Source benutzt. Ist so eine Art Fallback die hoffentlich im nächsten Update obsolet wird.

Link to post
hackbart

Hmm, der Fehler sagt eigentlich nur das der MP4 Videodekoder nicht geht. Wäre interessant die Log mit aktiviertem Debug Parameter zu sehen.

Link to post

Hmm, der Fehler sagt eigentlich nur das der MP4 Videodekoder nicht geht. Wäre interessant die Log mit aktiviertem Debug Parameter zu sehen.

 

Kannst du netterweise nochmal 'n Blick auf meine Log (vorheriger Post) werfen, ich konnte da nichts entdecken...

 

Danke :-)

Link to post
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...