Jump to content
Sign in to follow this  
VIDEOFAN

Ungewollter Kanalwechsel nach ca. 10 Sek auf android device

Recommended Posts

VIDEOFAN

Hallo,

 

Ich habe seit einiger Zeit einen seltsamen Effekt auf meinen Androiden - 3 Stück- beim streamen vom RS.

Im PC läuft eine tbs6985 mit 4 Tunern. Parallele Aufnahmen sind kein Problem auch streamen auf windows Geräte oder auch Popcorn Hour geht problemlos.

 

Auf den Androiden mit Hilfe der DVBViewer App startet der gewählte TV- Kanal und wechselt plötzlich nach wenigen Sekunden zum nächsten. Und dann immer so weiter.

Das Verhalten ist reproduzierbar. Ich habe noch nicht herausgefunden, ob es evtl. Einen Zusammenhang gibt, wenn der PC mit dem RS gerade beschäftigt ist (DVBViewer läuft oder eine Aufnahme läuft) oder wenn er gerade nichts zu tun hat.

 

Es Version ist 1.29 DVBViewer 5.3.1 . Kennt jemand das Problem?

 

Videofan

Share this post


Link to post
Tjod

Das hört sich nach Sat>IP (mit der gesamten Senderliste als Playlist) an und einem Client Programm das nicht regelmäßig meldet das es noch da ist.

Share this post


Link to post
VIDEOFAN

Ich denke, dass es tasächlich in diese Richtung geht, wobei durch die app auf die eigentiche SAT>IP Funktion des RS nicht zugegriffen wird.

 

Es ist schon auffällig, dass es nur bei den androiden passiert - verschiedene Gerätetypen.

Hier habe ich das Problem inzwischen auch weiter eingegrenzt. Ich nutze dort die DVBViewer app 1.09 und als player den MXPlayer in der normalen version oder als pro.

 

Nehme ich einen anderen player statt Mx Player - leider sind nicht viele dafür überhaupt nutzbar, z.b. wondershare - tritt das Problem nicht auf. Der wondershare buffert sich aber einen Wolf dabei - das ist dann nicht wirklich ein TV Genuss.

Mit einem workaround bin ich aber einen Schritt voran gekommen. Die DVBViewer app erlaubt auch transcodierte streams. Wenn ich diese Variante wähle, tritt der Effekt nicht auf. Das streaming läuft konsequent durch. Da hier auch die Option besteht trotz Transcoding mit HD-Qualität (5 mbit) und schneller encodierung ("ultrafast" - also wenig Rechneleistung vermute ich mal) zu streamen, habe ich auch keine qualitativen Einbussen feststellen können.

 

Beim "direkten streamen" tritt der Effekt aber weiter auf - in Verbindung mit dem MX-Player, was eben noch vor wenigen Wochen / Monaten nicht der Fall war. Da an den Player-apps ja auch permanent geschraubt wird, ist die Ursache vermutlich eher dort zu suchen...

 

Was mir noch aufgefallen ist: ich habe die Senderliste nach ÖR und Privaten sortiert. Wenn ich direkt streame und beginne bei Das Erste HD dann switched der player im ca. 10sek-Takt immer zum nächsten Kanal der Senderliste, alle Kanäle werden in Top-Qualität dargestellt und bei zdf Neo HD bleibt der Player dann auf diesem Kanal und wechselt nicht mehr... Auch das ist reproduzierbar.

 

Sehr spannend. Der workaround hilft aber erstnal.

 

Videofan

Share this post


Link to post
VinoRosso

Aha, da es noch keiner gemeldet hat, dachte ich schon es liegt nur an mir....

 

Ich kann auch nicht sagen woran es liegt, aber ich dachte auch eher an den MX Player, bei mir switcht er komischerweise nur PayTV Sender alle anderen gehen ohne Probleme.....

 

SAT IP wird von der App nicht genutzt, nur der UPNP Stream

Share this post


Link to post
Tjod

Lade dir mal über das Webinterface (Irgend eine Sendung anklicken > Streaming) die channels.m3u und rtspchannels.m3u und versuch die beide mal auf dem Android gerät zu öffnen.

 

Wenn es bei der channels.m3u kein automatisches weiter springen gibt und bei der rtspchannels.m3u nach ca. 10 Sek. dan ist das recht sicher die Problematik.

Share this post


Link to post
ThulsaDoom

Ich nutze den BS-Player in der Pro Version (der m.M.n. gegenüber dem MX-Player das bessere Bild bei Interlaced Material macht) und dort habe ich sowas noch nicht beobachten können. Wenn gewünscht, kann ich aber gerne mal den MX-Player auf meinem ASUS Infinity TF700T installieren und gegentesten. Muss nur warten bis ich zuhause bin und das Tablett wieder Saft hat :original:

Share this post


Link to post
ThulsaDoom

So, das Problem konnte ich mit dem MX-Player so nicht nachstellen. Sowohl Free-TV als auch Pay-TV Kanäle laufen auch über Minuten mit dem MX-Player durch. Habe allerdings nur HD-Sender getestet. Der MX-Player in der Freeversion ist allerdings so bescheiden bei mir, dass ich ihn schnell wieder entfernt habe. Wer den Grund wissen möchte: holprige Wiedergabe in den ersten Sekunden und keine AC3-Dekodierung; HW+ Einstellung geht auch nicht mit 720p...aber das nur am Rande.

 

Getestet wurde mit dem RS 1.29 und der neuesten Version der DVBViewer-App für Android. Testgerät das o.a. Asus-Tablet mit nvidia tegra3.

Share this post


Link to post
VinoRosso

Bei mir gehts mit dem BS Player dafür problemlos, das reicht immerhin zum Streamen, aber mir gefällt der MX PLayer besser ;-)

Share this post


Link to post
ThulsaDoom

Ja, ich nehme auch den BS-Player in der Pro-Version. Damit ist alles butterweich! :D

Share this post


Link to post
VIDEOFAN

Wie ich sehe, bin ich damit tatächlich nicht allein.

 

Den BSPlayer hatte ich zuletzt nicht mehr genutzt, da der MX-Player bzgl. HW-Unterstützung meiner Hardware deutlich die Nase vorn hatte.

 

Ein Eintrag hier hat mich bzgl. HW- und SW decoding etwas ins Nachdenken gebracht und so habe ich den MXPlayer "gezwungen" in SW (Software) zu dekodieren. Das ruckelte zwar, aber der Kanalsprung blieb aus. Danach habe ich manuell wieder auf HW+ gestellt und alles war gut...

 

Ich hatte nicht viel Zeit und konnte das ganze Prozedere nicht 1:1 wasserdicht nachstellen, aber evtl. ist auch das ein Ansatz, den man weiter verfolgen kann.

Es sieht aber immer mehr nach einem kleinen bug im MXPlayer (pro) aus, Insofern hoffe ich auf die nächsten updates...

 

Videofan

Share this post


Link to post
VIDEOFAN

Gestern hat sich auf meinem Tablet eine neue Version der DVBViewer app (1.0.10) installiert und damit tritt der Fehler offensichtlich erst mal nicht wieder auf.

Ich werde das demnächst verstärkt testen :-)

 

Videofan

Share this post


Link to post
VinoRosso

Das wird wieder kommen, weil ich daran nix geändert hab :D

Aber es gibt ne MX Player Version die funktioniert ;-)

https://sites.google.com/site/mxvpen/translation/test-build

 

Bei mir läuft die wieder normal.

Laut changelog und XDA hat er auch einige Bugs gefixed die er mit der letzten Version eingeführt hat ;-)

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...