Jump to content

Rec. Service App (iOS 8.x - 11.x)


MarkusK

Recommended Posts

MarkusK war seit dem 25 März nicht mehr hier im Forum, keine Ahnung was los ist.

 

Da es mit der neuen Webinterface Version noch ein paar Probleme mit Timout Meldungen gab und MarkusK nicht da war, um das zu beheben, haben wird die erst mal entfernt und die alte Version in das 1.33er Setup gepackt.

Link to comment
  • 2 weeks later...

Hallo,

 

seit dem Update (gestern) von 1.32 auf 1.33 geht nun die App nicht mehr und ich komme auch nicht über Safari drauf. Was habter denn da wieder gemacht^^

 

Hat es jemand hinbekommen und kann eventuell einen Tip geben, woran es liegen kann? Benutzername und Passwort sind jedenfalls wie zuvor hinterlegt.

 

MfG

Link to comment

Hallo,

 

seit dem Update (gestern) von 1.32 auf 1.33 geht nun die App nicht mehr und ich komme auch nicht über Safari drauf. Was habter denn da wieder gemacht^^

 

Hat es jemand hinbekommen und kann eventuell einen Tip geben, woran es liegen kann? Benutzername und Passwort sind jedenfalls wie zuvor hinterlegt.

 

MfG

 

Bei mir läuft nach dem Update alles bis auf das iPad mini... :-/ immernoch nur der Punkt statt nem Stream.

 

Hab mich einfach an die Anleitung gehalten:

http://www.DVBViewer.tv/forum/topic/19628-recording-service-beta/page-4#entry447491

Link to comment

Moin,

 

ich komme ja nicht mal in die Benutzeroberfläche! Beim Verbindungsversuch kommt nur ein weißer Bildschirm, und dann die Fehlermeldung "Seite konnte nicht geladen werden". Nutze ich die Angaben aus der Wiki (http://de.DVBViewer.tv/wiki/IPhone/iPod/iPad_Unterst%C3%BCtzung) für den Aufbau mit einem Browser

 

http://[Nutzername]:[Passwort]@[serverIP]:[server Port]/ios/iphone-de.html

 

oder

 

http://[Nutzername]:[Passwort]@[serverIP]:[server Port]/ios/ipad-de.html

 

kommt der gleiche Spaß (keine Verbindung möglich). Nehme ich einen Laptop oder anderen PC im Netzwerk und verbinde über Browser mittels gleichem Weg, dann komme ich auf die Oberfläche (Stream habe ich nicht getestet). Die von mir eingetragenen Werte sind also korrekt.

 

 

 

Welche Anleitung meinst du?

 

MfG

Link to comment

Hallo,

 

jap Handys (und iPad) sind natürlich im WLAN. An den Einstellungen auf den Endgeräten habe ich auch ncihts verändert :/

 

Die 3 Puntke unter "WICHTIG" isnd bei mir von Haus aus auf mein System korrekt eingestellt. Am PC, auf dem der RS läuft, habe ich auch eine meiner Lizenzen für den DVBViewer installiert und nutze auch den RS (und nciht die TV-Karte). Das funktioniert ja...

 

Wenn jemand eine Idee hat, imemr raus damit. Irgentwie. Ich vermute aber, dass eine Neuinstallation her muss (da habe ich aber eigentlich keinen Bock drauf^^).

 

MfG

Link to comment

Es gibt Router wo du den zugriff aus dem WLAN auf Geräte im LAN verbieten kannst.

 

Es könnte auch sein das LAN und WLAN verschiedene Netze sind (grob die erste drei Ziffern Blöcke der IP Adressen sind nicht identisch). Dann würde sowohl die Firewall, mit der Standard Regel die das Setup erstellt, als auch der RS wenn Zugriffe aus dem Internet nicht erlaubt sind und nicht konfiguriert ist welche Netze alle zum LAN zählen, Zugriffe Blockieren.

 

Oder es gibt ein Problem mit Zeichen im Benutzernamen oder Passwort.

(Ich weiß nicht ob die App über all wo es nötig ist URL Encodiert)

 

Dann sollte ein Aufruf von http://[serverIP]:[server Port]/ios/iphone-de.html im Browser aber gehen. Wenn die Daten in den vom Browser geöffneten Dialog eingegeben werden.

Link to comment

Hallo Tjod,

 

also Netzwerk ist komplett unverändert. Weder IP noch Hardware der Geräte haben siuch verändert. Einzige Änderung ist das Update von RS 1.32 auf 1.33. Eine Neuinstallation hat übrigens nichts gebracht. Es scheint, als ob das Update auch Einträge in der Registry verändert hat. Für mich ist es gerade sehr schwierig und auch frustrierend. Benutzername und Passwort für den RS sind übrigens (sehr originell) admin und admin :P

 

MfG

 

 

EDIT:

Ich habe nun nochmals nach dem "Reinigen" durch den CCleaner die 1.32 installiert. 1 Klick und die Oberfläche ist geladen. Also ist definitiv irgendetwas in der neuen Version "falsch" oder für die App unpassend eingestellt. Risikofreudig wie ich bin habe ich dann den 1.33 nochmal drüber installiert. Gleiches Verhalten wie zuvor. Also 1.32 wieder drauf und es geht. Schade :(

 

 

EDIT 2:

Ich hätte auch noch einen verbesserungsvorschlag. Anstelle alles in den "Einstellungen" vom iOS zu erledigen, könnte man bei Start von der App eine Oberfläche (Wie einen Startbildschirm) haben. Hier könnte man dann z.B. mehrere Server installieren. Ich habe z.B. 3 Lizenzen. Eine in meinem Elternhaus, eine für meinen Arbeits-PC und eine für den HTPC. Manchmal ist der Arbeits-PC und manchmal der HTPC an. Ich muss dann immer erst in den Einstellungen vom iOS die IP Adrese ändern. Der Rest ist natürlich gleich eingestellt. Für meinen einsatzfall wäre ein Startbildschirm wirklich super!

Edited by Flixer
Link to comment

Die 3 Puntke unter "WICHTIG" isnd bei mir von Haus aus auf mein System korrekt eingestellt. Am PC, auf dem der RS läuft, habe ich auch eine meiner Lizenzen für den DVBViewer installiert und nutze auch den RS (und nciht die TV-Karte). Das funktioniert ja...

 

Die Antwort passt nicht zu dem, was da unter "Wichtig" steht. Als ob du es nicht richtig gelesen oder nicht richtig verstanden hättest.

 

In vorherigen Versionen konfigurierte Benutzernamen und Passwörter für den Webserver müssen in der Recording Service-Optionen → Web Einstellungen neu eingegeben werden.

 

Das ist nichts, was "von Haus aus" richtig eingestellt sein kann. Wenn es Benutzername und Passwort für den Webserver gab, müssen sie nach dem Update auf den RS 1.33 auf jeden Fall in den Recording Service-Optionen -> Web Einstellungen neu konfiguriert werden. Hast du das gemacht? Falls ja - hast du es schon mal ohne Benutzername und Passwort probiert?

Link to comment

@Griga

Die Punkte habe ich gelesen, verstanden und diese sind von Haus aus richtig eingestellt, weil ich dies immer als Erstes überprüfe und ggf. anpassen (siehe Post 484: "Benutzername und Passwort sind jedenfalls wie zuvor hinterlegt.").

Wenn du nun meinen letzten Post bis zum Ende gelesen hast weißt du, dass ich auch durch aufspielen von 1.32 und erneutes Update auf 1.33 keine Verbindung bekomme. Erst das abermalig Downgrade auf 1.32 brachte eine Verbindung. Nochmal: jeweils mit Neustart des PCs und Eintragen vom korrekten Benutzernamen/Passwort.

 

MfG

Link to comment

Meine Fragen beziehen sich weitgehend auf Änderungen zwischen RS1.32 und RS 1.33 aber wenn du alles besser weißt und die Fragen nicht beantworten möchtest kann ich dir nicht weiterhelfen.

Link to comment

Die Rec.Service App, zeigt mehr oder weniger einfach das iOS Webinterface an. Im Browser gab es glaube ich mit dem streaming etwas Probleme und da macht es die App leicht anders.

Da kannst du aber Timer im RS erstelle, und es werden auch EPG und Senderliste vom RS verwendet.

 

Die "SAT>IP App for iOS" ist unabhängig vom RS. Der wird wenn nur als Sat>IP Server verwendet. Die App kann aber auch mit jedem anderen Server genutzt werden. Und die bezieht weder EPG vom RS noch kann die da Timer erstellen. Das heißt Senderliste, EPG einsammeln (und bin mir Grade nicht sicher ob aufnahmen auch gehen) laufen alle lokal in der App auf den iOS gerät ab.

Link to comment
  • 1 month later...

Moin,

 

entschuldigt aber ich hatte in letzter Zeit kaum Zeit, daher kann ich erst jetzt antworten.

 

Meine Fragen beziehen sich weitgehend auf Änderungen zwischen RS1.32 und RS 1.33 aber wenn du alles besser weißt und die Fragen nicht beantworten möchtest kann ich dir nicht weiterhelfen.

Ich weiß jetzt nicht wirklich was du damit meinst. Ich habe doch alle von dir gestellten Fragen beantwortet, bin die verlinkte Anleitung Punkt für Punkt durchgegangen und habe ausreichend das Problem beschrieben.

 

Aber nochmal: Ich habe den RS 1.32 normal am Laufen, soll heißen, alle Einstellungen sind korrekt hinterlegt, die Geräte befinden sich in einem Netzwerk und Ports, MAC-Adressen etc. pp. werden intern nicht geblockt. Das Streaming funktioniert wunderbar auf einem iPad 2, iPhone 5s, iPhone 6s und iPad Air. Wenn ich nun auf 1.33 oder 1.33.1 aktualisiere (als Administrator mit vollen Schreibrechten, zuvor beendetem RS 1.32 usw.) wird keine Verbindung mehr aufgebaut (App meint Netzwerkfehler und zwar auf allen Geräten). An den Einstellungen in meinen Netzwerkgeräten (Router, AccessPoint etc.) wurde nichts verändert. Alle Geräte finden sich untereinander (gleiche Gruppe, gleiche Subnet etc. pp) und das anpingen ist ebenfalls möglich. Die Einstellungen im RS sind ebenfalls unverändert, wurden von mir aber auch kontrolliert! Nutze ich lokal den DVBViewer und den soeben aktualisierten RS funktioniert der Stream einwandfrei.

 

Anschließend, da es ja nicht geht, installiere ich einfach den RS 1.32 wieder drüber und siehe da, das Streaming funktioniert wieder (wie auch die lokale Nutzung). Ehe die Frage kommt: der DVBViewer ist lokal, beim Versuch vom iOS Device auf den Service zuzugreifen, natürlich beendet.

 

 

Nochmal: Hast du es schon mal ohne Benutzername und Passwort probiert?

Ja auch das habe ich probiert. Nur Benutzername & kein Passwort, kein Benutzername & ein Passwort, beides leer und beides vergeben. Nur das Installieren der alten Version 1.32 bringt den Stream wieder zum Laufen.

 

Ich bin momentan bei 1.32 geblieben da es einfach mit der iOS App nciht funktionieren will... Wenn jemand noch eine Idee hätte, ich wäre wirklich sehr Dankbar für eine Lösung.

 

MfG

Link to comment
  • 2 weeks later...

Sehe ich das richtig, dass wenn ich den RS auf die aktuellste Version aktualisiere, dass ich die RS App für iOS dann nicht mehr wirklich nutzen kann?

Hab bisher immer noch den RS 1.32 am Laufen und die App läuft damit bisher einwandfrei.

 

Link to comment

Ich weiß, dass bevor die neue Rs Version released wurde, es zwei Leute probiert haben ob die App noch geht. Mit positiver Rückmeldung.

 

Dass es bei einigen nicht geht kann man ja dem Thread hier entnehmen.

Genauso kann man den Thread entnehmen, dass der Entwickler der App schon eine ganze Weile nicht mehr hier anwesend war.

 

Das heißt, bevor es nicht genügend Leute es mal probieren, wird diese Frage ob es geht oder nicht niemand richtig beantworten können.

Link to comment

Bei uns läuft die alte Version einwandfrei. Wir möchten nur wissen, ob dies auch mit der neuen Version klappt. Wenn schon jemand das Update aufgespielt hat und mit der iOS-App ausprobiert hat wäre es nett von euch wenn Ihr uns eine Antwort geben könntet. Weiter oben sprach jemand von Schwierigkeiten im Zusammenspiel mit der neuen Version.

Wir bitten euch ja nur darum die Erfahrungen zu teilen.

 

Herzlichen Dank,

SHC

Link to comment

Zumindest bei zwei Betatestern hat es funktioniert.

Und ich würde jedem dringend raten den aktuellen RS 1.33.1 zu nutzen wenn der RS aus dem Internet erreichbar ist und nicht nur aus dem LAN oder per VPN. Da es in allen älteren Versionen als 1.33 möglich ist z.B. auf streams generell ohne Passwort zuzugreifen.

 

Und wer den Proxy Support nutzt sollte 1.33.1 nutzen. Da es da auch noch Probleme geben konnte.

Link to comment

Danke für die Antwort, Tjod!

 

Ich habe es jetzt mal riskiert mit dem Ergebnis: die App läuft weiterhin beim mir mit der 1.33.1 Beta.

Ich musste nur, wie in der Anleitung beschrieben, Nutzername und Passwort neu setzen für den Webzugriff.

Link to comment
  • 4 weeks later...

Habe nun das neue iOS 9.3.5 aufgespielt. Seitdem läuft die App rec service nicht mehr auf dem iPhone. Es kommt das Fenster, in dem ich die Einstellung ändern soll.

Dort ist aber schon alles eingetragen, sowohl IP Adresse als auch Benutzer und Kennwort.

Ein Zugriff über die App auf den Rec Service ist nicht mehr möglich.

Auf dem iPad mit iOS 9.3.4 fährt die app noch hoch, aber beim starten einer Funktion kommt dann eine falsche Anzeige.

Der Rec. Service 1.33.1. ist über den Browser Safari mit der IP Adresse aufrufbar und funktioniert.

Der Fehler liegt denke ich am neuen iOS und der App - nicht am Rec Service

Link to comment

Klar, auf den Homebutton 2x klicken und die App schliessen. Ein Softreset ist, wenn man den Ausschaltknopf so lange drückt bis der Ausschalten-Slider erfolgt und dann einfach den Homebutton so lange gedrückt halten bis man wieder im Hauptmenü ist.

Link to comment

Vielen Dank für Eure Hilfe

Heute habe ich die App vom iPad gelöscht, das iPad neugestartet und die App neu installiert aus dem AppStore .

Jetzt läuft alles

Danke

Link to comment
  • 6 months later...

Hallo,

ich benutze die App und es funktioniert auch alles sehr gut. Was ich aber nicht richtig verstanden habe ist wie ich extern darauf zugreifen kann.

Habe eine Fritz box und auch eine Adresse um darauf von extern zugreifen zu können.

Kann ich diese verwenden und unter IP/Host eintragen ?  Funktioniert leider nicht!

Vielleicht kennt sich jemand aus mit der Kombi zugriff von Extern über die Fritz durch die App.

Danke

 

Gruß Garon 

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...