Jump to content
matze456475

DVBViewer geht nicht in Windows 10

Recommended Posts

Odie13690

Hallo,

 

habe heute auf 5.5.0 upgedatet. Davor lief 5.3.2 unter Windows 10 Pro ohne Probleme. Nach dem Update auf 5.5.0 werden die Sender in 720x576 verkleinert im Fenster dargestellt. Kann ich das durch irgendeine Einstellung beheben?

 

odie13690

Share this post


Link to post
getilus

Der DVBViewer ist kompatibel mit Windows 10 und funktioniert definitiv. Wie bei Windows 8 (ohne MCE Erweiterung) fehlt bei den meisten Systemen nach der Installation ein geeigneter Dekoder.für die Anzeige. Dafür kann man den LAV Filter nutzen, welcher u.a. hier geladen werden kann (Installer verwenden).

 

Hallo,

 

na ja, dass der DVBV mit Win 10 funktioniert, kann ich bestätigen. Dafür hat wohl der LAV-Filter noch so seine Probleme mit Win 10, denn DXVA2-Decoding, weder "copy-back" noch "nativ", scheint mit AMD-Treibern zu funktionieren?!

 

Ich verwende die DVBV 5.5.0.0 mit dem RS 1.31 beta.

System:

AMD APU A8 3870K, onboard-Graka über HDMI an Full-HD Monitor

Windows 10 pro 64-bit mit aktuellem AMD Catalyst-Treiber 15.7.1

 

Mit der Einstelleung des DXVA2-Decoding auf "none" geht's einwandfrei.

 

Getestet auch im DVBV-Debug-Modus.

 

Kann das vielleicht mal jemand gegenprüfen, wenn mögl. auch mit einer APU?

 

Grüße

 

 

getilus

support.zip

Share this post


Link to post
Griga
Nach dem Update auf 5.5.0 werden die Sender in 720x576 verkleinert im Fenster dargestellt.

 

??? Nicht sehr informativ, deine Problembeschreibung ;)

 

Will ich sehen. Screenshot? Die Video Decoder- und Renderer-Einstellungen könnten dabei eine Rolle spielen.

Share this post


Link to post
nuts

@getilus: Was bedeutet funktioniert nicht? Fallback auf Software Decoder? Crasht die ganze Anwendung?

Renderer = EVR Custom? EVR gleicher Fehler?

Share this post


Link to post
thkreg

@getilus: Was bedeutet funktioniert nicht? Fallback auf Software Decoder? Crasht die ganze Anwendung?

Renderer = EVR Custom? EVR gleicher Fehler?

 

 

 

Hallo,

 

na ja, dass der DVBV mit Win 10 funktioniert, kann ich bestätigen. Dafür hat wohl der LAV-Filter noch so seine Probleme mit Win 10, denn DXVA2-Decoding, weder "copy-back" noch "nativ", scheint mit AMD-Treibern zu funktionieren?!

 

Ich verwende die DVBV 5.5.0.0 mit dem RS 1.31 beta.

System:

AMD APU A8 3870K, onboard-Graka über HDMI an Full-HD Monitor

Windows 10 pro 64-bit mit aktuellem AMD Catalyst-Treiber 15.7.1

 

Mit der Einstelleung des DXVA2-Decoding auf "none" geht's einwandfrei.

 

Getestet auch im DVBV-Debug-Modus.

 

Kann das vielleicht mal jemand gegenprüfen, wenn mögl. auch mit einer APU?

 

Grüße

 

 

getilus

 

Die Fehlermeldung sagt mir jetzt nicht wirklich was:

Ich würde (wenn das bei mir auftreten würde) als erstes Probieren den Grafikkarten Treiber mal neu zu installieren und den PC danach neu zu starten.

 

Habe Windows 10 aber bisher nur in einer VM laufen und da geht der DVBViewer ohne Probleme.

 

@getilus @nuts Da hat AMD am Treiber etwas geändert hatte es aber am Anfang schon gepostet mit einer AMD APU und DXVA2 Decoding kommt die Fehlermeldung unter allen Windows versionen egal was für ein CODEC benutzt wird habe LAV ,MS und Totalmedia Decoder getestet und der Viewer crasht

 

Ich schätze mal du hast eine AMD Grafik eingebaut mit windows 10 wird auf auf die Catalyst 15.7 upgedated bei mir mit einer A6-3500 APU mit 6530D (Sockel FM1) funktioniert es auch nicht mit dem neuen Treiber weder unter Windows 7 ,Windows 8.1 noch Windows 10 (alle 64 bit) mit DDU (Display Driver Uninstaller) alles deinstallieren lassen. Dann den alten 14.12 von Windows 8.1 installieren und alles funktioniert wie vorher. Dann musst du noch mit diesem Tool "Tool zum Verstecken oder Blockieren von Updates" den Treiber download blockieren. http://winfuture.de/downloadvorschalt,3535.html

Share this post


Link to post
getilus

@getilus: Was bedeutet funktioniert nicht? Fallback auf Software Decoder? Crasht die ganze Anwendung?

Renderer = EVR Custom? EVR gleicher Fehler?

 

Hallo nuts,

 

sorry für meine ungenaue Fehlerbeschreibung.

Fallback auf Software Decoder = nein.

Jetzt wird's aber schon kurios: bei Einstellung "copy back" (direct)" - wird so angezeigt, d. h. available - erscheint ein grüner Bildschirm. Kein Absturz des DVBV. Bei "native" = schwarzes Bild und - nach ein paar Sekunden - vollständiger Absturz der Anwendung und nur noch durch den Taskmanager zu beenden. - getestet mit dem Custom EVR und EVR.

Mit dem madVR als Renderer habe ich allerdings noch nicht getestet. Ich befürchte allerdings, das der hierbei auch gleiches Verhalten zeigt.

 

@thkreg: dieser Thread war mir gar nicht mehr in Erinnerung, aber ich denke danach kam noch ein neuer AMD-Treiber raus....hätte also sein können, dass im Neuen diese Probleme beseitigt wurden....scheint aber nicht so zu sein??

 

 

Gruß

Share this post


Link to post
nuts

Ok ich denke der DVBViewer selbst hat damit weniger zu tun, aber um das zu verifizieren könntest du noch versuchen das Problem mit dem LAV Splitter (Aufnahme, .ts aus den Vorgaben für den DVBSource Filter entfernen) zu reproduzieren.

 

Hört sich stark nach einem Treiberproblem von AMD an. :(

Edited by nuts

Share this post


Link to post
thkreg

Ist ein AMD Treiber Problem wird auch schon im AMD Support Forum gepostet und im Kodi Nerds Forum

 

15.7: DXVA hardware accelerated video playback not working anymore

https://community.amd.com/message/2657983#2657983

 

Lösung für Abspielprobleme unter Windows 10 mit AMD-Hardware (Kodi Nerds Forum)

http://www.kodinerds.net/index.php/Thread/46727-L%C3%B6sung-f%C3%BCr-Abspielprobleme-unter-Windows-10-mit-AMD-Hardware/?s=a84c367ceb9748f822a5cfef51badd154a579597

Edited by thkreg

Share this post


Link to post
craig_s

AMD durchleidet seit einiger Zeit mit heftig eingebrochenen Verkaufszahlen ein generelles Formtief.

Als alter Ati-Fan und Athlon-User der ersten Stunde (K7) hoffe ich dass es dabei bleibt und bald wieder Licht am Ende des Tunnels auftaucht (wie schon öfter) !! :lbounce:

Share this post


Link to post
getilus

Ok ich denke der DVBViewer selbst hat damit weniger zu tun, aber um das zu verifizieren könntest du noch versuchen das Problem mit dem LAV Splitter (Aufnahme, .ts aus den Vorgaben für den DVBSource Filter entfernen) zu reproduzieren.

 

Hört sich stark nach einem Treiberproblem von AMD an. :(

 

Jo, ist'n AMD-Treiberproblem!

 

Im MPC-HC mit LAV 0.65.X ist es dasselbe! Nur ohne DXVA2-Decoding läuft's.

 

Nur der Lösungsvorschlag auf eine Vor-15.7.1-Treiberversion zurückzugehen ist wohl in Win 10 nicht so ohne Weiteres möglich, denn hier wir gleich wieder der aktuelle, neueste Treiber (15.7.1) geladen und installiert.

 

Da hilft wohl nur abwarten und sehen, was AMD so macht.....schöne, neue Windows 10 Welt......

 

Da kommt DAS: https://www.youtube.com/watch?v=4-Y-nSYkFi8 mal ziemlich Scheiße rüber.....

Share this post


Link to post
woody32

Au man.... ich war eigentlich auf der Suche nach einer Lösung für gelegentliche Klötzchenbildung (mit DXVA bei Nvidia GT730) seit dem Update auf Win10 und jetzt lese ich das hier.... da kann ich ja noch froh sein das es einigermassen läuft.

 

Komischerweise macht Kodi bei LiveTV mit dem Rec-Service und DXVA keine gelegentlichen Klötzchen....

Share this post


Link to post
PeterF

Und was hat dein Geschriebenes mit den 3 Posts vorher zu tun? Da geht es um AMD, du schreibst von einer NVidia.

PeterF

Share this post


Link to post
getilus

Ist allerdings so, es ging hier - zuletzt - um AMD-Treiberprobleme.....

 

Soweit mir derzeit bekannt ist, ist Nvidia - und auch Intel - hiervon (DXVA2-Decoder Crash) nicht betroffen.

Share this post


Link to post
woody32

Der Thread-Titel bezieht sich ja nicht nur auf AMD..... sondern Probleme mit DVBViewer und Win10.

 

Und bei mir gibts halt seit der Umstellung auf Win10 (mit LAV und EVR Custom, die unter Win7 auch schon benutzt wurden) Probleme mit gelegentlicher Klötzchenbildung....

 

Hatte halt gehofft das einer schreibt "kenne ich, schalt halt mal das oder das ein...." und fertig.....

Edited by woody32

Share this post


Link to post
getilus

Hatte halt gehofft das einer schreibt "kenne ich, schalt halt mal das oder das ein...." und fertig.....

 

Nö, das wird nix!

 

Ich hab' dann mal den Tipp von thkreg aus Post #88 angewendet....nämlich AMD-Treiber 15.7.1 komplett runterschmeißen, den automatischen Download und Installation aller Treiber ausschalten und dann Treiber 15.6 beta installiert.

 

Und, was soll ich sagen......funktioniert wieder!!

 

Aber: Tags darauf war wieder der 15.7.1 installiert....automatisch (!!!) und gänzlich ohne mein zutun (natürlich auch die Funktion nicht wieder eingeschaltet). Und wie selbstverständlich, gleicher Fehler wie vorher - DXVA2-Decoding: Fehlanzeige.

 

Also heißt es wohl: Griga's Rat befolgen und "viele haben es wiedermal zu eilig"...

 

Und noch meine Einschätzung: Wer meint, es würde gleich beim nächsten AMD-Treiberupdate besser, ich glaub' erst nach ausführlichen, eigenen Tests dran. Aber wetten, für AMD ist es sicher wichtiger, dass die neuesten Sch...-Baller-EGO-Shooter ca. 1 - 1,5 fps schneller laufen als mit dem 15.7.1 als dass das Thema DXVA2-Decoding angefasst wird. Wer wettet dagegen?

 

 

Gruß

Edited by getilus

Share this post


Link to post
craig_s

thkreg sprach oben ja von einem "Tool zum Verstecken oder Blockieren von Updates".

 

Obwohl man überall von Win10 Zwangsupdates liest war es in Win10 Pro über die Gruppenrichtlinien recht einfach den Zwang abzustellen.

Ohne Pro braucht es eine Registry-änderung. Deskmodder hilft..

 

Jedenfalls fragt mich Win10 jetzt immer brav ob es was updaten darf fast so wie in Win7. Da kann man vorher evl. noch ein Backup machen.

Das AMD so einfach zwangs-updatet und nur in Win10 glaube ich nicht. Kann man alles immer irgendwo abstellen.

Edited by craig_s

Share this post


Link to post
elo22

Da sich der Thread sich ja auf alle Probleme mit DVBViewer und Win10 bezieht werfe ich mal ein neues ein: Seit dem upgrade von Windows 7 professional auf 10 ist mein DVDViewer auf einem Rechner in englisch. Ich kann einiges an Sprachen auswählen aber deutsch ist nicht dabei. Wo muss ich schrauben?

 

Lutz

Share this post


Link to post
craig_s

Sieh nach ob im Programm-ordner von DVBViewer im Ordner 'Languages' das 'Deutsch.lng' fehlt oder beschädigt ist.

Aber wenn das ein Win10-Problem ist fress ich nen Besen!

 

Als HD-Fernsehen eingeführt wurde vermutete jeder das JEDES Problem im DVBViewer und darüber hinaus NATÜRLICH an der Umstellung aufs HD Format liegt. Was schlimmer ist, die Leute hörten einfach auf die einfachsten Sachen selbst nachzusehen sondern steckten sofort den Kopf in den Sand: 'HD ist schuld, da kenn ich mich nicht aus'. So wurde HD zeitweise gar zum erklärten Feind des DVBViewer!

 

Ähnlich läufts grad mit Win10..? ;)

Share this post


Link to post
BeFi

Hatte seit dem Win10 Upgrade auch das Problem mit dem Aufwachen. Ist offensichtlich ein Win10 Problem des S3 Sleep Modus.

Bei mir funktioniert aber das Aufwachen unter dem Hybrid Sleep oder mit dem Hibernation Modus problemlos.

Fuer beide Modi musst Du Hibernation enablen. Hybrid Sleep kannst Du unter den erweiterten einstellungen des Power Mgrs aktivieren. Dazu musst Du die standardmaessig verborgenen Einstellungen sichtbar machen.

Ob Deine Hardware den Hybrid Sleep unterstuetzt siehst Du mit dem Kommando powercfg /a

 

Gruesse Bernhard

Share this post


Link to post
craig_s

..mit wem sprachest du? Lies erstmal hier, das Prob ist längst gelöst. Geht auch ohne hybrid mit normalem Standby.

Win10 schlafenlegen mit 'echten' Windows-Mitteln, darauf kommts an.

Share this post


Link to post
BeFi

Also mindestens in meinem Fall (Win10 Pro, DVBViewer 5.5.0) ging es eben gerade nicht mit dem normalen S3-Sleep mit dem ich unter Win 8 und 8.1 DBViewer Aufnahmen auf der selben Hardware immer erfolgreich programmiert hatte.

 

In Foren bin ich dann auf einen Fall mit einem Lenovo Laptop gestossen, wo der S3 Sleep auch nicht funktionierte, Hybrid Sleep und Hinbernate aber schon. Und siehe da, genaus so ist es auch bei mir.

 

Wenn man jetzt den Hybrid Sleep nutzen möchte muss man entweder im Startmenu->Power->Sleep, Alt-F4->Sleep vom Desktop oder psshutdown -d aus den PSTools verwenden. Die bisherigen Sleepkommandos aus Win 7 oder 8 leiten explizit den S3 Sleep ein, aus dem zumindest mein Rechner nicht per Scheduler erwacht.

 

P.S.: Der Ton des Powerusers der mich hier gerade wie einen Schuljungen behandelt hatte, war unangebracht.

Share this post


Link to post
craig_s

bei mir (kein Laptop) geht es so:

 

Einfach im DVBViewer wie gewohnt den Timer setzen, DVBViewer beenden, in Win10 dann PC über -> Start > Ein/aus > Energie sparen - schlafenlegen und gut ist.
Edited by craig_s

Share this post


Link to post
fwoerndle

Ich habe eine leichte Variation zum Thema. bis Windows 8.1 ist alles mit Technisat SkyStar USB 2 HD CI sehr gut gelaufen. Leider ging mein 8 Jahre alter Desktop-PC über den Jordan. Neuen gekauft mit Win 10 vorinstalliert. Da ich alle Daten komplett separiert hatte, konnte ich leicht umziehen. Ich mußte noch die Applikationen nachinstallieren. Der Treibe für das Technisat Teil war nicht aufzutreiben. War auch bei 8.1 schon ein Problem, aber der 7er ging.

Jetzt gabs aber immer Bluescreens mit dem 7er Treiber. Also habe ich einen funktionell gleichwertigen TBS 5980 gekauft. Die Bluescreens sind jezt weg. Aber ich bekomme keinen stabilen Betrieb mehr hin. D.h. Aufnahmen kreiern zwar die Datei im Ordner, aber es ist nichts drin. Er sagt dabei immer, er sei am Aufnehmen. Aber es ist nie ein Ergebnis da. Manchmal bekomme ich eine Bildschirdarstellung, die friert aber bald ein.

 

Ich ersuche um irgendwelche Ratschläge von Leuten die sich auskennen.

 

Danke

Share this post


Link to post
Rockon

Hatte nach Installation von V.5.5.2.0 seit einiger Zeit ein seltsam verfremdetes Bild, alles kleine Nullen gleichmäßig neben- und untereinander!

 

Hab dann mal aus reiner Neugier die Demo Version (V 5.5.1.0) runtergeladen u in einem anderen Ordner installiert inkl. aller LAV-Filter, dann allerdings Version 5.5.2.0 gestartet,

Und, siehe da, das vorher fehlerhafte Bild ist wieder klar und ganz ohne "0-Füllung"!!!

Moral: Probieren geht wohl doch über studieren... ;-)

Edited by Rockon

Share this post


Link to post
Griga

Da war im DVBViewer wohl Einstellungen -> Shader -> Effect -> Discman aktiviert.

 

Probiere die Möglichkeiten mal durch - da gibt es verschiedenes, um ahnungslose DVBViewer-User in Verzweiflung zu versetzen. :) Siehe dazu auch hier:

 

http://www.DVBViewer.tv/forum/topic/56524-bild-wackelt/

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...