Jump to content

HEVC / H.265 Wiedergabe mit Asrock j3455-itx


Findus

Recommended Posts

  • 1 month later...

Hi,

 

Ich habe dieses Board.

 

Wiedergabe von 4k H.265 Filmen mit Kodi funktioniert auch einwandfrei.

 

Wenn ich allerdings mit dem DVBViewer normales HD Fernsehen schauen will, habe ich 100% CPU Last, und es laggt.

Liegt das an den LAV Filtern?

Edited by strex
Link to comment

 

Wenn ich allerdings mit dem DVBViewer normales HD Fernsehen schauen will, habe ich 100% CPU Last, und es laggt.

Liegt das an den LAV Filtern?

Das würde mich aber auch interessieren, da ich in die ähnliche Richtung geschaut habe!

Hast Du die Prombleme bei 720p und 1080i?

 

Mir wurde in einem anderen Thread zu folgender Einstellung geraten:

 

Aktuelle Intel Grafiktreiber benutzen!

Lav codecs installieren und sie überall im DVBViewer/DirectX einstellen.

LAV Video mit Hardware Decoding auf DXVA copyback, nichts mehr anfassen, kein Software deinterlacing!

EVR Custom Renderer und DXVA Scaling benutzen.

Monitorausgabe in Full RGB mit nativer Auflösung und 50Hz.

Video Options im Intel Treiber: Verbesserer AUS, Filmmode erkennen AUS

 

Kannst ja mal testen.

Link to comment
  • 6 months later...
Am 1.1.2017 um 15:41 schrieb strex:

Ich habe dieses Board.

 

Wiedergabe von 4k H.265 Filmen mit Kodi funktioniert auch einwandfrei.

 

Wenn ich allerdings mit dem DVBViewer normales HD Fernsehen schauen will, habe ich 100% CPU Last, und es laggt.

Liegt das an den LAV Filtern?

Habe auch das Asrock-Board,

in Kodi kann ich problemlos 4k schauen als Client vom Recording-Service (auf dem selben Rechner).
In DVBViewer Pro 6.03 funktioniert Full-HD ebenfalls mit den LAV-Filtern (Einstellungen s.o.).
4k geht mit DVBViewer allerdings nicht.

Weshalb kann Kodi das auf dem selben Rechner höherauflösend als DVBViewer?

Link to comment
vor 7 Minuten schrieb Derrick:

4k ist eben nicht 4k, soll heissen aus dem Internet oder über Sat ist nicht dasselbe ;)

Und was soll mir das jetzt sagen?

Ausgangsmaterial ist bei beiden DVB-S über den Recording-Service, welcher sich auf dem selben Rechner wie die Clients (DVBViewer und Kodi) befindet.

Link to comment

Wenn es ums selbe 4k geht, könnte Kodi ev. mit einem 64bit Dekoder arbeiten. Dvbv ist eine 32bit Applikation und damit ev. weniger leistungsfähig. Aber es gibt noch viele andere Schrauben, an denen man drehen kann .

 

Link to comment

Der olle Apollo-Lake dekodiert sicher auch mit 64bit kein 4k HEVC in Software ...

 

Ansonsten schau mal hier rein: http://www.DVBViewer.tv/forum/topic/59166-probleme-mit-der-wiedergabe-in-4k-uhd-hevc/?tab=comments#comment-456227

Ich bekomme bestimmte 4k Sender mit dem J4205 zusammen mit dem EVR Custom auch nicht flüssig hin.

Mit madVR als Videorenderer funtkioniert es. Die genaue Ursache ist leider unklar. :(

 

Kannst du vielleicht mal den normalen EVR ohne Custom testen (EVR einstellen und DVBViewer neu starten)?

Link to comment
vor 22 Minuten schrieb nuts:

Kannst du vielleicht mal den normalen EVR ohne Custom testen (EVR einstellen und DVBViewer neu starten)?

Gerade versucht von EVR Custom auf EVR Enhanced Renderer. Keine Besserung.

Alle anderen Renderer (System, VMR, Overlay) erzeugen überhaupt kein Bild (nur grün oder schwarz).

 

Das ganze ist in DVBViewer für mich momentan nicht sonderlich wichtig, da es in Kodi ja läuft und EPG z.B. eh übersichticher dort funktioniert.
Mich interessiert einfach nur, warum Kodi 4k umsetzt und DVBViewer nicht.

 

Link to comment

Kann deine Beobachtung tatsächlich bestätigen. Ich fasse für Griga nochmal zusammen, wobei ich mir nicht sicher bin ob man im DVBViewer dagegen etwas tun kann: 

 

Hardware: Intel Apollo-Lake 

Software: Win10, DVBViewer, LAV (jeweils Neuste Version) 

Decodereinstellungen: DXVA2 native

Testsender: Astra SES UHD Demo Kanal (4K HEVC 10bit) http://www.satindex.de/channel/8729/

 

Problembeschreibung: Der EVR Custom mit aktiviertem DXVA Scaler zeigt kein flüssiges Bild, im DVBViewer Filter sind als Fehler ständig "buffer overflows" zu sehen. 

Sobald man den DXVA Scaler im DVBViewer deaktiviert erhält man ein flüssiges Bild ohne Pufferüberläufe.

madVR liefert mit dort eingestelltem DXVA Scaler allerdings ebenso ein flüssiges Bild. 

 

 

P.S. dxva copyback im LAV kann ich leider nicht testen, da mir dabei der Arbeitsspeicher ausgeht und dies in keiner Kombination funktioniert. Läuft das bei dir @grobiralf?

Edited by nuts
Link to comment
14 hours ago, grobiralf said:

Gerade versucht von EVR Custom auf EVR Enhanced Renderer. Keine Besserung.

 

Der DXVA Scaler ist die selbe Komponente, die der Standard-EVR verwendet. Wenn es bei dem nicht funktioniert, kann es beim Custom EVR auch nicht gehen.

 

Bei abgeschaltetem DXVA Scaling verwendet der Custom EVR das bilineare D3D Scaling mit eventuell etwas schlechterer Qualität. Weitere Alternativen gibt es nicht (außer halt MadVR).

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...