Jump to content
xtrapeque

Cant streaming hd iptv channels

Recommended Posts

xtrapeque

Have few days not is posible streaming hd channels, only sd. Provider movistar tv, in spain.

Any solution?

Share this post


Link to post
keonos

The same happens to me. Iptv channels in HD. DVBViewer pro work fine but whit kodi only rstp, direct view impossible .

Un saludo. 

Share this post


Link to post
eXtremeDevil

Hello.

 

I also suffer this problem and I want to try and boost this post/issue a little.

 

Without any changes to the RS and DVBV versions (I'm using the latest ones), I was able to see HD and SD channels from DVB-S2 and from IPTV. One day, for some reason, HD IPTV channels stopped working on RS streaming. DVBV still plays them fine (luckily). Also, RS streams SD IPTV channels fine.

 

I can still watch HD DVB-S2 channels on RS streaming, NOTHING has changed from my side. The only thing I can think of is a change on the HD IPTV channels broadcast.

 

I can only think of uploading two smalls recordings of an HD DVB-S2 channel and a HD IPTV one and see if someone around here notices something in the enconding, or the stream.

 

Makes sense? If so, tell me, and I will upload two samples.

 

Thank you.

Share this post


Link to post
Griga

The most important information is missing.

 

What kind of streaming to which client? Transcoded to another format? The original stream? Sat>IP / RTSP?

Share this post


Link to post
eXtremeDevil

In the same PC where DVBV and RS is. No matter the option, transcoded or direct stream.

 

Please tell me if you need any more info, and thanks.

Share this post


Link to post
eXtremeDevil

Up

Share this post


Link to post
eXtremeDevil

Upp

Share this post


Link to post
Griga

It's hard to say something about it because we can't receive these IPTV channels. Too little information anyway. Maybe you should attach a support.zip. And investigate a bit more. Provide more facts.

 

Is the RS able to to record the channels in question? If yes, does streaming of the recordings work?

 

On 27.2.2017 at 0:41 PM, eXtremeDevil said:

I can only think of uploading two smalls recordings of an HD DVB-S2 channel and a HD IPTV one. (..) Makes sense?

 

Who knows? Just do it. The HD IPTV recording will be enough, no need for the DVB-S2 channel.

Share this post


Link to post
eXtremeDevil

I'll do all that in a moment. How do I get the suppport.zip file? I forgot :(

 

I am able to record. I'll try and check if the record can stream correctly.

 

Thanks.

Edited by eXtremeDevil

Share this post


Link to post
Tjod

To generate a support.zip run the Supporttool in the DVBViewer folder.

Share this post


Link to post
Tjod

Are you sure your internet connection is able to handle 9 simultaneous (65 Mbps+) if not you should reduce the number of IPTV devices in the RS. The same applies if your IPTV provider has a limit for simultaneous channels per customer.

 

Then the RTSP IPTV devices in the DVBViewer are configured wrong. Best remove them all and run the RS Wizard and let it generate the devices in the DVBViewer.

http://en.DVBViewer.tv/wiki/Recording_Service_Installation_Guide

 

Are you then able to see the IPTV channels in the DVBViewer as streamin Client via the RTSP device?

If yes are you able to see them in the web interface as well? If not make sure the channel data in the DVBViewer channel list are up to date and the restart the RS so that it gets the up tu date channel list.

Share this post


Link to post
Griga

The whole hardware configuration looks a bit chaotic and needs to be cleaned up. In DVBViewer there are RTSP network devices that are named "IPTV RTSP Network Device" but are configured for DVB-S as tuner type.

 

Maybe the same applies to the channel list used by the RS. In both DVBViewer and RS the "Adjust PAT/PMT" option is switched on. However, the PMT in the recording uploaded by eXtremeDevil is not adjusted to the actual content (the PMT = Program Map Table is a kind of "table of contents" in the file). This suggests that the channel data is wrong, particularly the Service ID of the recorded channel, which may let streaming fail.

 

At least transcoded streaming of the recording doesn't work here, because FFmpeg can't cope with audio tracks that are indicated in the PMT but actually are missing in the recording. The PMT indicates 2 x MPEG Audio and 2 x E-AC3 Audio, but only one E-AC3 track is present.

Share this post


Link to post
eXtremeDevil

Any config I have has been valid before the channels suddenly broke. But I will take a look and clean it, so thanks for the tips.

 

As for the channels, I figured out the problem. My provider changed the Service PIDs. That was all. But DVBV played them fine so I didn't notice.

 

Thanks to all.

 

Now I need to find a way to update those PIDs without losing my custom names and logos xD

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×