Jump to content
deMatze

SAT>IP Viewer läuft nicht auf MacBook

Recommended Posts

deMatze

Hallo,

 

habe vor einigen Tagen erstmals den Viewer installiert. Auf MacBook mit OS 10.10.5. Als Server läuft ein kleiner Xoro 8670 der problemlos erkannt wird und auch der Sendersuchlauf läuft durch. Sobald aber ein Sender wiedergegeben werden soll verabschiedet sich der Viewer kommentarlos. Auch wenn die manuelle Sendeliste editiert wird. Sind bestimmte Systemvoraussetzungen wie Silverlight oder ähnliches nötig? 

Share this post


Link to post
hackbart

Bildschirmfoto 2017-05-02 um 09.17.41.png

 

Nein, ab Mountain Lion sollte die Anwendung gehen. Geht denn Radio? Was passiert, wenn Videos abgespielt werden?

Wurde denn ein richtiger Sendersuchlauf getätigt? Das laden der vorkonfigurierten Astra Liste zählt da nicht :)

Share this post


Link to post
hackbart

Ich werde wahrscheinlich heute Abend oder morgen eine neue Version in den Store laden. Derzeit teste ich noch diverse Funktionen, da ich plane neben Sat>IP auch echte Geräte mittelfristig zu Unterstützen. Die dafür nötige Plugin-API ist auch schon fertig und muss nur noch dokumentiert werden.

Share this post


Link to post
deMatze

Hab jetzt auf V1.3 upgedatet. Leider verabschiedet sich das Programm immer noch sofort bei Auswahl eines Radio- oder TV-Senders. Ein neuer Suchlauf ist jetzt auch nicht mehr möglich. Sobald er startet hängt er (Spinner im Dauerlauf)...

Share this post


Link to post
hackbart

Stürzt die Anwendung ab, wenn ein Video oder eine Musikdatei geladen wird? Übrigens der Spinner kommt sofern sich die Software auf einen Server verbinden will den man manuell eingetragen hat und der nicht erreichbar ist. Ich behebe das noch und lade eine neue Version hoch.

Share this post


Link to post
hackbart

Nachtrag, das Problem ist Trivialer. Ich habe da einen Fehler eingebaut der dadurch hervorgerufen wird, dass ich kurz vor dem Release die Transponderlisten aktualisiert habe. Bei Astra wurde aus dem Astra 19.2° ein Astra 1KR/1L/1M/1N (19.2E). Der letzte Wert wird in den Einstellungen gespeichert und sofern er nicht existiert gibts beim Suchlauf eine Exception. Eine neue Version ist schon hochgeladen und kommt vorr. heute Nacht ins Review. So lange muss man in der Combobox oben Astra manuell auswählen.

Share this post


Link to post
roger2102

Hallo, ich häng mich einfach mal an das Thema ran: Es läuft Sierra 10.12.4 und als Box die Telestar digibit. Bis gestern wurden die Box als auch die Senderliste, nach einigem Anklicken beim scan und Umstellen auf Astra 1KR etc. erkannt und im Menü angezeigt. Allerdings fror das Programm nach ca. fünf Sekunden ein und am rechten Rand erschien ein kleines Kästchen mit einem zweizeilihen "010101..".

Heute dann das update. Senderliste gleich auf Astra 1KR ohne weiteres Umschalten. Scan, 530 (freie) Sender werden erkannt. Klickt man dann drauf, erfolgt die Fehlermeldung "Sender konnte nicht eingestellt werden". Gleiches beim Radio.

Das ist natüröich alles sehr ernüchternd, um nicht zu sagen ärgerlich.

 

Bildschirmfoto 2017-05-08 um 23.56.25.png

Share this post


Link to post
hackbart

Die Beschreibung ist ehrlich gesagt dürftig. Das Bild mit den binären Zahlensalat bedeutet nur, dass sich die Anwendung zwar mit dem Server verbinden konnte, aber keine Daten empfangen wurden.

Normalerweise verschwindet das nach knapp einer Sekunde, außer der Server liefert keine Daten.

Wenn man unter Hilfe -> Status auswählt, sieht man genau ob Daten kommen und ob der Tuner den Transponder einstellen konnte.

Bildschirmfoto 2017-05-09 um 12.58.05.png

Es wäre praktisch, wenn nicht die vorkonfigurierte Kanalliste geladen würde, sondern man einen Sendersuchlauf tätigt. Außerdem gibt es da noch eine Firewall die eventuell den Empfang verhindern kann: https://support.apple.com/de-de/HT201642

 

Vielleicht habe ich das ganze noch nicht so richtig klar gestellt: Ich habe kein Problem zuzugeben, wenn Bugs sich in der Entwicklung eingeschlichen haben (siehe oben). Das ist nur allzu menschlich und passiert halt. Generell ist die Anwendung aber ausgereift und sobald Grundfunktionen wie der Empfang bzw. das finden und die Darstellung von Sendern nicht funktionieren, liegt das nicht an der Software. 

 

Share this post


Link to post
deMatze

Hallo Christian,

 

mit der 1.4 gelingt nun wieder der Sendersuchlauf. Allerdings verabschiedet sich das Programm immer noch sofort nach Auswahl eines TV- oder Radiosenders. Auch beim öffnen einer lokalen Datei...

Share this post


Link to post
hackbart

Ok, ich melde mich mal via PM.

Share this post


Link to post
roger2102

Hallo,

mein Hinweis sollte nicht als Kritik verstanden werden :). Habe deinen Tipp mit der Firewall beachtet und jetzt findet er auch die Sender . Allerdings habe auch ich das gleiche Problem wie deMatze, sh. Bild5913474841cae_OhneTitel.png.351d63005a64a0fc3104ae01a402e62f.png

Edited by roger2102
Neues Bild

Share this post


Link to post
hackbart

EPG scheint ja geladen zu werden. Teletext bei TV Sendern auch?  Wie sieht denn eine Aufnahme aus (also auf Record drücken und mal eine Sequenz von ein paar Sekunden aufnehmen) bzw. was passiert, wenn eine Mediadatei geladen wird? Bei Matze scheint jede Wiedergabe zum Absturz zu führen. Das hatte ich mit den aktuellen Dekoder, wenn diese nicht mit --enable-memalign-hack kompiliert wurden - sprich da warte ich noch auf eine Rückmeldung.

 

Share this post


Link to post
roger2102

EPG bei RTL

Ohne Titel.png

Share this post


Link to post
roger2102

Rec.: Bleibt nach wenigen Sekunden ebenfalls hängen

 

 

Share this post


Link to post
hackbart

Öhm, EPG dauert etwas bis es geladen ist. Ich denke TV wird gar nicht angezeigt?

Share this post


Link to post
roger2102

Doch TV wird angezeigt, friert aber dann nach wenigen Sekunden ein.  Datei abspielen funktioniert nicht, da dreht sich hur der SAT.1-Ball. Sorry, muss mich korrigieren, Dateiabspielung läuft problemlos.

Edited by roger2102

Share this post


Link to post
hackbart

Passiert das selbe auch bei der Debugversion? Das Binärsymbol tritt auf, wenn über 2 Sekunden keine Daten vom Sat>IP Gerät empfangen wurden.

 

Was ist, wenn in den Einstellungen eine Aufnahme von sagen wir einer Minute programmiert wird? 

Share this post


Link to post
roger2102

Dann friert das Bild/die Aufzeichnung ebenfalls nach wenigen Augenblicken ein.

Share this post


Link to post
deMatze

Hallo Christian, beide Testversionen funktionieren nun bei mir. Auch der IPTV-Test war erfolgreich...

Share this post


Link to post
hackbart

Gut, dann werde ich am Wochenende oder so eine neue Version hochladen.

Share this post


Link to post
roger2102

Leider haben bei mir beide Testversionen nicht funktioniert. Die Fehlermeldungen bleiben identisch einschließlich IPTV-Test und Aufnahmen.

 

Kann es vllt. doch an der Sierra-Version des Mac (iMac) liegen?

 

 

Ohne Titel.png

Edited by roger2102

Share this post


Link to post
ThatOneAss

Unter 10.12.4 keine Probleme.

Share this post


Link to post
hackbart

Wie gesagt ich streite ja nicht ab, dass es kein Problem gibt. Bedenkt man das Apple ja nur seine eigene Hardware anbietet und die API nicht durch irgendwelche Drittparty Hardware verkompliziert wird, sollte man meinen das sowas nicht auftritt. Ich teste hier auf einem 2011er Macbook Air und einem 1014er iMac 4k. Beide nutzen Sierra und in VMs kann ich Mountain Lion, Yosemite und Mavericks testen. Auf allen Systemen lief es problemlos. In ThatOneAss'es Fall half die Nutzung einer älteren (3 Monate älter) Decoderbibliothek. 

Share this post


Link to post
U120884

Hi, ich habe gestern den Viewer in Version 1.7.4 geladen. Wenn ich meine Digibit Sat>IP Box konfigurieren will, ist diese bereits nach dem Start unter "Hardware" eingetragen. Mit "Weiter" komme ich dann in die Details der Konfig, kann dort aber nur dort aber nur "Zurück" und nicht "Weiter" klicken. Wenn ich dann auf "Wiedergabeliste" klicke (dort ist bereits "/m3u" eingetragen, stürzt das Programm "kommentarlos" ab. Any ideas? Was kann ich da noch machen?
Danke,
Achim

Share this post


Link to post
hackbart

Im Normalfall muss der Server nicht eingetragen werden. Abstürzen sollte die Anwendung allerdings nicht. Normalerweise findet die Software alle Sat>IP Server im gleichen Netzwerk.

Share this post


Link to post
lsby

Hallo,

 

den Absturz beim hinzufügen der Wiedergabeliste: /satipsrv/satip.m3u

kann ich Bestätigen!

Kann mann die liste irgendwie als Datei laden, um zuschauen woran der Absturz liegt?

 

Gruß aus Köln

 

 

 

 

Share this post


Link to post
hackbart

Hmm, das ist hier nicht reproduzierbar. Allerdings  liefert hier lediglich der DMS eine Wiedergabeliste.  Wirklich verwenden sollte man die Liste allerdings nicht. Ich empfehle wirklich den normalen Sat>IP Betrieb. Es ist normal, dass man den Weiter Knopf nicht drücken kann. Da gibt es schlichtweg nichts wo es weiter gehen sollte. Bitte die Software so wie in der Anleitung beschrieben ist verwenden.

1. Das Gerät manuell hinzufügen, sofern es nicht gefunden wird und

2. Unter Scanner einen Suchlauf tätigen

 

Man kann eine Playlist auch über die Sektion Netzwerk->Importieren hinzufügen. Dort trägt man die URL für die M3U ein.

 

Christian

Share this post


Link to post
U120884

...super - das hat geholfen! Ich habe die Digibit Box zuerst manuell angelegt und dann Senderliste über Netzwerk>Importieren hinzugefügt und das funktioniert. Aber der Aufruf und Wechsel des Senders dauert extrem lange (>20 Sek.!). Danach ist aber das Bild sehr gut und es läuft stabil. Dazu noch einen Tip?

 

Share this post


Link to post
lsby

Hallo,

mach mal wie @hackbart

vorgeschlagen einen Scann

vor 22 Stunden schrieb hackbart:

2. Unter Scanner einen Suchlauf tätigen

 

Gruß 

Share this post


Link to post
hackbart

Es gab einen derben Fehler in der App, wenn du eine Playlist mit 9000 Einträgen oder so importierst. Da ich die Sender im Hauptmenü alphabetisch als Menüeinträge hinzugefügt habe hat der Mac gestreikt. Ich limitiere das jetzt auf 1000 Sender. Ich glaube so viele Menüeinträge haben die wenigsten. Das betrifft aber nicht obiges Problem. Wie gesagt der Suchlauf sollte alle Sender finden, außer aber der Empfang ist gestört.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...