Jump to content
muhkuh64

ios app funktioniert nichr mehr

Recommended Posts

muhkuh64

Hallo.

Das war ein kostspieliges Update für mich um nach der Installation vom neuen Media Server feststellen zu dürfen, dass die iOS App nicht mehr funktioniert. Leider ist der Entwickler ewig nicht mehr im Forum aktiv gewesen und somit wollte ich mal fragen, ob man vielleicht noch über ein Update etwas nachhelfen könnte.

Den Fehler habe ich bereits identifiziert: Die App versucht die Seite iOS/iPhone-de bzw. iOS/iPhone-en.html zu öffnen. Diese gibt es jedoch nicht mehr, da die Sprachendungen anscheinend entfernt wurden. Gibt es eine Chance, dass eine Art "Redirect" im build-in Webserver realisiert werden kann, damit die App wieder nutzbar ist?

Vielen Dank im Voraus und viele Grüße,

muh

Share this post


Link to post
Griga

Der DMS Installer sollte bei dir in Programme\DVBViewer\Backup\2.0.2\SVCweb ein Backup des vorherigen ios-Ordners angelegt haben. Kopiere von dort die fehlenden Dateien in den neuen Programme\DVBViewer\SVCweb\ios Ordner. Das sollte das Problem (hoffentlich) beheben.

 

Siehe dazu auch hier und meinen nachfolgenden Post. Leider habe ich darauf noch keine Antwort erhalten. Inzwischen gibt es weitere Fixes und Verbesserungen für das Mobil-Webinterface. Falls du sie testen willst, sage Bescheid.

 

Share this post


Link to post
ralfpc6

Hallo Zusammen,

hatte das gleiche Problem, konnte die iOS App nicht mehr nutzen, seit der Installation von Media Server.

Dank des Tipps von Griga funktioniert es nun wieder. Habe den iOS-Ordner in SVCweb umbenannt und aus dem Backup wieder in den Ordner kopiert. Vielen Dank Griga!

 

Heirzu habe ich allerdings noch ein paar Verständnisfragen.

 

1. Wenn durch die Installation des Media Servers die rec. Service App nicht mehr funktioniert, womit hätte man dann auf dem IPad  Fernsehen sollen? Gibt es hierfür jetzt eine neue App?

 

2. Wofür ist der ios Ordner in SVCweb, wenn die rec. Service App damit nicht funktioniert?

 

3. Habe ich durch die Umbenennung des originalen ios-Ordners eventuell eine Funktion deaktiviert im neuen Media Server?

 

4. Sind wir beide die Einzigen, die das Problem haben, oder die Rec Service App nutzen, oder was könnte bei uns schief gelaufen sein? Helfe gerne mit die Ursache zu erforschen.

 

Installiert habe ich die neueste Version des DVBViewers und die neueste Version des Media Servers, Win10 pro 32 Bit creators update. Da fällt mir ein, das ich Wechselplatten habe und heute erst das creatorsupdate gemacht habe. Habe aber noch eine Festplattenkopie vor dem Update von heute. Werde ich gleich mal testen, ob es an dem Cratorsupdate liegt. Melde mich gleich.

 

An dieser Stelle noch ein herzliches Dankeschön an die Entwickler für diese tolle Arbeit!!!!!!

 

 

 

 

 

  • Like 1

Share this post


Link to post
Griga
28 minutes ago, ralfpc6 said:

1. Wenn durch die Installation des Media Servers die rec. Service App nicht mehr funktioniert, womit hätte man dann auf dem IPad  Fernsehen sollen? Gibt es hierfür jetzt eine neue App?

 

Man kann das Mobil-Webinterface einfach im Browser (Safari) aufrufen, indem man die Adresse eingibt, also http://[MediaServer IP]:[Webserver-Port]/ios - die Platzhalter mit eckigen Klammern musst du durch die bei dir gültigen Werte ersetzen. Der Standard-Webserver-Port ist 8089. Ohne App sind ein paar Sachen nicht ganz so bequem, aber im Prinzip sollte es gehen.

 

Früher oder später werden wir ohne die App auskommen müssen, wenn Markus nicht wieder auftaucht und sie aktualisiert. Zu befürchten ist, dass das nicht passiert.

 

28 minutes ago, ralfpc6 said:

2. Wofür ist der ios Ordner in SVCweb, wenn die rec. Service App damit nicht funktioniert?

 

Es war nicht geplant, sie aus dem Verkehr zu ziehen. Es liegt einfach daran, dass ich kein iOS-Gerät habe und es nicht merke, wenn da irgendwas schiefgeht. Es fehlen Tester, die das im Auge behalten.

 

Der ios-Ordner ermöglicht wie gesagt generell, das Mobil-Webinterface in Browsern zu verwenden, inzwischen auch in Chrome oder Firefox unter Android. Es ist das mobile Gegenstück zum Desktop-Webinterface im übergeordneten SVCweb-Ordner.

 

28 minutes ago, ralfpc6 said:

3. Habe ich durch die Umbenennung des originalen ios-Ordners eventuell eine Funktion deaktiviert im neuen Media Server?

 

Ja, hast du. Alles, was hier für das Mobil-Webinterface angegeben ist. Vorgeschlagen hatte ich dehalb, nicht den SVCweb\ios-Ordner komplett durch die vorherige Version zu ersetzen, sondern nur die Dateien, die die App vermisst, aus dem alten Ordner in den neuen zu kopieren, also iphone-de.html, iphone-en.html, ipad-de.html, ipad-en.html.

 

Wie sich das genau auswirkt, weiß ich nicht, weil ich immer noch auf jemand warte, der darüber präzise Auskunft gibt.

 

28 minutes ago, ralfpc6 said:

4. Sind wir beide die Einzigen, die das Problem haben, oder die Rec Service App nutzen, oder was könnte bei uns schief gelaufen sein?

 

Nein, es betrifft alle und wird im nächsten Bugfix Release behoben wereden. Zunächst brauche ich aber mehr Informationen bzw. Tester, auch für weitere Neuerungen, die es inzwischen gibt.

 

 

  • Like 1

Share this post


Link to post
ralfpc6

Hallo Griga,

 

super vielen Dank für deine Antworten!

 

Habe getestet ohne Creatorsupdate, Problem ist das gleiche. Habe den Originalordner ios wieder hergestellt und die von dir genannten Dateien dort hineinkopiert.

 

Läuft jetzt alles wieder. 

 

Werde das mit dem Browser morgen mal testen. Hört sich gut an. 

 

Nochmals vielen Dank und einen schönen Abend.

 

Viele Grüße Ralf

Share this post


Link to post
Griga

Ok, danke, also neuer ios-Ordner plus darin die vier genannten HTML-Dateien aus dem Backup\2.0.2\SVCweb\ios-Ordner, und Markus' App funktioniert wieder wie sie soll, richtig? Bitte behalte das weiter im Auge.

 

Weiteres zu dem Thema:

 

http://www.dvbviewer.tv/forum/topic/59876-löschen-von-aufnahmen-bei-version-202-nicht-möglich-ios/

 

Es gibt auch noch ein Problem mit dem Löschen von Aufnahmen. Das ist inzwischen behoben. Dazu kommen weitere Fixes sowie kleinere Neuerungen (z.B. dass sich das Mobil-Webinterface die zuletzt eingestellte Lautstärke merkt). Wie gesagt brauche ich Tester. Gerade erörtere ich mit Christian, ob Testversionen im Download-Bereich zur Verfügungt gestellt werden können. Ansonsten per PM.

  • Like 1

Share this post


Link to post
Griga
9 hours ago, Griga said:

Ok, danke, also neuer ios-Ordner plus darin die vier genannten HTML-Dateien aus dem Backup\2.0.2\SVCweb\ios-Ordner, und Markus' App funktioniert wieder wie sie soll, richtig?

 

Ich habe mir die Sache noch mal angeschaut und zweifle inzwischen daran, dass das so eine dauerhafte Lösung ist. Die alten HTML-Dateien aus dem Backup-Ordner beziehen sich nämlich auf weitere alte Dateien, die es im neuen ios-Ordnern nicht mehr gibt. Womöglich funktioniert das nur, weil sie Safari noch im Cache hat. Und bestimmte Sachen funktionieren gar nicht mehr.

 

Zum Beispiel wird in der iphone-de.html eine nicht mehr existierende Datei help-de.html nachgeladen, wenn man Hilfe anwählt. Ich vermute, da tut sich nichts mehr. Stimmt das?

 

Man müsste es wohl eher so machen:

  • Die alten HTML-Dateien mit -de und -en im Dateinamen wieder raus.
  • Von der neuen iphone.html zwei Kopien herstellen und diese in iphone-de.html und iphone-en.html umbenennen. So dass sich drei identische Dateien im ios-Ordner befinden: iphone.html, iphone-de.html und iphone-en.html.
  • Ebenso mit der ipad.html.

Ich weiß leider nicht, was die App mit den HTML-Dateien genau anstellt (also iphone-de.html usw.) und kann es wie gesagt selbst nicht testen. Das müssen jetzt wieder andere probieren...

 

  • Like 1

Share this post


Link to post
ralfpc6

Hallo Griga,

 

werde das mit dem Umbenennen der Dateien mal testen und schauen, ob es funktioniert.

 

Komme aber leider erst morgen dazu und melde mich anschließend.

 

Wünsch dir noch einen schönen Tag.

Share this post


Link to post
Haifisch

Bei mir funkt die app nach Deiner Anleitung bestens. Auch die Hilfe.

 

Albert

Share this post


Link to post
Haifisch

Die in dem thread, den ich begonnen habe (löschen funktioniert nicht ...) Hab dort auch beschrieben, was ich getan habe.

 

Albert

 

PS: Wie kann man den link zu einem thread setzen?

Share this post


Link to post
Griga
42 minutes ago, Haifisch said:

Wie kann man den link zu einem thread setzen?

 

Text markieren, dann hier klicken

 

Zwischenablage01.png

 

und die Adresse eingeben. Wenn man auf einen bestimmten Beitrag verlinken will, kann man dessen Adresse kopieren, indem man oberhalb des Beitrags auf Zwischenablage02.png klickt.

 

22 minutes ago, Haifisch said:

Die in dem thread, den ich begonnen habe (löschen funktioniert nicht ...)

 

Du meinst diese hier? Ich bin mir inzwischen nicht mehr sicher, ob die Lösung unbegrenzt hält und würde inzwischen die oben gepostete vorziehen. Sie wird auch im nächsten Bugfix Release enthalten sein, vorausgesetzt, dass sie gut funktioniert. Dazu fehlen noch Rückmeldungen.

Share this post


Link to post
muhkuh64
vor 15 Stunden schrieb Griga:

 

Ich habe mir die Sache noch mal angeschaut und zweifle inzwischen daran, dass das so eine dauerhafte Lösung ist. Die alten HTML-Dateien aus dem Backup-Ordner beziehen sich nämlich auf weitere alte Dateien, die es im neuen ios-Ordnern nicht mehr gibt. Womöglich funktioniert das nur, weil sie Safari noch im Cache hat. Und bestimmte Sachen funktionieren gar nicht mehr.

 

Zum Beispiel wird in der iphone-de.html eine nicht mehr existierende Datei help-de.html nachgeladen, wenn man Hilfe anwählt. Ich vermute, da tut sich nichts mehr. Stimmt das?

 

Man müsste es wohl eher so machen:

  • Die alten HTML-Dateien mit -de und -en im Dateinamen wieder raus.
  • Von der neuen iphone.html zwei Kopien herstellen und diese in iphone-de.html und iphone-en.html umbenennen. So dass sich drei identische Dateien im ios-Ordner befinden: iphone.html, iphone-de.html und iphone-en.html.
  • Ebenso mit der ipad.html.

Ich weiß leider nicht, was die App mit den HTML-Dateien genau anstellt (also iphone-de.html usw.) und kann es wie gesagt selbst nicht testen. Das müssen jetzt wieder andere probieren...

 

Hallo Griga,

ausgezeichnete Idee und genau das, was ich auch umgesetzt habe. Es existieren jetzt drei identische Dateien im besagten Ordner. Alles scheint gut zu funktionieren. Vielen Dank dafür. Da wir täglich mit dem ipad Ausnahmen abspielen, werde ich dir auch schnell mitteilen können, wenn es zu weiteren Einschränkungen kommt.

Aber der von dir gewünschte "intensiv-dauertest" ist das leider nicht...

  • Like 1

Share this post


Link to post
ralfpc6

Hallo Griga,

habe jetzt gerade mal getestet. Das Umbenennen der Dateien in -de führt zum Erfolg und man kann auf IPhone oder einem IPad fernsehen.

Was mir aber aufgefallen ist, man kann nur gleichzeitig auf einem Gerät schauen, z. B. IPad. Versucht man dann gleichzeitig auf einem anderen Gerät die Wiedergabe zu starten, erscheint eine Fehlermeldung "Der Stream konnte nicht geladen werden".

Dabei ist es auch egal, ob ich die Dateien aus dem Backup nehme, oder die Dateien umbenenne, man kann immer nur auf einem Ios-Gerät fernsehen.

 

Viele Grüße

 

Ralf

 

 

Share this post


Link to post
Griga
1 hour ago, ralfpc6 said:

Was mir aber aufgefallen ist, man kann nur gleichzeitig auf einem Gerät schauen, z. B. IPad.

 

Der selbe Sender oder verschiedene Sender von der selben Frequenz oder verschiedene Sender von verschiedenen Frequenzen? Wieviele Tuner sind für die Empfangsart verfügbar? Sowas kann man kaum ohne nähere Angaben und eine support.zip vom Server PC klären.

Share this post


Link to post
ralfpc6

Sorry, hat sich erledigt, habe an meinem Zweitrechner getestet, der nur einen Tuner hat. Geht natürlich dann nur auf einem Gerät.

 

Share this post


Link to post
ralfpc6

Mir ist noch etwas aufgefallen, dass dem Einen oder Anderen möglicherweise hilft.

Habe ja die beiden Dateien iPhone und IPad in -de umbenannt, mit dem Ergebnis, das Rec Service wieder funktioniert.

Später habe ich dann versucht über Safari fernzusehen. Das ging aber dann nicht, es wurde eine Seite geöffnet, auf der ich iPhone oder iPad auswählen könnte. Bei der Auswahl passierte nichts, also kein Fernsehen etc.

ich hatte mir die iPhone und iPad Dateien ohne -de vorher gesichert und zurück in den iOS Ordner kopiert.

Jetzt sind dort also vier Dateien, jeweils iPhone und iPad mit und ohne -de.

Am besten also die Originaldateien in einen anderen Ordner kopieren, dort umbenennen und wieder zurückkopieren.

 

 

Share this post


Link to post
Griga

Genau das hatte ich zuletzt als Fix angegeben, damit die iOS-App wieder funktioniert:

 

On 19.5.2017 at 6:25 AM, Griga said:
  • Von der neuen iphone.html zwei Kopien herstellen und diese in iphone-de.html und iphone-en.html umbenennen. So dass sich drei identische Dateien im ios-Ordner befinden: iphone.html, iphone-de.html und iphone-en.html.
  • Ebenso mit der ipad.html.

 

Vorgehen würde ich so:

  • Eine Kopie der iphone.html im SVCweb\ios-Ordner erzeugen (die Windows dann iphone - Kopie.html nennt) und in iphone-de.html umbenennen.
  • Eine weitere Kopie der iphone.html im SVCweb\ios-Ordner erzeugen (die Windows wieder iphone - Kopie.html nennt) und in iphone-en.html umbenennen.
  • Die ganze Prozedur entsprechend mit der ipad.html.
  • Like 2

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...