Jump to content
gleddamax

"Alle ausblenden"-Taste toggelt manchmal Vollbild

Recommended Posts

gleddamax

beim DVBViewer 6.0.2 fiel mir eben folgendes auf, schätze ist ein Bug:

 

Wenn ich bei "Ansicht" -> "Videofenster 1" (Rahmen & Leisten angezeigt, immer im Vordergrund) ausgewählt habe, kann ich mit # zwischen Videofenster 1 und 2 wechseln.

Wenn Videofenster 1 aktiv ist, kann ich auch in Vollbild und wieder zurück wechseln und danach mit # zwischen Videofenster 1 und 2 wechseln.

 

Sobald ich im Modus Videofenster 2 einmal ins Vollbild und zurück gewechselt habe und mit # zwischen den Videofenstern wechsle, wird stattdessen zwischen Videofenster 2 und Vollbild gewechselt.

 

Erst nachdem ich über das Kontexmenü -> "Ansicht" -> "Videofenster 1" gehe, kann ich mit der #-Taste wieder zwischen den beiden Videofenstermodi wechseln.

Edited by gleddamax

Share this post


Link to post
Griga
5 hours ago, gleddamax said:

beim DVBViewer 6.0.2 fiel mir eben folgendes auf, schätze ist ein Bug:

 

Der Bug ist beabsichtigt und deshalb kein Bug, sondern ein Feature :)

 

On 11.4.2017 at 5:34 PM, hackbart said:

Die Anwahl der momentanen aktiven Ansicht veranlasst den DVBViewer, zur vorherigen Ansicht zurückzukehren.

 

Du wählst Videofenster 2 an. Wenn Videofenster 2 bereits aktiv ist und du dich vorher im Vollbild befunden hast, geht's halt zurück ins Vollbild.
 

Der klassische Name der dazugehörigen Action ist Hide All=71" und steht noch so in der actions.ini (siehe Installationsverzeichnis) - müsste eigentlich Video Window 2 heißen. Entweder habe ich die Umbenennung vergessen oder mich aus Kompatibilitätsgründen nicht getraut ;) Ich mache das jetzt mal und schaue, ob sich jemand beschwert...

 

Was aber definitiv in der actions.ini fehlt, sind die Actions Video Window 1=130 und Radio Window=131. Wenn man sie nachträgt, kann man dafür auch Tasten belegen.

 

Share this post


Link to post
gleddamax

danke fürs Erklären Griga, verstehe. Da hat mich die Bezeichnung der Funktion in den Eingabe-Einstellungen in die Irre geführt :) .

Share this post


Link to post
gwr

 @Griga und @gleddamax, ich bin jetzt auch über dieses Verhalten gestolpert.

 

Am 7.6.2017 um 21:51 schrieb Griga:

 

...

Du wählst Videofenster 2 an. Wenn Videofenster 2 bereits aktiv ist und du dich vorher im Vollbild befunden hast, geht's halt zurück ins Vollbild.
 

Der klassische Name der dazugehörigen Action ist Hide All=71" und steht noch so in der actions.ini (siehe Installationsverzeichnis) - müsste eigentlich Video Window 2 heißen. Entweder habe ich die Umbenennung vergessen oder mich aus Kompatibilitätsgründen nicht getraut ;) Ich mache das jetzt mal und schaue, ob sich jemand beschwert...

 

Was aber definitiv in der actions.ini fehlt, sind die Actions Video Window 1=130 und Radio Window=131. Wenn man sie nachträgt, kann man dafür auch Tasten belegen.

 

 

also habe ich jetzt Video Window 1=130 und Radio Window=131 in der actions.ini nachgetragen, einen Befehl "Videofenster 1" angelegt

und die Taste ä (liegt neben der #) angelernt.

Jetzt toggelt Befehl 71 "#" zwischen Fenster 1 und 2 oder zwischen Fenster 2 und Vollbild

Befehl 130 "ä"  toggelt zwischen Fenster 1 und 2 oder zwischen Fenster 1 und Vollbild

Befehl 5 "f" (Vollbild) toggelt zwischen Fenster 1 und Vollbild oder Fenster 2 und Vollbild

Kommt immer darauf an, was vorher aktiv war. korrekt so?

Edited by gwr

Share this post


Link to post
gleddamax

so verstehe ich das auch.

Die Tasten rufen die entsprechende Ansicht auf, die vorige Ansicht wird denke ich mal im Hintergrund temporär gespeichert. Durch erneuten Druck derselben Taste wird die jeweils vorige Ansicht wieder dargestellt.

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • !MAXX!
      By !MAXX!
      Hallo,
      ich bin seit einigen Jahren Nutzer dieser Software und habe Heute ein Update installiert (5.5.2 zu 6.0.1.0), weil seit Kurzem das Programm aus ungeklärten Gründen stecken blieb und der PC komplett neu gestartet werden musste.
       
      Zu meinen eigentlichen Problemen:
      Die Soft läuft auf einem PC mit OS win10Pro und der Technisat Skystar 2 Express HD mit drei angeschlossenen Monitoren. Er hat eigentlich gar nichts zu tun, als TV wieder zu geben. Mein Arbeitsrechner ist ein weiterer PC, so dass mich die plötzlichen Systemabstürze schon verwundert haben. 
      Nach dem Update auf die aktuelle Version startet nun das Programm über die Autostart - Funktion von Windows 10 Pro nicht mehr auf dem zuletzt vorgegeben Monitor, sondern immer nur auf dem Monitor, der auch als primär ausgewiesen ist.
      Wenn ich aber das Programm nicht im Vollbildmodus nutze und es auf einen erweiterten Monitor ausführe und dann schließe, merkt sich DVBViewer diese Konfiguration und öffnet sich auch wieder auf dem Monitor in der Screengröße, auf dem es zuletzt gelaufen ist.
      Das Funktioniert mit der Option "Im Vollbild starten" nach dem Update nicht mehr, egal wie ich es anstelle. Ist das ein Bug oder bin ich zu doof?
        Ich nutze die original Fernbedienung der Technisat express Karte. Durch das Update erhoffte ich mir die Fehlerbeseitigung, dass die Fernbedienung nicht richtig funzt. Sie reagiert nicht, wenn der PC neu gestartet wird, jedoch funzt einwandfrei, wenn ich einen NEUSTART des PC ausführe!?? 
      Was ist das denn? Ich habe irgendwie den Eindruck, dass ein Dienst beim Einschalten des PC nicht geladen wird, den er aber lädt, wenn ich den PC neu starte...wie kann das sein?
      Das Update brachte hinsichtlich dieses Problems keine Besserung und in den Einstellungen eine andere FB einrichten hat auch nicht geklappt. Wer kann mir hier weiter helfen? ich habe keine Ahnung mehr, worin die Probleme begründet sind und hier im Forum hatte insbesondere mein FB-Problem auch noch niemand - jedenfalls habe ich dazu nix finden können!
       
      Danke und Gruß
      MAXX
       
    • AJM
      By AJM
      Problem:
      Nach dem Update auf 6.0.0 Pro "verschwand das Bild" beim Umschalten in den Vollbild-Modus und der Desktop wurde angezeigt. Solange das Bild im frei skalierbaren Fenster-Modus angezeigt wurde, gab es keinerlei Probleme.
       
      Details:
      Im Preview-Bild in der Task-Leiste wird der Programmrahmen beim Mouse Over noch angezeigt (ohne TV-Bild, nur weiß mit zentralem dvbvr-Icon und darunter den neuen Icons "EPG Window" usw.) und im Rahmen des Task-Leisten-Vorschaubilds "DVBViewer (keine Rückmeldung)".
      Eine Reaktivierung des Fenster-Modus ist nicht möglich.
      Nach Klicken auf X (Schließen) im Task-Leisten-Vorschaufenster erscheint dann die Windows-Meldung "Programm reagiert nicht =>Beenden?")
       
      Ursache und Notlösung:
      Das DVB-Tool „Supporttool.exe“ zeigte im DVBViewer.LOG zahlreiche „Access violations“ in d3d9.dll. Da diese dll-Datei zu DirectX gehört, lag ein GPU-Treiberproblem nahe.
      Nach der Änderung der Grafikeinstellungen im Laptop von „Bevorzugte GPU = Radeon 970M“ in AUTO (=> Nvidia 530) trat das Vollbildproblem bislang nicht mehr auf.
       
      Scheint also eher ein Laptop-spezifisches Problem bei zwei GPUs zu sein, wenn dort der Default AUTO geändert wurde.
       
      Vielleicht hilft es ja dem einen oder anderen.
       
      Viele Grüße!
      AJM
    • TeXeG
      By TeXeG
      Hallo leute;)
       
      also weiß nicht ob ich hier richtig bin wenns falsch ist könnt ihrs ja moven:D
      jo also mein problem ist halt wenn ich DVBViewer TE 2 starte funktioniert alles normal aber wenn ich dann in ein programm gehe wo im vollbild modus ist wird das bild beim viewer schwarz und ich muss es neu starten damit ich wieder was sehe
       
      hoffe auf antworten mfg TeXeG
×
×
  • Create New...