Jump to content
Sign in to follow this  
Klassikfan

Probleme mit Hardware-Beschleunigung und H.264

Recommended Posts

Klassikfan

Hallo!

Ich hab hier ein Problem, das ich nicht durchblicke.

Vor ein paar Tagen kam mien neues Notebook an. Eines mit dem neuen Ryzen 5 2500U mit Vega 8-GPU. Damit habe ich beim Fernsehen ein Problem, das ich auch auf meinen PC habe - allerdings permanent. Gebe ich ein Programm mit H.264-Codierung (DVB-S2 als Quelle) wieder, dann klötzelt es mit aktivierter Hardwarebeschleunigung extrem. Ruckeln, Bildsprünge vor- und rückwärts etc., vor allem Bewegungen im Bild sind furchtbar - es ist teilweise gar nicht mehr zu sehen, was da eigentich passiert.

 

Der Player scheint das Bild nicht synchronisiert zu bekommen. Vielleicht bringen ihn die Fülldaten aus dem Takt. Der Media Player Classic verhält sich identisch - wied ja auch mit LAV befeuert. Wenn ich einen der Filme mal kurz durch den Smart Renderer schmeiße, wobei der Anfang neu berechnet wird, klappt die Wiedergabe vom Beginn her. Springe ich dann aber im Film, klötzelt es wieder. VLC macht die Probleme mit den identischen Filmen (.ts-Streams vom Satelliten) nicht.

 

Am PC (Grafikkarte von AMD) gibt es dieselben Probleme, allerdings erst mit einiger Zeitverzögerung und weniger stark. Schalte ich die Hardwarebeschleunigung ab, ist alles ok, a. PC und auf dem Laptop - aber die CPU-Last ist natürlich höher. Schade, da die Grafik das ja eigentlich in Hardware kann. Das Verrückte: Mit DVB-T2 als Quelle, und somit dem neueren Codec H.265 ist alles ok! Auch mit Hardware-Beschleunigung. In allen Fällen benutze ich im DVBViewer die LAV-Filter.

 

 

Am PC ist zusätzlich ein MainConcept-Decoder verfügbar, der das Problem nicht hat. Den am Notebook zu installieren, stellt mich alerdings vor das Problem, daß ich nicht weiß, wie der auf dne PC gekommen ist. Irgendwelche halblegalen Codec-Packs hab ich auf beiden nicht installiert. Steckt der in irgnedeinem Programm wie Adobe Premiere, MKV Toolnix, ffmpeg for Audacity, die ich auf dme PC installiert habe, mit drin? Ps: TMPEnc Smart Renderer ist auch installiert.

 

Schön wäre natürlich. wenn ich LAV und H.264 zum Laufen brächte. Am alten Laptop gibts die Probleme übrigens nicht. Und auch der hat eine AMD-Grafik (Stoney Ridge APU). Daher irgendwie mysteriös...

 

Jemand eine Idee?

Edited by Klassikfan

Share this post


Link to post
al3344fa

Zur Frage, wie der MainConcept Decoder auf den PC gekommen ist: ich habe eine TechniSat Sat-Karte im Rechner und mit deren Software wurde auch der MainConcept Decoder mitinstalliert.

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...