Jump to content
marcello64

Kein Sender in 4k/UHD läuft bei mir fehlerfrei ... genaue Beschreibung

Recommended Posts

Griga

P.S. Ich habe für eine Live-Simulation die fehlerfreie TS Reader-Aufnahme als TS Stream-Senderlisteneintrag eingerichtet und sie den DVBViewer erneut aufnehmen lassen. Das Ergebnis war fehlerfrei. Am Recorder liegt es also nicht.

 

Um eine TS-Datei im DVBViewer als Live-Simulation abzuspielen, geht man so vor:

  • Im Explorer Rechtsklick auf die Datei mit gedrückter Umschalttaste -> Als Pfad kopieren (zumindest geht das unter Windows 7).
  • Im DVBViewer Senderlisteneditor einen passenden Ordner bzw. eine passende Stelle selektieren, dann rechts unten Neu ->  TS Stream
  • Im Leerformular Rechtsklick in das Eingabefeld "Adresse" -> Einfügen. Da sollte nun der Dateipfad stehen. Doppelte Anführungszeichen stören nicht.
  • Einen passenden Sendernamen eintragen, dann auf Hinzufügen klicken.
  • Den neuen Sender mit einem Doppelklick anwählen.

Das Ergebnis des Versuches deutet darauf hin, dass der DVBViewer vom DVB-Gerät einen fehlerhaften Stream erhält. Es fragt sich warum. Ich möchte fast wetten, es ist ein TBS-Gerät... ;)

 

Share this post


Link to post
marcello64

Hey Griga, ich hätte auch darauf wetten können , dass es wieder an etwas anderen liegen soll, nur nicht am DVBViewer ;-). Da ich den Live-Modus durch dich auch kenne, habe ich genau das, was du jetzt gemacht hast, schob vor Tagen ebenfalls durchprobiert.

 

Stelle es dir doch mal neutral vor ... es gibt verschiedene Übertragungen von unterschiedlichen Providern mit unterschiedlich hohen Datenraten. Allesamt sagen wir mal mit 50 Mbit/s und darüber. Die Symbolraten liegen zwischen 17.000 und 40.000. Die meisten UHD/HEVC, aber mindestens eine auch in h.264. Mehrere andere genannte  ähnliche Programme funktionieren fehlerfrei in Echtzeit mit und ohne Wiedergabe + Aufnahme. Bei allen sind die Aufnahmen dabei fehlerfrei. Nur mit dem DVBViewer kann ich weder gucken und aufnahmen. Ausprobiert wurden 3 Karten von 2 Herstellern, die bei den anderen Programmen fehlerfrei funktionierten, nur beim DVBViewer nicht. Was könnte die Ursache sein?

 

Dann noch ein Beispiel; momentan läuft  die Tour de France auf dem gleichen Satelliten. Auch mit dreifach (ca. 33-35 Mbit/s) erhöhter Datenrate und Symbolrate 20.000 gegenüber den Mainstreamkanälen. Und bei dieser niedrigeren Kategorie funktionieren auch die bösen TBS-Karten mit dem DVBViewer. Fehlerfreie Wiedergabe + Aufnahme möglich. Hmm, was jetzt?

 

Ich befürchte, auch eine RTX 2080 (Ti) oder sonstiges neuerliches Hardwareupgrade würde nichts bringen, solange immer nur andere Fehlerquellen angenommen werden. Hmm.

 

 

 

Share this post


Link to post
Griga

Und woher soll ich wissen, woran es bei dir liegt? Wie soll ich etwas daran ändern? Es ist dein Setup, ich kann nur vermuten... bei mir werden  60 MBit Transponder mit diversen DVB-Geräten (DVBSky, Hauppauge, Digital Devices, TechniSat) fehlerfrei empfangen. Transponder mit höheren Datenraten sind außerhalb meiner Reichweite. Wenn hier im Forum Probleme aus der Kategorie gemeldet werden, ist oft ein TBS-Gerät am Werk.

 

Das einzige TBS-Gerät, dass ich besitze (eine uralte USB QBox mit CI) habe ich letztlich aussortiert, da es unter Windows 10 ständig Diskontinuitäten und gelegentlich BSODs produzierte. Jetzt hängt es an einem Nostalgie PC-mit Windows XP. Da benimmt es sich einigermaßen erträglich. Ich denke, es wäre nicht schlecht, wenn ich eine modernere TBS USB Box für Testzwecke hätte... mal beim Chef nachfragen, ob sowas drin ist :) Die Super-Profi-Geräte, die du hast,  sind allerdings preislich auch außer Reichweite.

 

Was ich in deinem Fall zwecks Eingrenzung des Problems noch probieren würde: Alles weg, was den Datenstrom durchschleust, aber nicht zwingend gebraucht wird. Alle Plugins ausklinken (DVBViewer im Safe Mode starten, siehe Windows Start-Menü). "Hat CI Modul" in den Hardware-Optionen ausschalten, damit die TbsCIapi.dll außen vor bleibt, die öfters Probleme macht (und die die anderen von dir gelobten Programme garantiert nicht verwenden). Und dann mal schauen... im Grunde ist es nämlich wenig plausibel, dass ein TBS Treiber einer Anwendung einen fehlerfreien und einer anderen einen Stream mit zahlreichen Aussetzern liefert. Ich wüsste nicht, wo ich da nach einer Ursache suchen sollte, außer bei Sachen, die dein DVBViewer im Vergleich zu anderen Anwendungen zusätzlich benutzt.

 

Und die Signalanzeige im DVBViewer-Hauptfenster kannst du auch mal probeweise ausschalten (draufklicken), weil sie den Wert periodisch vom Treiber abfragt. Bei meiner QBox ließ das immer den gesamten DVBViewer kurzzeitig einfrieren, was man merkte, wenn man ihn mit der Maus über den Desktop zog: Ruck-Ruck-Ruck...

 

Share this post


Link to post
marcello64
Posted (edited)

Du musst dich auch, selbst wenn's schwer fällt, von dem falschen Gedanken verabschieden, dass es an mir liegt. Das ist schlichtweg nicht richtig. Es liegt am DVBViewer oder am Zusammenspiel der Komponenten mit ihm. Du kannst ja meine Aktivitäten aus Mangel an technischen Möglichkeiten gar nicht nachvollziehen. Das ist ja die Krux. Transponder mit um die 80 Mbit/s sind problemlos fehlerfrei empfangbar, aber einzelne Kanäle so ab 45 Mbis/s aufwärts machen anscheinend Probleme. Das ist schon ein kleiner und feiner Unterschied.

 

Es mag ja ein Fünkchen Wahrheit an der Behauptung, dass die TBS-Karten fehleranfälliger sind, dran sein. Ich kann das Gegenteil nicht beweisen und behaupte es deshalb auch nicht, aber wenn sämtliche Alternativsoftware funktioniert, kann ich die Ursache des Nichtfunktionierens nur bei der übrig gebliebenen Software suchen. An welchem Detail genau wäre eher dein Part. Das öfters TBS bei Fehlern mit im Spiel ist, liegt vielleicht auch daran, dass die Karten sehr gängig sind und über gewisse Programme Funktionen haben, die DD & Co nicht hat. TBS hatte zu Beginn eine Schrottkarte mit am Start, die nicht lange überlebte, aber danach gab es zumindest keine nennenswerten Totalausfälle mehr.

 

Ich muss noch mal meine Platzverhältnisse im Gehäuse genau abchecken und wenn es slotmäßig passt, könnte ich eine RTX 2080 Ti in Betracht ziehen. Meine dritte Karte von Prof Tuner wollte ich sowieso mal wechseln und habe deshalb eine DD Max S8X bestellt - dürfte Ende der Woche kommen. Die hier diskutierten Probleme wird das sicher nicht beheben, nehme ich an, aber für eine längere Zeit alle Hardwareanforderungen erfüllen.

 

Meine jetzige GTX 1080 könnte ich dann für einen annehmbaren Preis abgeben :biggrin: .

 

Und @Griga, ich habe keine anderen Programme gelobt, nur als Vergleich herangezogen. DVB Dream gefällt mit nicht besser als der DVBViewer, aber es läuft eben bei Extremempfang, wenn man das überhaupt so bezeichnen kann, gut. Warum auch immer. Auch DVB Dream nutzt haargenau die gleiche TbsCIapi.dll wie ihr beim Viewer - habe ich nachgesehen.

 

Die restlichen Anregungen behalte ich im Auge. Eine neuere USB-Box würde ich nicht in Betracht ziehen, da per USB angeschlossene Satkarten noch nie das Gelbe vom Ei waren; eher schon eine gut erhaltene gebrauchte Drehanlage Da gibt es noch sehr gute 80iger/90iger Jahre-Qualität... 

Spoiler

 

 

 

Edited by marcello64

Share this post


Link to post
Griga
2 hours ago, marcello64 said:

Transponder mit um die 80 Mbit/s sind problemlos fehlerfrei empfangbar, aber einzelne Kanäle so ab 45 Mbis/s aufwärts machen anscheinend Probleme.

 

Bei BDA-Geräten kommt im DVBViewer grundsätzlich der Datenstrom des gesamten Transponders an. Er durchläuft einen Software-PID-Filter, der die für bestimmte Zwecke (Wiedergabe, Aufnahme...) angeforderten TS-Pakete herauspickt und an die zuständige Instanz weiterleitet. Wenn du also eine Aufnahme startest, bestellt der Recorder die Pakete mit den gewünschten PIDs beim PID Filter und schreibt sie auf Platte. Das funktioniert fehlerfrei, wie du selbst mittels Live-Simulation und einer fehlerfreien Aufnahme als Quelle festgestellt hast. Also gehen Daten verloren, bevor sie den PID Filter erreichen. In dem Bereich werden aber einzelne Kanäle überhaupt nicht separat und im Detail behandelt, es sei denn, es sind  Entschlüsselungsmechanismen legaler oder illegaler Art am Werk (was auch unverschlüsselte Daten betreffen kann).

 

Wenn deine Theorie stimmt, dass im DVBViewer nur die Verarbeitung einzelner Kanäle mit hoher Datenrate Probleme macht, aber nicht die von Transpondern mit gleicher oder wesentlich höherer Datenrate, müssten in den problematischen Fällen im DVBViewer Aufnahmen des gesamten Transponders ohne Wiedergabe fehlerfrei sein (siehe Aufnahme-Programmierung -> Timer Aktion ->Transponder Dump)  - da werden die Daten noch vor dem PID-Filter abgegriffen und unbesehen weggeschrieben. Außerdem dürften dann im TransEdit Analyzer bei den betreffenden Frequenzen keine Diskontinuitäten bzw. Missing Packets auftauchen.

 

Aber das erscheint mir unlogisch. Wenn man Entschlüsselungsmechanismen als Ursache ausschließen kann, wäre noch denkbar, dass es sich bei den problematischen Fällen um Transponder mit speziellen Eigenschaften handelt, bei denen der Treiber/ die Hardware mit den vom DVBViewer gelieferten Empfangsparametern keinen stabilen Empfang hinbekommt.

 

Share this post


Link to post
marcello64

Mal etwas anderes zwischendurch ... in der DVBSource haben wir ja damals einen Buffer eingefügt, stand jedenfalls bei mir noch nicht drin. HEVCBufferSize=64/128 etc. bspw. Solch einen Buffer für h.264 einbauen ist wohl nutzlos? Denn das letzte Feed mit der hohen Datenrate war ja h.264.

Share this post


Link to post
Griga

Wenn es einen Zusammenhang mit dem Puffer im Quellfilter gäbe, wären Aufnahmen ohne Wiedergabe nicht betroffen. Aufnahmen mit HEVC Video funktionierten vor der Einführung der Puffer-Einstellung fehlerfrei. Nur bei der Wiedergabe gab es in bestimmten Fällen Probleme.

 

Wenn es Diskontinuitäten in Aufnahmen gibt, heißt das im allgemeinen, dass entweder die Daten schon kaputt eintreffen, oder dass Windows nicht mehr dazu kommt, seinen Disk-Cache rechtzeitig wegzuschreiben, was allerdings nur selten passiert - es gab mal so Fälle, als Leute den DVBViewer auf Echtzeit-Priorität gestellt hatten.

 

Share this post


Link to post
marcello64

Danke Griga, ich probiere weiter, dass kann ich aber nur, wenn Übertragungen laufen. Mal sehen, wenn die DD kommt...

Share this post


Link to post
marcello64
Posted (edited)

Ich habe weiter probiert, nachdem die DD Max SX8 angekommen und verbaut ist. Leider ist sie noch fehleranfälliger in Hinsicht der hohen Datenraten oder an was es auch immer liegt. Bei ihr liegt die Fehlereinstiegsquelle deutlich niedriger als bei den TBS-Karten. Bei der TBS-6903 habe ich öfters keine Discontinuities bei hohen Datenraten, bei der 6983 ein paar und bei der DD hohe Stückzahlen und ab der ersten Sekunde diesen vertikalen Matsch.

Edited by marcello64

Share this post


Link to post
nuts

Hast du schon den DPC Latency Checker über das System laufen lassen? 

Vielleicht ist auch an anderer Stelle ein Flaschenhals in deinem System? 

Share this post


Link to post
marcello64

Und was soll der DPC Latency Checker deiner Meinung nach anzeigen? Außer das Abgebildete kann ich nichts erkennen.

 

 

DPC Latency.jpg

Share this post


Link to post
nuts

Einen möglichen Flaschenhals in deinem System. ;) 

Sieht aber gut aus. Ist das während der Wiedergabe? 

Share this post


Link to post
marcello64

Ich habe keine Flaschenhälse, dass ist immer der Neid der anderen ;-))). Was bei mir fehlerfrei in der Wiedergabe läuft bekommst du nicht mal ansatzweise bei dir geladen/eingelesen. So - jetzt habe ich es dir gegeben :biggrin: . Ich habe natürlich während der Wiedergabe getestet und separat. 

 

Ich habe jetzt auch noch eine RTX 2080 Ti drin, die allerhand ausgleichen kann. Aber nicht alles.

 

Es mangelt an einer 64 Bit-Version des DVBViewers und sicher auch an dem hardwaretechnischen Equipment auf neuesten Stand. Ebenso an den Sat-Empfangsmöglichkeiten zum über den Tellerrand hinausschauen. Das 28.2E-Testmaterial in 8k kann ich mit allen möglichen Programmen relativ lastarm und absolut fehlerfrei mit teilweise nur 5 Prozent CPU-Last abspielen, nur eben mit dem DVBViewer nicht. Von einer Echtzeit-Simulation ganz zu schweigen.

 

Der Herr Hackbart möchte mir bitte noch einmal in einem separaten Thread erklären, warum es noch keine 64 bit-Version gibt bzw. wie lange man das noch verschlafen will. Ich kenne das Argument der 32bit-Plugins schon und das ist auch berechtigt, aber nicht mehr zeitgemäß. Man könnte bzw. sollte die 32bit-Version unbedingt weiter pflegen, aber auch eine 64bit-Version in Angriff nehmen und die parallel anbieten und sich natürlich separat bezahlen lassen. Unter 30 EUR dürfte der Preis nicht liegen. Meine Meinung.

 

gN8

 

 

 

Share this post


Link to post
SnoopyDog
Posted (edited)

Ich dachte immer, der DPC Latency Checker funktioniert ab Windows 8 nicht mehr korrekt (?)

 

https://www.thesycon.de/eng/latency_check.shtml

 

Zitat

Windows 8 Compatibility: The DPC latency utility runs on Windows 8 but does not show correct values. The output suggests that the Windows 8 kernel performs badly and introduces a constant latency of one millisecond, which is not the case in practice. .... Thesycon is working on a new version of the DPC latency utility and will make it available on this site as soon as it is finished.

aber eine neue Version gibt es wohl leider noch nicht.

 

Zitat

und bei der DD hohe Stückzahlen und ab der ersten Sekunde diesen vertikalen Matsch.

Ich besitze seit längerem eine Max S8 und habe ebenfalls den Eindruck, daß da manchmal erhöht Fehler auftreten gegenüber der Cine S2. Es kann aber viele Ursachen haben. Bei bestimmten Unicable-Kanälen scheint es häufiger aufzutreten. In der Log-Datei des Media Server steht dann immer "Signal loss". Vielleicht auch ein Amateur-Funker.

 

Mit einer nVidia 1030 und dem EVR Custom Renderer laufen die UHD Kanäle von ASTRA bei mir flüssig. Weil aber 4k Blu Rays mit HDR mit dieser Kombination nicht so ohne weiteres korrekt wiedergegeben werden (HDR läßt sich nur in den Windows 10 Optionen ein- und ausschalten), verwende ich madVR. Der ist in der Lage, korrekt zwischen HDR und nicht-HDR hin und her zu wechseln. Obwohl madVR auch ohne aufwendige Bildverbesserer eine deutlich höhere GPU- und CPU-Last verursacht, als der Custom EVR, laufen 4k Blu-Rays flüssig damit. Die SAT-Sender jedoch leider nicht alle, manche ruckeln hin und wieder.

Weiterhin behaupten die UHD-Sender auf ASTRA, daß teilweise in HDR gesendet würde und das Bild schaut auch manchmal leicht "grau" aus, aber nicht so extrem wie bei den Blu-Rays, wenn HDR nicht auf dem PC aktiv ist, aber benötigt wird. Gibt es da schon eine senderseite Kennung für HDR?

 

Edit: Meine Frage wurde hier beantwortet:

https://www.DVBViewer.tv/forum/topic/62492-madvr-hdr-umschaltung-bei-uhd-hdr-tv-sendern/

 

madVR unterstützt derzeit kein HLG.

Edited by SnoopyDog

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • nickneutrino
      By nickneutrino
      Always when  i play a transcodec 4K MKV H265 to WEBM stream from Dbviewer Media Web Server appear in the middle of screen a circle.
       
      Anybody knows Is posible remove that circle and for what reason show this circle because the movie plays well? 
    • backfix
      By backfix
      Hallo zusammen,
      ich bin seit mehreren Jahren sehr zufriedener DVBViewer-Benutzer und habe ein Problem, zu dem ich im Forum und auch über allgemeine Internetrecherche nicht fündig geworden bin. Es betrifft NUR den UHD-Sender TravelXP 4k.
      Das Bild ist einigermaßen flüssig, ab und zu Ruckler bzw. kurze "Verlangsamung", ähnlich einer Zeitlupe. Der Ton kommt nur sehr abgehackt, zeitweise gar nicht. Benutze die LAV-Filter neueste Version (0.70.2.88). Aber auch mit anderen Versionen keine Änderung. Wenn ich das Programm aufnehme und anschließend abspiele, funktioniert es perfekt, keine Ruckler, einwandfreier Ton. Hardware ist eine GTX 950 und ein i7-6700 mit 3,4 GHz. Andere 4K-Programme wie der UHD1 oder Testkanäle laufen damit einwandfrei ohne jegliche Störungen. Eine Idee vielleicht: Mir ist aufgefallen, dass von den UHD-Kanälen nur TravelXP 4k AAC-Ton verwendet, vielleicht liegt das Problem auch hier. Hardware-Beschleunigung usw. ist eingestellt, wie in einigen vergleichbaren Threads beschrieben und funktioniert auch prima, die CPU-Last ist immer sehr gering. Da ich seit Jahren HD+-Kunde bin und alle anderen Kanäle dieses Pakets funktionieren, habe ich auch dies als Fehlerquelle ausgeschlossen. Vielleicht hat noch jemand dieses/ein ähnliches Problem? Weiß leider nicht mehr, wo ich mit neuen Tests noch ansetzen soll.
    • dvbmitglied
      By dvbmitglied
      Guten Tag,
      wegen der besseren Auflösung habe ich meinen DVB-T2 Stick Opti-Combo als zusätzlichen Tuner mit dem DVBViewer Pro, der andere Tuner ist Sat, verwendet. Das Bild ist erwartungsgemäß sehr gut, nur beim Umschalten der Sender gibt es Klötzchen. Den Stick verwende ich sonst an einem andern Pc, der im Gegensatz zum aktuellen Pc eine Nvidiagrafikkarte besitzt, das ist im Wesentlichen der einzige Unterschied, und dort gibt es keine Klötzchen beim Umschalten. Gibt es eine Lösung gegen die Artefakte, oder ist das ein spezielles AMD Problem ? Ich arbeite noch möglichst lange mit Windows 7 64 bit.
      An dieser Stelle möchte ich mich für dieses großartige Programm bedanken, dass mich schon sehr lange begleitet und allen einen guten Rutsch und ein glückliches Neues Jahr wünschen.
       
      PS Ich denke über die Anschaffung eines neuen Tuners nach und würde mich über Erfahrungen mit dem TBS Usb-Multituner mit DBS-Sx-C-T2 freuen, falls vorhanden
    • Mirrr
      By Mirrr
      Woran kann ich in der generierten CSV Datei vom Sendersuchlauf erkennen, welche Sender SD, HD oder UHD sind?
       
      Bei Enigma Boxen wird dies z.B. mit dem Service Type (leider auch nicht immer ganz zuverlässig) angegeben
       
      Dank & Gruß
    • dominiks
      By dominiks
      Guten Tag zusammen,
       
      ich habe seit neustem etwas mit dem DVBViewer pro rumexperimetiert und komme nicht mehr weiter.
       
      Ich besitze einen i7 2600k 24GB Ram und eine GTX 960.
       
      Wenn ich den SES UHD Sender aufnehme und die .ts Datei abspiele läuft alles flüssig (CPU 20% da die GPU übernimmt mit DXVA2). Auch im DVBViewer ist alle flüssig bei der Testdatei.
       
       
      Folgendes Problem:
       
      Sobald ich den UHD Sender auswähle habe ich massig Buffer Overflows als Video Decoder nutze ich den LAV Video Decoder (Screenshots sind angehängt).
       
      Leider schaltet dieser nur bei der Datei wiedergabe (4k) in den DXVA2 Modus die GPU an.
      Anscheind stimmt etwas mit dem DVB Splitter nicht oder eine Einstellung wurde von mir übersehen.
       
      Kann ich den DVBViewer zwingen den LAV Splitter zu nutzen? wenn ja wie? Achja bei der Datei Wiedergabe ruckelt es sobald ich in den Optionen den Haken für DVB Filter nutzen für .ts setze -> hier vermute ich das Problem. Sobald ich den haken entferne läuft die Datei wieder flüssig und in der Taskleiste wird der LAV Splitter zusätzlich angezeigt.
       
      Hatte jemand das selbe Problem oder Ideen ???
      Hab schon verschiedene Optionen durchprobiert und wenn ich DasErsteHD schaue als TV Stream wird beim LAV Video Decoder auch die Hardware Acceleration aktiviert.... es wird immer merkwürdiger....
       
       
      Sollten Informationen fehlen stelle ich diese gerne bereit
       
      Mit freundlichen Grüßen
       
      Dominik
       
       
      Edit: Habe das hier auch gesehen aber scheit trotzdem nicht zu gehen: http://www.DVBViewer.tv/forum/topic/58473-hevc-h265-wiedergabe-mit-nvidia-gtx950-gtx960/







×
×
  • Create New...