Jump to content

DVBViewer Media Server "vergisst" Hardware


Thomas Prötzsch

Recommended Posts

Dass ich nach einem Rechnerneustart stets die Hardwareerkennung ("Geräte suchen") in DVBViewer Media Server neu starten muss ist zwar ärgerlich und kann bein einem automatischen Neustart schon mal zu unangenehmen Überraschungen führen, aber damit kann ich irgendwie klarkommen.

Nicht wirklich klarkommen kann ich aber damit dass gefühlt ohne Vorwarnung und mitten im laufenden Betrieb ein oder mehrere Tuner "vergessen" werden sodass nicht alles aufgenommen wird. Die Einträge erscheinen dann rot und ich muss die Geräte dann neu suchen und denen stets einen Unicable-Kanal zuweisen denn das hat der DVBViewer Media Server dann stets auch "vergessen".

Und man kann das auch nicht "on the fly" korrigieren, weil dann laufende Aufnahmen unterbrochen werden.

Wenn alle Stricke reißen: könnte ich mir ein externes Tool bauen welches das ausliest und ggfs wieder repariert? Gibt's auch für den Media Server ein API?
MfG
 

Edited by Thomas Prötzsch
Link to comment
vor 3 Minuten schrieb Thomas Prötzsch:

Die Einträge erscheinen dann rot und ich muss die Geräte dann neu suchen und denen stets einen Unicable-Kanal zuweisen denn das hat der DVBViewer Media Server dann stets auch "vergessen".

 

Der Media Server reagiert hierbei auf Windows-Botschaften, dass die Geräte aus der Systemkonfiguration entfernt wurden. Sowas ist z.B. von USB-Geräten mit Wackelkontakt bekannt. Entsprechende Meldungen müssten sich im svcdebug.log finden (siehe Konfigurationsverzeichnis).

 

Ungewöhnlich ist jedoch, dass die Geräte danach neu gesucht werden müssen. Das ist normalerweise nur notwendig, wenn sich die Hardware ID geändert hat - mitunter passiert das nach Installation einer neuen Treiberversion. In dem Fall kann der Media Server die alten Einstellungen nicht übertragen, weil es sich aus seiner Sicht um neue Geräte handelt. Wenn Windows einfach nur den Kontakt zum Gerät verliert und später wiederfindet, werden die Einträge in der Geräteliste wieder schwarz, und alle Einstellungen bleiben erhalten.

 

Jedenfalls handelt es sich nicht um ein bekanntes Problem des Media Servers. Irgendwie scheint bei dir der Wurm drin zu sein. Eventuell lässt sich mehr dazu sagen, wenn du hier eine support.zip anhängst.

 

Link to comment

Du schreibst leider nicht, um welche Hardware es sich handelt.

 

Ich hatte ein ähnliches Problem mit meiner PCIe DVB-C Karte (Digital Devices Cine C2/T2). Sporadisch verschwanden beim PC-Start die Tuner im Media Server und meist sogar im Windows Gerätemanager. Nach Rücksprache mit dem Hersteller-Support stellte sich heraus, dass mein Mainboard-UEFI (MSI Z370 Gaming Carbon Pro) anscheinend in der Standardkonfiguration der PCIe-Slots die Wartezeit für die Kartenerkennung nicht einhält (Karte brauch etwas zur Initialisierung). Die Zeit war offenbar immer so hart an der Grenze und deshalb wurde sie von Windows beim Kaltstart manchmal einfach nicht erkannt. Lt. Support scheint das ein häufiges Problem von Gaming-Boards zu sein (evtl. um die Bootzeit zu schönen?).

 

Geholfen hat schliesslich, im UEFI für den PCIe-Slot mit der Karte das PCIe-Protocol 1 oder 2 vorzuschreiben. Damit werden offenbar nun die korrekten Wartezeiten eingehalten, seitdem ist die Karte nie wieder "verschwunden".

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...