Jump to content
sir drake

DMS Timer active/inactive | API in Seite Timer

Recommended Posts

sir drake

Hallo Griga,
nach dem Update auf 2.1.3.0 beim active/inactiv setzen eines vorhandenen Timers mittels MausClick auf den grünen/grauen Bubble links am Rand in der Seite "TIMER" 
kommt es zu einem Fehlverhalten.
Als Antwort bekomme ich die TimerSeite mit einem TimerFrame ohne Inhalt zurück.
Nur das Template denke ich ist die antwort.
siehe bitte die 2 grafiken im Anhang.

 

Die Aktion als solche wird ausgeführt.
Damit meine ich das active/inactive setzen des Timers.
 

Problem kommt vor in 
CHROME
FIREFOX
EDGE

vg & Dank fürs kümmern


2019_01_19_12_09_15_DVBViewer_Media_Server_2.1.3.0_MEDIA_PC_.png.52ab39530d37c7d4b432d2cfeae801cb.png

2019_01_19_12_08_24_DVBViewer_Media_Server_2.1.3.0_MEDIA_PC_.png.5c43d99be058028c744d4b2fd31e4141.png

Edited by sir drake

Share this post


Link to post
Griga

Kann ich hier nicht auf Anhieb nachvollziehen. Sonst jemand?

Share this post


Link to post
HaraldL

Nein, hier auch alles wie gewohnt. Hab wegen vieler Autotimer 4 Bildschirmseiten Timer im Webinterface und kann da de-/aktivieren wie ich will, funktioniert wie vorher.

Share this post


Link to post
Griga

Auf einem anderen PC mit einem frisch installierten DMS unter Windows 10 809 funktioniert es hier auch. Vermutlich spielen bei @sir drake Bedingungen mit, die bei uns nicht gegeben sind. Deutlich wird, dass der DMS bei ihm das HTM Template sendet, ohne die Platzhalter zu ersetzen. Eine mögliche Ursache könnte ein Ausnahmefehler sein,  bei dem der DMS aus der Kurve fliegt. Er sollte im svcdebug.log sichtbar sein.

 

Share this post


Link to post
sir drake

svcdebug.log

OK,
hier das LogFile.

Nachdem ich den Service gestoppt, mit AdminRechten in die Konfig rein bin, mit OK wieder raus ohne was zu ändern,

hat sich das verhalten "gebessert".  Ich finde immer noch einzelne Timer, bei dem der Fehler auftritt.
Viele andere Timer hingegen akzeptiert die Funktion klaglos.

Im Fehlerfall wird der Fehler NICHT protokolliert im LOG.


Ich lasse die ganze Konfig noch so für den Fall, das du was testen möchtest.

Falls nicht werde ich die nächsten Tage einmal komplett neu aufsetzen.

das die DB wieder hin habe ich nebenbei auch bemerkt.

aber das ist ein anderes Thema.

 

Mein System:   WIN10 / 1809
Rest wie unten beschrieben

 

vg

Share this post


Link to post
Griga
vor 52 Minuten schrieb sir drake:

Im Fehlerfall wird der Fehler NICHT protokolliert im LOG.

 

Zumindest ist heute bei dir schon allerhand schiefgegangen. Die beiden folgenden Meldungen traten serienweise auf:

 

19.01.19 15:20:35.341 TServiceMain         Exception:       Zugriffsverletzung bei Adresse 0062A855 in Modul 'DVBVservice.exe'. Lesen von Adresse 00000000

 

19.01.19 15:23:25.687 TVCR                 Invalid timer:   Die Simpsons - L.S. - Meisterin des Doppellebens - Little Girl in the Big Ten

 

Dem werde ich im Code mal nachgehen...

 

vor 50 Minuten schrieb sir drake:

Ich finde immer noch einzelne Timer, bei dem der Fehler auftritt.
Viele andere Timer hingegen akzeptiert die Funktion klaglos.

 

Was unterscheidet die Timer? Das scheint mir die entscheidende Frage zu sein. Ich würde mal einen Blick in die svctimers.xml werfen.

 

Share this post


Link to post
sir drake

Hallo Griga,

Ein Blick in die svctimers.xml zeigt mir, das es sich nicht um Aufnahmen in der Zukunft handelte ( Inavlid Timer: aus svcdebug.log) 
sondern um bereits abgelaufene. Die Aufnahmen selbst sind getätigt worden.
Kann es sich bei der Stelle im Source um einen CleanJob handeln, der aufräumt ?
 

So sieht zum Test ein Timer aktuell bei mir aus, wenn ich ihn aus der svctimers.xml heraus kopiere.
 

    <Timer Type="1" ID="{3AAE35EA-4FF8-43B0-9D7D-E73291B84858}" Enabled="-1" Priority="50" Date="20.01.2019" Start="20:10:00" Dur="225" PreEPG="5" PostEPG="30" IntID="804" Action="0" EPGEventID="5275">
      <Descr>Promi Shopping Queen - Motto in Potsdam, Berlin und Köln: Klassiker neu interpretiert: Zeige, wie stylisch ein Kostüm oder Anzug sein kann!</Descr>
      <Options AdjustPAT="-1" AllAudio="-1"/>
      <Format>1</Format>
      <Folder>Auto</Folder>
      <NameScheme>%year-%date_%time_%station_%name</NameScheme>
      <Series>Promi Shopping Queen</Series>
      <Source>API</Source>
      <Channel ID="2359890883044192028|VOX" EPGID="577023706623192860"/>
    </Timer>
  </Timers>

 

 

Sowohl vor als auch nach dem Update habe ich meine Art und Weise wie ich timer erzeuge nicht geändert.
Mittels API von TVBrowser -> WEB-LISTENER -> API call into DMS

Ich sehe das Problem auch nicht mehr, seit ich die DMS-Konfig mit Admin-Rechten geöffnet und ohne Änderungen mit OK verlassen habe.

Die DB habe ich wie gehabt gelöscht und lasse Sie Neu einlesen.

Ich belasse das System weiterhin in dem Zustand.
Noch sehe ich keine Notwendigkeit alles Neu aufzusetzen.

 

vg

Share this post


Link to post
Griga

Ich habe inzwischen eine Ahnung, was da schiefgelaufen sein könnte, muss es aber noch reproduzieren.

 

Share this post


Link to post
Griga

Ist hier reproduzierbar. Das Problem wird durch einen Bug verursacht, der zuschlägt, wenn die folgenden Bedingungen alle zutreffen, soweit ich zur Zeit sehen kann:

  • Es gibt mindestens einen Timer für DVB-C/T/S.
  • Es gibt mindestens einen weiteren Timer für die Empfangsart TS Stream.
  • Der Tweak "TS Stream-Geräte bei Bedarf automatisch erzeugen" ist eingeschaltet (Standard).

Unter diesen Voraussetzungen erfolgen Zugriffe auf undefinierte (zufällige) Speicherinhalte, wobei neben Zugriffsverletzungen alles mögliche passieren kann. Der DVBViewer ist auch betroffen (eventuell hier).

 

Sieht so aus, als sollten wir ein Bugfix Release in Betracht ziehen.

 

Share this post


Link to post
sir drake

Hallo Griga,
bei mir stellen sich leider noch mehr Fehler ein.
Ich gehe davon aus, das es sich um Folgefehler auf Grund der Exception's handelt.

EPG-Update lief gestern nicht an ( erst nach Restart )
8 laufende Aufnahmen ( im SVC-tray nur 1 angezeigt ( Hoover )  ) 
Aufnahmen brechen grundlos ab
Exception ohne Ende im Log etc...

Für wann genau planst du das BugFix-Release ? 
Ich würde sonst einen Rollback ins Auge fassen müssen.

vg & Dank

Share this post


Link to post
Griga

Siehe PM.

Share this post


Link to post
sir drake

Vielen dank  ! 

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...