Jump to content
hse

DVBViewer is stretching 16:9 channels.

Recommended Posts

hse
Posted (edited)

Hello, I have a channel that is 16:9, DVBViewer detects it as 16:9, but it stretches the image

if I record the channel and open it with a media player it is displayed correctly and not stretched.

It worked fine last week. Any ideas how to fix?

 

https://i.imgur.com/oeGLb7H.jpg

support.zip

 

EDIT: here is a comparison with another channel working

http://screenshotcomparison.com/comparison/133467

Edited by Griga
topic title corrected

Share this post


Link to post
Griga

Looks like the channel specifies a non-standard aspect ratio in the video headers. Please post a screenshot that shows what the DVBViewer Filter property page displays when this channel is played.

 

 

Share this post


Link to post
Griga
Posted (edited)

The aspect ratio read from the headers is 544:297 = 1.83, which is outside the DVBViewer "catch range" for 16:9 = 1.78. That's why no 16:9 icon is displayed in the status bar.

 

However, DVBViewer scales the picture correctly according to the information in the video headers, which means, what you see is actually 544:297. For me it looks like a 4:3 picture wrongly squeezed to "near 16:9". IMO the broadcaster sends wrong headers. You can force a 4:3 aspect ratio in the Settings -> Aspect Ratio sub-menu. But that is no convenient solution, because you have to return to Aspect Ratio = Auto for other channels ;)

 

P.S. You can try to tick "Keep track of H.264 Aspect Ratio" on the property page. It will let DVBViewer recognize aspect ratio changes.

 

Edited by Griga

Share this post


Link to post
hse

Hey again Griga.

Setting aspect ratio to 4:3 then applying a custom zoom does indeed fix the issue.

 

https://i.imgur.com/m2kW7mf.jpg

 

But like you said it has to by enabled and disabled each time I view one of these channels as it's a global setting that effects everything else :(

Could a feature be added in future updates to make aspect ratio and zoom settings, setable on a per channel basis instead of only on a global basis?

 

Thanks again for your help.

 

-hse

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...