Jump to content
Holy Work Bomb

EAccessViolation beim ersten Start nach dem Hochfahren

Recommended Posts

Holy Work Bomb

Seit letzten Herbst plagt mich ein Zugriffsfehler beim Starten von DVBViewer.

TApplication   EAccessViolation at 007807C3: Access violation at address 007807C3 in module 'DVBViewer.exe'. Read of address 00000010

Der Fehler tritt nur nach dem Hochfahren von Windows auf - nicht jeden Tag, aber so gut wie, siehe Log. Ergebnis: DVBViewer startet nur bis "Initialisiere OSD-Skin" und der Task verschwindet. Beim nächsten Start sind die Ansicht-Einstellungen weg.

 

Seit dem Update auf 6.1.4 habe ich nichts am Programm oder den Codecs verändert. Manchmal läuft es sogar zwei Wochen am Stück ohne Probleme. Ende Januar habe ich den Skin und die Codecs aktualisiert, brachte aber alles nichts.

support.zip

Share this post


Link to post
Griga
vor 11 Stunden schrieb Holy Work Bomb:

Ende Januar habe ich den Skin (...) aktualisiert,

 

Welchen?

 

vor 11 Stunden schrieb Holy Work Bomb:

Der Fehler tritt nur nach dem Hochfahren von Windows auf

 

Startest du den DVBViewer kurz nach dem Hochfahren? Oder passiert das auch nach längerer Wartezeit?

 

Da geht etwas bei der Initialisiierung des OSD schief, und das zieht die Zugriffsverletzungen nach sich. Mehr könnte man vielleicht im DVBViewer.log sehen, wenn das Problem im Debug-Modus reproduziert würde - siehe hier.

 

Share this post


Link to post
Holy Work Bomb
Am 27.4.2019 um 06:43 schrieb Griga:

 

Welchen?

 

Moin,

 

der Skin ist aktuell BluFuzz. Passiert aber auch beim Default-Skin.

 

Am 27.4.2019 um 06:43 schrieb Griga:

 

Startest du den DVBViewer kurz nach dem Hochfahren? Oder passiert das auch nach längerer Wartezeit?

 

Ich kann DVBViewer sofort starten oder einen halben Tag später, macht keinen Unterschied.

 

Am 27.4.2019 um 06:43 schrieb Griga:

Da geht etwas bei der Initialisiierung des OSD schief, und das zieht die Zugriffsverletzungen nach sich. Mehr könnte man vielleicht im DVBViewer.log sehen, wenn das Problem im Debug-Modus reproduziert würde - siehe hier.

 


Den Debug-Modus hab ich glatt übersehen. Aber ich starte den jetzt jedesmal, bisher aber kein Fehler ... typisch

Share this post


Link to post
Griga

Im Debug-Modus startet der DVBViewer ohne Plugins. Könnte das eine Rolle spielen?

 

Share this post


Link to post
Holy Work Bomb

Hallo

 

Im Debug-Modus tritt der Fehler nicht auf. Ich hatte die Tage mal DVBViewer im Debug-Modus beendet und gleich normal gestartet, der Fehler trat sofort wieder auf. Also könnte es wirklich mit Sachen zu tun haben die im Debug-Modus nicht geladen werden. Ich habe den plugins-Ordner geleert, bis auf univeral.dll wegen der Fernbedienung, und werde nacheinander die Sachen wieder reinpacken. Wird sicher langwierig, da der Fehler durch einfaches Herunterfahren und wieder Hochfahren des Rechners nicht wirklich reproduziert werden kann.

Share this post


Link to post
Griga

Da hilft die binäre Suche. Erst die Hälfte der Plugins hinzufügen. Wenn der Fehler damit auftritt, befindet sich der Übeltäter in dieser Hälfte. Ansonsten in der anderen. Danach halbierst du die "böse" Hälfte erneut, usw. So geht es am schnellsten.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...