Jump to content
tucb

Stream kann im Webinterface nicht abgespielt werden

Recommended Posts

tucb

Hallo zusammen,

 

wenn ich über das Webinterface einen Stream aufrufe zum Abspielen kommt folgender Fehler (siehe Anhang).

 

404 Not Found

The requested URL /streamint.html was not found on this server.

 

 

 

Alle anderen Seiten des Webinterfaces funktionieren. Auf dem Server selber ist der Aufruf problemlos möglich, nur von einem Client PC leider nicht. Testweise habe ich mal die komplette Firewall auf dem Server deaktiviert, leider ohne Erfolg.

 

Gibt es dafür einen Workaround? Das Supporttool hängt sich leider auf und daher kann ich keine support.zip erstellen.

 

Mfg

tucb

 

 

 

 

screen.png

Edited by tucb
typo

Share this post


Link to post
Griga

Du könntest zumindest die Datei svcdebug.log aus dem Konfigurationsordner zippen und hier anhängen.

 

Share this post


Link to post
Griga

Du hast nur ein virtuelles TS Stream Device in der Geräteliste des Servers? Das ist für Internet TV/Radio geeignet, die aber kaum einen EPG hergeben, es sei denn, du importierst ihn aus anderen Quellen. Wie passt das zusammen?

 

Share this post


Link to post
tucb
14 hours ago, Griga said:

Du hast nur ein virtuelles TS Stream Device in der Geräteliste des Servers? Das ist für Internet TV/Radio geeignet, die aber kaum einen EPG hergeben, es sei denn, du importierst ihn aus anderen Quellen. Wie passt das zusammen?

 

 

Das ist richtig, ich habe eine Vu+ als TS Stream Device eingebunden. Das EPG funktioniert auch wunderbar. Auf dem Server selbst mit "localhost:8089" habe ich keine Probleme.

Share this post


Link to post
Griga

Soweit klar.

 

Ich habe nachgeforscht, wie dieser Fehler entstehen kann, bin aber zu keinem Ergebnis gekommen. Tatsache ist jedenfalls, dass eine Verbindung zwischen Client und Server zustande kommt. Der Browser startet eine Request, und der Server antwortet "Geht nicht, gibt's nicht". Ein netzwerktechnisches oder Firewall-Problem, dass die Verbindung verhindert, würde sich anders äußern. Der Browser würde dann melden, dass er keine Verbindung herstellen kann.

 

Im svcdebug.log ist keine fehlgeschlagene Anfrage zu sehen. Es gibt natürlich Gründe, die den Server veranlassen, "404 Not Found" zu antworten, z.B. weil die Datei streamint.html im SVCweb-Ordner fehlt oder der angeforderte Sender nicht in der Senderliste auffindbar ist. Aber dann würde der Zugriff lokal auf dem Server PC auch scheitern.

 

Bestand das Problem schon immer, oder ging es bereits mal und dann plötzlich nicht mehr?

 

Share this post


Link to post
BirdOfPrey

Hallo!

Auf dem Mac habe ich das gleiche Problem. Probiert mit Safari und Edge. Unter Windows 10 mit Edge funktioniert es.

 

Gruß

Share this post


Link to post
tucb
On 5/21/2020 at 10:48 PM, Griga said:

Soweit klar.

 

Ich habe nachgeforscht, wie dieser Fehler entstehen kann, bin aber zu keinem Ergebnis gekommen. Tatsache ist jedenfalls, dass eine Verbindung zwischen Client und Server zustande kommt. Der Browser startet eine Request, und der Server antwortet "Geht nicht, gibt's nicht". Ein netzwerktechnisches oder Firewall-Problem, dass die Verbindung verhindert, würde sich anders äußern. Der Browser würde dann melden, dass er keine Verbindung herstellen kann.

 

Im svcdebug.log ist keine fehlgeschlagene Anfrage zu sehen. Es gibt natürlich Gründe, die den Server veranlassen, "404 Not Found" zu antworten, z.B. weil die Datei streamint.html im SVCweb-Ordner fehlt oder der angeforderte Sender nicht in der Senderliste auffindbar ist. Aber dann würde der Zugriff lokal auf dem Server PC auch scheitern.

 

Bestand das Problem schon immer, oder ging es bereits mal und dann plötzlich nicht mehr?

 


Ich habe einen Windows Server 2016 komplett neu aufgesetzt, seit dem besteht das Problem. In einer früheren Version von DSM 2.0 unter Windows Server 2012 hatte ich das Problem nicht.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...