Jump to content

DVBViewer Pro reagiert manchmal nicht mehr


Webturtle

Recommended Posts

Hallo, 

 

der DVBViewer Pro 6.1.7.2 reagiert an meinem W10 64-Bit Notebook manchmal nicht mehr.

 

Gestern waren die Fenster des DVBViewers (DVBViewer, Senderliste, Aufnahme- und Gerätestatistik) zuerst geghosted :iiam: und in der Titelleiste stand sinngemäß "Der DVBViewer reagiert nicht mehr". Ich mußte ihn mit dem Taskmanager abbrechen und neu starten.

 

Später trat das Problem noch ein zweites Mal auf. In der Mitte des Displays wurde ein kleines Fenster mit der Meldung "Der DVBViewer funkitoniert nicht mehr" (oder so ähnlich) und einem grünen Fortschrittsbalken angezeigt. Ich mußte den DVBViewer ebenfalls mit dem Taskmanager gewaltsam beenden.

 

Bei derartigen Störungen werden begonnene Aufnahmen in der Regel weiterhin aufgenommen. Die werden aber nicht mehr automatisch beendet und neue anstehende Aufnahmen werden nicht mehr begonnen. 

 

Woran könnte diese Fehlfunktion liegen und was könnte ich dagegen tun?

 

support.zip

 

 

Viele Größe

 

Webturtle

Link to post
15 hours ago, Webturtle said:

Woran könnte diese Fehlfunktion liegen und was könnte ich dagegen tun?

 

Bei welchen Abläufen bzw. unter welchen Bedingungen treten sie auf?

 

Wieso sind deine DVBSky S960-Boxen in der hardware.xml mit Vendor = 13 fälschlich als TBS-Geräte klassifiziert? Da muss jemand auf untaugliche Weise dran herumgebastelt haben...

 

  • Like 1
Link to post

Darf ich mich anschließen, neuer Laptop mit Intel Tigerlake CPU/Chipsatz

W10 Build: 20H2  19042.662

Bei der Wiedergabe einer aufgenommenen Nachrichtensendung vom Recording Medie Server >>

mit Doppelclick auf Vollbild, Bildschirm friert ein, Vollbild aber ohne Fehler,

Viewer kann aber anstandslos ohne irgendwelche Meldung geschlossen werden,

anbei support zip.

Sonnengrüße

support.zip

Link to post

Hallo,

 

manchmal tritt die Störung einfach so während des Betriebes (Aufnahme und Anzeige eines anderen Programmes im DVBViewer-Fenster) auf. Ich merke es dann in der Regel,wenn der DVBViewer sich nicht mehr bedienen läßt oder blasser als normal aussieht (geghostet :iiam:). Das Bild läuft meist weiter als wäre nichts passiert. Es kann aber auch einfrieren.

 

Meistens habe ich den Rechner so aufgefunden, während er ein AutoHotkey-Script abgearbeitet hat. Dieses tunt die in einer Liste vorgegebenen Sender und speichert nach einiger Zeit automatisch den Videotext als HTML-Seiten. Die Videotext-Seiten des noch angezeigten Senders sind wohl schon gespeichert aber noch kein neuer Sender eingeschaltet worden. Im Hintergrund kann ein anderer Sender (DVB-S oder DVB-T2 HD) während dessen aufgenommen worden sein (zweiter DVBS/S2 Receiver bzw. DVB-T2 HD Stick). Die Aufnahme ist natürlich auch von der Störung betroffen, läuft aber zumeist weiter. Wenn es keine Wiederholung gibt, kann ich versuchen auf dem Standalone Receiver für den TV die Sendung solange zur Überbrückung aufzunehmen bis der DVBViewer oder im ungünstigsten Fall der Rechner wieder neu gestartet ist.

 

Manchmal läßt sich der DVBViewer Pro (wie auch der DVBViewer GE) nicht durch den Taskmanager beenden. Wenn sich daran auch nichts durch Herausziehen des USB-Steckers des Empfängers ändern läßt, ist ein Reset des Notebooks erforderlich (wenn nicht Windows durch diese Aktion abstürzt).

 

Also an den Vendor-Nummern hat niemand herumgebastelt. Die sind automatisch so vergeben worden. Dies müßte ja wohl bei der Hardwaresuche passiert sein. Welche Wert müßten denn in der hardware.xml stehen? Ich kann sie ja mal händisch korrigieren.

 

Ich habe gerade mal in der Harware.xml meines neuen Notebooks, an dem ich das hier poste, nachgesehen. Dort habe ich zwei DVBS/S2 Empfänger mit der Vendor-Nummer 0 und einen mit der Nummer 3 gefunden. Die 2 DVBSky S960-Boxen, anscheinend die Nummer 0,  habe ich damit einmal ausprobiert, um einem Forums-User mitteilen zu können, ob sie mit dieser Windows-Version laufen. Ansonsten habe ich daran ab und zu eine TechnoTrend S2-3600 DVB-S2 USB Box laufen. Das könnte die Nummer 3 sein. Auch dort habe ich nichts an den Vendor- Nummern herumgebastelt

 

 

 

Viele Grüße

 

Webturle

Edited by Webturtle
Link to post
2 hours ago, Webturtle said:

Also an den Vendor-Nummern hat niemand herumgebastelt. Die sind automatisch so vergeben worden.

 

Kaum vorstellbar. Der Eintrag in der Hardware-Datenbank für USB\VID_0572&PID_6831 (Vendor ID & Product ID) ist eindeutig DVBSky S860. Lösche die beiden Geräte aus der Hardwareliste, führe danach "Geräte suchen" aus und überprüfe, was sich daraus nach Schließen des DVBViewers in der hardware.xml ergibt. Die Vendor-Nummer sollte 32 sein. Ich habe schon seit Jahren die DVBSky S960 bzw. S960C in Betrieb, die in die selbe Kategorie fallen. Hätte der DVBViewer sie bei der Erkennung auf TBS umgebogen, wäre das nicht unbemerkt geblieben.

 

Link to post

Hallo aus Österreich,

Leider tritt dieser Effekt immer öfter auch beim Start des Viewers auf.

Dann reagiert das Programm auf keine Eingabe mehr, paradoxerweise läßt

sich das Programm ohne die übliche Fehlermeldung schließen.

Ranking meiner Fehlerquellen Vermutungen >>

neuere Intel Chipsätze mit integrierter Grafik

W10 letzte updates

Bei meinen Desktop PC's mit dez. Grafikkarte ist mir dieser Effekt noch nie untergekommen.

 

Studio2.PNG

support.zip

Link to post
31 minutes ago, intell said:

Vermutungen >> neuere Intel Chipsätze mit integrierter Grafik

 

Dann würde ich das mal mit einem anderen Video Renderer testen, insbesondere dem Standard EVR (mit dem allerdings das DVBViewer-OSD weniger ansehnlich ist), oder MadVR.

 

Link to post

Hallo Griga,

 

ich habe das von Dir vorgeschlagene Verfahren durchlaufen. Danach stand wieder 13 als Vendor- Nummer in der Hardware.xml:

 

Spoiler

  <section name="@device:pnp:\\?\usb#vid_0572&amp;pid_6831#20120511#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{f31bcf3b-9623-4937-8228-bd895ba00b21}">
    <entry name="HasCI">1</entry>
    <entry name="SharedLNB">1</entry>
    <entry name="UseHardwareFilter">1</entry>
    <entry name="DVBS2">1</entry>
    <entry name="NoStandard">1</entry>
    <entry name="Name">Professional DVB Digital TV DVB-S2 (1)</entry>
    <entry name="TunerType">1</entry>
    <entry name="Status">1</entry>
    <entry name="InstID">Professional DVB Digital TV DVB-S2 0</entry>
    <entry name="DeviceNr">1</entry>
    <entry name="Vendor">13</entry>
    <entry name="Priority">2</entry>
    <entry name="Tag">0</entry>
    <entry name="DeviceType">1</entry>
    <entry name="Groups">255</entry>
    <entry name="Retune">0</entry>
    <entry name="SkipComponents">0</entry>
    <entry name="DiSEqCCount">1</entry>
    <entry name="Slot">0</entry>
    <entry name="SlotFrequency">0</entry>
    <entry name="UnicablePIN">0</entry>
  </section>
  <section name="@device:pnp:\\?\usb#vid_0572&amp;pid_6831#6&amp;352025c5&amp;0&amp;4#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{f31bcf3b-9623-4937-8228-bd895ba00b22}">
    <entry name="HasCI">1</entry>
    <entry name="SharedLNB">1</entry>
    <entry name="UseHardwareFilter">1</entry>
    <entry name="DVBS2">1</entry>
    <entry name="NoStandard">1</entry>
    <entry name="Name">Professional DVB Digital TV DVB-S2 (5)</entry>
    <entry name="TunerType">1</entry>
    <entry name="Status">1</entry>
    <entry name="InstID">Professional DVB Digital TV DVB-S2 4</entry>
    <entry name="DeviceNr">5</entry>
    <entry name="Vendor">13</entry>
    <entry name="Priority">2</entry>
    <entry name="Tag">0</entry>
    <entry name="DeviceType">1</entry>
    <entry name="Groups">255</entry>
    <entry name="Retune">0</entry>
    <entry name="SkipComponents">0</entry>
    <entry name="DiSEqCCount">1</entry>
    <entry name="Slot">0</entry>
    <entry name="SlotFrequency">0</entry>
    <entry name="UnicablePIN">0</entry>
  </section>
 

 

Danach habe ich mal händisch statt der "13" "32" als Vendor-Nummer eingertragen und den DVBViewer neu gestartet.  Damit lief er wieder mit beiden Empfängern. Aber mit dem Problem scheint die Vendor-Nummer nichts zu tun zu haben. Denn heute hat der DVBViewer wieder mal nicht reagiert, obwohl immer noch 32 als Vendor-Nummer in der Hardware.xml steht.

 

 

Viele Grüße

 

Webturtle

 

Edited by Webturtle
Link to post

Da der Fehler nur bei meinen 2 Laptops mit Intel Wlan auftritt, keimt Hoffnung mit neuem Treiber auf >>

  • Beim Abspielen von Online-Videos kann es zu zufälligen Verbindungsabbrüchen kommen.
  • Windows Stop-Fehler (BSOD) können auftreten, die mit dem Intel Wireless-Treiber zusammenhängen.
  • Falscher RCPI 802.11K-Baken-Messbericht.
  • Gelbes Ausrufezeichen im Gerätemanager, welcher mit dem Intel Wireless-Adapter verbunden ist.
  • Intel PROSet/Wireless Software 22.10.0 wurde aktualisiert, um Funktions- und Sicherheitsaspekte zu berücksichtigen. Benutzer sollten auf die neueste Version aktualisieren.
Link to post
18 hours ago, Webturtle said:

ich habe das von Dir vorgeschlagene Verfahren durchlaufen. Danach stand wieder 13 als Vendor- Nummer in der Hardware.xml:

 

Das kann ich mir weder erklären noch nachvollziehen. Ich habe probeweise im DVBViewer Pro direkt an der Quelle (d.h. bei der Abfrage der Geräte von Windows) dafür gesorgt, dass meine DVBSky S960C die Gerätekennung deiner Box erhält (also USB\VID_0572&PID_6831 statt richtig USB\VID_0572&PID_960C). Dementsprechend wurde sie erkannt, aber wie erwartet mit Vendor = 32, nicht mit 13 wie bei dir.

 

Probiere noch mal, deine hardware.xml bei geschlossenem DVBViewer woanders hin zu verschieben. Dann starte den DVBViewer, worauf er die hardware.xml neu erzeugt. Steht immer noch Vendor = 13 drin? Wie verhält es sich bei TransEdit (siehe TransEdit.ini, Sektion [Hardware]) oder dem DVBViewer GE (Setup.ini)?

 

Woraus die Hänger beim DVBViewer resultieren, ist deinem DVBViewer.log leider nicht zu entnehmen. Es bricht zwar ohne reguläres Ende ab, aber sonst gibt es keine Hinweise. Allenfalls fällt die Meldung "MHEG5Host_CREATE Engine failed to load!" auf, die mit dem HbbTV/MHEG Add-On zusammenhängt. Läge es daran, wäre jedoch der DVBViewer GE nicht betroffen.

 

Ich nehme an, es gibt irgendein Problem in deinem System, über das der DVBViewer stolpert. Man könnte versuchen, es durch systematischen Probieren einzugrenzen, also mal den DVBViewer nur mit TV laufen lassen, mal nur mit Dateiwiedergabe, mal mit Video, mal nur Audio (Radiosender oder MP3-Dateien) und anderen Variationen... oder Sachen deaktivieren, die nicht zwingend für den Betrieb des DVBViewers notwendig sind, insbesondere Plugins, Add-Ons... und dann schauen, ob sich etwas ändert. Mehr fällt mir dazu im Moment nicht ein.

 

Link to post

Hallo Griga,

 

hier zunächst nur soviel: Betroffen ist der DVBViewer Pro. Am GE verwende ich nur zwei Astrometa DVB-T2 HD Sticks von denen einer an unserer alten Dachantenne hängt, um BR-Alpha (ARD-Alpha), Bayern  Fernsehen - Der Süden und MDR zu empfangen. Die DVB-S/S2 Emfänger werden zwar gefunden aber nicht verwendet. Und das

 HbbTV/MHEG Add-On habe ich zwar erworben, aber meines Wissen nicht verwendet

 

Deinen Tips werde ich sobald wie möglich nachgehen.

 

 

Viele Grüße

 

Webturtle

 

Link to post

Hallo Girga,

 

mit dem Pro habe ich es noch einmal so gemacht wie Du es wolltest, allerdings habe ich die alten Hardware.xml und Hardware.bak nicht gelöcht, sondern gezippt.

Danach stand wieder 13 als Vendor-Nummer drin. Bei Transedit habe ich die Transedit.ini in Transedit [1].ini umbenannt. Nach dem nächsten Start stand .0=13 und .4=13 und für .1 - .3.=0 für die Astrometas. Den GE werde ich auch noch testen.

 

Als ich den DVBViewer Pro nach dem Zippen der Hardware.ini neu gestartet habe, waren allle Empfänger auf Anhieb wieder da. Ich mußte nur bei den DVB-S2 Empfänger "Benutzt selben LNB" wieder anklicken und beim Astrometa, der unserer alten Hausantenne und dem GE zugeordent ist, nicht benutzen aktivieren. Woher nimmt der DVBViewer eigentlich die Vendor-Nummern? Kann es sein, daß auf dem Rechner trotz der Installation der aktuelle Version noch eine alte Datei herumgeistert?

 

Nun noch zum HbbTV/MHEG Add-On:  Ich habe es zwar mal ausprobiert, verwende es aber nicht, da der Rechner meist nicht mit dem Web verbunden ist. Unter Plugins im Menu wird es nicht angezeigt, aber in Info-Fenster. Wie deinstalliert man es richtigj?

 

Viele Grüße

 

Webturtle 

 

Link to post
3 hours ago, Webturtle said:

Kann es sein, daß auf dem Rechner trotz der Installation der aktuelle Version noch eine alte Datei herumgeistert?

 

Das bringt mich auf eine Idee. Schaue nach, ob im DVBViewer-Programmverzeichnis oder in C:\Program Files (x86)\Common Files\DVBViewer Shared\ eine uralte Datei BDADevices.dat herumgeistert. Falls ja, bestelle die Ghostbusters...

 

Link to post

Hallo Griga,

 

zunächst mal zur Vendor Nummer: Der GE hat in seiner Ini-Datei die Nummer 32 gespeichert. Der Pro und Transedit dagegen die 13. Ich werde mal den Computer-Dungeon durchsuchen.

 

Noch mal zum HbbTV/MHEG Add-On welchen Namen hat die Datei und wie deinstalliert man die richtig?

 

 

Viele Grüße

 

Webturtle

 

Link to post
51 minutes ago, Webturtle said:

wie deinstalliert man die richtig?

 

Wie üblich. Systemsteuerung -> Programme -> Programme deinstallieren (zumindest unter Windows 8.1). Man kann das Add-On aber auch über Tweaker.exe deaktivieren (Haken bei HbbTV deaktivieren und MHEG-5 deaktivieren).

 

Link to post

Hallo Griga,

 

ich werde mal sehen, ob es wirklich noch installiert und es nach Deiner Anleitung deinstallieren.

 

Also ich habe die Ghostbusters engagiert. Im gemeinsamen Abstellraum (Common Files) haben sie nicht gefunden, aber im Wohnzimmer des DVBViewers (sprich Programmverzeichnis) einen Lauerer (BDADevices.dat  von 2011). Sie haben ihn in eine der von ihnen entwickelten Sicherheitsboxen gepackt. Nach dem Verschiebe der Hardware.xml in die Ablage und Neustart des DVBViewers steht jetzt auch in der Hardware.xml des Pro eine 32 als Vendor Nummer.

 

Dazu erst mal vielen Dank Griga.

 

Ob es bei meinem Problem hilft oder ob noch irgendwo ein Poltergeist lauert, werde ich mal beobachten. Damit sich so ein Biest nicht im Rechner einnisten kann, habe ich bewußt bisher die Poltergeister aller Art gemieden.

 

 

Viel Grüße

 

Webturtle

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...