Jump to content
Dahl1978

DVBViewer 5.5 Windows 10 + Technisat Cablestar Combo HD CI

Recommended Posts

Dahl1978

Hello

 

I need a bit help with my combination of Technisat Cablestar Combo HD CI - Windows 10 Clean install and DVBViewer 5.5.0.

 

My device can be found, and installs with no what so ever problems.

 

i can find the device in DVBViewer,, but when i want to make a channel scan nothing happens and the pc restarts.

 

I have made 2 screen dumps , when i try to de a channel scan the device is not listed "in the bottom"

 

What is wrong?

 

I have contacted Technisat and they dont support windows 8 , windows 8.1 og windows 10, but it worked fine in windows 8.1

 

Regards

 

Morten

post-150193-0-71565700-1440837233_thumb.jpg

post-150193-0-14065700-1440837236_thumb.jpg

support.zip

Share this post


Link to post
mak73

Hi.

I have exactly the same problem - it worked fine on Windows 8.1 but on Windows 10 it just crashes with BSOD. I'm afraid there is nothing we can do about it. :(

Just one question, do you connect your CableStar to USB 3.0 or 2.0? Could you try 2.0? I just don't have 2.0 on my laptop to try it.

Share this post


Link to post
mch

This is bad news. Im also going to move on Win10 with this tuner, but as I see, it is not good idea.

I understand DVBViewer developer team that this is not their job but maybe they could push little bit on Technisat to update their drivers little more. I believe they cooperate on many things. So thank you for any reply ;)

Share this post


Link to post
t0urista

Hi, I got the same problem and I fixed it !

 

My chinese PC running windows 10 has 2 Intel USB controllers, one xHCI for USB 3.0/2.0 and one eHCI for USB 2.0 devices only.

by default all USB2.0 ports are routed to the xHCI controller, and the technisat Cablestar combo USB2.0 ports does not seem to like it....

 

2 solutions to ensure the USB2.0 ports of the Cablestar is routed to the eHCI controller :

1) disable USB3.0 ports in the BIOS, but then no more USB3.0 ports !

 

2) for Intel USB controller, change a USB controller register with a small utility called PCIUTILS

 

setpci -H1 -d 8086:DEV d0.W=0000

 

where DEVcan be obtained by Control Panel - Devices Manager - USB controller - properties - details and check for something like PCI\VEN_8086&DEV_9CB1&SUBSYS_72708086&REV_03

VEN 8086 means intel and in my case DEV = 9CB1
This register was by default set to 07ff, meaning all USB2.0 ports routed to the xHCI controller. With 0000, all USB2.0 ports are routed to the eHCI controller.
Notes :
1) This setting does not affect USB3.0 ports
2) the register setting does not survive a reboot, so I entered the command through the Task scheduler so that it is executed at each reboot
  • Like 1

Share this post


Link to post
ipadorhan

 

Hi, I got the same problem and I fixed it !

 

My chinese PC running windows 10 has 2 Intel USB controllers, one xHCI for USB 3.0/2.0 and one eHCI for USB 2.0 devices only.

by default all USB2.0 ports are routed to the xHCI controller, and the technisat Cablestar combo USB2.0 ports does not seem to like it....

 

2 solutions to ensure the USB2.0 ports of the Cablestar is routed to the eHCI controller :

1) disable USB3.0 ports in the BIOS, but then no more USB3.0 ports !

 

2) for Intel USB controller, change a USB controller register with a small utility called PCIUTILS

 

setpci -H1 -d 8086:DEV d0.W=0000

 

where DEVcan be obtained by Control Panel - Devices Manager - USB controller - properties - details and check for something like PCI\VEN_8086&DEV_9CB1&SUBSYS_72708086&REV_03

VEN 8086 means intel and in my case DEV = 9CB1
This register was by default set to 07ff, meaning all USB2.0 ports routed to the xHCI controller. With 0000, all USB2.0 ports are routed to the eHCI controller.
Notes :
1) This setting does not affect USB3.0 ports
2) the register setting does not survive a reboot, so I entered the command through the Task scheduler so that it is executed at each reboot

 

This works. Thank You.

Share this post


Link to post
Ducya

Hi t0urista,

 

Thank you very much! It works!

 

Some time ago I spent the best part of a day trying to get my Technisat Cablestar Combo HD to work on my computer running Windows 10, without success. I was so angry that I almost threw the Cablestar away. Fortunately I didn't. :original:

 

Thanks again for this great fix.

Share this post


Link to post
laszlodomokos
Help!

How to use the solution?

Share this post


Link to post
bjanuszs46

I've just upgraded my VivoPC from Windows 7 to Windows 10 and tried to apply your solution. The result was that after an error message the keyboard and mouse became unusable :-(

 

Can somebody provide a more detailed and more safe instruction?

 

How to check what is the original setting of the register? Where the values are documented?

 

Best regards

 

P.S. For laszlodomokos: what exactly are you missing in the t0urista description? I'm primarily a Linux user, but perhaps I can help.

Share this post


Link to post
bjanuszs46

I've just upgraded my VivoPC from Windows 7 to Windows 10 and tried to apply your solution. The result was that after an error message the keyboard and mouse became unusable :-(

 

 

 

There is some logic in it, as both Technisat and keyboard/mouse are connected to the USB 2 ports...

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...