Jump to content
boostermax

Record from PC to a NAS QNAP 251

Recommended Posts

boostermax

Hello

I have a nas qnap ts 251 and I would like the recordings that are made from my pc come register on the nas, but that does not work, though i have configured DVBViewer and recording service but The recordings always go in c: / public / videos despite the good setting of the software

I have checked the access rights of the shared directory on the nas and the rights are good, the pc can connect well to the nas, I even try to change the version of the samba server in the nas but nothing fact.

Should it make a particular setting or DVBViewer is not able to write on the nas?

Thank you
Aurélien

Share this post


Link to post
Tjod

The RS is running by default in the system user account. Therefore drive mappings or user name an password from you windows user will have no effect.

First you need a UNC to the recording folder (select it as sub folder from Network in the explorer). And then it should be a folder without the need for a password.

Share this post


Link to post
boostermax

I ever  did it , please see screenshot and tell me if that's good, thanks

pb dvb viewer.PNG

Share this post


Link to post
Tjod

In the RS service settings you should see \\SERVEUR\Video and nothing from P:

P: is a mapped drive which only works for the currently running user but not for the system  account.

Share this post


Link to post
boostermax

Hello ;

 

i ever try what you said , but recording service and / or not DVBViewer always recording in public videos, and i ever try to uninstall DVBViewer and recording service and reinstall it , and pb is still not resolved

Share this post


Link to post
boostermax

Hello ,

 

i have found the cause of the problem , the cause is Recording service doesn't see UNC .

 

If i uninstall recording service and setup DVBViewer to record on my nas : IT' S WORKS

 

 

so,can you upgrade recording service for see UNC ?

 

 

Thanks

Share this post


Link to post
HaraldL

If you use Win10 then there is a restriction by Microsoft. The "System" account in which the RS/DMS is running is no longer allowed to access UNC pathes which worked in previous Windows versions. You have to go to the services list and change the account of the RS from "system" to your normal user account and password (I'm pretty sure it does not work if the user has no password). You have to restart the service afterwards. And it's possible that you have to do it again after each update of the RS/DMS.

 

Didn't try this myself yet but this issue was mentioned a lot of times here in this forum.

Share this post


Link to post
boostermax

Ok, thanks but how must i do for change settings ? I must to change in services in windows and / or recording service or other ?

Thanks

Share this post


Link to post
HaraldL

In Windows. For example press Windows+R and enter "services.msc". In the list there is "DVBViewer Media Server". Right mouse click, properties. In the second register you can switch between system account and a manual entered account. I would stop the service before the change and restart it afterwards.

 

As written, I never did this myself but this was obviously necessary for many people after upgrading to Win10. And every time you install DMS again, for example a newer version, the setting can be reset and you have to check and change it again.

Edited by HaraldL

Share this post


Link to post
boostermax

Hello , i found , and it's works !!

 

Thank you very much !!

Share this post


Link to post
globalist

I have the same problem but on Win7. So I'm not sure this is Win10-specific. :)

Share this post


Link to post
HaraldL

On Win7 you can solve this if you can enable guest access for the share on your NAS. Because the RS/DMS doesn't access the NAS with your username/password but with the windows system account. If your NAS wants authentification the system account is an unknown user. So with guest access the system account can store on the NAS on Win7 (other than Win10 where any access to UNC pathes is always blocked for system account, no setting in the NAS can solve this).

 

Of course, if you can't (or won't for security reasons) allow guest access on the NAS you can do the same as described in my last post above, works in Win7/8.x too.

Share this post


Link to post
globalist

I know - I just used your advise to run the service with an actual user account that can access the NAS. I was just pointing the underlying issue was not Win10-specific. :)

Share this post


Link to post
HaraldL

The fact that the service always run as system account and not as actual user is independent of the windows version and is valid for most services on windows, not only RS/DMS. But for Win7/8.x you have two options to solve this: 1. allow access for the system account on your NAS or 2. change service to run as normal user account.

 

On Win10 something was changed by MS, option 1 is no longer possible. A drawback is that with option 2 you have to change the service user account after every update of RS/DMS (Option 1, once configured on the NAS would continue to work after an update of RS/DMS). If you forget it after an update new recordings will be stored in a local C: drive folder instead of the NAS.

Share this post


Link to post
Griga
On 19.5.2017 at 9:10 AM, HaraldL said:

A drawback is that with option 2 you have to change the service user account after every update of RS/DMS

 

We will try to avoid re-registering the DMS (= re-creating its registry entries) on installation, provided the DMS has not been uninstalled before and it is no RS -> DMS upgrade. This should preserve the service user account in future versions  if it works as intended (yet to be tested) .

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...