Jump to content
Sign in to follow this  
FlorianX

Probleme mit USB TV Sticks

Recommended Posts

FlorianX

Hallo,


ich hatte vor einiger Zeit schon einmal ein Beitrag zu einem ähnliche Thema erstellst, was nun allerdings schon etwas her ist. Die grundproblematik besteht aber leider nach reichlichem herumprobieren nachwievor.


Daher habe ich mich nun dazu entschlossen das Thema noch einmal aufzugreifen und hoffe das mir ggf. auch durch Erfahrungen anderer Nutzer geholfen werden kann.


Zu meinem Systemaufbau:

Ich nutze derzeit aus Ernergiespargründen ein leistungstarkes Laptop mit relativ geringem Stromverbrauch als Server und zur Realisierung meiner Medien und TV Versorgung.


Das Laptop selbst arbeitet mit "Windows 7 Professionell (64 Bit)", sowie mit dem aktuellen "DVBViewer Media Server 2.1.5.1". Dabei ist das Gerät direkt über ein LAN Kabel mit "1 GBit/s" an eine "FritzBox 6590 Cable" mit einem vorhandenen "Vodafone Kabel Anschluss (Internet und Phone 1000 Cable)" angebunden.


Der Kabel Anschluss liefert dabei folgende stabile Werte. 750 MBit/s im Download und rund 44 MBit/s im Upload (effektiv).

 

Als TV Hardware kommt derzeit der "Haupauge HVR 935 USB TV Stick" zum Einsatz, welcher an einem "USB 3.0 Port" angeschlossen ist und ebenfalls das "DVB C Singnal" des Vodafone Kabel Anschlusses nutzt.

 

Nun zum Problem:
Bei Versuchen ein TV Programm über ein anderes Gerät (VLC Media Player am PC oder DVBViewer App auf dem Smartphone) zu öffnen, braucht es ungefähr 10 bis 15 Sekunden, bis ein TV Programm erscheint. Gleiches passiert auch beim Wechsel der Sender. Das Problem besteht sowohl bei Aufrufen innerhalb und außerhalb des Netzwerks, weshalb ich schon die Vermutung hatte, dass es villeicht auch am TV Stick liegen kann.

 

Bevor ich nun aber los renne und Unmengen an Geld für andere Geräte ausgebe, daher meine Frage.

 

Kann es wirklich an dem TV Stick liegen oder hat jemand bereits ähnliche Erfahrungen gemacht oder kann mir villeicht auch eine TV Stick Empfehlung geben, wo es reibungslos funktioniert?


Beste Grüße
Flo

Edited by FlorianX

Share this post


Link to post
Griga
15 hours ago, FlorianX said:

Bei Versuchen ein TV Programm über ein anderes Gerät (VLC Media Player am PC oder DVBViewer App auf dem Smartphone) zu öffnen, braucht es ungefähr 10 bis 15 Sekunden, bis ein TV Programm erscheint.

 

Ich habe hier auch einen Hauppauge WinTV HVR 935 Stick für DVB-T2 sowie eine Hauppauge WinTV 88 AKA Nova S2 HD, beide unter Windows 7 Pro. Beide Geräte brauchen relativ lange für die Inititialisierung, d.h. bis beim ersten eingestellten Sender im VLC ein Bild kommt, vergehen etwa 10 (HVR 935) bzw. 8 (Nova S2) Sekunden - andere Geräte sind da deutlich schneller. Nachfolgende Senderwechsel gehen jedoch bei den Hauppauge-Geräten zügig in ca. 3 Sekunden über die Bühne.

 

Getestet habe ich es auf dem Server PC (also via localhost) mit Anwahl der Original-Streams im VLC 64-Bit 3.0.7.1 -> Universal  Plug 'n Play -> DVBViewer Media Server  -> TV.

 

Bei dir fehlen leider präzise Angaben darüber, wie du den TV Stream anwählst. Wenn es sich nicht um Original-Streams, sondern transkodierte Streams handelt, ist es normal, dass es so lange dauert. Teste es am besten auch wie ich auf dem Server PC, damit ein Vergleich möglich ist.

 

Share this post


Link to post
FlorianX

Hallo,

 

erst einmal vielen Dank für die schnelle Antwort.

 

Ich verwende auschlieslich "original" Streams ohne das Transkodiert wird.

 

Das Problem mit den langen Ladezeiten besteht auch, wenn man direkt über den Server (localhost) einen Stream öffnet oder auch den Sender wechselt.

 

Auch eine komplette Neuinstallation des Betriebssystems inkl. des "DVBViewer Media Servers und aller Treiber ergab keine Veränderung.

 

Gibt es sonst Empfehlungen für einen anderen TV Stick oder auch Hardware Hersteller, der nicht so lange braucht?

 

Beste Grüße

Flo

Share this post


Link to post
Griga

Das Verhalten des HVR 935 bei Kabelempfang kenne ich nicht, würde ihn aber erst austauschen, wenn andere Ursachen ausgeschlossen sind. Wie verhält es sich mit dem Stick, wenn er direkt im DVBViewer ohne Media Server und Netzwerkverbindung dazwischen verwendet wird? Dazu am besten den Media Server stoppen, den Stick in den Hardware-Optionen des DVBViewers zeitweilig aktivieren (Haken bei "Gerät benutzen") und mit der Maus an die oberste Listenposition verschieben.

 

Share this post


Link to post
FlorianX

Hallo,

 

der Stick wurde bereits getauscht und durch einen neuen aus dem Laden ersetzt. Das Problem ist das gleiche geblieben.

 

Sofern ich übrigends den Stick über z.B "DVB T" bzw. "DVB T2" verwende, besteht das gleiche Problem.

 

Bei direkter Verwendung über den "DVBViewer Pro" am Server (also Gerät an dem der TV Stick angeschlossen ist), erscheint das TV Programm sofort. Selbes gilt dabei auch beim Wechseln der Sender.

 

Beste Grüße

Flo

 

PS. Eventuell bestehende Netzwerkprobleme können ebenfalls ausgeschlossen werden, da ich dieses bereits mehrfach auf seine Leistungsfähigkeit und Stabilität überprüft habe.

Share this post


Link to post
Griga
3 hours ago, FlorianX said:

Bei direkter Verwendung über den "DVBViewer Pro" am Server (also Gerät an dem der TV Stick angeschlossen ist), erscheint das TV Programm sofort.

 

Dann kann es schlecht am Hauppauge HVR 935 liegen. Als nächstes würde ich testen, wie schnell (oder langsam) der Media Server Empfang erhält. Das ist etwas knifflig, weil Wiedergabe nur über eine Netzwerkverbindung geht, und die sollte erst mal außen vor bleiben. Also bleibt nur ein Versuch mit einer Aufnahme. Gehe am besten so vor:

  1. Stelle sicher, dass Media Server-Optionen -> DVBViewer Media Server -> Debug-Log schreiben und Aufnahmen -> Log-Datei schreiben angehakt sind.
  2. Bereite im Webinterface über Timer -> Neuer Timer eine Aufnahme eines DVB-C- Senders vor, die sofort startet, wenn du auf Speichern klickst. Das ist mit den Standardvorgaben für das Datum und die Start/Stoppzeit der Fall.
  3. Blende durch einen Klick auf die Systemzeit unten rechts die Windows-Uhr mit dem Sekundenzeiger ein.
  4. Klicke zu einem Zeitpunkt, den du dir sekundengenau merkst, auf Speichern im Timer-Dialog des Webinterface und warte eine halbe Minute.
  5. Lösche den Timer im Webinterface, was die Aufnahme stoppt.

Danach ist der Vorgang einerseits im svcdebug.log verzeichnet (die Datei liegt im Konfigurationsordner) und andererseits in einem Aufnahme-Log (mit der Endung .log),  das der DMS im selben Verzeichnis wie die Aufnahme speichert. Interessant sind in letzterem besonders die Zeilen, die das erkannte Video/Audio-Format angeben, z.B.

10:02:12 / 00:00:02 (~ 0,55 MB) PID 500: H.264 Video, 16:9, 1920x1080, 25 fps
10:02:12 / 00:00:02 (~ 0,55 MB) PID 510: AC3 Audio Stereo, 48 khz, 384 kbps

denn zu dem Zeitpunkt hat der DMS Daten vom Stick erhalten. Vergleiche die Zeitangabe am Anfang der Zeilen mit dem Zeitpunkt, an dem du auf Speichern geklickt hast. Es wäre auch gut, wenn du beide Logs hier gezippt anhängst. Ich kann vielleicht noch mehr daraus ersehen.

 

Share this post


Link to post
FlorianX

Hallo,

 

ich habe nun eine Aufnahme zum folgenden Zeitpunkt über das Webinterface angelegt und die entsprechenden "Log Dateien" angefügt.

 

01.08.2019 - 20:43:01 Uhr

 

Wenn ich es so richtig erkannt habe, benötigt der "DMS" etwa 10 Sekunden bis er ein Singnal empfängt.

 

Beste Grüße

Flo

svcdebug.log 2019-08-01_20-43-09_Das Erste HD_Test.log

Share this post


Link to post
Griga
On 8/1/2019 at 9:07 PM, FlorianX said:

Wenn ich es so richtig erkannt habe, benötigt der "DMS" etwa 10 Sekunden bis er ein Singnal empfängt. 

 

Als du um 20:43:01 die Aufnahme gestartet hast, lief offenbar (kurz zuvor) noch ein transkodierter Stream im Browser, der den HVR 935 Stick besetzt hielt. Er musste ihn erst freigeben, damit die höher priorisierte Aufnahme starten konnte. Wenn man ein Problem durch Tests lokalisieren will, ist es wichtig, nur einen Vorgang zu untersuchen und andere Einflüsse möglichst zu unterbinden. Deshalb wäre es besser gewesen, nur die Aufnahme durchzuführen und auf alles Drumherum zu verzichten.

 

Um 20:43:02 war das Gerät freigegeben, etwa um 20:43:06 hatte es sich der Recorder gekrallt, neu initialisiert und stellte den Sender ein. Das Tunen dauerte bis 20:43:09, direkt danach konnte die Aufnahme starten. Eine Sekunde später hatte der Rekorder das Video- und Audioformat ermittelt. Ich würde insgesamt etwa 8 Sekunden Startzeit veranschlagen.

 

Das ist beim HVR 935 zumindest unter Windows 7 ein üblicher Wert und spricht gegen ein Problem mit dem Stick. Bei mir sind die Zeiten ähnlich. Etwa 4 Sekunden für die Initialisierung - die Zeit ist beim HVR 935 leider relativ lang -  und 3 Sekunden für das Tunen. Nachfolgende Senderumschaltungen beim bereits initialisierten Stick sollten jedoch deutlich schneller gehen, wie hier beschrieben.

 

Wenn du im VLC 10 bis 15 Sekunden Senderumschaltzeit erhälst, lässt es einen weiteren Faktor vermuten, der für Verzögerung sorgt. Deshalb wäre jetzt ein weiterer Test angebracht, bei dem du das Problem im VLC reproduzierst (nur das, nichts anderes dabei), und zwar am besten auf dem Server PC via localhost, damit andere Netzwerkgegebenheiten außen vor bleiben. Und danach können wir schauen, was dazu im svcdebug.log steht...

 

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...