Jump to content

Problem - DMS is allocating 2 streams to one TS device


davyboy2011

Recommended Posts

davyboy2011

Hi I have a problem with the media server. Sometimes when I stop a stream in kodi it still shows as live in the dms web interface. So when i start another stream it creates another instance for the same device causes glitching. I've tried  disabling "automatically create ts stream devices on demand" using dmstweaker.bat but made no difference. Also updated to latest kodi and DVBViewer/dms.

 

My setup:

 

1 pc (localhost 127.0.0.1) with DVBViewer and  recording service installed. Using kodi as front end on same PC.

2 tsmedia hardware devices (for iptv recording of 1 channel whilst watching another). 

 

Normal:

 

Start stream in kodi (shows as 1 client connected in web interface)

Stop stream in kodi (video stops. 0 clients connected in web interface)

Start stream in kodi (shows as 1 client connected in web interface)

 

from log:

18.02.20 19:43:00.459 TFileDevice          RunDevice        
18.02.20 19:43:00.459 TLiveStream          AllocateHardware TS Stream Device 2
18.02.20 19:43:00.459 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 1434225535, LOF: 49528, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 23454, Flags: 24, Group: 0
18.02.20 19:43:25.426 Release              TS Stream Device 2
18.02.20 19:43:25.426 Free                 TS Stream Device 2
18.02.20 19:43:25.449 TFileDevice          StopDevice       
18.02.20 19:43:25.449 TFileDevice          CloseDevice      
18.02.20 19:43:25.449 Freed                TS Stream Device 2
18.02.20 19:43:25.449 hamDeleted           TS Stream Device 2

 

Intermittent Problem (see attachment):

 

Note: nothing else is using DMS and no recordings are taking place.

 

Start stream in kodi (shows as 1 client connected in web interface)

Stop stream in kodi. (Video stops as normal but still shows as 1 client connected in web interface).

Start stream in kodi (shows as 2 clients connected in web interface and causes glitching).

 

from log:
18.02.20 18:30:16.211 TFileDevice          RunDevice        
18.02.20 18:30:16.211 TLiveStream          AllocateHardware TS Stream Device 2
18.02.20 18:30:16.211 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 1434225535, LOF: 49528, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 23454, Flags: 24, Group: 0
18.02.20 18:32:21.424 TBaseProcess         API_HandleStatus 
18.02.20 18:32:21.619 TBaseProcess         API_HandleStatus 
18.02.20 18:32:33.179 TLiveStream          AllocateHardware TS Stream Device 2
18.02.20 18:32:33.179 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 1434225535, LOF: 49528, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 23454, Flags: 24, Group: 0

 

 

 

 

 

web.jpg

Link to post
Griga
9 hours ago, davyboy2011 said:

Stop stream in kodi. (Video stops as normal but still shows as 1 client connected in web interface).

Start stream in kodi (shows as 2 clients connected in web interface and causes glitching).

 

Looks like the client doesn't close the connection, but establishes another one for the same channel. It is intended that the DMS uses the same device for both connections in such a case.

 

I can see nothing that is wrong in the second log. So it comes down to the question why the first connection isn't closed properly.

 

Link to post
davyboy2011

Problem also exists when changing channel. Tried clean install of DVBViewer and dms but still no joy. Restarting dms clears problem for a while.

 

Problem:

19.02.20 14:03:08.631 TBaseProcess         API_HandleStatus 
19.02.20 14:03:08.840 TBaseProcess         API_HandleStatus 
19.02.20 14:03:16.849 TFileDevice          RunDevice  

19.02.20 14:03:16.849 TLiveStream          AllocateHardware TS Stream Device 2
19.02.20 14:03:16.849 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 3421403067, LOF: 11596, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 21800, Flags: 24, Group: 0
19.02.20 14:03:50.885 TFileDevice          RunDevice        
19.02.20 14:03:50.885 TLiveStream          AllocateHardware TS Stream Device
19.02.20 14:03:50.885 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 4151002781, LOF: 16000, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 16766, Flags: 24, Group: 0
19.02.20 14:04:22.723 TFileDevice          CheckAutoRetune  Retuning TS Stream Device 2
19.02.20 14:04:22.723 TFileDevice          StopDevice       
19.02.20 14:04:22.723 TFileDevice          CloseDevice      
19.02.20 14:04:31.586 TLiveStream          AllocateHardware TS Stream Device 2
19.02.20 14:04:31.586 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 3421403067, LOF: 11596, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 21800, Flags: 24, Group: 0
19.02.20 14:04:33.778 Release              TS Stream Device
19.02.20 14:04:33.778 Free                 TS Stream Device
19.02.20 14:04:33.797 TFileDevice          StopDevice       
19.02.20 14:04:33.797 TFileDevice          CloseDevice      
19.02.20 14:04:33.797 Freed                TS Stream Device
19.02.20 14:04:33.797 hamDeleted           TS Stream Device

 

Normal:

19.02.20 14:28:44.051 TFileDevice          RunDevice

19.02.20 14:28:44.051 TLiveStream          AllocateHardware TS Stream Device 2
19.02.20 14:28:44.051 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 619169065, LOF: 26888, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 18171, Flags: 24, Group: 0
19.02.20 14:28:55.151 TLiveStream          AllocateHardware TS Stream Device 2
19.02.20 14:28:55.151 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 3067006364, LOF: 2572, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 16861, Flags: 24, Group: 0
19.02.20 14:28:55.191 TFileDevice          StopDevice       
19.02.20 14:28:55.191 TFileDevice          CloseDevice      
19.02.20 14:29:03.119 TLiveStream          AllocateHardware TS Stream Device 2
19.02.20 14:29:03.119 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 2445780184, LOF: 55299, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 21790, Flags: 24, Group: 0
19.02.20 14:29:03.139 TFileDevice          StopDevice       
19.02.20 14:29:03.140 TFileDevice          CloseDevice      
19.02.20 14:29:11.658 TLiveStream          AllocateHardware TS Stream Device 2
19.02.20 14:29:11.658 TFileDevice          SetTuner         TType: 6, Freq: 0, Symrate: 1136775969, LOF: 50313, Tone: 7, Pol: 0, DiseqC: 0, FEC: 0, APID: 257, VPID: 256, PMT: 4096, SID: 1, TID: 1, NID: 65281, SatMod: 0, DiseqCVal: 19566, Flags: 24, Group: 0
19.02.20 14:29:11.695 TFileDevice          StopDevice       
19.02.20 14:29:11.695 TFileDevice          CloseDevice     

Edited by davyboy2011
Link to post
davyboy2011

Think I may have found the problem. Seems to be an addon running in background in kodi that affecting the dms. When i disable it, the dms works as normal. 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...