Jump to content
Derrick

funny TOT

Recommended Posts

Derrick

In DVB there are tables defined that give an indication for the time (TDT) as UTC and an offset (TOT) for the local time.

 

Here's an example of a TOT that I haven't seen so far :)

 

<?xml version="1.0" encoding="iso-8859-1" ?> 
- <Astra_1D_3A_at_23.5_E_11953_H>
- <TOT PID="0x0014">
 <DateTime String="23.11.2006 23:15:41" /> 
- <Descriptor HValue="0x58" Name="Local Time Offset">
- <Country String="DEU">
 <CountryRegionID Value="0" /> 
 <LocalTimeOffsetPolarity Value="0" /> 
 <LocalTimeOffset String="01:00:00" /> 
 <TimeOfChange String="25.03.2007 02:00:00" /> 
 <NextTimeOffset String="02:00:00" /> 
 </Country>
- <Country String="AUT">
 <CountryRegionID Value="0" /> 
 <LocalTimeOffsetPolarity Value="0" /> 
 <LocalTimeOffset String="01:00:00" /> 
 <TimeOfChange String="25.03.2007 02:00:00" /> 
 <NextTimeOffset String="02:00:00" /> 
 </Country>
- <Country String="CHE">
 <CountryRegionID Value="0" /> 
 <LocalTimeOffsetPolarity Value="0" /> 
 <LocalTimeOffset String="01:00:00" /> 
 <TimeOfChange String="25.03.2007 02:00:00" /> 
 <NextTimeOffset String="02:00:00" /> 
 </Country>
- <Country String="LUX">
 <CountryRegionID Value="0" /> 
 <LocalTimeOffsetPolarity Value="0" /> 
 <LocalTimeOffset String="01:00:00" /> 
 <TimeOfChange String="25.03.2007 02:00:00" /> 
 <NextTimeOffset String="02:00:00" /> 
 </Country>
 </Descriptor>
 </TOT>
 </Astra_1D_3A_at_23.5_E_11953_H>

Share this post


Link to post
Griga

Here is an example of a channel that claims to broadcast MPEG1 Video:

 

<?xml version="1.0" encoding="iso-8859-1"?>
 <Astra_19.0_E_11538_V>
<ServiceID Value="6905" Name="France 24 (en Francais)">
  <PMT PID="655">
	<PCR PID="605"/>
	<ES PID="605" Name="MPEG1 Video">
	  <StreamType HValue="0x01" Name="MPEG1 Video (ISO/IEC 11172-2)"/>
	</ES>
	<ES PID="625" Name="MPEG Audio">
	  <StreamType HValue="0x03" Name="MPEG Audio (ISO/IEC 11172)"/>
	</ES>
  </PMT>
</ServiceID>
 </Astra_19.0_E_11538_V>

 

Consequently the TransEdit Preview, when started from the analyzer window, does not play the video stream, because the Analyzer wants to see MPEG2 or H.264. However, when started from the scanner window, the Preview plays it, because the scanner doesn't care... :)

 

P.S. Obviously it isn't MPEG1 video, because it's interlaced, and the sequence header is followed by the extension_start_code 00 00 01 B5. Stream type 0x01 is simply wrong.

Edited by Griga

Share this post


Link to post
Derrick

..at least the service can be watched with all applications that I have checked. TSReader says it's mpeg1 but at the same time parses the stream and gets the correct parameters.

 

Elementary Stream PID 606 (0x025e) MPEG-1 Video

MPEG Video: Bitrate 15.000 Mbps Resolution 720 x 576i

MPEG Video: Framerate 25 fps Aspect Ratio 4:3 Chroma Format 4:2:0

 

 

btw. stream type 1 is inserted by the old dvb2000 in the CA_PMT for video as a fixed value :)

Share this post


Link to post
Griga
..at least the service can be watched with all applications that I have checked.

Sure. It's plain MPEG2.

 

TSReader says it's mpeg1

Fooled by the wrong stream ID, like the analyzer. Retrieving the correct type requires parsing the ES (me -> hex viewer).

Share this post


Link to post
Derrick

Information: 1005  TPT->PES(PID=606), MPEG 1 Video->VES(224)->This is an MPEG-2 Video Elementary Stream
Semantic Error: 1014  TPT->PES(PID=606), MPEG 1 Video->VES(224)->PSI in Transport Stream specifies MPEG 1 Video

..they won't get away with this crap ! :)

Share this post


Link to post
Griga

A wrong TOT (not updated to local_time_offset = 01:00:00 and next time of change):

 

<?xml version="1.0" encoding="iso-8859-1"?>
 <Astra_19.0_E_10920_H>
<TOT PID="20">
  <DateTime String="24.11.2006 11:50:20"/>
  <Descriptor HValue="0x58" Name="Local Time Offset">
	<Country String="CZE">
	  <CountryRegionID Value="0"/>
	  <LocalTimeOffsetPolarity Value="0"/>
	  <LocalTimeOffset String="02:00:00"/>
	  <TimeOfChange String="29.10.2006 01:00:00"/>
	  <NextTimeOffset String="01:00:00"/>
	</Country>
	<Country String="HUN">
	  <CountryRegionID Value="0"/>
	  <LocalTimeOffsetPolarity Value="0"/>
	  <LocalTimeOffset String="02:00:00"/>
	  <TimeOfChange String="29.10.2006 01:00:00"/>
	  <NextTimeOffset String="01:00:00"/>
	</Country>
	<Country String="SVK">
	  <CountryRegionID Value="0"/>
	  <LocalTimeOffsetPolarity Value="0"/>
	  <LocalTimeOffset String="02:00:00"/>
	  <TimeOfChange String="29.10.2006 01:00:00"/>
	  <NextTimeOffset String="01:00:00"/>
	</Country>
  </Descriptor>
</TOT>
 </Astra_19.0_E_10920_H>

Share this post


Link to post
hurda7

A wrong TOT (not updated to local_time_offset = 01:00:00 and next time of change):[/code]

 

Don't think that's a thing of the past:

 

<?xml version="1.0" encoding="utf-8"?>

<Cabel__QAM_256__314>

<TOT PID="20">

<DateTime String="10.04.2015 17:41:33"/>

<Descriptor HValue="0x58" Name="Local Time Offset">

<DescriptorLength Value="13"/>

<Country String="AUT">

<CountryRegionID Value="0"/>

<LocalTimeOffsetPolarity Value="0"/>

<LocalTimeOffset String="01:00:00"/>

<TimeOfChange String="29.03.2015 01:00:00"/>

<NextTimeOffset String="02:00:00"/>

</Country>

</Descriptor>

</TOT>

</Cable__QAM_256__314>

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...