Jump to content
Sign in to follow this  
Guest buggy12

Keine Aufnahmen mit Task Scheduler möglich

Recommended Posts

Guest buggy12

Hi,

 

ich hab das Problem, dass ich mit dem Task Scheduler generell nicht aufnehmen kann (egal ob der Computer zuvor angeschaltet, im Standby oder im Sleep ist):

Die Aufnahme startet und stoppt jeweils zur gewünschten Zeit, jedoch werden keinerlei Daten aufgezeichnet. Die resultierende Video-Datei ist völlig leer, d.h. 0KB groß.

Was mir aufgefallen ist: Wenn die Aufnahme (und damit der DVBViewer) startet, erhalte ich lediglich ein schwarzes Videofenster, die Statusleiste des Viewers bleibt ebenfalls leer. Wenn ich denn Sender manuell wechsle erscheint jedoch ein Bild.

 

 

Wenn ich direkt im DVBViewer aufnehme funktioniert übrigens alles einwandfrei.

 

 

Systeminfos:

- Terratec Cynergy HTC USB XS - Fernsehen über DVB-C (KabelBW)

- Windows Vista Business x86

 

Weitere Infos in der Support.zip

Außerdem habe ich noch das erweiterte Logfile der Aufnahme angehängt

 

Hoffe Ihr könnt mir helfen.

Danke und Gruß

Buggy

 

support.zip

04_13_22_57_01_ProSieben_Scrubs___Die_Anf_nger.log

Share this post


Link to post
Guest buggy12

Keiner eine Idee?

 

Hatte jetzt noch die möglichkeit eine DVB-S USB-Box im zusammenspiel mit dem DVBViewer zu testen. Hier funktionierte die Aufnahme (das mit dem leeren Videofenster scheint aber normal zu sein, oder?)

 

Hoffe ihr könnt mir helfen.

Share this post


Link to post
Devastation
das mit dem leeren Videofenster scheint aber normal zu sein
Ja, nur für die Aufnahme ist kein Bild da, erst wenn du das Programm einschaltest.

 

Ist Dein DVB-C Pro7 verschlüsselt?

Share this post


Link to post
Guest buggy12
Ist Dein DVB-C Pro7 verschlüsselt?

Nein, alles unverschlüsselt. Konnte bisher auch keine Senderabhängigkeit ausmachen, scheint ein generelles Problem zu sein.

Share this post


Link to post
Guest buggy12

Kennt das Problem keiner? Wäre echt schade, wenn ich das Problem nicht in den Griff bekommen würde, denn sonst war ich bisher vom DVBViewer begeistert.

 

Kleines Update:

Wenn ich zwei Timer programmiere, einen mit "Sender einstellen" und kurz darauf einen mit "Aufnehmen", dann funktioniert die Aufnahme. Besonders Nutzerfreundlich ist das aber nicht, und bestimmt auch nicht Sinn der Sache.

Share this post


Link to post
Prinz

Hallo,

Wenn ich zwei Timer programmiere, einen mit "Sender einstellen" und kurz darauf einen mit "Aufnehmen", dann funktioniert die Aufnahme. Besonders Nutzerfreundlich ist das aber nicht, und bestimmt auch nicht Sinn der Sache.

0KB-Video-Dateien deuten ind der Regel auf ein Problem mit dem BDA-Treiber hin. Kann diesbzgl. auch ein Lied mit der Cinergy 1200-C singen.

 

Probier mal den Service aus, der hat noch ein paar Möglichkeiten mehr widerspenstige Hardware zum Laufen zu bekommen.

 

In der Konfiguration des Services dann folgende Punkte aktivieren:

  • Reset nach standby
  • Bei fehlendem Stream neu tunen
  • Neustart Aufnahme, wenn keine Daten innerhalb von 60s

Anleitung zur Installation des Service findest Du hier:

http://de.DVBViewer.tv/wiki/Recording_Serv...ationsanleitung

 

Gruß

Prinz

Edited by Prinz

Share this post


Link to post
Guest buggy12

Die Installation des RecordingService wollte ich vermeiden, da dieser viele Funktionen enthält, die ich nicht brauche.

Außerdem läuft der DVBViewer bei mir auf einem Laptop, das oft an unterschiedlichen Standorten mit unterschidlicher/gar keiner DVB-Hardware verwendet wird, also nicht gerade gute Vorraussetzungen.

 

Gibt des denn (als Workaround) etwas äquivalentes zum Programm HelpTimer? Im Wiki wird dieser ja aufgrund von Bugs nicht mehr empfohlen.

Share this post


Link to post
Prinz

Hallo,

 

Die Installation des RecordingService wollte ich vermeiden, da dieser viele Funktionen enthält, die ich nicht brauche.

Außerdem läuft der DVBViewer bei mir auf einem Laptop, das oft an unterschiedlichen Standorten mit unterschidlicher/gar keiner DVB-Hardware verwendet wird, also nicht gerade gute Vorraussetzungen.

 

Ich habe den DVBViewerService auch auf dem Laptop drauf und die Hardware ist nur auf Reisen dran, ging bisher ohne Probleme.

 

Auch bei einem Laptop finde ich den Service sinnvoll, schließlich laufen die Aufnahmen im Hintergrund, ohne das man davon etwas mitbekommt (außer dass das Service-Icon rot wird). Auch braucht man den DVBScheduler/EventGhost nicht, da das Aufwachen zur Aufnahme der Service beherrscht.

 

Gruß

Prinz

Share this post


Link to post
Guest buggy12

Nein, ich möchte den RecordingService NICHT installieren.

 

Ich habe mir dabei etwas gedacht mich für den TaskScheduler zu entscheiden, und hatte gehofft, dass mir jemand eine Lösung für mein konkretes Problem hat.

Share this post


Link to post
Prinz
ich hab das Problem, dass ich mit dem Task Scheduler generell nicht aufnehmen kann (egal ob der Computer zuvor angeschaltet, im Standby oder im Sleep ist):

 

Noch mal eine Frage, wie startest Du Deinen Laptop? Wird er immer aus dem Standby/Ruhezustand hochgefahren oder bootest Du immer neu?

 

Tritt das Problem auch auf, wenn Du neu gebootet hast?

 

Gruß

Prinz

Share this post


Link to post
Guest buggy12

Hey,

 

das Laptop wird stets ordnungsgemß heruntergefahren bzw. neu gestartet.

 

Ich als Laie würde behaupten, dass mein Problem unabhängig vom Systemstart an sich ist, da es ja auch dann nicht funktioniert, wenn der Computer schon an ist und ich angemeldet bin.

Normales Fernsehen mit dem DVBViewer funktioniert hingegen immer, auch Aufnahmen mit einem vorgeschaltenen Umschalttimer (wie oben beschrieben) werden abgearbeitet.

 

Mir scheint eher, dass das Problem darin liegt, wie der Task Sheduler den DVBViewer startet.

Aber wie gesagt, ich kenne mich mit den Internas nicht aus und hoffe, dass ihr die Ursache meines Problems aufspühren könnt.

Share this post


Link to post
Dauni30

Hi

 

Wirklich helfen kann ich dir nicht hatte mal ein Ähnliches Problem mit meinem Stick von HP.

Da war es ein Treiber Problem,(aufnahme nach Standby)

 

Ähm wenn dein Laptop an ist du eine Sendung Prog. denn Laptop nicht aus machst nur DVBViewer schließen tust.

Dann klappt die Aufnahme auch nicht?

 

Welche Versionen Scheduler und DVBViewer nutzt du?

Hast es auch mal mit der ß Versucht? seid dem ich ß benutze ist bei mir alles bisher bestens

 

Dauni

Share this post


Link to post
Prinz
Normales Fernsehen mit dem DVBViewer funktioniert hingegen immer, auch Aufnahmen mit einem vorgeschaltenen Umschalttimer (wie oben beschrieben) werden abgearbeitet.

 

Bist Du Dir sicher? Wenn Du den Viewer startest und Du wählst einen Kanal aus, kommt dann direkt das Bild?

 

Wie startest Du den Viwer normalerweise? Defaultmäßig wird - soweit ich weiß - immer der letzte empfangene Sender eingestellt. Hast Du dann - falls diese Otion aktiviert ist (Einstellungen/TV+Radio/Schalte letzten Sender beim Starten ein) - direkt ein Bild oder erst nach dem ersten Umschalten?

 

Gruß

Prinz

Share this post


Link to post
Hartwig

Ich würde es mal mit einem etwas stärker verzögertem Start, als bisher, versuchen.

Öffne dazu mal die Scheduler.ini. Dort findest du einen Eintrag

DVBStartDelay=

Den wert dahinter erhöhe mal auf z.B. 15000 für 15 sec verzögerung und teste dann mal, ob es so funktioniert.

Share this post


Link to post
Prinz
Wie startest Du den Viwer normalerweise? Defaultmäßig wird - soweit ich weiß - immer der letzte empfangene Sender eingestellt. Hast Du dann - falls diese Otion aktiviert ist (Einstellungen/TV+Radio/Schalte letzten Sender beim Starten ein) - direkt ein Bild oder erst nach dem ersten Umschalten?

 

Also habe mir nochmal Deine Setup-Datei angesehen. Du hast den DVBViewer so konfiguriert, dass er direkt nach dem Starten den letzten Sender anzeigen soll. Ist das der Fall oder musst Du erst einmal umschalten?

 

Wenn Du im TaskScheduler mit der Option "Restart DVBViewer Without Tuning Large Channel" (ist Default) betreibst, gibt es an dieser Stelle einen Unterschied zwischen Scheduler-Start und normalem Start.

 

Gruß

Prinz

Edited by Prinz

Share this post


Link to post
SupaChris

Hilft es was, den Viewer mit -x53 als Parameter zu starten? Ich hab das drin, das baut sofort nach dem Start den Wiedergabe-Graph neu auf. Sorgt bei mir dafür, dass das CAM bei jedem Start sofort zuverlässig arbeitet und keine Aufnahmen versaut.

Share this post


Link to post
Guest buggy12

Prinz, du hast das Problem gefunden! Wenn ich im Sheduler die Funktion "Restart DVBViewer Without Tuning Large Channel" deaktiviere, dann erhalte ich von Anfang an Bild/Ton und die Aufnahme ist erfolgreich.

Blöd, dass ich das nicht früher entdeckt habe, aber ich war der Meinung alle Optioen im Sheduler schonmal ausprobiert zu haben.

 

Die Option -x53 brachte keine Veränderung.

Den Sheduler lasse ich jetzt lediglich noch die Option -x25 an den DVBViewer übergeben um den Ton während der Aufnahme stummzuschalten.

 

Danke nochmal an alle, vor allem Prinz!

Das Problem ist hiermit für mich erledigt, mit dieser Lösung kann ich gut leben.

Wenn ihr noch weiter forschen wollt warum es mit den Standardeinstellungen nicht funktioniert, stehe ich euch jedoch zur Verfügung :(

Share this post


Link to post
Prinz

Hallo,

 

Das Problem ist hiermit für mich erledigt, mit dieser Lösung kann ich gut leben.

Du musst aber beachten,dass vermutlich dann eine Aufnahme wieder nicht erfolgreich sein wird, wenn ein Sender des gleichen Bouquets aufgenommen werden soll, der auch schon beim Starten des Viewers eingestellt ist.

 

Ich vermute - und so ein Problem hatte ich mit einer meiner Karten auch schon - das die TV-Karte einfach ein Senderwechsel benötigt. Bei meiner Karte war das Problem mit einem Treiberupdate behoben. Bist Du sicher, dass Du den aktuellesten hast?

 

Wenn Du ein Bouquet hast, wo Du nur selten etwas aufnimmst, solltest Du das erst mal wählen.

 

Gruß

Prinz

Share this post


Link to post
Guest buggy12

Hey Prinz,

 

habe gerade folgende Fälle getestet:

1. Sender der aufgenommen werden sollte war beim DVBViewer-Start bereits eingstellt.

2. Sender der aufgenommen werden sollte liegt auf dem gleichen Transponder wie der bereits eingstellte.

3. Sender der aufgenommen werden sollte liegt auf einem anderen Transponder wie der bereits eingstellte.

 

Die Aufnahme war in allen drei Fällen erfolgreich!

Bei 1. wurde logischerweise nicht umgeschalten.

Bei 2. wurde nicht umgeschalten, sondern lediglich im Hintergrund der andere Sender aufgenommen.

Bei 3. wurde auf den aufzunehmenden Sender umgeschaltet.

 

Wenn ich Dich richtig verstanden habe, meintest du, dass Fall 2 Probleme bereiten könnte?

Soweit also alles wie es soll.

Share this post


Link to post
SupaChris

Gut, wenn es jetzt klappt. Sowas hatte ich aber auch mal mit dem TechniCrypt CX. Das wollte unbedingt einen Senderwechsel auf einen verschlüsselten Sender haben, bevor es was gemacht hat. Hab deshalb dann ein anderes CAM gekauft, bei dem ist das nicht. Der Viewer stellt den Sender erst direkt bei der Aufnahme ein, das hat nicht gereicht. Bei buggy12 wirds jetzt so sein, dass irgendein Sender getuned werden muss, bevor was los geht. Und da das ja durch den Scheduler 3 min vor der Aufnahme passiert, haben alle Komponenten genug Zeit.

Share this post


Link to post
dvb-michi

Das mit der Einstellung "... Without Tuning Larst Channel" im Task Scheduler hatte ich auch schon rausgefunden, siehe hier.

 

Denke dass du das nicht weiter verfolgen musst, hatte mit dem Sendereinstellen oder Umschalten weiter nichts zu tun.

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...