Jump to content
Derrick

Ohne I-Frames bleibt LAV dunkel

Recommended Posts

Derrick

Vor ca. 2-jahren hatte ich diesen LAV-bug schon mal intern gepostet. Jetzt habe ich mal wieder LAV auf den neusten stand (0.68.1) gebracht. Der bug besteht leider immer noch. Wahrscheinlich wissen die gar nichts davon. Also noch mal, aber jetzt public :)

 

Hier ist ein link zu einem Mpeg2-HD-testfile, der von von einem feed stammt. Das besondere ist, dass es keine I-frames sondern nur P-frames in den GOPs gibt. Das bild wird von den meisten codecs nach einem mehr oder weniger langsamen bildaufbau normal abgespielt.Nur von LAV nicht :(

Share this post


Link to post
Griga

Das wird vermutlich an FFmpeg liegen. LAV ist ja im wesentlichen das DirectShow Framework.

Share this post


Link to post
Derrick

..zunächst lief es nicht, aber das lag nicht am video sondern an der DolbyE-audiospur, mit der ffmpeg nichts anfangen konnte. Die spur hätte ich wohl vorher besser entfernen sollen ;)

Ohne AES3 PCM Audio funktionierte es ohne probleme. Es gab nur eine warnung am anfang über einen missing keyframe. Ansonsten lief es durch und liess sich auch mit dem vlc abspielen, allerdings war der konvertierte file doppelt so gross.

 

Vielleicht wartet LAV ja auf einen I-frame wie andere auf Godot..

Snap6.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...