Jump to content
lehtikissa

After Win 10 Creators Update "AllocateHardware Open failed!"

Recommended Posts

lehtikissa

Sorry about writing in English, but my German isn't of sufficient quality. Please move this to English section if you wish, I added it here because of the context.

 

I believe I have this same issue with Windows 10 Creators Update and DVBViewer 6.0.2.0 + Media Server 2.0.2.0. Tuner is Digital Device Max A8.

 

I updated to Creators Update AND to DVBViewer 6.0.2.0 / Media Server 2.0.2.0 last weekend and everything worked fine until this evening when I noticed that recordings scheduled for this evening had all failed.

 

When I had a look at svcdebug.log, I found numerous "AllocateHardware Open failed" errors, etc. No actual recordings were made either (only recording logs).

 

Curiously, when I try to open channels in DVBViewer, some open correctly, so it seems only some tuners are affected (Digital Device Max A8 has 8 tuners). With the non-functioning channels I get message "Channel switched by Media Server".

 

Should someone from the development team still be available this evening, I'll be happy to provide more information now that my system still is in malfunctioning state (it might help you find the underlying reason in case DVBViewer has anything to do with it).

 

I will reboot in a few hours to increase the likelihood that the system works fine again tomorrow morning when new recordings are scheduled (at least for some time until the issue resurfaces).

 

Update: actually, it seems the issue might not after all be specific to individual tuners in this multi-tuner card. That "Channel switched by Media Server" was returned when I still had Media Server trying to record that specific channel. When I stopped the recording and tried to open the channel again directly in DVBViewer, it opened ok. However, when I try to record it (launching the recording from DVBViewer while Media Server of course is responsible for the actual recording), no recording is made. Of course, it is possible that DVBViewer opens it using different tuner than what Media Server tried to use to record.

Edited by lehtikissa
typo, more info

Share this post


Link to post
lehtikissa

Here is also TransEdit_Test.txt should it help.

 

TransEdit_Test.txt

Edited by lehtikissa

Share this post


Link to post
Griga
2 hours ago, lehtikissa said:

Please move this to English section if you wish

 

Please post in the English section if you want to write in English!!!

 

Solution for issues caused by the Destroyers Update see here.

 

Share this post


Link to post
lehtikissa

To update, reboot "fixed" the issue (I also updated DD drivers just in case).

 

As I wrote, the system worked correctly after Creators Update until today, so apparently BDA devices aren't broken completely by Creators Update.

 

If Creators Update is the culprit, the issue apparently occurs only after it has been running for some time.

 

I'll see if the issue returns and in that case try the repair install solution.

 

About "ConnectDirect failed, remove filter" in the log: is that something that should not normally appear in the log? I run TransEdit_Test.exe again after reboot and I still have that line in the log even though recording works ok.

 

What I do NOT see in the log is "Failed to add and connect the tuner filter" that is discussed in the other thread. I did not have that error in the log even before reboot.

Share this post


Link to post
lehtikissa

This happened again. This time I first noticed it when I tried to watch live TV in DVBViewer, which told me "No hardware available" (as I understand, also DVBViewer sessions go through DMS in DMS setup).

 

i then tried to access DMS web interface, but it didn't open. I then had a look at whether the service was running, and yes, it was. I stopped the service.

 

I then re-started the service and was able to again access the web interface. Also watching live TV worked.

 

However, when the next scheduled recording was up in a few minutes, the recording failed. It also no longer was possible to watch live TV in DVBViewer and neither did DMS web interface work.

 

This time re-starting the service didn't seem to help even for a moment (it is possible that it simply failed immediately again as that scheduled recording was still active and it most likely started immediately again once the service was re-started, which then caused DMS to fail).

 

I then restarted computer after which everything worked again (just like when the issue occurred the last time in May).

 

There was also the following entry in Event Viewer concerning DVBVRecorder:

 

The description for Event ID 0 from source DVBVRecorder cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Media Server Create

 

Does this still seem like something caused by Windows 10 Version 1703 (I uploaded TransEdit_Test.txt previously, but got no comments about it)?

 

The fact that web interface stops working seems to imply that this might have something to do with DMS as well. Until I upgraded to DMS, Recording Service worked reliably for years.

 

Ps. If possible, please move this thread to DMS section as the issue is primarily related to it.

 

Ps2. Maybe also this report is related: http://www.DVBViewer.tv/forum/topic/59966-dms-stopping-working/

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...