Jump to content
eife

Video "hoppelt" nach dem Schnitt

Recommended Posts

eife

Grüß Gott,

 

eine DVBViewer-Aufnahme wollte ich mit der Demoversion des Video-Editors vorne und hinten beschneiden. Hat im Prinzip geklappt, aber das neue Video ruckelt beim ansehen mit den VLC-Media-Players, genau wie beim abspielen im DVBViewer pro, doch ziemlich extrem. Das Ausgangsvideo (.ts) ist ok.

Hängt das mit "Demo" in der Demoversion zusammen oder muss man weiter forschen?

 

Dank im Voraus!

Uwe

 

Share this post


Link to post
hackbart

Was für ein Format ist denn das Video? Mpeg2, H264 oder HEVC? Wenn der Editor mit Parameter -debug gestartet wird, dann wird beim Schneiden einiges an Infos in einer Log Datei gespeichert. Da steht dann wahrscheinlich drin was falsch läuft.

 

Christian

Share this post


Link to post
eife

Videoformat ist ein MPEG-TS (1280*720). Wohin wird denn die Log-Datei abgelegt? Ich finde sie nicht.

Uwe

 

Share this post


Link to post
hackbart

In den Optionen auf Konfigurationsverzeichnis klicken. Ich gehe mal davon aus, dass es ein H264 HD Video ist. Wie gesagt es wäre nützlich die Log Information zu bekommen. Die werden aber erst erstellt, wenn man den Editor mit Parameter -debug startet. 

 

Share this post


Link to post
gleddamax

Werden im Video-Editor Parameter für den Bitstreamfilter verwendet?  Habe mir letztes Jahr eine Batchdatei mit verschiedenen Optionen für FFMPEG zusammengezimmert, wobei ich ähnliche Probleme hatte. Vielleicht kann etwas davon hier hilfreich sein?

 

Beim Kopieren und/oder Schneiden der Streams aus TS- oder anderen Kontainern in TS-Kontainer beseitigte bei mir folgende Parameter für das Videostreammapping jegliche Probleme in der neuen Datei :    -map 0:v -f mpegts -bsf:v chomp -c:v copy -copytb -1

 

In der Kommandozeile verwende ich als globale Parameter stets:         -copyts -start_at_zero

 

Beim Kopieren der Streams aus einem mp4-Kontainer in eine TS-Datei half für den Videostream folgende Parameter:   -map 0:v -f mpegts -bsf:v h264_mp4toannexb,chomp -c:v copy

 

Beim Muxen von separaten Video- & Audiodateien zu einer TS-Datei konnte ich mit dem Parameter  -bsf:v h264_mp4toannexb   nach dem Mappingparametern vorher auftretende Probleme erfolgreich beseitigen.

 

Edited by gleddamax

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...