Jump to content
beeswax

[Deactivate auto-timers if a recording exists] function not quite working

Recommended Posts

beeswax

When I'm creating a search-based timer, set this option and tick both the [EPG title] and [EPG subheading] boxes, it's my understanding that only programmes where both match will have the timers disabled.  I'm finding that timers are being disabled for unique shows though.  Here is a timer I've set up: Search-based timer

 

Here are the EPG entries for each of the resulting shows: EPG Data

 

And here are the resulting timers: Timers

 

As you can see, half the timers are being disabled even though they all have a unique subheading/description.  If I delete all the timers, edit the search with the 2 boxes unticked, all timers are set and enabled.  This is one example, X-Factor on ITV1 HD also does this.  And ideas why this happens and how to fix it?

 

edit: here's my epg.dat in case you want to try and reproduce: EPG.dat

 

support.zip

Edited by beeswax

Share this post


Link to post
Griga
vor 1 Stunde schrieb beeswax:

Here are the EPG entries for each of the resulting shows: EPG Data

 

They have a description, but no subheading. The comparison does not include descriptions. Here you can see how EPG data with title, subheading and description looks like:

 

Zwischenablage01.png

 

Share this post


Link to post
beeswax

Hm, that sort of makes sense but then why aren't 3 of the 4 timers that are created not being disabled too?  None of these EPG entries have what I now know are subheadings so that should mean only the first one is left enabled.

Share this post


Link to post
beeswax

Update: I've worked my way around this by changing how my EPG data is formatted (I use EPG Collector).  I had the "Format data so that subtitle is visible" option enabled so by unticking this, the entire description is now dumped into the subheading field.  It makes for a much messier looking EPG and Timer list in the web view but it does solve this problem.

Share this post


Link to post
Griga
vor 11 Stunden schrieb beeswax:

I had the "Format data so that subtitle is visible" option enabled so by unticking this, the entire description is now dumped into the subheading field. 

 

That's the original state of Freesat EPG data. I've just tried... and got flooded by celebrities ;)

 

Zwischenablage02.png

 

Most of the timers are disabled, because "Additionally check against recording timers" was ticked to sort out duplicates.

Share this post


Link to post
beeswax

Hi Griga, thanks for confirming.  Yes, I think I was mislead by the EPG Collector option "Format data so that subtitle is visible".  It makes it sound like it's correcting something when in fact its creating a new problem.  I guess it fixes issues for some EPGs but in Freesat's case, not.

 

On the Kodi end, this option actually makes no difference to how EPG data looks so this is definitely resolved now, thank you for the assistance!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×