Jump to content
Mikefield

Wieder kein EPG Empfang, Wiedergabe am DVBViewer nicht möglich

Recommended Posts

Mikefield

Seit ein paar Tagen zeigen einige Sender keine EPG Daten mehr an: 

SAT1, Pro7 etc. Mittlerweile sind die Sender auch aus der Timeline heraus geflogen (ich weiß, ist do konfiguriert) 

Das Problem hatte ich schon einmal mit dem Recording Service. Inzwischen nutze ich auch den MediaServer in

der letzten Version 2.1.2. 

 

Ich nutze eine Selfsat IP 21 SAT>IP Schüssel. Im Fernseher (am Legacy LNB), im SAT>IP Viewer auf dem Tablet

werden EPG Daten angezeigt. 

Wahrscheinlich tritt der Fehler nach einem Neustart des Windows Servers auf. Zumindest sehe ich sonst keinen 

Zusammenhang. Was auch auffällt, im Status von der MediaServer Webseite werden keine Kanäle in Benutzung 

angezeigt. Auch Aufnahmen von Sendern die noch in der Timeline sind, werden nicht geschrieben. 

 

Der DVBViewer meldet egal ob der Media Server oder die Selfsat IP 21 als Hardware eingerichtet sind, daß kein

passendes DVB Gerät zur Verfügung steht. 

 

Woran kann das liegen? Ich kann ja nicht immer die Software neu installieren... 

 

mf

support.zip

Share this post


Link to post
Griga

Der DMS kann den SelfSat-Server schlicht nicht mehr erreichen. Kann es sein, das dessen IP-Adresse wechselt?

 

Schau mal in den DMS-Optionen (svcoptions.exe) -> Hardware -> SelfSat-Eintrag selektieren -> Einstellungen nach (oder im DVBViewer an gleicher Stelle). Falls sich die IP geändert hat, müsste es sich dort zeigen bzw. der Server müsste mit neuer IP erkannt werden und auswählbar sein.

 

Share this post


Link to post
Mikefield

Die IP-Adresse vom Selfsat Server ändert sich nicht. Mit dem SAT>IP Viewer kann ich weiterhin darauf zugreifen, egal ob Tablet oder Handy. 

Der Port 554 vom Selfsat Server ist auch erreichbar: 

C:\xxxxxxxx\PingPort>pping xxx.xxx.xxx.18 -ports=554
Starting pinging host xxx.xxx.xxx.18 on TCP port(s) 554 4 times:
#   1 -> Pinging host xxx.xxx.xxx.18 (IP:-) on TCP port 554 with timeout 1: OPEN

#   2 -> Pinging host xxx.xxx.xxx.18 (IP:-) on TCP port 554 with timeout 1: OPEN

#   3 -> Pinging host xxx.xxx.xxx.18 (IP:-) on TCP port 554 with timeout 1: OPEN

#   4 -> Pinging host xxx.xxx.xxx.18 (IP:-) on TCP port 554 with timeout 1: OPEN

Finished pinging host xxx.xxx.xxx.18 (IP:-). 4 pings sent (4 OPEN, 0 CLOSED) 

 

Allerdings sind die UDP Ports 52000 oder 52100 nicht offen, auch von anderen Rechnern im Netz sind diese nicht erreichbar. 

Ich habe die Geräte unter Hardware gelöscht und neu eingetragen, aber ohne Erfolg. Es dauert auch schon ein paar Minuten

bis der "Einstellungen" Dialog wieder geschlossen wird. 

 

mf

 

PS: Den Text habe ich nochmal editiert, war ja ein schlimmes Deutsch... 🙂

Edited by Mikefield

Share this post


Link to post
Mikefield

Nachtrag: Habe auf dem Windows Server den VLC Player installiert. Darüber ist der Selfsat Server erreichbar. Die Sender können

aufgerufen und wiedergegeben werden, wenn auch nicht ganz ruckelfrei. 

 

mf

Share this post


Link to post
Griga
25 minutes ago, Mikefield said:

Allerdings sind die UDP Ports 52000 oder 52100 nicht offen, auch von anderen Rechnern im Netz sind diese nicht erreichbar. 

 

Das sind clientseitige UDP Ports. In dem angegebenen Bereich sucht der Client zwei benachbarte freie Ports und teilt sie dem Server mit. Der Server sendet den TV/Radio-Stream an den ersten Port und ergänzende Informationen wie die Signalstärke an den zweiten. Das ist RTSP-Standard.

 

Aber soweit kommt es bei dir überhaupt nicht. Das Log enthält nur die lakonische Mitteilung, dass keine Hardware verfügbar ist. Ich muss mir das noch mal genauer anschauen und mit dem DMS Code abgleichen. In der Vorweihnachtszeit ist es schwierig, dafür ein paar ruhige Minuten zu finden ;)

 

Share this post


Link to post
Mikefield
vor 44 Minuten schrieb Griga:

In der Vorweihnachtszeit ist es schwierig, dafür ein paar ruhige Minuten zu finden ;)

Es gibt schlimmeres. Von daher genieße die Zeit. Freue Dich aufs Fest, schöne Feiertage mit Deiner Familie und komme gut ins neue Jahr. 😉 

 

Mittlerweile habe ich den Windows Server heruntergefahren, stromlos gemacht, langsam bis 10 gezählt und das Teil neu gestartet. 

Jetzt tut der DVBViewer mit dem Selfsat Server sprechen und der DMS aktualisiert gerade wieder sein EPG. Sch... Technik! 😉 

 

Wenn Du trotzdem im neuen Jahr nochmal schauen willst, lass es mich wissen. 

 

mf

Share this post


Link to post
Griga

Ich hab's mir noch mal genauer angeschaut. Auffällig ist, dass das Log z.B. bei

 

Quote

14.12.18 21:00:00.223 TRecording           AllocateHardware Open failed

 

keine Ursache angib - die Zeile besagt nur, dass die Initialisierung des virtuellen RTSP-Gerätes scheitert. Normalerweise erscheint bei Fehlern noch ein Eintrag von der Stelle, wo es schiefgeht.

 

Bei der Initialisierung versucht der DMS/DVBViewer als erstes, eine TCP-Verbindung zum Server aufzubauen, um festzustellen, ob er überhaupt erreichbar ist. Das klappt offenbar, denn sonst gäbe einen Log-Eintrag der Art "OpenDevice Server not found".

 

Als nächstes findet die oben beschriebene Suche nach den freien UDP Ports im Bereich 52000...52100 statt. Wenn das scheitert, gibt es jedoch keinen zusätzlichen Log-Eintrag, weil es unwahrscheinlich erscheint, dass der DMS/DVBViewer unter 100 Ports keine zwei freien nebeneinanderliegenden findet (im nächsten Release wird es einen Eintrag geben - gerade ergänzt).

 

Vermuten könnte man deshalb, dass in deinem Windows Server etwas passiert, das den Portbereich blockiert - warum auch immer. Spielt vielleicht eine Sicherheitssoftware dabei mit? Firewall? Wenn es mit dem VLC klappt, funktioniert UDP an sich. Ich würde deshalb, wenn das noch mal passiert, probeweise einen anderen Portbereich weitab vom bisherigen konfigurieren (nicht sofort, sondern erst beim nächsten Störfall zwecks Vergleich). In der Auswahl bist du recht frei. Z.B. ist bekannt, dass der Real Player im Bereich 6970-7170 sucht (siehe hier). Zu Portbereichen allgemein siehe hier.

 

Share this post


Link to post
Mikefield

Danke für die weitere Beschreibung. Da werkelt nur die Windows Firewall und ESET NOD32 Antivirus. 

Die Firewall hatte ich schon mal deaktiviert, aber das half auch nicht. Und der VLC kam ja durch (bei aktiver FW). 

Das mit den Ports werde ich testen, kann aber dauern, ist ja nicht klar, wenn der Fehler wieder auftritt. 🙂 

 

mf

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...