Jump to content
Jussi_

DMS New Timer problem in Mobile web

Recommended Posts

Jussi_

Hi,

I am having problem creating new timer in Mobile DMS.

 

Have already tried a lot of different things, but the problem stays.

It won't matter if I do this with mobile or desktop browser.

In svcdebug log shows following 

10.10.19 20:02:59.281 TVCR                 Invalid timer:   Test

 

What actually means "Invalid timer" what it checks when generating that message

Can anyone help how could I solve this issue?

 

Regards,

  JL

 

Share this post


Link to post
Griga

"Invalid timer" means, the end time is already in the past, or there is no date assigned to the timer, or no channel.

 

Please provide a screenshot of your input on the time page.

 

Share this post


Link to post
Jussi_

Thanks Griga for replying,

Currently I am not in place where I could take a screenshot, not beside the computer. Will upload the screenshot later if needed.

 

This issue will come not only on manually setting timer, but also when trying to do timer from timeline (in future).

 

Have tried to reinstall the software (earlier had the recording server 1.x) where first notice this and later updated to this newest DMS.

Both version act the same.

 

Computer have localised Windows version (with latest updates), but have also tried with UK settings, especially noted the time and date settings. In localised version the time was like HH.mm and in UK version HH:mm, dates were the same.

 

 

Share this post


Link to post
Jussi_

Basically it seems like this, recording is selected in future.

image.thumb.png.ce589e1fe7dea6dca7f07d89549c97b7.png

 

Is there any other way to debug this issue or is there any other thing to check?

 

Share this post


Link to post
Griga

I tried to reproduce the issue by using exactly your timer settings (except the channel), but after saving the timer remained valid.

 

Did you already check the system time/date on the server PC? Maybe it is wrongly set to some date far in the future, which would make all timers invalid. Some people are really in advance of their time :)

 

Share this post


Link to post
Jussi_

Yes have checked the system time/date, it use NTP and sync with windows default ntp.

Do you have windows 10 Home edition or did you run your test with Professional edition, also are you using the default local system account with the service?

 

I am currently thinking the error message is miss leading and the reason for not being able to set the recordings is something else.

Share this post


Link to post
spachti

Not sure about it, but your date shows 21.10.2019, which means DD-MM-Year, Windows default is MM-DD-Year. Maybe that's the problem?

 

Edit:

On the other hand

Quote/

10.10.19 20:02:59.281 TVCR                 Invalid timer:   Test

/Quote

shouldn't make a difference then :rolleyes:

Edited by spachti

Share this post


Link to post
Jussi_

Thanks Spachti from your comments. The date format would depend on localisation, in Finnish localisation the format is DD.MM.YYYY. 

At least it seems good, both the log and the settings are having the same. I also change the separator from . to : didn't try - (dash). This didn't change the behaviour.

 

The odd thing is that with computer web page the recording is possible with either from search EPG or with manually set. At the same time on the mobile web the streaming work. It is possible to play the recorded programs. Only the save command won't go through. Not from timeline neither from manually set.

 

I can add more pictures or logs there could be any ideas of reason, I am really out of ideas.

Actually going next to grab some process monitor logs (sysinternals tools) if that could give some more information. Did that already, but didn't save the records.

At that time didn't notice anything odd.

Share this post


Link to post
Griga

As the debugger shows, the DMS gets something like this from the browser in the query part of the timer_add URL (sent after clicking Save):

 

...&dor=05.11.2019&starttime=18%3A49&epgbefore=5&endtime=19%3A19&epgafter=10...

 

where %3A is the "percent encoding" of the colon (yielding starttime=18:49 and endtime=19:19) and epgbefore/after the lead / follow-up time in minutes. The date format must be dd.mm.yyyy, or (as fallback) the local format of the account in which the DMS is running (usually the system account). Otherwise adding the timer may fail with "invalid timer".

 

However, regarding the screenshot above, I can't see a problem in this respect. :iiam:

 

vor 59 Minuten schrieb Jussi_:

Actually going next to grab some process monitor logs (sysinternals tools) if that could give some more information.

 

You may rather want to use the developer tools of your desktop browser (press F12) , e.g. by using the network analysis tab in Firefox and filtering for requests that contain dor.

 

Share this post


Link to post
Griga

I've found another possible reason for "invalid timer":

 

vor 14 Stunden schrieb Griga:

The date format must be dd.mm.yyyy, or (as fallback) the local format of the account in which the DMS is running (usually the system account).

 

The time is handled differently, as I could see in the code. There is no fixed format that is always accepted, but it must match the format of the account in which the DMS is running. If the usual hh:mm doesn't match, the time can't be decoded. Failure lets the DMS shift the date one day to the past. So if you try to schedule a recording for tonight, the timer will become invalid, because the date becomes yesterday.

 

However, if you try to schedule a recording for, let's say, the day after tomorrow in this way, the date will become tomorrow, thus not being invalid, and the timer should appear in your list, with something like 00:00 as start and end time, indicating that the time couldn't be decoded. Please try if this applies to your case.

 

You can also try if the "invalid timer" issue is generally related to the format settings of the system account. Maybe they are broken in some way. For a test, stop the DMS as service (by using the tray menu) and launch it as application by double-clicking DVBVservice.exe. It lets a small window appear that enables closing the DMS again. Please note that this mode entails some restrictions, so only use it for tests. Since the DMS is now running as application in the user account, it will use its format settings, not the system settings anymore. Try if the timer issue still persists.

 

Some DMS users already experienced trouble with the system account format settings. You can read a long story with a lot of information about this topic here.

 

  • Thanks 1

Share this post


Link to post
Jussi_

Thanks Griga !

Why didn't I actually realise that by myself earlier. Will check that and inform the results..

Share this post


Link to post
Jussi_

Now the problem is solved !

 

It seems that it was a time format issue, even I tested it with a new user in the service run as account.

I think in some Windows update the default localisation (regional) settings have changed to default US or something else.

 

Anyway thanks to Griga to pointing me to correct direction!

 

When looking the data transfer I didn't notice anything odd, the tip Griga gave about looking the browns Dev Mode gave the same values

 chid=0&dor=05.11.2019&epgbefore=2&starttime=10%3A00&endtime=10%3A50&epgafter=15

 

But when I stop the service and started it as a normal app, the Save worked.

Then after I copied the the current user language settings to system accounts in  'Administrative Language Settings - Welcome Screen and New User accounts' also the service account worked. Actually I thick the both boxes, never you when one or the other is needed.

 

That setting can be found from All Settings - Time & Language - Language under 'related Settings'

 

 

Share this post


Link to post
Griga
vor 7 Stunden schrieb Jussi_:

I think in some Windows update the default localisation (regional) settings have changed to default US or something else.

 

Default US format settings for the system account may occur if Windows initially got configured for English (USA), followed by a later change to another country / language. Pre-installed OEM versions are frequently affected by this kind of issue.

 

vor 7 Stunden schrieb Jussi_:

Then after I copied the the current user language settings to system accounts in  'Administrative Language Settings - Welcome Screen and New User accounts' also the service account worked.

 

The next release will accept the system account time format and independently from that always the 24 hours hh:mm time format. I think we both learned something from this case... that's a good result :)

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...