Jump to content
Lars Andersen

Multiple TS Stream Devices problem

Recommended Posts

Lars Andersen

Finally I think I have found the root course for this issue:

I have two TS Stream devices so I'm sure not to record more streams than my provider allows (two simultaneous streams in my case). Have unchecked "Automaticaly create TS Stream devices on demand" in DMSTweaker.bat. All is fine. Until my wife complains about recordings where something is missing.

 

I have 15 mins. followup time on all recordings. What happens is that a "back to back" recording on Viasat Series HD starts on the same TS Stream Device. Look at the screen shot where TS device 2 have two simultaneous recordings going on on Viasat. This should not be possible?

TS stream device 1 has another recording going on.

I have plenty more like this now and it ends up with one of the recordings is missing like half of the movie.

 

I hope there is a check mark or something somewhere so I can get this fixed........

 

 

Status.jpg

Timers.jpg

Share this post


Link to post
Griga
9 hours ago, Lars Andersen said:

I have 15 mins. followup time on all recordings. What happens is that a "back to back" recording on Viasat Series HD starts on the same TS Stream Device.

 

That's normal. It doesn't mean that an additional connection to your provider is established. The Media Server just records the same stream twice for a certain period of time, in your case from 21:45 (start of the second recording) to 22:02 (end of the first recording).

 

When a device delivers a stream, the DMS is able to distribute several copies of it, e.g. for two simultaneous recordings and three clients that are playing the channel, provided it is exactly the same URL for all of them. Your provider only sees a single client, though.

 

Here is a link to the previous discussion about your special reception conditions, just for looking something up, if necessary.

 

Share this post


Link to post
Lars Andersen

Hi griga and thanks for quick answer. Right after I have posted I was also coming to the conclusion that the stream devices must work as you describe. I am familiar to this from my earlier system (argustv) that uses dvb-t and dvb-s the same way. All good here. I must be hunting something else then.

 

My wife found this example where a recording on TS device 1 was scheduled to start 23:25 (5 min. lead time) but did actually start at 00:25 . So she is missing the start of the show.
TS device 2 was in action recording from viasat at the same time.
Something odd is going on? 

I have zipped the txt and log files for the recorings. 

 

 

 

 

dr1_log.jpg

recordings.jpg

log_and_txt_files.zip

Share this post


Link to post
Griga
26 minutes ago, Lars Andersen said:

a recording on TS device 1 was scheduled to start 23:25 (5 min. lead time) but did actually start at 00:25 .

 

The only reason I can think of: TS Stream Device 1 was occupied by another recording during the missing time.

 

How is DVBViewer configured? Does it get the streams from the DMS, or does it access your provider directly by using its own TS Stream devices?

 

Share this post


Link to post
Lars Andersen

Hmm. I can only upload pics with 0.08MB right now it says.

I will then try to explain DVBViewer configuration:

DVBViwer - setting - Options

Go down to DVBViewer Media server

I have check mark set in "Enable support for the DVBViewer Media server"

My media server is selected

Nothing in username and password for web interface

Next 5 check marks are all set.

Maybe I should uncheck "send timers to the server" and "connect to the timer list"?

 

I have a server connected to surround receiver with a Samsung TV. 

The server is running KODI as frontend.

DMS is installed for recordings etc.

DVBViewer installed but only in use for channel setup,  etc.

We use web interface on ipads to do the scheduling of recordings.

 

Share this post


Link to post
HaraldL
vor 23 Minuten schrieb Lars Andersen:

Hmm. I can only upload pics with 0.08MB right now it says.

 

In your user settings (top right of the page) you can delete older and no longer needed appended files to get back space.

 

The important part Griga meant is Options -> Hardware. Here only one or two "DVB.. RTSP Network Device" should be active in DVBViewer (Checkmark "Use Device" or similar checked below). Not a real Hardware or the stream devices the DMS is using. Those, if present, should have no check in "use Device" so DVBViewer is not allowed to use them.

 

The DMS must be the only(!) service that has access to the devices or provider streams. The DVBViewer client(s) access them through the DMS by the virtual RTSP devices. Also KODI must use DMS only, if KODI accesses the provider streams directly it steals one from the DMS who has no way to detect this.

Edited by HaraldL

Share this post


Link to post
Lars Andersen

Ok. In DVBViewer - Settings - Options - Hardware I have no devices. This should be ok? Or should I add a TS Stream Device and set no check in "use Device"?

I have checked in KODI that I only have DMS enabled. No other devices on my network should be able to access the provider streams.

 

 

Share this post


Link to post
Griga
2 hours ago, Lars Andersen said:

DVBViewer installed but only in use for channel setup,  etc.

 

1 hour ago, Lars Andersen said:

In DVBViewer - Settings - Options - Hardware I have no devices. This should be ok?

 

This is ok for the described purpose.

 

Share this post


Link to post
Lars Andersen

Since all my settings and setup seems to be all right I will keep an eye on this to see if it is something that really happens so often.

In theory it could be the DR1 stream that actually was down at the moment the recording starts (23:25). Then when the stream again was available the recording started (00:25). 

Not sure if it is a valid theory since the log for the recording do not log anything like that in the actual case. But that detail of logging info might not be intended in this log file anyway.     

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...