Jump to content

Multicast and Windows Firewall


Xtro

Recommended Posts

Hi, I recently acquired DVBViewer Media Server and found that only way other devices found the uPNP server is disabling firewall. Found in the wiki this: 

Quote

The UPnP AV Server uses additionally the UDP Multicast address 239.255.255.250 Port 1900

 but I have no idea how to enable this in Windows 10 Defender firewall, any help would be appreciated. As I said when switching off firewall it works OK.

Link to post
HaraldL

Your network is probably set as "public network", which is intended when connected to foreign unsecure networks like public wifi. On first connect or router replacement (when a network gateway with a new MAC address is detected) you are asked by windows if you want your computer to be found by other devices. If you don't answer this with "yes" or simply dismiss it your firewall is set to "public" and blocks nearly all connections from other devices. A "private" network setting is recommended for home or company connection.

 

You didn't write which windows version you use. Assuming windows 10 just do a google search for "windows 10 network public to private".

 

If it doesn't help post a support.zip.

 

Link to post

Thanks for the help. I am using Windows 10 latest build, my network is set to private but I had network discovery of the computer turned off. I turned on computer discovery over network but didn't solve the problem. I attach here the log from support tool.

support.zip

Link to post
HaraldL

Hmm, on first look I don't see a hint what can cause this. Just to be sure you could go into DVBViewer program folder (mostly c:\program files (x86)\dbvviewer) and execute DMS_Firewall_Rules.bat and DMS_IPTV_Firewall_Rules.bat both by right mouse click "as administrator". This should renew the firewall settings.

 

According to your log files your computer seems to have 3 IP Addresses? 192.168.100.10, 192.168.163.1 and 192.168.44.1, is this correct and which one should be used for streaming? Are they on different LAN/WLAN interfaces? If yes, the proper one used for uPNP must be set to private network as multiple networks can be set different..
 

 

 

Link to post

Thank you again HaraldL, executed DMS_Firewall_Rules.bat and DMS_IPTV_Firewall_Rules.bat as administrator but didn't solve anything. 192.168.100.10 is the IP of my computer,  192.168.163.1 and 192.168.44.1 are virtual networks used by VMware. I always use 192.168.100.10 as private network, on this IP I use static IP and google's DNSs if that matters??

I am an absolute noob with networks, but  is it possible to open UDP Multicast address 239.255.255.250 Port 1900 on the firewall as says the WIKI? I don't know how to do it with Windows 10 Defender Firewall.

Link to post
HaraldL

Found something about virtual network adapters causing problems with multicast here. It's about VirtualBox, not VMware but perhaps it helps. The metric change should only be done if virtual network adapters exist beside the real ones.

 

Btw. you can open the Media Server configuration via systray icon and in Web/UPnP you can enter the two VMware IPs separated by ";" in the lower text box. So UPnP doesn't try to announce on this networks. You see at Media Server website -> Status -> UPnP Server IPs on which addresses the service is active. Here it's my real local IP and 127.0.0.1 localhost.

 

Link to post

I tried blacklisting the IPs of VMware in UPNP Server without success. I even removed the virtual network adapters of VMware and didn't solve the issue, so must be something else. If I disable firewall it works OK, so I surely can open something in Windows firewall to enable DVB Media Server access.

Link to post

I opened all connections on Firewall for DVB Media Server and now it works. I checked that Windows 10 Media Server didn't work neither until I disabled firewall so something wrong on my config blocking multicast.  

Edited by Xtro
found solution
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...