Jump to content
Sign in to follow this  
VeroWeed

Eingebundene Netzlaufwerke werden nicht indiziert

Recommended Posts

VeroWeed

Hallo Freunde,

 

ich habe ein seltsames Problem.

Nach Anschaffung eines neuen PCs habe ich meine drei Laufwerke auf dem Videoserver wieder über die übliche Netzwerkverbindungen als Laufwerke "O", "P", "Q" auf meinem neuen PC eingerichtet.
Diese habe ich im DVBViewer als Video-Ordner verknüpft. Hier werden diese auch indiziert und deren Inhalte im OSD angezeigt.

 

Aber im Media-Player werden diese Laufwerke nicht indiziert - obwohl ich diese dort identisch eingetragen habe und bei jedem Eintrag "Video"  und "Rekursiv" in grün markiert habe.

Selbst, wenn ich die drei Laufwerke im Mediaserver über deren UNC-Pfade einbinde, findet keine Indizierung statt.
Das Indizierungsintervall habe ich im MS auf 60 min eingestellt - aber in den drei Tagen seit Neuinstallation meines neuen Rechners sind immer noch keine Einträge im Mediaserver sichtbar.

Auch das Audio-Laufwerk "N", das im DVBViewer alle MP3s anzeigt, wird im Mediaserver (als "Audio" und "Rekursiv" eingestellt) nicht indiziert.

Auf dem alten Rechner funktionierte das problemlos.

Woran könnte das liegen?

Kann mir da jemand helfen, das Problem zu beheben?

Beste Grüsse

Share this post


Link to post
Griga

Dein Post lässt vermuten, dass du Probleme mit der Eigenart von Windows 10 hast, dass es Windows Services, die in einem Systemkonto ohne Benutzername und Passwort laufen, keinen Zugriff auf geschützte Netzwerklaufwerke gestattet. Du kannst das ändern, indem du den Service mit den Anmeldedaten eines geeigneten Kontos ausstattest:

 

https://www.dvbviewer.tv/forum/topic/61985-dvb-c-to-ip-schritt-für-schritt/?do=findComment&comment=478230

 

Share this post


Link to post
VeroWeed

Hi Griga,

lieben Dank für Deinen Tip.

Aber nee, meine Benutzerkonten "Sysop" und "Administrator" haben jeweils Kennwörter vergeben.

Ich habe auch "EnableLinkedConnections" auf DWORD 1 gesetzt, damit ich mit dem Admin-Konto auf die Freigaben des Sysop zugreifen kann.

Die Laufwerke werden ja auch im Mediaserver zur Auswahl im Dialog angezeigt. Nur eben nicht indiziert.

Auch die UNC-Einbindingen zu.B. "\\IP-Adresse\Video1" lässt sich im Mediaserver einbinden - wird aber auch nicht indiziert.

Der Rest vom Media-Server funktioniert wunderprächtig- nur nicht das "Medien"-Tab.

Ich weiss überhaupt nicht, was das sein könnte.
Stehe total auf dem Schlauch...

Beste Grüsse

Share this post


Link to post
VeroWeed

Hi Griga,

lieben Dank für Deinen Tip.

Aber nee, meine Benutzerkonten "Sysop" und "Administrator" haben jeweils Kennwörter vergeben.

Ich habe auch "EnableLinkedConnections" auf DWORD 1 gesetzt, damit ich mit dem Admin-Konto auf die Freigaben des Sysop zugreifen kann.

Die Laufwerke werden ja auch im Mediaserver zur Auswahl im Dialog angezeigt. Nur eben nicht indiziert.

Auch die UNC-Einbindingen zu.B. "\\IP-Adresse\Video1" lässt sich im Mediaserver einbinden - wird aber auch nicht indiziert.

Der Rest vom Media-Server funktioniert wunderprächtig- nur nicht das "Medien"-Tab.

Ich weiss überhaupt nicht, was das sein könnte.
Stehe total auf dem Schlauch...

Beste Grüsse

 

P.S.

Waaaah - Du bist ein Genie!!!!!!!

Nachdem ich einfach wie in Deinem Link beschrieben, die Anmeldung des Mediaservers explizit meinem "Sysop" und seinem Passwort zugeordnet habe, klappt es mit dem Indizieren 🙂
Frag mich aber nicht, warum.
Ich verstehe es nicht.
Gaaaaaaanz lieben Dank für Deine Hilfe!

Beste Grüsse

Share this post


Link to post
VeroWeed

Ach ja, noch eine Frage zum Allgemeinverständnis.

 

Ich habe ja prinzipiell drei Möglichkeiten, mich im Browser mit dem Mediaserver zu verbinden:

1. http://localhost:Port-Nummer/index.html

2. http://IP-Server-Rechner:Port-Nummer/

3. http://www.Meine DYNDNS-Adresse.de:Port-Nummer/

 

Bei den ersten Beiden erscheint unter "Medien" nur "TV", "Aufnahmen", "Videos", "Audio", "Bilder"

Bei der Dritten erscheint in "Medien" aber "TV", "Radio", "Aufnahmen", "Videos", "Audio", "Bilder"

 

Warum erscheint im Medien-Tab der Eintrag "Radio" dabei nur bei der dritten Verbindungsart?

 

Ist nicht schlimm - mich wundert das nur.

 

Jetzt muss ich nur noch mein Icon zum Abspielen im DVBViewer in die "Media-List.html" einbauen (dabei hast mir ja auch geholfen) - und auf dieses Icon möchte ich nicht mehr verzichten.

Dann passt rund um den DVBViewer wieder alles.

Share this post


Link to post
Griga
vor einer Stunde schrieb VeroWeed:

Warum erscheint im Medien-Tab der Eintrag "Radio" dabei nur bei der dritten Verbindungsart?

 

Weil die Einstellungen im Webinterface -> Konfiguration -> In der Senderliste anzeigen in einem Cookie gespeichert werden, also in jedem Browser und für jede Adresse verschieden sein können.

 

Share this post


Link to post
VeroWeed

Danke Dir, Griga.

Oh, na dann ist klar😉

Wieder was gelernt.

 

Aber jetzt habe ich ein richtiges Problem.

Vorgeschichte ist, dass ich inzwischen einen HW-Router mit Firewall für meine verschiedenen Netzwerke habe und daher den Kaspersky Internet Security von meinen Rechnern entfernen kann.

 

Auf einem Rechner (dem, in welchem die TV-Karte steckt und auf dem der Medienserver rennt) klappte die Deinstallation auch problemlos.

Will sagen, hinterher lief alles wie gehabt.

 

Aber auf einem zweiten Rechner, dem, der als Client für den DVB-Medienserver werkelt, werden im Browser jetzt nur noch die dank Deiner Hilfe neu indizierten Medien im Medien-Tab des Media Servers angezeigt, wenn ich die Adresse des MS über meine DYNDNS.de aufrufe.

Also:

http://www.meineDYNDNS.de:Port-Nummer/

Rufe ich den Media-Server aber über die lokale IP des MS-Server-Rechners:

http://LokaleIP:Port-Nummer/

auf, bleibt das Medien-Tab leer.

Alle anderen Tabs des MS zeigen Inhalte.

 

Ich habe schon die Port-Nummer als Eingehende und Ausgehende Regel in der Win10-Firewall freigegeben, aber das hat leider nichts geholfen.

Ich vermute, dass hierzu noch weitere Regeln in der Firewall fehlen.

Aber im Manual finde ich nur, die Option "Netzwerke freigeben", was ich ja auch bei der Installation auf beiden Rechnern gemacht habe - das Fernsehen auf dem betroffenen Rechner über den Rechner mit der TV-Karte und dem Mediaserver funktioniert ja auch.

Kannst Du mir da auch weiterhelfen?

 

Herzlichen Dank

Share this post


Link to post
Griga

Wahrscheinlich

 

https://www.dvbviewer.tv/forum/topic/59060-ich-kann-nicht-mehr-zum-recording-service-verbinden/?do=findComment&comment=455010

https://www.dvbviewer.tv/forum/topic/61799-kein-bild-win10/?do=findComment&comment=477635

 

vor 5 Stunden schrieb VeroWeed:

Ich habe schon die Port-Nummer als Eingehende und Ausgehende Regel in der Win10-Firewall freigegeben, aber das hat leider nichts geholfen.

 

Besser keine Eigenkonstruktionen. Der Installer richtet für den DVBViewer und DMS die passenden Firewall-Regeln ein, allerdings für das private Profil. Die Dateien DVBViewer_Firewall_Rules.bat und DMS_Firewall_Rules.bat im DVBViewer-Programmverzeichnis machen (mit Adminrechten ausgeführt!) das gleiche.

 

Share this post


Link to post
VeroWeed

Hallo Griga,

Die Netzwerke auf dem Medienserver-PC und dem Client-PC sind Beide "Ethernet - Privates Netzwerk".

Zuvor, mit noch installiertem Kaspersky hat es ja auch problemlos über die lokale IP des Server-PCs geklappt, die Medien auf dem Client-PC anzeigen zu lassen.

 

Habe nochmal auf beiden PCs Deine zwei Batch-Dateien mit den Firewall-Regeln laufen lassen - habe aber auch danach immer noch auf dem Client-PC eine leere Seite, wenn ich im Browser den Medienserver aufrufe. Nicht mal die Kategorien "TV", "Audio", "Video" usw. werden angezeigt. Nur der Frame vom "Medien"!Tab ist sichtbar - aber eben ohne Inhalte.

Nicht mal der Root-Eintrag "Medien>" wird angezeigt.

Ich habe auch Deine originale "Media_List.html" zurückgespielt - jedoch immer das Selbe, keine Medien auf dem Client-PC.

 

Habe auch testhalber einen Videoordner auf dem lokalen Laufwerk C des Server-PCs im Medienserver indizieren lassen, um auszuschliessen, dass es an den verbundenen Netzlauwerken auf dem Videoserver liegt, dass diese Videos nicht auf dem Client-PC angezeigt werden.

Aber auch die Videos aus C:Videos werden nicht auf dem Client-PCs angezeigt.

 

Komisch, dass es über meine DYNDNS-Adresse problemlos funktioniert.

Hast Du vielleicht noch eine andere Idee, woran es liegen könnte bzw. was ich noch versuchen kann?

Ansonsten muss ich halt damit leben, den Media-Server über meine DYNDNS aufzurufen.

 

Beste Grüsse
 

Share this post


Link to post
VeroWeed

Hallo Griga,

Die Netzwerke auf dem Medienserver-PC und dem Client-PC sind Beide "Ethernet - Privates Netzwerk".

Zuvor, mit noch installiertem Kaspersky hat es ja auch problemlos über die lokale IP des Server-PCs geklappt, die Medien auf dem Client-PC anzeigen zu lassen.

 

Habe nochmal auf beiden PCs Deine zwei Batch-Dateien mit den Firewall-Regeln laufen lassen - habe aber auch danach immer noch auf dem Client-PC eine leere Seite, wenn ich im Browser den Medienserver aufrufe. Nicht mal die Kategorien "TV", "Audio", "Video" usw. werden angezeigt. Nur der Frame vom "Medien"!Tab ist sichtbar - aber eben ohne Inhalte.

Nicht mal der Root-Eintrag "Medien>" wird angezeigt.

Ich habe auch Deine originale "Media_List.html" zurückgespielt - jedoch immer das Selbe, keine Medien auf dem Client-PC.

 

Habe auch testhalber einen Videoordner auf dem lokalen Laufwerk C des Server-PCs im Medienserver indizieren lassen, um auszuschliessen, dass es an den verbundenen Netzlauwerken auf dem Videoserver liegt, dass diese Videos nicht auf dem Client-PC angezeigt werden.

Aber auch die Videos aus C:Videos werden nicht auf dem Client-PCs angezeigt.

 

Komisch, dass es über meine DYNDNS-Adresse problemlos funktioniert.

Hast Du vielleicht noch eine andere Idee, woran es liegen könnte bzw. was ich noch versuchen kann?

Ansonsten muss ich halt damit leben, den Media-Server über meine DYNDNS aufzurufen.

 

Beste Grüsse

 

EDIT: Die freiggegebenen Ordner zwischen Server-PC und Client-PC haben problemlos gegenseitig Zugriff.

Die beiden Rechner befinden sich auch im selben Netz.

In der HW-Firewall sollte daher m.E. alles stimmen - oder?

Zumal mit installiertem Kaspersky ja alles OK war.
 

Share this post


Link to post
VeroWeed

Waaaah, der Firefox ist schuld - mit dem Chrome, IE und Edge klappt es problemlos.

Mir ist schon aufgefallen, dass sich der FF trotz Deinstallation von Kaspersky beim Aufruf von HTTPS-Seiten dennoch mit dem Kaspersky-Server verbinden wollte.

Danach habe ich im FF über "Programme und Features" - Deinstaliieren FF - "FF säubern" ausgeführt.

Dabei hat der FF wohl irgendwas wichtiges für diese Seite verloren (vielleicht eben das von Dir angesprochene Cookie?

Also werde ich jetzt den FF komplett deinstallieren und ein neues Profil anlegen.

Mal sehen, ob der dann den Media-Server wieder lieb hat.

 

Beste Grüsse und Danke nochmal für Deine Hilfe.

Share this post


Link to post
VeroWeed

P.S. Es hat schon gereicht, ein neues Profil im Firefox anzulegen - jetzt spricht der Media-Server auch im FF mit mir.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...