Jump to content

Internet-Radio-Streams beginnen nach ca. >20 min zu stocken


Recommended Posts

Viele Jahre war das ganz problemlos - mit dem Update auf DVBViewer 7 und Media-Server 3, inklusive den letzten Updates 7.0.1 habe ich folgendes Problem:

 

Einige Internet-Radio-Streams beginnen immer ganz reproduzierbar nach ca. 20-30 min ab Einschaltzeitpunkt zu stocken, d.h. Ton geht dann für 1 sec aus, geht 3 sec, geht wieder aus ... etc. Wenn ich dann zwischen zwei Sendern hin und her wechsle, funktionierts wieder ca. 20 min, dann geht das Problem von vorne los. Läuft da irgendein Puffer voll?

 

Betroffen sind z.B. folgende URLs:

 

http://mp3channels.webradio.antenne.de:80/chillout

http://rmnrelax1.powerstream.de:8023/

 

Seltsamerweise tritt das Problem z.B. bei Schwarzwald-Radio nicht auf:

 

http://str31.creacast.com:80/hitradio_ohr_thema1

 

Ich nutze die LAV-Audio-Decoder 0.74.1.

 

Viele Grüße,

Stefan

Edited by Rayman
Update
Link to comment
vor 11 Stunden schrieb Rayman:

Ich nutze die LAV-Audio-Decoder 0.74.1.

 

Mit oder ohne Auto A/V Sync Correction (siehe Eigenschaftsseite)? Das kann in diesem Zusammenhang auch ohne Video eine Rolle spielen. Wenn die Option ausgeschaltet ist, produziert der Decoder Zeitstempel anhand der Dauer der erhaltenen Audio Frames. Ist sie eingeschaltet, übernimmt er die vom Quellfilter erzeugten Zeitstempel. Sie bestimmen den Wiedergabezeitpunkt im Audio Renderer.

 

Weiterhin: Was zeigt die Eigenschaftsseite des DVBViewer Filters an, wenn es zu dem Problem kommt? Ein Screenshot wäre gut.

 

Kannst du verifizieren, dass das Problem mit dem DVBViewer 6.x unter ansonsten gleichen Bedingungen nicht auftritt?

 

Link to comment

P.S. Weitere Tests erübrigen sich wahrscheinlich. Ich konnte das Problem bei Verwendung des LAV Audio Decoder mit der Einstellung "Auto A/V Sync Correction ein" reproduzieren. Ohne Auto A/V Sync Correction tritt es wahrscheinlich nicht auf, aber das habe ich nicht überprüft.

 

Ursache sind winzige Abweichungen bei den vom DVBViewer produzierten Zeitstempeln. Sie treten nur bei "krummen" Sampleraten wie 44,1 kHz auf. Deshalb bleibt das Schwarzwaldradio mit 48 kHz verschont. Und der Fehler macht das, was kleine Fehler am liebsten machen: Sie kumulieren über die Zeit. Deshalb geht die Wiedergabe erst nach 20 bis 30 Minuten baden.

 

Ich werde bald einen Fix hochladen und sage dann hier Bescheid.

 

  • Thanks 1
Link to comment
vor 2 Stunden schrieb Griga:

Ohne Auto A/V Sync Correction tritt es wahrscheinlich nicht auf, aber das habe ich nicht überprüft.

 

Danke für die Überprüfung Griga! Ich habe Auto A/V Sync Correction ausgeschaltet und getestet. Der Fehler tritt trotzdem weiterhin auf.

 

Anbei ein Screenshot meiner LAV-Optionen; Grundsätzlich hatte ich dort keine Einstellungen vorgenommen, diese sind so wie sie bei Installation der LAV Decoder gesetzt worden (bis auf den Auto A/V Sync Test jetzt).

 

lav_options.PNG

Edited by Rayman
Fix
Link to comment
vor 14 Stunden schrieb Griga:

Ich habe den Fix hochgeladen. Nach einer Stunde war damit bei mir die Wiedergabe des Chillout-Senders immer noch ok. Nun probiere du es mal...

 

Danke für den Fix! Leider hat er bei mir bei beiden 44,1kHz Sendern NICHT geholfen. Weder mit "Auto A/V Sync correction" Option an, noch mit aus.

 

Ich habe den Fix (DVBViewer.exe mit Zeitstempel 13.01.2021 um 10:24 Uhr) sogar noch ein zweites Mal runtergeladen und rein-gepatcht, weil ich ein bisschen an mir selber gezweifelt habe. Pünktlich nach 25 Minuten beginnt der Stream wieder zu stocken. Edit: Bei nun insgesamt 6 Tests. 😞

Edited by Rayman
Weitere Tests
Link to comment
vor 6 Stunden schrieb Rayman:

Leider hat er bei mir bei beiden 44,1kHz Sendern NICHT geholfen.

 

Hier kein Problem, gerade noch mal überprüft. Ich bin schon bis zum Gehtnichtmehr gechillt, weil ich ständig diesen Sender testhöre. Aaaaber: Wenn es stimmt, was ich im Versionsverlauf geschrieben habe

 

Am 13.12.2020 um 16:48 schrieb hackbart:
  • Geändert: Media Server Client: Wenn der DVBViewer als Client eines Media Servers auf dem selben PC konfiguriert ist, delegiert er den Empfang aller TS Stream-Sender (außer denen mit localhost als Quelle) an den Webserver des Media Servers, der den Stream an den DVBViewer weiterleitet. Dies vermeidet eine doppelte Bandbreiten-Belegung, z.B. wenn der selbe Internet TV/Radio-Sender im DVBViewer wiedergegeben und gleichzeitig im Media Server aufgenommen wird. Bitte beachten: Dieses Feature erfordert den DVBViewer Media Server 3.0.0. oder eine spätere Version.

  • Ergänzt: Media Server Client: Der neue Tweak „TS Stream über den lokalen Media Server empfangen“ (→ Tweaker.exe starten) ermöglicht es, den TS Stream-Empfang über den Media Server auszuschalten, wenn unerwünscht (siehe oben).

 

brauchst du den Fix womöglich im Media Server? Daran hatte ich nicht gedacht, sorry... der ist noch nicht hochgeladen.

 

Link to comment

Ich habe hier den Chillout-Sender fast 90 Minuten am laufen gehabt und kein einziges Mal ein stocken gehabt, lief alles geschmeidig durch. Eventuell solltest du das Problem auf deiner Seite suchen oder aber es ist kein generelles Problem im DVBViewer. Getestet mit der Version 7.0.1.4

Link to comment

Doch, es war/ist ein Problem im DVBViewer und Media Server. Im DVBViewer 7.0.1.4 ist es bereits gefixt, aber @Rayman braucht wahrscheinlich in seiner Konfiguration den Fix im Media Server, den ich noch nicht hochgeladen habe. Anders ist nicht zu erklären, warum er bei ihm nicht greift.

 

Link to comment
vor 9 Stunden schrieb Griga:

Doch, es war/ist ein Problem im DVBViewer und Media Server. Im DVBViewer 7.0.1.4 ist es bereits gefixt, aber @Rayman braucht wahrscheinlich in seiner Konfiguration den Fix im Media Server, den ich noch nicht hochgeladen habe. Anders ist nicht zu erklären, warum er bei ihm nicht greift.

 

Ja, das stimmt! Ich nutze den Media Server. (Du kannst Dir mit dem Fix Zeit lassen, ich kann erst Anfang nächste Woche wieder testen ;-) )

Link to comment
Am 16.1.2021 um 10:48 schrieb Griga:

Es hängt nicht davon ab, dass du ihn nutzt, sondern wie du ihn nutzt (siehe meinen Post oben). Aber wie auch immer: Ich habe eine neue Hotfix-Version des Media Servers hochgeladen, die dich störungsfrei chillen sollte...

 

Mit dem Fix habe ich jetzt eine Stunde Radio gehört, alles ist wieder bestens! Ich danke Dir Griga!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...