Jump to content
Sign in to follow this  
mcdonald

nach Standby kein Bild, steigt nach öfterem Umschalten aus (CI)

Recommended Posts

mcdonald

support.zipVielen Dank für das schönes Stück Software. :D Es entspricht genau dem, was ich für meinen HTPC brauche, nur leider kommt nach dem Start aus dem Standby kein Bild und Ton mehr. Nach dem Schließen kommt dann immer eine Schutzverletzung. Funktioniert dann immer erst nach einem kompletten Neustart wieder, wie es sein soll. Es ist dabei egal, ob ich den DVBV über den Taskplaner oder manuell starte.

Desweiteren passiert das Selbe, wenn ich zwischen HDTV und SD-Kanälen hin- und herschalte. Irgendwann ist kein Bild und Ton mehr da. Nach Beenden dann wieder Schutzverletzung. Dann reicht aber ein einfacher Neustart. Ich habe ein T-Rex-Modul mit Original-Karte. Auch dauert es sehr lange (10Sek.) bis ein erstes Bild kommt.

Als erste Karte habe ich eine Technotrend DVB-S2 3200, auf "Normal" eingestellt. Als zweite Karte eine Hauppauge Nova plus, auch auf "Normal" eingestellt. Bei dieser Einstellung läuft die TT einwandfrei, die Hauppauge wird aber nicht genutzt. Kein Mosaik, oder Schauen auf einem anderen Kanal möglich, wärend der Aufnahme. Nur die Kanäle des gleichen Transponders natürlich.

Stelle ich die Nova auf "bevorzugt", dann geht zwar die Nova, aber die TT nicht mehr. (kein HDTV, kein CI, etc.)

Ich habe da schon alle Einstellungen durchprobiert, es gehen nie beide gleichzeitig. o:)

kann mir jemand bei diesen 3 Problemen helfen? :(

Share this post


Link to post
hdv

Hallo,

 

zu Standby,

 

benutzt du den DVB Task-Scheduler?

 

Desweiteren stelle mal den CyberLink Video/SP Decoder (PDVD7) als Video Decoder ein.

 

Bei dieser Einstellung läuft die TT einwandfrei, die Hauppauge wird aber nicht genutzt...Ich habe da schon alle Einstellungen durchprobiert, es gehen nie beide gleichzeitig
mache mit der TT eine Aufnahme und schalte auf einen anderen Transponder (Frequenz), dann wird die Hauppauge benutzt. o:)

 

Mosaik und Bild im Bild (Preview) funktionieren im DVBViewer Pro nur auf/mit einem Transponder.

Der DVBViewer GE unterstützt auch das anschauen von 2 Sendern, welche auf unterschiedlichen Frequenzen liegen, verwendet also beide Karten. Jedoch bietet der GE keine Unterstützung für CI.

 

:(

Share this post


Link to post
mcdonald
Hallo,

 

zu Standby,

 

benutzt du den DVB Task-Scheduler?

 

Desweiteren stelle mal den CyberLink Video/SP Decoder (PDVD7) als Video Decoder ein.

 

mache mit der TT eine Aufnahme und schalte auf einen anderen Transponder (Frequenz), dann wird die Hauppauge benutzt. o:)

 

Mosaik und Bild im Bild (Preview) funktionieren im DVBViewer Pro nur auf/mit einem Transponder.

Der DVBViewer GE unterstützt auch das anschauen von 2 Sendern, welche auf unterschiedlichen Frequenzen liegen, verwendet also beide Karten. Jedoch bietet der GE keine Unterstützung für CI.

 

:(

 

 

den CyberLink Video/SP Decoder (PDVD7) hab ich auch schon benutzt. Kein Unterschied. Den DVB-Scheduller benutze ich. Hat aber damit nix zu tun. Der DVBV startet nach dem Standby wie gewünscht, allerdings kommt kein Bild und kein Ton mehr. Auch wenn ich manuell starte. Erst, wenn ich einen Neustart mache, startet er wie gewünscht.

Was ist mit meinem Problem mit der Instabilität mit den HDTV-Kanälen? Ist das bekannt?

Edited by mcdonald

Share this post


Link to post
mcdonald

schade, dass niemand mir etwas zu meinem Standby-Problem sagen kann... ich hab alles aus dem Autostart, Speicher, etc. rausgemacht. es ist ein nacktes MCE-System.

Kann es sein, dass es an WinMCE liegt, dass der DVBV nach dem Standby kein Bild und kein Ton mehr zeigt? Aufnahmen abspielen funktioniert aber. Nach dem Beenden des DVBV kommt dann eine Win32-Ausnahmefehler-Meldung.

Share this post


Link to post
Derrick

Du musst schon genauer zwischen verschlüsselt und unverschlüsselt unterscheiden. Gilt es nach standby für beide kategorien?

 

Nur wenn du mehrere karten mit CI und karte gleichzeitig im betrieb hast, wäre ein preview von einem 2. verschlüsselten kanal während einer aufnahme (oder live wiedergabe) eines verschlüsselten programms möglich.

 

Verletzungsfehler beim schliessen kommen meist durch irgendwelche plugins. Um das einzuengen, ohne pluins probieren.

 

CI ist weit davon entfernt, perfekt zu funktionieren. Ob es bei mce besser oder schlechter ist, kann ich nicht sagen. Ich würde vermuten, gleich schlecht :bye:

Share this post


Link to post
mcdonald
Du musst schon genauer zwischen verschlüsselt und unverschlüsselt unterscheiden. Gilt es nach standby für beide kategorien?

 

Nur wenn du mehrere karten mit CI und karte gleichzeitig im betrieb hast, wäre ein preview von einem 2. verschlüsselten kanal während einer aufnahme (oder live wiedergabe) eines verschlüsselten programms möglich.

 

Verletzungsfehler beim schliessen kommen meist durch irgendwelche plugins. Um das einzuengen, ohne pluins probieren.

 

CI ist weit davon entfernt, perfekt zu funktionieren. Ob es bei mce besser oder schlechter ist, kann ich nicht sagen. Ich würde vermuten, gleich schlecht :bye:

 

verschlüsselt, oder unverschlüsselt... beides Mal das Selbe. Das hatte ich schon, als ich erst nur die Hauppauge alleine im System hatte. Ohne CI.

Ich hatte es mal mit diesem Meedio probiert... da ging das TV-Programm nach dem Standby einwandfrei. Verstehe bloß nicht, warum anscheinend niemand anderes das gleiche Problem hat... :bye:

Share this post


Link to post
gwr

Hi,

 

Meine Nova S Plus geht nach dem Standby auch nicht mehr.

Scheint bei mir mit Girder zusammen zu hängen. Ich benutze Girder für die Hauppaugefernbedienung.

Girder 3.2.9 + irremote.DLL von WINTV + Hauppauge IRRemote-Plugin von Peter Heitman + Girderplugin für den

DVBViewer.

Dabei habe ich nun folgendes beobachtet: wenn Girder vor dem Standby läuft, geht danach die Fernbed.

nicht mehr und die Nova gibt weder Bild noch Ton von sich.

Manchmal kann ich Tuner/Demod durch Deaktivieren und Aktivieren im Gerätemanager wieder zum Leben

erwecken.

Machmal auch den IR-Decoder für die Fernbedienung. Girder muss ich vor diesem Reset beenden und dann wieder starten.

Meistens geht die Fernbedienung aber erst nach einen Neustart wieder.

Ich habe auch schon das andere Hauppauge-Plugin für Girder von Jeffrey Harris probiert. (wird hier in den

Anleitungen empfohlen) Das Verhalten ist das Gleiche.

Beende ich dagegen Girder vor dem Standby, ist die Karte danach noch funktionsfähig.

Das Tool von Hauppauge für die Fernbedienung zeigt dieses Verhalten nicht. Ist aber umstandlich für

den DVBViewer einzurichten und geht wohl nur wen dieser im Vordergrund ist.

Scheinbar greift Girder über das IRRemote-Plugin und die irremote.DLL im falschen Zeitpunkt

auf die Karte zu und schiesst diese ab.

Beim Ruhemodus sieht es so aus, daß nach dem aufwachen nur die Fernbedienung nicht geht,

Bild und Ton funktioniert noch. Die Fernbedienung konnte ich bis jetzt immer durch beenden von

Girder, reset des IR-Decoders und neustart von Girder wieder beleben.

Auch hier funktioniert nach dem Aufwachen noch alles,wenn ich vor dem Einschlafen Girder beende.

 

So sind meine Beobachtungen, ob das immer so ist weiss ich nicht. hatte noch nicht viel Zeit der

Sache nach zugehen. Vielleicht spielen da auch noch andere Sachen mit rein.

 

Zur Technotrend DVB-S2 3200 (hab ich nicht) gibt es hier eine Meldung über Probleme

nach dem Standby.

Mit der dort empfohlenen devcon.exe bin ich nicht klar gekommen. Die deaktiviert oder resetet

alles mögliche nur nicht das was sie soll.

So, das war alles.

 

mfG Gerd

Edited by gwr

Share this post


Link to post
mcdonald
Hi,

 

Meine Nova S Plus geht nach dem Standby auch nicht mehr.

Scheint bei mir mit Girder zusammen zu hängen. Ich benutze Girder für die Hauppaugefernbedienung.

Girder 3.2.9 + irremote.DLL von WINTV + Hauppauge IRRemote-Plugin von Peter Heitman + Girderplugin für den

DVBViewer.

Dabei habe ich nun folgendes beobachtet: wenn Girder vor dem Standby läuft, geht danach die Fernbed.

nicht mehr und die Nova gibt weder Bild noch Ton von sich.

Manchmal kann ich Tuner/Demod durch Deaktivieren und Aktivieren im Gerätemanager wieder zum Leben

erwecken.

Machmal auch den IR-Decoder für die Fernbedienung. Girder muss ich vor diesem Reset beenden und dann wieder starten.

Meistens geht die Fernbedienung aber erst nach einen Neustart wieder.

Ich habe auch schon das andere Hauppauge-Plugin für Girder von Jeffrey Harris probiert. (wird hier in den

Anleitungen empfohlen) Das Verhalten ist das Gleiche.

Beende ich dagegen Girder vor dem Standby, ist die Karte danach noch funktionsfähig.

Das Tool von Hauppauge für die Fernbedienung zeigt dieses Verhalten nicht. Ist aber umstandlich für

den DVBViewer einzurichten und geht wohl nur wen dieser im Vordergrund ist.

Scheinbar greift Girder über das IRRemote-Plugin und die irremote.DLL im falschen Zeitpunkt

auf die Karte zu und schiesst diese ab.

Beim Ruhemodus sieht es so aus, daß nach dem aufwachen nur die Fernbedienung nicht geht,

Bild und Ton funktioniert noch. Die Fernbedienung konnte ich bis jetzt immer durch beenden von

Girder, reset des IR-Decoders und neustart von Girder wieder beleben.

Auch hier funktioniert nach dem Aufwachen noch alles,wenn ich vor dem Einschlafen Girder beende.

 

So sind meine Beobachtungen, ob das immer so ist weiss ich nicht. hatte noch nicht viel Zeit der

Sache nach zugehen. Vielleicht spielen da auch noch andere Sachen mit rein.

 

Zur Technotrend DVB-S2 3200 (hab ich nicht) gibt es hier eine Meldung über Probleme

nach dem Standby.

Mit der dort empfohlenen devcon.exe bin ich nicht klar gekommen. Die deaktiviert oder resetet

alles mögliche nur nicht das was sie soll.

So, das war alles.

 

mfG Gerd

 

ich hab sämtliche Plugins rausgeschmissen, und versucht, das System so nackt wie möglich laufen zu lassen. Es ist immer das Selbe. Nach Standby kein TV-Programm.

Aber ja, das Girder-Plugin und auch das JaLCD-Plugin steigen auch öfters aus. Leider gibts von beiden keine neueren Versionen. Und Alternativen auch nicht.

Share this post


Link to post
gwr

Hast Du Girder mal vor dem Standby beendet?

Passiert es dann immer noch?

Wie schon beschrieben, habe ich auch bessere Erfahrungen mit dem Ruhezustand gemacht, da geht

wenigstens der Empfang noch. Vielleicht das mal versuchen.

 

mfG Gerd

 

Nachtrag neue Erkenntnis nach Ruhezustand: ich brauch den IR-Decoder gar nicht zu reseten,

sondern nur Girder beenden und neu starten. dann geht die FB wieder :jump:

Edited by gwr

Share this post


Link to post
edudvd

Hallo

wegen dem Standbyproblem mit der Technotrend DVB-S2 3200 (auch andere ältere Karten sind davon betroffen)

Probiert mal:

Devcon und WatchTVProDevcon siehe:

http://www.dvbshop.net/forum/modules.php?n...p;view=previous

oder Devcon solo:

http://www.dvbshop.net/forum/modules.php?n...ht=devcon#18137

 

Ich habe auch eine Technotrend DVB-S2 3200 und bei mir geht es mit folgenden bat file:

c:\Programme\devcon_789\devcon.exe restart *PCI\VEN_1131

 

Das hilft übrigens auch falls die Karte von system sporadisch mit "fehler 10" nicht erkannt wird. Das hatte ich auf meinen alten Rechner mit via600 Mainboard.

Aber mit meinem neuen Asus P5b-E mir Core 2 duo E6300 @z.Z. 2800mhz (aber da geht sicher noch mehr:)) habe ich dieses Problem nicht und schnell genug für Premiere HD ist er auch mit standart Tackt;)

Nur leider habe ich mit dem cam welches bei HD geht bei Premiere SD also 1-4 und die anderen ca. alle 60 sec. bild und Tohnaussetzer:(

Das scheint ein allgemeines Problem des Cams zu sein bzw dessen Sotware aber das ist ein anderes Thema und betrifft wohl nur die alten 4.1? Die neuen Superduper 4.6 sollen auch bei SD, mit natürlich originaler PW Karte, einwandfrei laufen? Aber 1. sind die schweine teuer ~125,- und ausserdem kaum lieferbar :angry:

Da stecke ich für PW SD doch lieber mein URALT irdetto allcam se ins CI. Das läuft bei SD nach wie vor einwandfrei ;)

 

Gruß

Edu

Share this post


Link to post
dagolard

Habe dasselbe Problem. Nach Standby - kein Bild. XP Pro mit FireDTV C/CI (DVB-C).

Also bist Du nicht der einzige :)

Nur daß es bei mir nach 3-4* Umschalten plötzlich wieder geht....

 

Werd wohl mal so eine "Support.zip" machen müssen (wenn ich rausfinde, wie).

Share this post


Link to post
dagolard

So, da haben wir die Support.zip :)

 

Nebenbei habe ich den Effekt mal bei Mediaportal getestet - das hat in der Beziehung kein Problem. Muß also ein Kommunikationsproblem zwischen DVBViewer und dem BDA-Treiber sein.

 

Kleine Nebenfrage für experten: gibt es einen Remotecontrol-Editor? Würde meine MCE-Fernbedienung gern voll nutzen (z.B. daß er auf "Video" springt, wenn ich die Videotaste drücke...). Oder hat jemand eine in dieser Weise bereits konfigurierte mce.remote? :)

support.zip

Share this post


Link to post
Engelbert

FB gehört nicht zu meinen Interessen, habe ich seit Jahr und Tag ausgelassen.

 

Deine PRO läßt sich allerdings mit der Beta V 3.5.0.100 (intern 101) aktualisieren, dabei bitte auch den DVB Filter auf V 2.8.2 (und registrieren!) nach Anleitung.

 

Deine Cyberlink-Decoder sind wohl älter.

Derzeit empfiehlt sich als Video-Decoder der von Cyberlink (PowerDVD 6 besser noch 7, Trial genügt), als Audio-Decoder beide male der Ac3Filter:

http://www.soft-ware.net/multimedia/audio/...licht=AC3Filter

 

Das Standby-Problem kann auch daran liegen, daß Dein Mainboard bzw. BIOS nach dem Hochfahren keine Neuinitialisierung der Karte zuläßt.

Share this post


Link to post
dagolard

Also ich hab die Beta ja schon drauf und den cyberlink decoder (6.0) aktiv; den DVB-Filter aktualisieren kann ich auch noch.

 

Der Firewire Port (und damit die Karte) werden beim Aufwachen neu initialisiert. Daran kann es nicht liegen; auch ein ziehen und wieder einstecken bringt nix. Meine Vermutung geht eher dahin, daß der DVBViewer gerade WEGEN der Neuerkennung der Karte ein Problem hat. Fragt sich, wie das in Mediaportal gehandled wird, da dort das Problem nicht auftritt.

 

Vielleicht müßte der DVBViewer einfach beim Reaktivieren aus dem Standby den "gemerkten" letzten Kanal neu anwählen.

 

Ich kann evtl. mal versuchen, einen anderen Remote-Treiber zu verwenden. Dieser würde dann ja "durch" Mediaportal angesprochen. Die Standby-Taste der MCE geht ja direkt auf die Win-Funktion...

 

Eine Funktion, die den DVBViewer vor dem Standby schließt und nach dem Standby wieder startet, wäre genial :)

Edited by dagolard

Share this post


Link to post
dagolard

So, alles gemacht. Kein Ergebnis. An der FB liegt es übrigens nicht; nachdem ich den PC so konfiguriert habe, daß er per Power-Taste in den Standby geht, tritt der Fehler immer noch auf. :)

Und nu kommst Du ;)

 

Am Treiber der Karte liegt es jedenfalls nicht. Die funzt unter MCE und Mediaportal, wie sie soll. Aber ich will den DVBViewer nutzen! (geringere CPU-last, bessere Bedienbarkeit). Nur wenn dat net jeht, waren 15 Euronen in den Sand gesetzt :)

Share this post


Link to post
Engelbert

Naja, auch wenn die 'üblichen Verdächtigen' nicht helfen, sind Deine 15 € noch lange nicht verloren.

 

Mangels Deiner FireDTV-Cab CI muß da wohl jemand helfen, der sich mit den Besonderheiten dieses Teil auskennt.

 

Versuche doch mal mit der 'Suche' die nicht wenigen Beiträge zu Deiner Karte 'durchzuflöhen'.

Share this post


Link to post
dagolard

Hab noch etwas experimentiert. Kann es ein Timing-Problem sein?

Der Firewire-Anschluß wird nach dem Aufwecken neu initialisiert. Soweit klar; ich höre das Getütel meiner 4USB- und des Firewireports deutlich beim Aufwecken.

Ein ähnlicher Effekt wie nach dem Standby entsteht aber auch, wenn ich kurz den Firewire Stecker ziehe. Bild bleibt stehen, dann geht aber trotz Einstecken erst wieder was, wenn ich DVBViewer neu starte. Dieser reagiert also "allergisch" auf Trennung von Komponenten an Firewire (und evtl. USB?). Also würde es eventuell was bringen, den DVBViewer tatsächlich vor dem Standby zu beenden und nach dem Standby neu zu starten. Würde ja nur wenige Sekunden Unterschied machen.

 

Hat jemand eine Lösung dafür? :)

 

P.S. Gesucht hab ich schon. Leider nix gefunden...

Edited by dagolard

Share this post


Link to post
Griga

Ich kann den Effekt mit meiner FireDTV-S simulieren, indem ich softwaremäßig die LNB-Stromversorgung abschalte. Da der DVBViewer Pro sie (noch) nicht beim Start automatisch einschaltet, ist der Sender natürlich erst mal tot. Wenn ich jetzt die LNB-Stromversorgung außerhalb des DVBViewers aktiviere, bleibt er tot.

 

Das hat mit einer Eigenart der FireDTV-Tuner zu tun. Wenn ein Sender nach dem Einschalten keine Daten liefert, schaltet sich das Gerät quasi ab und merkt auch nicht, wenn später doch Daten kommen. In gang kommt es nur, wenn man einen neuen Tune-Befehl sendet. Dies geschieht beim DVBViewer aus Effizienzgründen nur, wenn man einen Sender auf einer anderen Frequenz einschaltet - bei einem Senderwechsel innerhalb ein- und der gleichen Frequenz ist das normalerweise nicht nötig. Deshalb vermutlich:

 

Nur daß es bei mir nach 3-4* Umschalten plötzlich wieder geht....

Allerdings gibt es ein Gegenmittel, das in dem oben beschriebenen Fall bei mir funktioniert: Optionen -> Hardware -> Gerät wählen -> bei fehlendem Stream neu tunen nach... z.B. auf 2 Sekunden stellen. Dann wiederholt der DVBViewer den Tune-Befehl, bis Daten kommen.

Share this post


Link to post
dagolard

Hab ich schon gemacht. Bringt Nix bei der Karte. Bin auch kein totaler Computeranfänger, aber das Problem ist echt ein harter Brocken.

 

Axo - wieso verschwinden eigentlich Beiträge mit Ergänzungskommentaren zu meinem letzten Beitrag? Da hatte ich das nämlich schon dargelegt.

 

Wäre folgender Beitrag im firedtv-Forum ein Hinweis zur Fehlereingrenzung? http://www.firedtv.com/Forums/tabid/311/fo...ic/Default.aspx

Mich deucht, die Ursache könnte dieselbe sein :)

Share this post


Link to post
hdv

Hallo,

 

Eine Funktion, die den DVBViewer vor dem Standby schließt und nach dem Standby wieder startet, wäre genial
verwende für solche Sachen bitte den DVB Task Scheduler.

Dieser achtet darauf, das vor Ruhezustand/Standby der DVBViewer geschlossen wird.

 

Siehe hier, DVBViewer starten nach Ruhezustand

 

:)

Share this post


Link to post
dagolard
verwende für solche Sachen bitte den DVB Task Scheduler.

Dieser achtet darauf, das vor Ruhezustand/Standby der DVBViewer geschlossen wird.

Danke für den Tip. Werde es mal testen.

 

Wäre es denn möglich, eine Routine in den DVBViewer einzuarbeiten, die genau das tut? Also

Shutdown DVBViewer - Standby als Befehlsfolge?

Share this post


Link to post
Griga
Hab ich schon gemacht. Bringt Nix bei der Karte.

Ich hatte noch etwas vergessen: "Stream beim Tunen stoppen" muss eingeschaltet sein, sonst reagiert die FireDTV nicht auf die wiederholten Tune-Befehle. Eine weitere Eigenart von dem Teil.

 

Wäre es denn möglich, eine Routine in den DVBViewer einzuarbeiten, die genau das tut? Also

Shutdown DVBViewer - Standby als Befehlsfolge?

:) Was für ein Vorschlag! Erst beendet sich ein Programm, und dann veranlasst es Standby? Sozusagen post mortem? Das ist doch wohl nicht dein Ernst!

 

Andersherum: Wenn ein Programm Standby auslöst, kann es sich nicht mehr beenden, weil der Aufruf der entsprechenden Windows-Funktion erst nach dem Wiederaufwachen zurückkehrt. Schlag nach bei MSDN.

 

Genau deshalb gibt es den DVB Task Scheduler...

Share this post


Link to post
villi

Ich hänge mich hier ab heute auch mal ran:

Und zwar habe ich rausgefunden, dass bei mir Fehler produziert werden (die man meist erst mit ProjectX entdeckt) und zwar nur dann wenn ich aus dem Ruhezustand hoch fahren lasse.

 

Ich habe es ausprobiert: Pay-TV automatisch starten, Aufnahme, sieht alles ganz normal aus.

Bis ich einen sehr kleinen Ruckler bemerkte. Da kam mir die Idee...

 

Noch ein paar Minuten weiter, dann die Aufnahme abgebrochen und PC neugestartet.

DVBViewer gestart, Aufnahme aktiviert - keine Fehler.

 

Tja - ich behaupte mal einfach: ACPI ??? :D

Das Thema ist doch nach wie vor nicht aus der Welt, wenn ich da an die letzten Tests von Kabel-Digital-Karten oder SAT-Karten in der C´t denke.

 

Hilft wieder mal der Autostart und BIOS was? :)

Der DVBTaskscheduler macht das ja alles sehr gut - für mich liegt es ganz klar an Hardwareherstellern, Treibern usw. ganz einfach deswegen, weil es eben nach dem Aufwachen da Probleme gibt.

 

Was anderes wie den DVBViewer starten macht der DVBTaskscheduler nicht (genau zur richtigen Zeit):

Aber wenn ich den DVBViewer dann von HAND starten würde, hätte ich doch genau die gleichen Probleme, also liegt es am Ruhezustand (ACPI usw.) weil die Treiber, Hardware damit nicht zurecht kommt.

 

GEZ-Pay-TV (öffentlich rechtliche) und Privates Free-TV habe ich auch hin und wieder Probleme.

Nur ich konnte es noch nicht so beweisen wie heute.

 

P.S. Zum Anfang kommen die Fehler, dass ist schon klar. Aber nach nicht mal 30 Sekunden sieht man davon "normal" nichts mehr im Bild.

support.zip

ProjectX_log_mit_Ruhezustand.txt

ProjectX_DVBViewer_normal_gestartet_log.txt

Edited by villi

Share this post


Link to post
dagolard
:D Was für ein Vorschlag! Erst beendet sich ein Programm, und dann veranlasst es Standby? Sozusagen post mortem? Das ist doch wohl nicht dein Ernst!

Andersherum: Wenn ein Programm Standby auslöst, kann es sich nicht mehr beenden, weil der Aufruf der entsprechenden Windows-Funktion erst nach dem Wiederaufwachen zurückkehrt. Schlag nach bei MSDN.

 

Doch, ist mein Ernst! Eine Routine muß nicht unbedingt im Programm verankert sein. Wenn ich ein externes Programm (z.B. DVB Task Scheduler) aus dem DVBViewer heraus starte, kann dieses genau das tun, was der DVBViewer selbst nicht kann ;). Wußtest Du, daß Windows neuerdings Multitasking-fähig ist (auch mit nur einem Prozessor)? :P

 

Ich schau mir den Scheduler morgen mal an. Heut geht nicht, sonst werde ich von meiner besseren Hälfte exkommuniziert oder so. :) ...

Share this post


Link to post
Benarty
Doch, ist mein Ernst! Eine Routine muß nicht unbedingt im Programm verankert sein. Wenn ich ein externes Programm (z.B. DVB Task Scheduler) aus dem DVBViewer heraus starte, kann dieses genau das tun, was der DVBViewer selbst nicht kann :P. Wußtest Du, daß Windows neuerdings Multitasking-fähig ist (auch mit nur einem Prozessor)? :D

 

Ich schau mir den Scheduler morgen mal an. Heut geht nicht, sonst werde ich von meiner besseren Hälfte exkommuniziert oder so. :) ...

 

 

Das standby problem kan einfach gelöst werden.

Vor standby DVB karte treiber stoppen.

Nach standby DVB karte treiber starten, dan DVBViewer.

 

So DVBViewer: exit nach standby = ...treiber stoppen dann standby.

Aufwachen aus standby, DVBViewer soll ein mechanismus haben das erst der treiber zurück gestarted wird, dan reststart von DVBViewer.

 

 

Diese methode löst alle standby probleme mit alle karten.

Share this post


Link to post
Griga
Doch, ist mein Ernst! Eine Routine muß nicht unbedingt im Programm verankert sein. Wenn ich ein externes Programm (z.B. DVB Task Scheduler) aus dem DVBViewer heraus starte, kann dieses genau das tun, was der DVBViewer selbst nicht kann

Herzlichen Glückwunsch! Du hast die Lösung gefunden! Genial! Allerdings sind wir auf den Trick schon etwas früher gekommen und haben dann den DVB Task Scheduler programmiert... :D

 

Wußtest Du, daß Windows neuerdings Multitasking-fähig ist (auch mit nur einem Prozessor)?

Tatsächlich? Was du nicht sagst. Das haut mich jetzt aber um! :) Wenn das wahr sein sollte, müssten wir einiges im DVBViewer komplett neu konzipieren.

 

Ich schau mir den Scheduler morgen mal an. Heut geht nicht, sonst werde ich von meiner besseren Hälfte exkommuniziert oder so.

Willst du damit etwa sagen, dass *du* nicht multitasking-fähig bist? Sehr schwaches Bild... :P

Share this post


Link to post
dagolard
Willst du damit etwa sagen, dass *du* nicht multitasking-fähig bist? Sehr schwaches Bild... :D

 

Ja ich weiß. Liegt wohl daran, daß mein persönlicher Bordcomputer aus dem Jahre 1963 stammt und noch unter CP/M 1.0815 läuft :)

 

Wenigstens habt ihr hier Humor. Ist viel wert. In manchen Foren (z.B. einigen Zigarrenforen) springen Leute rum, die nehmen sich ja sooooo wichtig :P

Share this post


Link to post
Engelbert

Altes Sprichwort:

 

'Spaß muß sein bei der Beerdigung, sonst geht keiner mit.'

Share this post


Link to post
mcdonald
Also ich hab die Beta ja schon drauf und den cyberlink decoder (6.0) aktiv; den DVB-Filter aktualisieren kann ich auch noch.

 

Der Firewire Port (und damit die Karte) werden beim Aufwachen neu initialisiert. Daran kann es nicht liegen; auch ein ziehen und wieder einstecken bringt nix. Meine Vermutung geht eher dahin, daß der DVBViewer gerade WEGEN der Neuerkennung der Karte ein Problem hat. Fragt sich, wie das in Mediaportal gehandled wird, da dort das Problem nicht auftritt.

 

Vielleicht müßte der DVBViewer einfach beim Reaktivieren aus dem Standby den "gemerkten" letzten Kanal neu anwählen.

 

Ich kann evtl. mal versuchen, einen anderen Remote-Treiber zu verwenden. Dieser würde dann ja "durch" Mediaportal angesprochen. Die Standby-Taste der MCE geht ja direkt auf die Win-Funktion...

 

Eine Funktion, die den DVBViewer vor dem Standby schließt und nach dem Standby wieder startet, wäre genial :)

 

Ich hab den Cyberlink decoder 7.0. Geht trotzdem nicht nach dem Standby. Umschalten hilft bei mir allerdings auch nicht.

Den DVBViewer vor dem Standby zu schliessen und nach dem Standby wieder zu starten geht ganz einfach mit dem DVB Task Scheduler. Hilft bei mir allerdings auch nicht.

Ich habe schon das Motherboard in Verdacht... es ist ein Intel DG965SSCK S775 mit einem Core2Duo.

Habe den DVBV jetzt mal testweise auf meinen Medion MD8800 mit eingebauter Doppel-DVB-Karte installiert, da funktioniert es einwandfrei...

Edited by mcdonald

Share this post


Link to post
Derrick

Der thread is sehr unübersichtlich geworden und es laufen anscheinend mehrere probleme durcheinander. Man kann das verhalten der TT_PCI-karte nicht gut mit der FireDTV_Firewire-karte vergleichen. Die erste habe ich nicht aber zur 2. kann vielleicht einige dinge ergänzen. Nicht dass dadurch die probleme gelöst werden.. :)

 

Schliessen und öffnen der firedtv mit dem DVBViewer bewirkt keinen reset vom CI. Stärker noch, die smart card wird weiterhin mit ECMs/EMMs gefüttert (kann dann irgendwann festlaufen).Abschalten des LNBs hat zwar zur folge, dass nichts mehr empfangen wird (bei bestimmten konfigurationen, wo die lnbs anders gespeist werden, bin ich mir da auch nicht so sicher :D ) und damit natürlich auch die CA_streams versiegen.

 

Beim erwachen aus dem standby wird auch das CI neu gestartet, da die ganze karte stromlos war. Aber aufgepasst, das gilt nur für die grossen 6-poligen 1394-stecker, da darüber auch die stromversorgung läuft. Mit den kleinen, in notebooks verbauten steckern funktioniert reset über standby nicht, da die karte über das externe steckernetzteil versorgt wird.

 

Wenn das CI einmal hängt, ist es beim DVBViewer nur durch reset wiederzubeleben. Reset funktioniert aber nur über kappen der versorgung oder ziehen des moduls/karte.

 

Verbessern liesse sich das verhalten, wenn es so wie bei MT läuft. Da werden lnb/ci zwar auch nicht abgeschaltet beim beenden des programms, es erfolgt aber immer ein reset beim start des programms..

Share this post


Link to post
dagolard

So, dank dem Scheduler geht es nun. Zwar spinnt jetzt die Fernbedienung, wenn ich den Neustart zu schnell mache, aber bei 15s Verzögerung ist alles erkannt und der Tag gerettet.

 

Aber keine Bange, die nächsten Probleme finde ich mit Sicherheit . :)

Share this post


Link to post
villi

Meine Meinung

 

Finger weg von TWINHAN CAB-CI und dem Ruhezustand.

 

Ich habe einen Test gemacht, mit einem Sender im Pay-TV "Freitag der 13." dann wisst ihr welchen Sender ich meine.

 

-Und zwar eine Aufnahme programmiert

-der DVBTaskscheduler hat sie richtig eingetragen

-den Rechner in Ruhezustand runtergefahren

-Rechner wachte kurze Zeit später wieder auf

-DVBViewer wurde gestartet

-Kanal eingestellt und ich konnte schon die Fehler sehen... das ganze habe ich dann 15 Minuten laufen lassen.

 

*ProjectX meldet mir auch Minuten nach Beginn der Aufnahme noch einen Haufen Fehler!

 

-Rechner neugestartet um bei Null zu beginnen

-Dann noch einmal um es zu beweisen, dass gleich Spiel

-Rechner konnte aber gar nicht erst aus dem Ruhezustand hochfahren weil ich einen BLUE SCREEN bekam mit dem Fehler "MTSBDA.SYS" verursachte einen Fehler.

-Wenn man jetzt bei der Installation der TWINHAN BDA-Treiber aufgepasst hat, dann weiß man das diese .sys Datei dazu gehört.

 

Da es nicht das erste mal ist, dass ich auf diesem Sender Fehler habe und zwar nur nach dem Aufwachen aus dem Ruhezustand ist genau da das Problem.

 

Ich habe danach noch mal einen Test gemacht, der DVBTaskscheduler arbeitet ja perfekt, deswegen brauche ich keinen Autostart-Ordner...

 

-Also Programm einprogrammiert

-Rechner neugestartet

-Im BIOS wie früher eine Startzeit einprogrammiert, 4 Minuten vor dem Taskscheduler

-Rechner runtergefahren

-Rechner startete neu

-nach einiger Zeit startete auch der DVBViewer

-Die Aufnahme startet

-nach 15 Minuten NULL FEHLER wenn man mal von der Zeit 0.00.00 absieht in der die Entschlüsselung gerade erst beginnt...

 

P.S. Schöne Welt der Ruhezustand und Standby-Modi.

Wenn es denn funktioniert bzw. die Treiber das mitmachen. Für mich hat sich das erledigt, da lasse ich lieber den Rechner laufen (auch wenn es mehr Strom kostet) selten gezeigte Sachen im TV sind mir da wichtiger.

Es gibt ja leider nicht alles zu kaufen...

Edited by villi

Share this post


Link to post
Engelbert

Da läßt sich kaum widersprechen.

 

Allerdings macht meine TwinHan mit Standby und Ruhezustand keine derartigen Probleme, dafür haben die Aufnahmen hunderte bis tausende Fehler pro Stunde - Kabelprobleme? Die CableStar kanns fehlerfrei (ohne CI).

 

Abgesehen von der obendrein bisher mangelhaften CI-Unterstützung, die ja mit der nächsten PRO-Beta wohl besser wird, kann man von TwinHan-Cab-CI vorerst wohl nur abraten - Conexant und Mantis - bis die Ursachen klar sind.

Edited by Engelbert

Share this post


Link to post
mcdonald

das vielgeratene Tool Devcon.exe ist leider auch nicht unbedingt eine grosse Hilfe... es verlangt nämlich nach dem Desable und Enable der Karte einen Neustart. Da kann ich gleich Neustarten...

Das WatchTVProDevcon macht alles richtig, allerdings nur bei meiner Nova... so etwas bräuchte ich für die TT-3200

Edited by mcdonald

Share this post


Link to post
yaRincewind

Was die Probleme mit der TwinHan und den Errors angeht, so kann ich dem nur zustimmen. Allerdings ist es wohl kein Problem welches die Karte prinzipiell hat, sondern nur in bestimmten Boards auftritt.

 

Kollege von mir hatte das Ding => zig Fehler

Er hat sich neues Board gekauft (~400€)=> keine Fehler mehr

 

Ich hatte das Ding => zig Fehler

Andere Sat Karte gekauft (~170€)=> keine Fehler mehr :blink:

 

Bei mir waren es übrigens immer so um die 20-40 Fehler / 2 Stunden, egal ob mit CI oder ohne.

Share this post


Link to post
edudvd
das vielgeratene Tool Devcon.exe ist leider auch nicht unbedingt eine grosse Hilfe... es verlangt nämlich nach dem Desable und Enable der Karte einen Neustart. Da kann ich gleich Neustarten...

Das WatchTVProDevcon macht alles richtig, allerdings nur bei meiner Nova... so etwas bräuchte ich für die TT-3200

Wieso Dissable und Enable?

Bei mir geht es mit "restart *PCI\VEN_1131" siehe:

C:\>c:\Programme\devcon_789\devcon.exe restart *PCI\VEN_1131

PCI\VEN_1131&DEV_7146&SUBSYS_101913C2&REV_01\4&1FAF5EA3&0&10F0: Restarted

1 device(s) restarted.

Geht das bei dir nicht?

Share this post


Link to post
mcdonald
Wieso Dissable und Enable?

Bei mir geht es mit "restart *PCI\VEN_1131" siehe:

 

Geht das bei dir nicht?

 

C:\Dokumente und Einstellungen\chef>devcon restart *PCI\VEN_1131

PCI\VEN_1131&DEV_7146&SUBSYS_101913C2&REV_01\4&35FAE160&0&08F0: Requires reboot

Not all of 1 device(s) restarted, at least one requires reboot to complete the o

peration.

 

sonst noch irgendwelche Ideen? enable geht ohne Restart. Es kommt aber kein Bild... disable verlangt wiederum restart...

Edited by mcdonald

Share this post


Link to post
edudvd
C:\Dokumente und Einstellungen\chef>devcon restart *PCI\VEN_1131

PCI\VEN_1131&DEV_7146&SUBSYS_101913C2&REV_01\4&35FAE160&0&08F0: Requires reboot

Not all of 1 device(s) restarted, at least one requires reboot to complete the o

peration.

 

sonst noch irgendwelche Ideen? enable geht ohne Restart. Es kommt aber kein Bild... disable verlangt wiederum restart...

Lass mich raten...

 

Du hast dabei den DVBViewer oder eine andere Software die die TT-3200 benutzt gestartet?

 

Genau diese Meldung bekomme ich wenn ich devcon starte während DVDviewer läuft.

Ist ja auch klar das die karte nicht reseted werden kann während ein Programm darauf exclusiv zugreift.

 

Also DVBViewer beenden und noch ein Mahl

"C:\>c:\Programme\devcon_789\devcon.exe restart *PCI\VEN_1131"

Eventuell geht es dann?

Share this post


Link to post
mcdonald
Lass mich raten...

 

Du hast dabei den DVBViewer oder eine andere Software die die TT-3200 benutzt gestartet?

 

Genau diese Meldung bekomme ich wenn ich devcon starte während DVDviewer läuft.

Ist ja auch klar das die karte nicht reseted werden kann während ein Programm darauf exclusiv zugreift.

 

Also DVBViewer beenden und noch ein Mahl

"C:\>c:\Programme\devcon_789\devcon.exe restart *PCI\VEN_1131"

Eventuell geht es dann?

 

Negativ. Ich habs sogar nach einem Neustart, nicht nach Standby probiert. Den Autostartordner geleert, weil ich dachte, JaLcd oder Girder könnten was damit zu tun haben. Die selbe Meldung. Verlangt Neustart.

 

Also... ich hab jetzt nochmal folgendes Probiert: Ich hab nach einem Neustart alle Tasks die ich beenden konnte, beendet. Mein MCE sieht plötzlich aus wie Win98 ;-) dann:

 

C:\Dokumente und Einstellungen\chef>devcon disable *PCI\VEN_1131

PCI\VEN_1131&DEV_7146&SUBSYS_101913C2&REV_01\4&35FAE160&0&08F0: Disabled

1 device(s) disabled.

 

C:\Dokumente und Einstellungen\chef>devcon enable *PCI\VEN_1131

PCI\VEN_1131&DEV_7146&SUBSYS_101913C2&REV_01\4&35FAE160&0&08F0: Enabled

1 device(s) enabled.

 

soweit so gut... da scheint es dann zu funktionieren. Ich weiss nur nicht, welcher Task das war...

Dann hab ich es nochmal mit Restart probiert:

 

C:\Dokumente und Einstellungen\chef>devcon restart *PCI\VEN_1131

PCI\VEN_1131&DEV_7146&SUBSYS_101913C2&REV_01\4&35FAE160&0&08F0: Requires reboot

Not all of 1 device(s) restarted, at least one requires reboot to complete the o

peration.

 

Das geht also nicht... Dann habe ich ein Standby gemacht, nach dem wieder hochfahren ein Disable probiert:

 

C:\Dokumente und Einstellungen\chef>devcon disable *PCI\VEN_1131

PCI\VEN_1131&DEV_7146&SUBSYS_101913C2&REV_01\4&35FAE160&0&08F0: Disabled on rebo

ot

Not all of 1 device(s) disabled, at least one requires reboot to complete the op

eration.

 

Also geht anscheinend ein Disable nur nach einem Neustart...

Edited by mcdonald

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...