Jump to content
maluk

Online Mediathek

Recommended Posts

maluk

Ich habe eine kleine Änderung an der OnlineMediathek.dll vorgenommen. Überschreibe bitte die DLL im Plugins-Verzeichnis mit der angehängten DLL (vorher entzippen) und versuche es nochmal.

Edited by maluk

Share this post


Link to post
quax1306

Sorry, kein Erfolg :blush:

 

Ich versuche mal einen Screenshot anzuhängen.

post-13588-0-60783700-1333969933_thumb.jpg

Mir ist aufgefallen: unten in der Statuszeile steht "keine Wiedergabe", der DL läuft mit 1286 Bit/s (laut DSL-Manager), der Ton (klatschen, Moderator) ist da.

 

Reclock, im Systray als Wecker angezeigt, verschwindet!

 

Was mache ich falsch?

Edited by quax1306

Share this post


Link to post
maluk

Hallo Quax1306,

 

leider weiß ich noch nicht, wo der Fehler genau passiert. Daher habe ich in die DLL an ein paar Stellen Logging eingebaut. Bitte kopiere die angehängte OnlineMediathek.dll in dein Plugins-Verzeichnis und stelle in den DVBViewer-Optionen unter "OSD - Allgemein" den Loglevel auf 20 oder kleiner (siehe http://de.DVBViewer.tv/wiki/Optionen_OSD_Allgemein). Rufe danach einige Videos aus der ARD oder KiKa-Mediathek ab und stelle mir dann die Datei osd.log zur Verfügung, die im ProgramData-Verzeichnis des DVBViewer dann erzeugt wurde. In dieser Logdatei müssten sich dann Einträge der OnlineMediathek befinden.

 

Gruß

maluk

OnlineMediathek.dll.zip

Share this post


Link to post
quax1306

Hallo maluk,

 

anbei die log-Datei! Es war immer "schwarzbild", hin und wieder mit Fehlrmeldung (s.o.)!

 

Gruß

Quax1306

osd.log

Edited by quax1306

Share this post


Link to post
maluk

Ich konnte jetzt zumindest die Stelle identifizieren, die zu dem Fehler führt: ich ermittle über die SendMessage Funktion MSG_GETVIDEOWINDOW das Handle des Fensters, das ich mit dem Flash Player überlagere. Wenn diese Funktion kein gültiges Handle zurückliefert, erscheint die von dir dargestellte Fehlermeldung und es läuft nur der Ton im Hintergrund.

 

Leider kann ich jedoch nicht nachvollziehen, warum bei dir bei der Funktion kein gültiges Handle ermittelt werden kann. Ich musste bei mir im Source Code die Funktion deaktivieren, um das Problem nachstellen zu können. Ehrlich gesagt fehlt mir gerade der Ansatzpunkt, wie ich das Problem lösen kann. Aber ich werde weitersuchen ...

Share this post


Link to post
Fruchtzwerg

Ich habe auch ein Windows XP und bekomme die ESQLiteException, wenn ich die Konfiguration von OnlineMediathek aufrufen möchte. Die ProgramData-ZIP mit der Datenbank habe ich auch schon an alle möglichen Stellen kopiert, also unter All Users und ins Programmverzeichnis, ohne Erfolg. DVBViewer Pro 4.8.0.1

Share this post


Link to post
Tjod

Bekommst du die Probleme auch mit dem DVBViewer Pro 4.9.6.20?

Das Plugin verlässt sich glaube ich darauf das alle Dateien, die der DVBViewer mitbringt, in einer aktuellen Version vorhanden sind z.B. die sqlite3.dll.

Share this post


Link to post
Fruchtzwerg

Der Fehler kommt auch bei der 4.9.6.20.

Share this post


Link to post
Fruchtzwerg

Es funktioniert jetzt, ich habe nochmal die Dateien überschrieben. Wie kann ich die Mediathek unter BluFuzz aufrufen?

Share this post


Link to post
morph8000

hi,

ich benutze den HD glass mod bl4ck -Skin

code.google.com/p/bl4ckhd/

Leider tut sich dann nix wenn ich auf den Online Mediathek-Eintrag klicke, irgendwelche Lösungsvorschläge?

thx

Share this post


Link to post
cambies

@Fruchtzwerg & morph8000:

Ihr könnt es nicht aufrufen, da für die von Euch genutzten OSD-Skins kein angepasster/s Screen/Panel existiert.

 

Sowohl für BluFuzz als auch für bl4ck-Mod gibt es keine "onlMediathek.xml". Nur wegen dieses coolen Skins habe ich zu INCA gewechselt.

Ich habe derzeit Urlaub und werde mich vormittags schön in die Sonne setzen, bis ds Kind aus'm Kindergarten kommt. Da hatte ich mir eigentlich vorgenommen, eine für "onlMediathek.xml" für BluFuzz anzupassen.

Also.... entweder ich stell' es bis Ende dieser Woche hier 'rein oder es wird zumindest von meiner Seite aus nie was und es muß sich jemand anderes in die Bresche werfen ;-)

 

Gruß, Cambies

Share this post


Link to post
maluk

Die onlMediathek.xml für BluFuzz ist in OnlineMediathek_1.0.1.zip enthalten. Ich nutze inzwischen selbst BluFuzz.

Share this post


Link to post
cambies

Is ja peinlich! Aber so hab ich mir Arbeit gespart, hihihi. Das ist doch tatsächlich eine für BluFuzz in der ZIP. Na denne, prima und vielen Dank an maluk.

Schönen Herrentag, hicks... :dvbviewer:

Share this post


Link to post
borisffm

bei mir wird gar keine ZDF Mediathek angezeigt nur ARD, NDR und Co.

 

Habe ich etwas falsch gemacht?

Share this post


Link to post
maluk

Vermutlich fehlt die onlineMediathek.ini im Verzeichnis C:\ProgramData\CMUV\DVBViewer\Plugins. Hast du die Datei OnlineMediathek_ProgramData_1.0.zip in das Verzeichnis C:\ProgramData\CMUV\DVBViewer ausgepackt?

Share this post


Link to post
borisffm

super, genau daran lag es . Vielen Dank!!!!!

Share this post


Link to post
maluk

Leider komme ich zur Zeit nicht dazu, neue Features in das Plugin einzubauen. Allerdings habe ich einige Probleme behoben und stelle euch eine neue Version 1.0.1 mit folgenden Bugfixes zur Verfügung:

 

- Logos in ARD Mediathek wurden teilweise nicht mehr korrekt geladen

- Logos in KiKa Mediathek wurden teilweise nicht mehr korrekt geladen

- ARD Mediathek wurde nicht mehr richtig aktualisiert, da MediathekView auf neues File Format 3.0 umgestellt hat

- teilweise wurden falsche Infos zum abgespielten Stream angezeigt, wenn man während des Abspielens OSD-OK gedrückt hat

Share this post


Link to post
Elektriker

Danke, sehr schönes Plugin. Damit wird die Mediathek nun auch ehefrauentauglich ;-)

 

Allerdings habe ich noch ein Problem. Beim Aufruf von ARD-Streams bekomme ich folgende Fehlermeldung:

 

"Exception EOleSysError in Modul OnlineMediathek.dll bei 00021346."

 

Als System läuft WinXP SP3 mit dem aktuellen DVBViewer Pro.

Adobe Flashplayer ist in der aktuellen Version installiert und über Firefox funktioniert die ARD-Mediathek.

 

Eine Besonderheit ist, daß seit einer Neupartitionierung und -installation die Systemfestplatte nicht C:\ sondern I:\ ist. Aber daran sollte es eigentlich nicht liegen, hab bisher damit noch keine Probleme gehabt.

 

Wo könnte es denn klemmen?

Share this post


Link to post
peff

Hi,

 

ich bin völlig begeistert von dem Plugin. Super Arbeit!

Ich hätte eine Frage zu dem JWPlayer.

Irgendwie scheint mein Ion mit Atom damit nicht klar zu kommen es ruckelt ohne Ende :-(

Wenn ich das Video direkt aus der Mediathek abspiele läuft es sauber.

Was mir dazu aufgefallen ist, die DVB Version des Videos sieht viel hochauflösender aus, wird das noch irgendwie umgemodelt, vielleicht bekommt meine Mühle damit Probleme?

 

Bin für jede Info dankbar

 

Infos:

Atom mit Ion

W7 64bit

PDVD12 / LAV

aktueller Flashplayer

Share this post


Link to post
maluk

Hallo peff,

 

im jwplayer gibt es eine Option smoothing, die die Bildqualität verbessert und standardmäßig aktiviert ist, jedoch wohl etwas Performance kostet. Im angehängten ZIP-File befindet sich eine OnlineMediathek.dll, in der ich die Option deaktiviert habe. Bitte kopiere die DLL ins Plugins-Verzeichnis des DVBViewer und versuche nochmal, Flash Videos abzuspielen. Falls die Performance bei dir dann besser ist, werde ich in die nächste Version eine Konfigurationsoption aufnehmen, mit der man das Smoothing deaktivieren kann.

OnlineMediathek.zip

Share this post


Link to post
peff

Hi,

 

danke für die schnelle Antwort.

Habe es sofort getestet, und es sieht in der tat gröber aus... allerdings rucken tuts immer noch heftig :-(

Ich habe mit Rechtsklick nen Menu gesehen dort ist die Hardwarebeschleunigung drin.

CPU liegt so bei 50% muß also irgendwie an dem Ion liegen. Allerdings kann der Flash normaler weise ohne Probleme?!?

 

Noch eine Idee?

 

Gruß

Peff

Share this post


Link to post
maluk

Versuche mal, wie die Performance mit dem angehängten HTML im Browser ist (auch mal auf Vollbild umschlaten, um reale Bedingungen zu simulieren). Falls der Film dann nicht mehr ruckelt, muss ich in meinem Plugin weitersuchen. Ansonsten liegt es leider am jwplayer, dann kann ich nichts machen.

jwPlayer.html

Share this post


Link to post
peff

Hi,

 

habs gleich mal gestestet.

Also es scheint ja hier wieder hochauflösend zu sein. Bei Fullscreen ruckelt es minimal.

Ich habe mal die CPU Last beim abspielen im DVB und direkt verglichen... keine nennenswerten Unterschiede.

Am besten lief das Video übrigends mit der Einstellung "Strech is extrafit" war dann aber net Fullscreend

 

Gruß

Peff

Edited by peff

Share this post


Link to post
maluk

Ich habe festgestellt, dass der Flash-Player nicht optimal eingebunden war. Auch auf meinem Rechner war ein Ruckeln erkennbar allerdings hatte ich mich wohl daran gewöhnt. Da ich dieses Wochenende einige Experimente mit dem DVBViewer Plugin gemacht habe und dabei einige Erkenntnisse gewonnen habe, habe ich gleich die Flash-Anbdinung etwas überarbeitet.

 

Die neue Version 1.0.2 (Download auf Seite 1) enthält folgende mit folgenden Bugfixes:

 

- kein Ruckeln mehr beim Anzeigen von Flash-Filmen

- Stoppen von Flash-Filmen jetzt auch mit Stopp-Taste möglich

- Bugfix Detailbeschreibungen in ARD- und Kika-Mediathek

 

@Elektriker: kannst du mal prüfen, ob deine Probleme mit der neuen Version auch behoben sind?

Share this post


Link to post
peff

Habe soeben getestet, ist wohl etwas besser... aber kommt leider nicht ansatzweise an jwplayer.html heran.

Diese habe ich durch Treibereinstellungen sogar noch flotter bekommen.

Die DVB Version ist aber nicht nutzbar, leider :(

Share this post


Link to post
Elektriker

@maluk

Hab eben mal getestet, ist leider immer noch das gleiche.

ZDF funktioniert, MDR auch, bei ARD die beschriebene Fehlermeldung.

Bei den anderen Dritten ist mir aufgefallen, daß in den Kategorien keine Beiträge angezeigt werden, aber vielleicht hatte ich jetzt einfach nicht genug Geduld bis die geladen waren...

Share this post


Link to post
maluk

Die ARD Mediathek wurde nicht mehr aktualisiert, da die Daten aus MediathekView jetzt nicht mehr mit zip sondern (wieder) bzip2 komprimiert werden. Daher habe ich die neue Version 1.0.3 bereitgestellt, mit der auch die ARD Mediathek wieder funktioniert.

 

@peff: ich befürchte, dass ich an der Performance nichts mehr verbessern kann. Mir fällt momentan keine Optimierungsmöglichkeit ein.

 

@Elektriker: um das Problem mit den dritten Programmen werde ich mich noch kümmern, nur habe ich leider momentan keine Zeit dazu.

Share this post


Link to post
mikromann

Hi,

 

erstmal vorab vielen Dank für deine Arbeit und Mühen.

Leider habe ich auch das bereits beschriebene Phänomen bei ARD: Kein Bild, aber Ton.

Außerdem habe ich einmal versucht selbst Streams hinzuzufügen, erhalte aber bei Aufruf folgenden Fehler:

Exception EParserException in Modul OnlineMediathek.dll bei 000AE03C.

Bei dem Stream handelt es sich um einen RTSP-Stream.

Den jwPlayer kann ich problemlos im Browser benutzen - darüber spiele ich auch die Streams normalerweise außerhalb des DVBViewer ab.

 

Über Anregungen und Hilfestellungen würde ich mich sehr freuen.

Share this post


Link to post
maluk

Hallo mikromann,

 

als Stream können nur RSS-Streams sowie die URL's von ZDF und KiKa hinzugefügt werden. RTSP ist an dieser Stelle als Protokoll nicht erlaubt. Leider werden Fehler an dieser Stelle nicht sauber abgefangen.

 

Wegen des Problems mit dem Bild würden mich einige Dinge interessieren:

 

- welches Betriebssystem verwendest du?

- welche Version des Flash-Player ist bei dir installiert?

- bekommst du beim Start des ARD-Streams eine Exception?

Share this post


Link to post
mikromann

Hallo,

 

also ich bekomme keinerlei Exception beim Aufruf der ARD-Streams.

Ich nutze Vista Ultimate in der 32bit Version und habe die aktuellste Flash-Version installiert.

Als Video-Decoder ist standardmäßig der LAV eingestellt.

 

Danke für deine Ausführungen zu den RTSP-Streams.

Share this post


Link to post
peff

Hi,

 

ich wollte mich noch mal melden.

Das Problem mit dem Ruckeln beim jwplayer bin ich nie losgeworden Asus Eee(Atom/Ion2).

Durch einen glücklichen Zufall konnte ich mein System gegen einen Shuttle (Atom/ATI7410M) tauschen.

Das Teil rennt wie sau :D

Was ich allerdings auch hatte und hier ausch schon beschrieben ist, schwarzer Bildschirm bei ARD. Trotz Flash etc.

Komischer weise hat der LAV abhilfe geschaffen, gibts dafür ne Erklärung?

Ich nutze ihn nicht mal für die Decodierung, da habe ich PDVD12.

 

Gruß

Peff

 

P.S.

Absolut göttliches Pulgin!!!!

Edited by peff

Share this post


Link to post
maluk

Für alle, die eine Exception beim Aufruf von Sendungen aus den ARD-Mediatheken haben, habe ich einen Tipp: vermutlich habt Ihr Flash aus dem Firefox heraus installiert. Es gibt aber zwei Versionen von Flash zum Download: Flash für Internet Explorer und Flash für andere Browser. Ihr müsst auf Euren Rechner Flash für Internet Explorer installieren, dann funktioniert auch Online Mediathek. Also entweder Flash über den Internet Explorer installieren oder vom Firefox die Webseite http://get.adobe.com/de/flashplayer/otherversions/ aufrufen und in Schritt 2 Flash Player for Internet Explorer auswählen.

Share this post


Link to post
maluk

Ich haben noch eine neue Version 1.0.4 des Plugins zur Verfügung gestellt, das folgende Fehler behebt (betrifft die ARD Mediathekten):

  • eine unzuverlässige Update Site aus MediathekView wird jetzt ignoriert. Damit sollte der Update der ARD Mediatheken zuverlässiger werden.
  • Kategorien ohne Beiträge werden beim Update automatisch gelöscht (siehen Anmerkung von Elektriker)

Share this post


Link to post
chinhu

Hallo Maluk

 

ist es möglich,das du dein Plugin für den X-Skin Black Glass anpasst?

Share this post


Link to post
peff

Hi,

 

ich nutze dieses Plugin wirklich gerne mittlerweile.

Was mir allerdings auffällt, ist das die DB scheinbar nur nach einem Neustart des DVB Viewers aufgefrischt wird.

Gibts da ne Möglichkeit, das nach Zeit / Standby zu regeln?

 

Gruß

Peff

Edited by peff

Share this post


Link to post
maluk

Es gibt wieder eine neue Version 1.0.5 des Plugins mit folgenden Features:

 

- Unterstützung für Skin X-Skin Black Glass (@chinhu: hatte leider die letzten Wochen keine Zeit dazu, daher erst jetzt)

- Refresh der ARD-Datenbank auch ohne Neustart des DVB Viewers (@peff: du hattest Recht, der Refresh erfolgte nur beim Neustart des DVBViewer. Da ich beim Standby DVBViewer automatisch beende, ist mir das nie aufgefallen).

Share this post


Link to post
peff

Hi,

 

danke für den Einbau des Autorefreshes, aber 6Std. sind arg lang.

Ich nutze Dein Plugin z.B. zum Tagesschau gucken. Wenn ich um 21Uhr den TV starte hat er diese dann leider net drin :-(

Könntest Du den Standby abfangen, oder eine Menufunktion einbauen?

Das wäre genial!

 

Gruß

Peff

Share this post


Link to post
mieszekatz

Hallo zusammen,

Da ich grad bissel langweile hatte hab ich hier mal bissel rumgelesen und war auf das OnlineMediathek Plugin gestossen. Klingt super und ist das was das leben noch bissel schöner macht dacht ich so und gleich rein damit in den DVBViewer. Vorsichtshalber Rechner neu gestartet und siehe da, im OSDmenü auch gleich da, nur wenn ich nun auswähle geht nix, Anzeige bleibt wie vorher, also aktuelles TV Bild.

 

W7 64bit

DVBViewer 5

Skin ist noskin

 

Was mach ich falsch?

 

Danke im voraus

Share this post


Link to post
maluk

Hallo mieszekatz,

 

hast du OnlineMediathek_ProgramData_1.0.zip heruntergeladen und in das Verzeichnis C:\ProgramData\CMUV\DVBViewer entpackt? Für mich klingt es so, als ob das Plugin die Konfiguration (C:\ProgramData\CMUV\DVBViewer\Plugins\onlineMediathek.ini) nicht findet.

Share this post


Link to post
mieszekatz

Danke für die Antwort, habe jetzt das blufuzz OSD Skin nachgepackt und die beiben zip's nochmal reingepackt, jetzt gehts, obwohl ich gern das froschnskin aus der downloadsek behalten hät, werd mich aber dran gewöhn :-)

 

Hab aber nun das prob das ich bei ARD und MDR nur Ton hab. Java,Flash,Shockwave ist alles auf dem Rechner, oder brauch ich noch einen zusatz dafür?

ZDF geht mit Bild.

 

Und noch eine Frage, wie binde ich zB die arte Mediatek ein? einfach die URL der webseite zutun oder muss das was spezieles sein?

 

Danke

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...