Jump to content
cp2

Hauppauge Colossus

Recommended Posts

cp2

I've read the thread on Grabber/ capture cards but it stopped in November 2016 with no clear/ relevant outcome that I could see.

I have just replaced my Hauppauge HD PVR USB capture box, which I could successfully record from using DVBViewer, with a Colossus 2 PCIe card. Whilst DVBViewer lists it in the hardware section as  "Hauppauge Sierra Video Capture" I can get no further than that. I am seeking to capture HDMI and have the feeling that DVBViewer could well do a better capture job than the undled software should i be able to get it to work.

Am I missing something and it is possible to get it working or is this not (yet?) supported?

Share this post


Link to post
fxv1

I use a PCI and a PCIe cards in my PC using DVBviwer, works fine on both cards for capturing Terrestial and Satellite content.

I presume the box comes with some kind of software for HDMI capture, if yes does that work.

What operating system are you using? 

Share this post


Link to post
cp2

My OS is Windows 10 and the Huppauge capture software does work but it is a bit flaky compared to the Arcsoft software I previously used with the HD PVR. (I suspect that it wouldn't recognise the Colossus card as it pre-dates its release).

I also have a satellite tuner card and a terrestrial tuner card in my PC and DVBViewer works fine with them. I just don't seem able to configure the Colossus 2 card within DVBViewer.

Edited by cp2
more detail

Share this post


Link to post
cp2
1 hour ago, McenterFreak said:

Maybe you can find some Gold, if you dig here: http://www.DVBViewer.tv/forum/topic/56510-grabberencodercapture-cards/

That's the thread i found but i have gone through it again.

DVBViewer recognises the hardware and i can use Settings to set the input type but and i can proceed to Scan but whether i'm scanning using the correct hardware escapes me and no "channels" are found and a root directory is not created.

 

Share this post


Link to post
McenterFreak

I am afraid that i cant help you. Dont have a card like yours. Have you tried to respond to the tread? Looks like it is the place to ask for help?. The Headprogrammer (Hackbart) of DVBViewer looks like he is paying attention to this

 

Share this post


Link to post
cp2

i did consider adding to the thread but it was flagged as an old thread with a suggestion that i should start a new thread, so i did. (Sometimes i do what i'm told).

 

Thanks for your interest. Maybe i'll get other responses during the week days.

Share this post


Link to post
cp2

I gather that the Colossus 2 is not supported.

 

Can anybody tell me whether DVBViewer intends to support it at some point?

Share this post


Link to post
hackbart

There is no limitation by the software. All devices found are used.

Share this post


Link to post
cp2

I agree that DVBViewer can "see" the Colossus 2.

Following advice from other posters I have configured it as terrestrial but isolated it as Group H. I can scan the frequencies but it finds no channels. So, for the moment I am stuck.

Share this post


Link to post
goldfinger21

I am one of the last to post in the grabber thread. The Colossus 2 is the same as my Hd Pvr 2, just internal instead of external. Unfortunately for whatever reason DVBViewer will not work with this device. I went through the same issues as you (along with another member with a hd-pvr 2), sees the device correctly but when it comes to the scan stage it fails to find any channel. As I have the external version I have the light around the box that lights up when any capture software connects to it and I believe this is where the problem lies specifically with this model (the hd-pvr 1, colossus 1 and rocket do not have this problem), DVBViewer fails to wake up the device and the light remains dim which suggests there is a communication error between software and device. I asked the head programmer hackbart to look into this but as all other hauppauge capture devices do not have this problem he kept on irriterating his original post regarding these capture devices with the same instructions and although tried to help failed to understand the communication error this particular model has. Hoping he see's this thread and maybe can look into it some more. Every other capture software I own (including jriver) works with this device except DVBViewer.

Edited by goldfinger21

Share this post


Link to post
hackbart

It is most likely because of the name. If you take a look into graphedit or graph studio. What is the devices named? 

Share this post


Link to post
goldfinger21

Thanks for the help hackbart, I'll have a look with graphedit as soon as I can and post.

Share this post


Link to post
goldfinger21

Hi Hackbart,

 

Haven't used graphedit since god knows when so for whatever reason could not get it to determine what the device name is (could you give me some instructions for idiots like myself if you don't mind or maybe cp2 could check) but when I use DVBViewer to try and connect to the device it says Hauppauge Siena Video Capture, When I use Jriver to connect to the device (lights up the device and works) it says Hauppauge Siena Video Capture 5B7930E4969F6FD, could the numbers after be the issue.

Edited by goldfinger21

Share this post


Link to post
goldfinger21

Right, managed to work out graphedit I think, in graphedit the device name under video capture sources is Hauppauge Siena Video Capture, so as above maybe its something to do with the numbers after (maybe need to be added somehow). Also, it is seen as an analogue device in both JRiver and graphedit if that is any help. Await your response hackbart. Thanks in advance.

Edited by goldfinger21

Share this post


Link to post
hackbart

Hmm, if it is listed as hauppauge siena it should be found anyway. Can you post your support.zip file?

Share this post


Link to post
hackbart

Are you sure that there is a sierra listed? According to your zip, the device is named Hauppauge HD-PVR2. 

 

I will add this device name in the next release

 

Christian

PS: Hackbart is my surname. I would really appreciate if you put at least the title before.

Share this post


Link to post
goldfinger21

 

Apologies about using your surname when referring to you, assumed it was your nick as well, I will refer to you by your first name Christian in future if that is ok.

 

Yes the device name is Hauppauge HD-PVR2 (Mine is the Gaming Plus model so it comes up in device manager as this) but as far as I am aware only Hauppauge's own Capture and Wintv 7 + 8 connect using this name. Every third party software including Jriver (with combination no's / letters added) and Graphedit see it as Hauppauge Siena Capture. Hopefully you can get to the bottom of this problem and I have included below links to screenshots from both Graphedit, Jriver, Wintv8, Haup Capture and Device Manager showing all the different device names it appears as in the quest to get this fixed.

 

Graphenit:

http://i.imgur.com/D4pQxea.png[/img]

http://i.imgur.com/Kuj3tFU.png[/img]

 

Jriver:

http://i.imgur.com/mmWoHCY.png[/img]

http://i.imgur.com/Ox5sgRP.png[/img]

 

Wintv8:

http://i.imgur.com/ZcZFLzs.png[/img]

http://i.imgur.com/CiZ58B7.png[/img]

 

Hauppauge Capture:

http://i.imgur.com/xoZ2SPJ.png[/img]

 

Device Manager:

http://i.imgur.com/2Ao7T9v.png[/img]

http://i.imgur.com/83x9Zbb.png[/img]

Edited by goldfinger21

Share this post


Link to post
goldfinger21

And here it is as it appears in DVBViewer, Hauppauge Siena Video Capture, setup correctly under group H and Terrestrial but when you scan range, the first time you press it does nothing, the second time you press it immediately fly's through the green line scan and no channels found (not correct behavior if it was properly connected to device), the device itself stays in hibernation with dim blue light on rather than flashing dim green and then constant bright green which it does when connected to other capture software. Obviously it could be like you said, Christian, the device name could be wrong:

 

DVBViewer Setup Screen:

 

http://i.imgur.com/0OrZDje.png[/img]

 

Finally, the op has incorrectly named this thread as Collossus (internal HD-PVR which works correctly as far as I am aware) rather than Collossus 2 (internal HD-PVR 2). Maybe it would be best to rename the thread as Colossus/HD-PVR 2 to avoid confusion for other members.

 

Await your further comments and thanks for any further help in advance.

Edited by goldfinger21

Share this post


Link to post
hackbart

Did you set up a virtual channel list map? The device is just a Encoder Box with a Video input and no Tuner or whatever. You have to create virtual channels which are used for the scan and you need a remote transmitter plugin which sends the ir command to the connected set top box.

Share this post


Link to post
goldfinger21

Please explain this virtual list channel list further i,e instructions, I thought that was only needed if you wished to have DVBViewer change channel on the receiver and having read the grabber thread and what you have said there seems to be the case.I don't believe anyone who has tried to connect the hd-pvr 2 has done this and with my hd-pvr 1 I just connected and scanned and it found 1 channel (capture channel and as I do with the other capture software I use), no virtual channel list needed. Also I do not need the ir command bit as I will just change the channel on the receiver manually. I will try this virtual channel list once you explain further  (if needed) but as the box is not been woken up and staying in hibernation I don't think it will work, I still think you hit the nail in the head with the name thoery but let's try if you think it will work.

Edited by goldfinger21

Share this post


Link to post
goldfinger21

Here is a few more screens from DVBViewer showing my setup:

 

Encoder Box Setup showing correct Video Serial Digital (hdmi) and Audio AES/EBU Digital (hdmi) and AC3:

 

http://i.imgur.com/5wp5WXE.png[/img]

 

Terrestrial Setup:

 

http://i.imgur.com/AMA1sv8.png[/img]

 

Scan Result showing 0 channels found (same whther scan frequency or scan range is pressed):

 

http://i.imgur.com/uINyW6U.png[/img]

 

Await your response about virtual channel setup which I don't think is needed for use with just 1 capture channel. Please let me know if so along with instructions or if a device name chsnge is needed.

Edited by goldfinger21

Share this post


Link to post
goldfinger21

Having looked into this virtual channel setup further I don't believe it will fix the problem with this particular device as we are setting it up as a single channel capture device as per your instruction's on the original grabber thread.  I think the best way forward with this would be like you said to add the HD-PVR 2 device name and see if that rectifies this problem. Please confirm Christian, this can be done for the next release.

 

Thanking you in advance.

Edited by goldfinger21

Share this post


Link to post
cp2

I've not looked at this thread for a while but I'm glad that it has progressed.

Confirming my experience

DVBViewer see my Colossus 2 as "Hauppauge Siena video capture". If I open the Options/ Hardware/ Settings/ Device window under Video capture tab it indicates that 1 1080 signal can been be detected. Unfortunately this isn't translated into a scannable channel.

My Hauppauge HD Capture software sees it as "Colossus 2" though there is another entry "Hauppauge ImpactCVB-e" which doesn't seem relevant.

My WinTV v8 software sees it as "Colossus 2" but if i go into setup it calls it "Colossus 2 000FE0B0001.

Interesting that my software calls it Colossus 2 rather than mentions earlier of HD-PVR2

 

I should also mention that my Windows 10 Device Manager sees it as Colossus 2 (model 152000). I think that this model reference has only just been added to the Hauppauge support site.

 

 

Share this post


Link to post
goldfinger21

Hi cp2,

 

The Colossus 2 is for all intents and purposes the same device as the HD-PVR 2, just internal, maybe the device name is different so as to distinguish them apart, DVBViewer sees them both as Hauppauge Siena Video Capture though. Mine also detects 1 1080 signal under the Video Capture Device tab. Hoping Christian has a better understanding of the problem now and the next software update will fix it but as he hasn't replied since my last post not sure whether this will be the case, fingers crossed. Maybe, to help him further you could post your support.zip so he can see how your system is setup.

Edited by goldfinger21

Share this post


Link to post
hackbart

Actually i'm quite unsure if i understood the problem. The device itself has a IT990 chip and i can set all of these kind of devices into the proper encoder mode. The hardware encodes any kind of input into a dvb similar format with a H264 and AAC compression. To select a channel you need a plugin which does the channel switching on the connected receiver box. The device i have here (an old hauppauge box) has a IR transmitter which can be linked to the connected set top box and emulates a remote signal in order to change the channel. For this function you need a plugin which does this, and you have to create a "map" which means you have to assign! a channel with a frequency in order to tell the DVBViewer something like: if transponder 474000 kHz is tuned in, send Number e.g. 21 via IR transmitter to the STB. 

Share this post


Link to post
cp2

I would agree that if you wish to change channels via DVBViewer you would need a plugin to operate a remote control. However, I for one don't want to do this. The PCIe card (or USB connected HD-PVR) for that matter only handles one channel. If I want to change channels I use the remote of the source device to do this.

Before I upgraded i used a HD-PVR which I managed to get DVBViewer to recognize - no plugin, no channel mapping. I managed to get it to scan and if "found" lots of channels, only one of which i needed.

With the Colossus 2 DVBViewer does not recognize it is the same way and finds nothing upon scanning.

 

 

Share this post


Link to post
hackbart

You have to add at least one channel with one frequency.

Share this post


Link to post
cp2

Yes! But if the scan finds nothing how can i add a channel?

Share this post


Link to post
goldfinger21

As per your instructions Christian have installed the required HDPVR scheduler files in DVBViewer to create a virtual channel but on opening the scheduler and selecting terrestrial it does not let me select a device (or change anything else for that matter) the field is totally blank as per attached screenshot link:

 

http://i.imgur.com/TWaxbgA.png

 

Either I am doing something wrong, in which case can you offer some advice please or there is a problem.

 

One thing that doesn't seem right I have discovered is under the Device settings in hardware section of DVBViewer it does not appear to recognise the device properly, alot of the fields are blank (in jriver all these settings appear to show various info on the device like bitrate etc) as per attached screenshot link:

 

http://i.imgur.com/BREpyAR.png

 

Could it be its not recognising the device correctly.

 

Await your further advice. 

 

 

Edited by goldfinger21

Share this post


Link to post
hackbart

In theory you could also use one of the frequencies which are used by default. They are calculated by the following code:

 

procedure THauppaugePVR.BuildDefaultList();
var n: integer;
  Max: integer;
begin
  case FTunerType of
    ttTerrestrial: max := 60;
    ttATSC: max := 69;
    else
      max := 106;
  end;
  SetLength(FChannels, Max);

  for n := 0 to Max - 1 do
  begin
    case FTunerType of
      ttCable:
        case n of
          00..007: FChannels[n] := 50500 + n * 7000;
          08..035: FChannels[n] := 107500 + (n - 8) * 7000;
          36..105: FChannels[n] := 306000 + (n - 36) * 8000;
        end;
      ttTerrestrial:
        case n of
          00..02: FChannels[n] := 50000 + n * 7000;
          03..10: FChannels[n] := 177500 + (n - 3) * 7000;
          11..59: FChannels[n] := 474000 + (n - 11) * 8000;
        end;
      ttATSC:
        case n of
          00..02: FChannels[n] := 57000 + n * 6000;
          03..04: FChannels[n] := 79000 + n * 6000;
          05..11: FChannels[n] := 177000 + (n - 5) * 6000;
          12..68: FChannels[n] := 473000 + (n - 12) * 6000;
        end;
    else
      FChannels[n] := 10729 + n * 15 {mhz};
    end;
  end;
end;

procedure THauppaugePVR.BuildDefaultList();
var n: integer;
  Max: integer;
begin
  case FTunerType of
    ttTerrestrial: max := 60;
    ttATSC: max := 69;
    else
      max := 106;
  end;
  SetLength(FChannels, Max);

  for n := 0 to Max - 1 do
  begin
    case FTunerType of
      ttCable:
        case n of
          00..007: FChannels[n] := 50500 + n * 7000;
          08..035: FChannels[n] := 107500 + (n - 8) * 7000;
          36..105: FChannels[n] := 306000 + (n - 36) * 8000;
        end;
      ttTerrestrial:
        case n of
          00..02: FChannels[n] := 50000 + n * 7000;
          03..10: FChannels[n] := 177500 + (n - 3) * 7000;
          11..59: FChannels[n] := 474000 + (n - 11) * 8000;
        end;
      ttATSC:
        case n of
          00..02: FChannels[n] := 57000 + n * 6000;
          03..04: FChannels[n] := 79000 + n * 6000;
          05..11: FChannels[n] := 177000 + (n - 5) * 6000;
          12..68: FChannels[n] := 473000 + (n - 12) * 6000;
        end;
    else
      FChannels[n] := 10729 + n * 15 {mhz};
    end;
  end;
end;

 

Share this post


Link to post
goldfinger21

Sorry to ask, could you please help me with how to implement the code above, a little above my expertise.

Share this post


Link to post
cp2

I have booted up my old PC upon which my HD PVR box was successfully recognised by DVBViewer. It's not ideal as significant bits of its hardware has been reassigned and the HD PVR hardware chain has been decommissioned.

DVBViewer saw the HD PVR as a "Hauppauge HD PVR Capture Device" and it was configured as a "ATSC" device. As this it was able to successfully scan and find channels.

The build on the old PC was V5.6.2.0 but the build on my new PC is V5.6.4.0: hopefully that is not significant.

As stated previously the new PC sees the Colossus 2 as "Hauppauge Siena Video Capture". If I configure it as "ATSC" it doesn't find any channels upon scanning.

In the hope that it may cast further insights I attach the support.zip files from my old PC and its replacement.

 

Colossus 2 support.zip

hd pvr support.zip

Share this post


Link to post
cp2

This thread seems to meander along punctuated with a quick flurry of activity and, perhaps, some progress.

My feeling is that for the moment this thread should not be classified as "hot"!

Share this post


Link to post
goldfinger21

Still waiting on Christian to answer my question in regards how to implement the code he suggested. Noticed as well the device name suggestion wasn't added to the latest update either.

Edited by goldfinger21

Share this post


Link to post
cp2
16 hours ago, goldfinger21 said:

Still waiting on Christian to answer my question in regards how to implement the code he suggested. Noticed as well the device name suggestion wasn't added to the latest update either.

Can't help thinking that using bits of code is not the way to go. Will it survive updates?

I much prefer what happened with my HD PVR - the DVBViewer software recognized it, you configured it and it worked. I'd just like the same thing for my Colossus 2.

Share this post


Link to post
hackbart

This code is part of the application since its beginning. I honestly have no idea why you can't get it work. The code for this kind of devices did not changed since a while. You might install an older version and try to create a scan, then you can use the channel file in the new one. 

Share this post


Link to post
cp2

Thrashing around trying other things...

I fired up my old PC and in Channel editor I exported the "ha pvr" (i can't type) root to an ini file.

 

I imported this file into my new PC and ended up with a new root entry. When double clicked on a "ha pvr" channel I got a "No Hardware Available" message.

This was not entirely unexpected as my previous hardware was a HD PVR and now I have a Hauppauge Siena Video Capture.

I did try to scan for channels using ha pvr as the root in the hope that the ha pvr root would be associated with the new hardware but as per usual nothing was found and the channels.dat file was not updated.

 

 

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...