Jump to content
Hoyul Lee

Media Server can't record streams

Recommended Posts

Hoyul Lee

* Sorry for poor English. I'm not a native speaker.

 

Recently, I made a ATSC stream server w/ DVBViewer Media Server.

 

Now I can get TV streams with Kodi/DVBViewer Pro, but can't record.

1st pic is the Timer Recordings table. The timer looks like well listed, but as you see, webinterface told me that it never written streams to a storage.(2nd pic)

And svcdebug.log said that Process(DVBVservice.exe) has Process Access Violation Error!(3rd pic, look red lines).

 

So... what can I do for clear this error? It makes me crazy...

 

support.zip

well listed.png

webinterface.png

violation.png

Share this post


Link to post
Hoyul Lee

Hello? Nobody here?

Share this post


Link to post
Griga

This is no chat and most likely there is a time difference between your country and Europe. Please take this into account.

 

It's quite obvious what happens: The DMS tries to start the recording, but the process is interrupted by the access violation, so the recording doesn't start and the DMS tries it again and again every second.

 

However, it is hard to pinpoint what actually causes this access violation. It is no known DMS issue, so it may be specific to your setup, particularly ATSC as reception type. Since ATSC can't be received in Europe there is no chance to reproduce the issue here. So all we can do is to try this and that in order to narrow the cause down.

 

So please first try if recording works with DVBViewer directly. For this purpose untick DVBViewer -> Settings -> Options -> (scroll down) DVBViewer Media Server -> Send timers to the server, Connect to the timer list, Connect to the recording list and Ignore local recording list. This makes DVBViewer a "stand alone" recorder.

 

Share this post


Link to post
Hoyul Lee

Tried your guide, it works. But still I need server-side recordings, not a local recording.

 

※ Re-installation or de-activate Anti-Virus SW are useless. I tried them several times already.

Share this post


Link to post
Griga

In the meantime I have enabled an ATSC simulation for the DMS (an ATSC sample file handled as live TV source by using a virtual file device). Recording worked without problems. However, such a simulation is not perfect. Particularly up-to-date EPG data that the recorder usually tries to read is missing.

 

The address of the access violation is located in the runtime libraries, not in the DMS code (if my debugger is right). It suggests an attempt  to read text that is no more in memory. Unfortunately that doesn't help much to find the part that causes the problem.

 

So the next test you could perform is running the DMS without EPG data. Please do the following:

  1. Stop the DMS by using the tray tool context menu.
  2. Remove the file epg.dat that is located in the config sub-directory of the configuration folder.
  3. Launch the DMS options (svcoptions.exe). Tick Hardware -> Disable EPG reception for all your ATSC tuners. Close with OK.
  4. Start the DMS. Open the web interface, go to the Timer page, click New Timer for creating a recording timer manually without EPG data being involved. Does it work?

Share this post


Link to post
Hoyul Lee

Tested.

 

Without EPG data, it works.

And after Re-enable EPG reception, it failed again.

 

Does it related to EPG?

Share this post


Link to post
Griga

Yes. Maybe. It's a mysterious bug. Why doesn't it happen in DVBViewer that basically uses the same code? Why doesn't it happen here in my ATSC simulation when I output ATSC EPG data as XML in the browser by using the DMS API?

 

Another thing you can try: Keep the DMS without EPG, but try to start the recording from the DVBViewer client as you initially did (like in the screenshots in your first post). Does it work?

Share this post


Link to post
Hoyul Lee

Yes it does.

I already tested both webinterface and clients.

Share this post


Link to post
Hoyul Lee

How's it going?

I've recieved last(and intermediate) answer about 4 days ago.

Share this post


Link to post
Griga

I've spent some time with examining ATSC EPG related code, but I could not find a reason for the problem described by you. Furthermore it did not occur on additional tests with ATSC files as (simulated) live TV source. It seems to be impossible to pinpoint it without an opportunity to reproduce the error with your live TV data source under debugger control. 

 

All I can provide for now is an attempt to catch the access violation before it interrupts the recording start. I will send it to you as an attachment of a personal message (PM). However, this is no real fix, but only a work-around (if it works). The issue may show up again on other occasions.

 

One more question: Are all channels affected that you are receiving or only some of them?

Share this post


Link to post
Hoyul Lee

Yes. All of korean EPG channel listed are same.

No recording, no happy :(

 

P.S. need my EPG.DAT?

Share this post


Link to post
majstang

What if using, in the meantime, for example WebGrab++ and grabbing the EPG from external sources and then import with XEPG? That would imply you to disable EPG reception for all ATSC tuners and still have an EPG. 

Edited by majstang

Share this post


Link to post
Hoyul Lee

@Griga Tried. and still cannot record, with no message. Same SVCdebug.log : support.zip

 

@majstang I don't know how to use WebGrab++, and sitepack has no Korean channel list. Can you help me to setup Korean channel EPG?

Share this post


Link to post
majstang
22 minutes ago, Hoyul Lee said:

@majstang I don't know how to use WebGrab++, and sitepack has no Korean channel list. Can you help me to setup Korean channel EPG?

 

Making a siteini is quite tricky to begin with and making it for a Korean EPG site would require master skills and using lots of google translations, which I dont have. Besides, Im having a hard time keeping up with everything im involved in as is. Best option for you is to search for Korean EPG that are available in xmltv format. If you find it you can import it as is with XEPG -> DVBViewer/DMS

Edited by majstang

Share this post


Link to post
Griga
9 minutes ago, Hoyul Lee said:

Tried. and still cannot record

 

This means the access violation does not happen where i thought it would happen. So I have to go on searching...

 

Another possibility would be to record a transponder dump from your with the TransEdit Analyzer including ATSC EPG data and upload it somewhere so I can check what is inside. However, in case of ATSC this is difficult because the EPG data is spread over many different streams (I have to explain how it must be done), and the resulting file can be quite big (maybe 100 MB or more). Do you have web space like DropBox where you can upload such a file?

Share this post


Link to post
Hoyul Lee

Ok. I'll upload some dumps this evening(Here's timezone is GMT-9) at Onedrive.

Share this post


Link to post
Griga

Thanks. I can reproduce the issue now and will provide a fix as soon as possible.

Share this post


Link to post
Griga

Please check your PMs. I think I made it work and also fixed another ATSC related bug. There was no ATSC category in the UPnP -> TV section (see Media page of the web interface).

 

Please let me know if you encounter other issues. It's always useful for DMS development if it is tested in an environment that can't be tested here.

Share this post


Link to post
Hoyul Lee

Finally, it works!!! Thanks!!!

Thank you very much!

I LOVE YOU GUYS!

 

P.S. Please release this test version as a public regular release.

Edited by Hoyul Lee

Share this post


Link to post
Griga

The next release will contain the fix. Thanks for your help :)

 

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • Fritz Meier
      By Fritz Meier
      Hallo, ich habe Windows10 64-bit (build 1803)installiert. Auf dem PC läuft auch der DVBViewer Pro ordnungsgemäß und korrekt. Gestern habe ich auf das Build 1809 upgedatet. Wenn ich jetzt den
      DVBViewer Pro 6.02 aufrufe, erhalte ich folgende Meldung: Exception EAccessViolation in module
      DVBViewer.exe at 0027CB03. Access violation at address 0067CB03 in modules 'DVBViewer.exe'. Read of
      address 000002F4.----Zitatende----.
      Auch nach einer Deinstallation und Neuinstallation des DVBViewer blieb der Fehler.(incl. Neustart etc.)  Eine
      Demo-Installation des Programms zeigte beim Programmstart nach der Installation den gleichen Fehler.

      Jetzt habe ich wieder auf Build 1803 downgedatet, und DVBViewer läuft sofort problemlos. Was ist der
      Grund? Ich möchte schon das neue Build 1809 haben. Meiner Meinung nach kann es also nur am Update
      liegen.

       
    • AJM
      By AJM
      Problem:
      Nach dem Update auf 6.0.0 Pro "verschwand das Bild" beim Umschalten in den Vollbild-Modus und der Desktop wurde angezeigt. Solange das Bild im frei skalierbaren Fenster-Modus angezeigt wurde, gab es keinerlei Probleme.
       
      Details:
      Im Preview-Bild in der Task-Leiste wird der Programmrahmen beim Mouse Over noch angezeigt (ohne TV-Bild, nur weiß mit zentralem dvbvr-Icon und darunter den neuen Icons "EPG Window" usw.) und im Rahmen des Task-Leisten-Vorschaubilds "DVBViewer (keine Rückmeldung)".
      Eine Reaktivierung des Fenster-Modus ist nicht möglich.
      Nach Klicken auf X (Schließen) im Task-Leisten-Vorschaufenster erscheint dann die Windows-Meldung "Programm reagiert nicht =>Beenden?")
       
      Ursache und Notlösung:
      Das DVB-Tool „Supporttool.exe“ zeigte im DVBViewer.LOG zahlreiche „Access violations“ in d3d9.dll. Da diese dll-Datei zu DirectX gehört, lag ein GPU-Treiberproblem nahe.
      Nach der Änderung der Grafikeinstellungen im Laptop von „Bevorzugte GPU = Radeon 970M“ in AUTO (=> Nvidia 530) trat das Vollbildproblem bislang nicht mehr auf.
       
      Scheint also eher ein Laptop-spezifisches Problem bei zwei GPUs zu sein, wenn dort der Default AUTO geändert wurde.
       
      Vielleicht hilft es ja dem einen oder anderen.
       
      Viele Grüße!
      AJM
×
×
  • Create New...