Jump to content

Kann Video/Ausgabe Pin nicht rendern, error: 0x80040154


Recommended Posts

Hallo Freunde,

Beim Start vom DVBViewer Pro bekomme ich diese Fehlermeldung:

"Kann Video/Ausgabe nicht rendern, error 0x80040154 Klasse nicht registriert"

Habe kein Bild. Ton ist OK. Hat vorher schon jahrelang einwandfrei funktioniert.

Dann habe ich am 02.05.2018 DVBViewer nach Fehler gelöscht und neu installiert. EPG und Senderliste werden angezeigt. Forum wurde ohne Erfolg durchforstet.

Was bewirkt die regfilter.exe? Wo erkenne ich, ob die Dekoder installiert sind?

Ich bitte um Hilfe mit Erläuterung.

 

TV-Karte: Cinergy C PCI --  Treiber Terratec, -Datum: 18.11.2010, -Version: 1.1.2.501

Grafikkarte: Intel ® HD Graphics 4000 – Treiber Intel Corporation, -Datum 0704.2017, -Version10.18.10.4653

 

Anhang :

 

support.zip

Link to post

Dem DVBViewer.log in deiner support.zip ist zu entnehmen, dass bei dir Einstellungen -> Video-Ausgabe B eingeschaltet ist. Deshalb werden die unter Optionen -> DirectX -> Video B eingestellten Decoder und Renderer verwendet. ist diese Einstellung eine bewusste Entscheidung? Die Standardeinstellung ist normalerweise "Video-Ausgabe B aus", so dass die unter Video A gewählten Decoder/Renderer zum Zuge kommen.

 

Unter Optionen -> DirectX ist bei dir offenbar als Renderer "System Default Renderer" eingestellt. Das ist unter Windows 10 im allgemeinen keine gute Wahl. Bevorzugt sollte der EVR Custom Video Renderer zum Einsatz kommen. Probiere das mal aus.

 

Weiterhin fällt in deiner SystemInfo.txt auf, dass bei dir offenbar der AC3 Filter installiert war, aber nicht ordnungsgemäß deinstalliert, sondern einfach gelöscht wurde. D.h. die Registry-Einträge sind noch da, aber die Datei fehlt. Sowas kann zu Problemen führen.

 

Um das zu reparieren, musst du entweder den AC3 Filter neu installieren, oder die verwaisten Registry-Einträge löschen. Das geht mit dem Radlight Filter Manager: Starte ihn mit Admin-Rechten (!), klappe in der Baumansicht den Zweig "DirectShow Filters" auf und selektiere dort den (wahrscheinlich grau angezeigten) AC3 Filter. Klicke dann auf "Unregister". Der Filter Manager wird darauf hinweisen, dass die Datei fehlt und fragen, ob er die Registry-Einträge löschen soll, was du bestätigst.

 

Als weitere Maßnahme kannst du probieren, die LAV Filters neu zu installieren.

 

Link to post

 

Hallo Griga,

herzlichen Dank für deine schnelle Hilfe.

Zu den Abschnitten habe ich Fragen und Bemerkungen.

Zum 1. Wozu gibt es die Einstellung "Video-Ausgabe B“ ? Dazu bitte noch einen Hinweis. Ich habe das Häkchen beim Einstellungs-Menü  entfernt.

 

Zum 2. Der Hinweis hat zum Erfolg geführt, das Bild ist wieder da und ich kann das Programm in allen Teilen nutzen.

 

Zum 3. und 4. Den verweisten Registry-Eintrag habe ich gelöscht. Ist es nötig, die AC3 Filters zu installieren, da der Ton m.E. in Ordnung ist?

 

Nun nochmals vielen Dank

Alles Gute

Petsieg

Link to post

Zu 1: Die Option geht auf Wünsche von Benutzern (mich eingeschlossen) zurück.

Für bestimmte Konfiguration benötigt man verschiedene Decoder und Renderer und damit kann man zumindest 2 Varianten abdecken.

In der Regel benötigst du das aber nicht und kannst bei A bleiben. 

 

Zu 3 und 4: Nein ist nicht nötig. Der AC3 Filter macht nur Sinn wenn du bestimmte Eigenschaften des AC3 Filters benutzen (Audio Processing etc.), die der LAV Filter nicht unterstützt.

Link to post

Es ist alles geschrieben. Da ich keinen Hinweis finde, wie man das Thema mit "gelöst" kennzeichnet, bitte ich einen Moderator oder admin dieses für mich zu tun.

Danke und Tschüss

Link to post
  • 1 year later...

Sorry, aber ich muss mich hier auch noch melden. Ich habe auch das Problem mit den fehlenden Filtern zum Rendern. der Fehlercode lautet bei mir 0x80040218, und beim DVBViewer laufen die öffentlich rechtlichen tadellos, aber bei den privaten kommt nur der Ton und ein schwarzer Bildschirm. Mit dem empfohlenen Radlight-Filtermanager komme ich leider nicht klar. Cyperlink Power-DVD habe ich auch schon installiert, es funktioniert auch. Aber beim DVBViewer ändert das nichts. In den folgenden Zeilen findet ihr die Systeminfo.txt. Vielleicht schaut mal jemand rein und ist mit einem Tipp gefällig.

 

Danke schon mal

lg Funky

Spoiler

 

MPEG2 Video Decoders:
-------------------------
Microsoft DTV-DVD Video Decoder V10.0.17763.802:   005FFFFF

-------------------------
H264 Video Decoders:
-------------------------
Microsoft DTV-DVD Video Decoder V10.0.17763.802:   005FFFFF

-------------------------
HEVC Video Decoders:
-------------------------

-------------------------
VC1 Video Decoders:
-------------------------

-------------------------
MPEG Audio Decoders:
-------------------------
MPEG Audio Decoder V10.0.17763.1:   03680001
Microsoft DTV-DVD Audio Decoder V10.0.17763.194:   005FFFFF

-------------------------
AC3 Audio Decoders:
-------------------------
Microsoft DTV-DVD Audio Decoder V10.0.17763.194:   005FFFFF

-------------------------
AAC Audio Decoders:
-------------------------
Microsoft DTV-DVD Audio Decoder V10.0.17763.194:   005FFFFF

-------------------------
MP3 Audio Decoders:
-------------------------


-------------------------
System:
-------------------------
DVBViewer Version: 6.1.5.2
DVBViewer Size: 1.768.
KeyTool Version: 1.2.0.0

DVBSource Path: C:\Program Files (x86)\DVBViewer\Filters\PushSource.ax
DVBSource Version: 3.9.6.0

DVBCOMServer Path:    C:\PROGRA~2\DVBVIE~2\DVBVIE~1.EXE
DVBCOMServer Version: 6.1.5.2

VODSource Path:    C:\Program Files (x86)\DVBViewer\Filters\VODSource.ax
VODSource Version: 2.2.1.1

OS:           Windows 10x64
OS Build:     1809-17763
Aero enabled: True
DirectX:      12.0
d3dx9_33.dll:   False
Memory:       8067 MB
CPU:          Intel(R) Core(TM) i5-9400F CPU @ 2.90GHz
CPU Speed:    2904 Mhz
CPU Count:    6
Videocard:    NVIDIA GeForce GTX 1050 Ti
Version:      26.21.14.3107
MS Media Center Receiver Service:    Stopped
MS Media Center Scheduler Service:   Stopped

-------------------------
Media Devices:
-------------------------

=== Realtek High Definition Audio ===
Description = Realtek High Definition Audio
DeviceID = HDAUDIO\FUNC_01&VEN_10EC&DEV_0671&SUBSYS_103C843B&REV_1000\4&11BDFC61&0&0001
DriverVersion = 6.0.1.8581
DriverDate = 27.11.2018
Manufacturer = Realtek

=== DVBSky S950 V3 - DVBS/S2 PCIe ===
Description = DVBSky S950 V3 - DVBS/S2 PCIe
DeviceID = PCI\VEN_1ADE&DEV_3038&SUBSYS_05504254&REV_01\4&22E14B01&0&00D8
DriverVersion = 11.17.38.33
DriverDate = 20.08.2018
Manufacturer = Bestunar

=== NVIDIA High Definition Audio ===
Description = NVIDIA High Definition Audio
DeviceID = HDAUDIO\FUNC_01&VEN_10DE&DEV_0080&SUBSYS_103C8465&REV_1001\5&1BBA6920&0&0001
DriverVersion = 1.3.38.16
DriverDate = 06.05.2019
Manufacturer = NVIDIA

Installed Antivirus Products
--------------------------------------------------
Windows Defender
Bitdefender Virenschutz

Private Firewall Profile is active
Rules:
  Rule Name:          DVBViewer Pro LAN/WLAN
   ----------------------------------------------
  Description:        
  Application Name:   C:\Program Files (x86)\DVBViewer\DVBViewer.exe
  Service Name:       
  IP Protocol:        256
  Direction:          In
  Edge:               False
  Action:             Allow
  Grouping:           
  Edge:               False
  Interface Types:    All


--------------------------------------------------
Created: 09.12.2019 18:49:03

 

 

Edited by Griga
Spoiler Tags ergänzt
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...